none
Windows 10 - Desktop icons moving to secondary monitor RRS feed

  • Dotaz

  • I recently added a second monitor with HDMI. My primary only allows DVI, and for some reason windows prioritizes HDMI as the primary monitor, so it identifies the secondary monitor as 1, and my primary as 2.

    I've recently run into a strange bug where my desktop icons will always go to the secondary monitor, regardless of which monitor is set as the primary. I've tried multiple fixes without success:

    1. Unplugging and plugging the monitor back in. Icons always default to the secondary monitor

    2. Moving the icons over to the primary monitor. Icons will move to the secondary monitor upon boot or any screen refresh

    3. Deselecting "auto arrange" for desktop icons; The icons will still go to the secondary monitor.

    I can't figure this out for the life of me and it's driving me crazy. There's no reason managing your screen setup should be this frustrating...

    pondělí 21. srpna 2017 8:59

Všechny reakce

  • tried multiple fixes

    Try using Win-P to find a solution?  Win-P PC Screen Only.  Then right-click Desktop and use Auto-arrange.  Then what does Win-P Extend do?  FWIW I have seen your symptom and that is how I fixed it but I wouldn't say that my monitors have ever switched from Primary or Secondary.  So fixing that Primary and Secondary thing may be more important to do first.  E.g. make sure that you are not confusing the screen identity with whether it is primary.  E.g. I think it is possible to have #2 as primary and then the workaround that I mentioned should work.  So, I imagine having #2 DVI and #1 HDMI is not the issue but whether  #2 DVI is allowed to be marked as primary and stay that way?

    Good luck



    Robert Aldwinckle
    ---

    pondělí 21. srpna 2017 21:46
  • Hi,

    According to your description, I find that some people have the similar issue. Please check the link below to get more information about the issue. Some methods you could have a try.

    https://answers.microsoft.com/en-us/windows/forum/windows_7-desktop/desktop-icons-move-from-main-screen-to-extended/7d066555-badd-4fc9-92ba-c5e05eb6a06e?auth=1

    Hope it will be helpful to you


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    úterý 22. srpna 2017 7:37
    Moderátor
  • When I use Win-P and set it to PC Screen only, all the icons move to the monitor that is displaying (DVI). After I extend the screen again over both monitors, the icons split back up. In the display settings, There isn't an option to designate which monitor is #1 or #2. Windows is defaulting the monitor with a DVI connection as the primary monitor.

    What's also weird is any new item added to desktop (such as I installing a new program) shows up on my main monitor (#2 DVI).

    • Navržen jako odpověď JDSMorton neděle 1. dubna 2018 1:46
    • Zrušeno navržení jako odpověď JDSMorton neděle 1. dubna 2018 1:46
    sobota 27. ledna 2018 22:22
  • When I use Win-P and set it to PC Screen only, all the icons move to the monitor that is displaying (DVI). After I extend the screen again over both monitors, the icons split back up. 

    Are you doing the Auto-Arrange step while there is one monitor?


    Robert Aldwinckle
    ---

    neděle 28. ledna 2018 4:31
  • I have the exact same issue. Were you able to find a solution?

    It just suddenly started 2 days ago.

    pátek 9. února 2018 7:51
  • i have a similar issue.  

    I can't control what goes on which monitor.

    The boot/sign in screen are on monitor two.  The 'type here to search' in its expanded form is on monitor two.

    I have two 32" TV displays... one is fed by DVI to HDMI and the other is fed by HDMI, both off the same graphics card.

    When i use the monitor numbering drag and drop on multiple displays, my monitor numbers will switch on the drag and drop, but when i 'identify' they remain the same.  Even when i switch cables in the back...   i'm not sure what's going on but i'd love to be able to set my main #1 monitor and have all the material i want displayed on that one, and use the secondary monitor as merely a secondary monitor.

    If anyone has any advice, that would be great.

    pátek 9. února 2018 16:25
  • When i use the monitor numbering drag and drop on multiple displays, my monitor numbers will switch on the drag and drop, but when i 'identify' they remain the same.

    That's normal.  The dragging of the icons in the Settings page is just to facilitate pointer movement to match the physical arrangement of the monitors.  The numbers have no bearing on which monitor is primary.  Use the Make this my main display checkbox to choose which one is primary.


    Robert Aldwinckle
    ---

    pátek 9. února 2018 17:47
  • I had this problem on two Displayport monitors daisychained.  Drove me crazy.  Then I found that if I went to Taskbar settings (right click on Taskbar)  and scrolled down to Multiple displays, I could make the desktop icons switch from monitor to monitor by changing "Show taskbar on all displays".  FWIW, I have the taskbar buttons on All taskbars, Always combining buttons and hiding labels.

    Go figure.

    pondělí 26. února 2018 3:22
  • I was able to resolve this problem by doing the following:

    1. Dock PC
    2. Unplug the HDMI cable cable from the back of display 2 (where the icons undesirably go to) 
    3. Undock PC
    4. Dock PC
    5. Plug display 2 back in 

    After doing these 5 steps, my desktop icons now stay on display 1, which is set as my primary display when docked. 

    pondělí 26. února 2018 20:34
  • I was able to resolve this problem by doing the following:

    1. Dock PC
    2. Unplug the HDMI cable cable from the back of display 2 (where the icons undesirably go to) 
    3. Undock PC
    4. Dock PC
    5. Plug display 2 back in 

    After doing these 5 steps, my desktop icons now stay on display 1, which is set as my primary display when docked. 

    pondělí 26. února 2018 20:34
  • I had the same problem and suddenly found a weird solution...   so simple it is actually almost funny.....

    select the desktop with your icons....   Ctrl-a...  (select all)  then put mouse cursor onto an icon , hold down the lh button and drag the icons to the other desktop...

    To a degree, you can lose a certain amount of sorting, but the icons all move to the other desktop .

    I am using a similar setup to you, but have the HDMI as primary and DVI secondary, but the icons were switched when I started an old game that used a different Vid resolution initially..  and I could find no way to get them back.

    I saw this thread and saw a comment about drag, and decided to try the drag/drop and it works....

    • Navržen jako odpověď Craigellachie pondělí 19. listopadu 2018 22:42
    neděle 1. dubna 2018 1:53
  • I came here looking for a solution to this annoying icon sorting issue but it seems there isn't any and what has been suggested are still workarounds.

    For me this issue happened especially when waking from sleep mode, all my icons would be scrambled on a single monitor. Also, if I would switch off my monitors without going in to sleep mode, my windows and icons would automatically move to the active monitor and at times completely mess up my icons locations.

    The only thing that worked for me was a cheap hardware gizmo:

    Look up: "monitor detect killer".
    Now turning the monitors on and off causes no change at all on the windows or icons configuration and it also works when waking up from sleep mode.

    Good luck.


    • Upravený GTP_racer neděle 1. dubna 2018 7:43
    neděle 1. dubna 2018 7:43
  • hi,

    i believe this issue can be solved by managing the desktop theme.

    try playing around with desktop icons and the theme as well.

    1. move all desktop icons to a folder and move that folder away from the desktop folder.

    2. click personalize

    3. click themes

    4. click desktop icons settings

    5. uncheck all boxes

    6. go to the primary desktop and create a new text file.

    7. test the project options between pc screen only / extend.

    8. does the desktop icon remain on the primary desktop?

    9. if yes, you can now reverse the steps.

    • Navržen jako odpověď gkhlim75 sobota 7. dubna 2018 15:50
    čtvrtek 5. dubna 2018 5:00
  • I had a similar problem and found that right-clicking on the #1 (primary) screen and choosing "View", then toggle between "Small icons" and "Large icons" solved the problem immediately. Hope it helps someone else if your problem was solved?
    • Navržen jako odpověď tbwill pondělí 18. června 2018 17:32
    středa 18. dubna 2018 9:50
  • Right click on your desktop

    Display settings

    (select the monitor you want to have all the icons on it (its 1 or 2

    Scroll down to Multiple displays and under it you will see "Make this my main display" check the box

    sobota 21. dubna 2018 20:07
  • IT IS ALREADY THAT
    pondělí 28. května 2018 8:43
  • Same thing I did and it worked the icons stayed there and you dont have to do anything to complicated...

    computer 101 drag and drop

    pondělí 4. června 2018 15:30
  • what the hell haha way too complicated. Drag and Drop
    pondělí 4. června 2018 15:32
  • What an absolutely useless and misleading reply, i bet 99% of the above have not changed that setting, now i know what caused it but MS need to make a small update to fix the problem with the other updates that should fix the first update

    The trouble started when i played around with "Task view button" normally i have it unticked but i ticked it and tried right clicking the task view and selecting "show windows side by side" nothing happen and i worked another hour on my pc it then got slogish i rebooted and voila MS easter egg all my icons are on the second monitor, and have to do ctrl+a drag them to the main i tried reversing backwards engineering but this is MS if every problem could be undone by doing the steps backwards MS would have to fire half of their staff and i can see the importance in having a OS that has more problems then President Bill Clinton telling a small white lie, i did not and so on, so i endorse MS ethics which is  make sure every update is flawed with at least 1 bug "BUT MAKE SURE IT DOES NOT START A AVALANCHE" meaning 1 bug turns into a nightmare MS is still working on that gl MS

    and could we please have a fix for the flawed task view and show windows side by side seems those steps turned a small issue into a bigger one

    Thank you 

    úterý 5. června 2018 13:42
  • Okay finally solved i did the same steps over and over meaning right click taskbar tick show task view right click task view tick show windows side by side and then just in case i made shortcuts for all my icons and put them on the screen without any rebooted no troubles ofc now i have to del the icons better save them this is MS = Must Save
    úterý 5. června 2018 14:23
  • I tried a couple of the other things in here, and this was literally the only thing that's seemed to fix it! I'll know for sure when I do my nightly reboot, but I was able to toggle between single display back to extended without my icons moving, which was a first.
    čtvrtek 7. června 2018 19:14
  • Use "DesktopOK"

    pondělí 25. června 2018 14:47
  •  I  moved all icons to the primary desktop then unplugged the second display's cable. Right clicked on thedesktop > View >selected Medium Icons. Then plugged the cable for the sec. display and it resolved the issue. Thanks TbWill.
    • Navržen jako odpověď silvio_dante pondělí 9. července 2018 8:12
    • Zrušeno navržení jako odpověď silvio_dante pondělí 9. července 2018 8:18
    pátek 6. července 2018 13:13
  • Here's a simple solution that work for me and I imagine it should work universally.

    1) Keep the second monitor connected

    2) Create a New Folder on the desktop where you want all your icons to appear

    3) Select all the icons and cut and paste them in the New Folder

    4) Cut and paste the icons from the New Folder onto the desired desktop

    • Navržen jako odpověď pens0r čtvrtek 28. března 2019 18:35
    pondělí 9. července 2018 8:16
  • I might have found the "real solution" and cause to this.

    https://support.microsoft.com/en-ie/help/12445/windows-keyboard-shortcuts

    On that site you can read:

    Ctrl + mouse scroll wheel - Change the size and appearance of file and folder icons.

    At the desktop the icons move to the other screen when I hold Ctrl and scroll up and back again when I scroll down.


    čtvrtek 16. srpna 2018 13:27
  • It really worked
    sobota 1. září 2018 20:58
  •  I  moved all icons to the primary desktop then unplugged the second display's cable. Right clicked on thedesktop > View >selected Medium Icons. Then plugged the cable for the sec. display and it resolved the issue. Thanks TbWill.

    Doing this worked for me, and it was the only thing that worked.

    • Navržen jako odpověď Bio-Nerd čtvrtek 31. ledna 2019 23:38
    středa 17. října 2018 14:44
  • I had a similar problem and found that right-clicking on the #1 (primary) screen and choosing "View", then toggle between "Small icons" and "Large icons" solved the problem immediately. Hope it helps someone else if your problem was solved?

    this!

    it work!

    pondělí 26. listopadu 2018 18:10
  • Rather odd.  When I toggle to "medium icons" the icons move from display 2 to display 1.  If I chose large or small icons they appear,  in the corrrect size,  on display 2.  So I can have my icons where they should be on display 1 but in a medium size only!    The two monitors are identical and set to the same screen resolution.
    neděle 2. prosince 2018 7:59
  • The Easiest Way To Resolve this, and what has always worked for me is to align the Monitors side by side with the one that is set to primary (this is the Monitor that you want the Icons on) on the farthest left.

    Steps:

    Make sure the icons are on the monitor you want them to be displayed on. Many solutions are in this post how to do that.

    Make this monitor the Primary Monitor - regardless of the number MS assigns to it. Monitor 2 or Monitor 3 can be Primary. 

    Make sure under Taskbar Settings and Multiple Displays the Show taskbar on all displays is Off -slide the dot.

    Then drag the primary Monitor to the far left of the select and rearrange Displays setup, whether it is #1 #2 or #3.

    This should then always be the only Monitor with Icons Arranged on it.

    neděle 2. prosince 2018 13:43
  • I have exactly the same issue with 3 monitors. When my primary monitor is turned off, the icons move to one of my other monitors and stay there even when the primary monitor is turned back on. Windows scaling is also wrong too.

    This has been an issue for 18 months and happens every time the main monitor is turned off.

    It's a 4K U2879VF via DP, the others are 1080+DVI and <720p+HDMI

    středa 5. prosince 2018 16:38
  • Wow, this is the solution. Simple and straight forward, stirring us in the face. technology can be simple but we complicate it. This actually works for me, after several weeks of toiling and playing with my display, plugging and unplugging etc.

    Simple fix. 

    Thanks

    úterý 18. prosince 2018 15:53
  • I had a similar problem and found that right-clicking on the #1 (primary) screen and choosing "View", then toggle between "Small icons" and "Large icons" solved the problem immediately. Hope it helps someone else if your problem was solved?

    úterý 18. prosince 2018 15:53
  • Unfortunately the icon size toggle trick does not work for me. It simply swaps icons from one monitor to another, then puts them back on the wrong monitor.
    úterý 18. prosince 2018 18:24
  • I have about 50 icons on my desktop.  I tried the Auto Arrange suggestion.  DO NOT DO THIS.  It messes up everything.
    čtvrtek 17. ledna 2019 0:36
  • Yes, this is definitely a glaring bug. It happens to me as well. I don't understand why it's not taken care of. My icons are going to Monitor 2 no matter what I do.
    pátek 25. ledna 2019 21:30
  •  I  moved all icons to the primary desktop then unplugged the second display's cable. Right clicked on thedesktop > View >selected Medium Icons. Then plugged the cable for the sec. display and it resolved the issue. Thanks TbWill.

    Doing this worked for me, and it was the only thing that worked.

    I've been quietly going through the gambit of solutions proposed in this thread and this is the only one that has worked for me as well, +1. Can't believe this is even an issue in 2019.
    čtvrtek 31. ledna 2019 23:39
  • Yeah cool,

    Just lost 70% of what was on the desktop,


    pondělí 18. února 2019 1:25
  • Yeah cool,

    Just lost 75% of what was on the desktop,

    Don't try this!

    pondělí 18. února 2019 1:26
  • This process will need to be repeated several times a day, so not really a solution.
    pátek 29. března 2019 12:22
  • This only works for that instance, it has to be repeated daily. Not a solution.
    pátek 29. března 2019 12:23
  • This problem is so intermittent that I would consider it a bug. The best solution is just to select all your icons from the second screen, and them move it to your first screen.  This will save you the headache of unplugging cables, deleting caches and reconfiguring your O/S, which will temporarily work only for the problem to happen again.
    středa 22. května 2019 18:03
  • Hilarious!!!! I literally slapped myself in the forehead!! LOL 
    úterý 4. června 2019 14:58
  • Holy Crap (And other bad words). Googling and found a solution that works for June 2019.

    Moved all icons to primary screen. Made an empty folder on second and named it what ever (More bad words). Log off. Log on. All in proper location. Done.

    • Navržen jako odpověď Oliver_FuH pondělí 22. července 2019 10:27
    středa 12. června 2019 15:13
  • I use a laptop with a 2nd monitor plugged into the HDMI port. Tthe icons correctly stayed on my primary (laptop) screen until last week. The answer above worked for me, with an extra step at the start:

    1) On the 2nd/extended screen (with incorrect icons), right-click Desktop, View, set "Auto-arrange" (will re-order all the icons on the 2nd screen), then de-select "Auto-arrange".

    2) Windows+P, set to "PC Screen Only."  (2nd screen will not be used and the icons will appear on the main screen).

    3) Right-click Desktop, View, set "Auto-arrange" (will re-order all the icons again!), then de-select it.

    4) Windows+P, set to "Extend" (2nd screen will be used again, and hopefully the icons will stay on the main screen!).

    pátek 12. července 2019 11:41
  • I also struggled with this after a w10 update. I was able to finally fix it by setting the screen view settings to 'Align icons to grid'.

    Hope this helps someone

    sobota 20. července 2019 13:28
  • Sir, 

    only the best words for you! This was annoying me to no ends, ever since Win10 started to behave in that odd that way. But the empty folder suggestion is what cured it. Many thanks for sharing this pain reliefer. 

    Brilliant, really.

    pondělí 22. července 2019 10:27
  • Just experienced the same issue (after W10 update) and tried:

    - making sure all aspects of computer were updated

    - r-click desktop - display settings - Identify displays and making sure screens were numbered correctly - scrolled down - "make this my main display" checked (while on main display)

    - r-click desktop - view - switching to large, or medium icons (worked) but as soon as I switched back to small the icons moved to 2nd screen

    - r-click taskbar - changed all settings (one by one) with no effect

    THEN 

    - Ctrl + mouse scroll wheel. Couple rotations and we are back to normal!

    The fact that all this effort is just expected to be applied to fix what breaks in updates is ridiculous (imo) 

    Thank you Aron J for the solution that fixed my issue!! 

    • Navržen jako odpověď georgi55 středa 16. října 2019 21:52
    středa 28. srpna 2019 12:35
  • Hi.

    This solution worked for me. Thank you. :)

    čtvrtek 29. srpna 2019 3:35
  • THEN 

    - Ctrl + mouse scroll wheel. Couple rotations and we are back to normal!

    Holy cow life saver! Thank you!
    • Upravený georgi55 středa 16. října 2019 21:52
    středa 16. října 2019 21:51
  • OLD POSTs new solution.

    1) the CTRL+ScrollWheel  seems to work any time sending and getting back from main to secondary.

    BUT

    Got the luck and found the exact problem:
    My Taskbar setting "hide in desktop mode" get unchecked when this happens
    (no reason given)

    2 )  --->>> If I go to Taskbar setting, recheck it .... instantly the icons goes back to main display.
    (no reason given)

    I never found this solution on the web. 
    Found it on my own by chance few months ago
    (we can agree: Windows10 sucks)

    Hope it help
    Alain 
    pátek 18. října 2019 11:50
  • THIS ACTUALLY WORKS!!! 

    THANK YOU SO MUCH!

    sobota 26. října 2019 17:37
  • You only need to adjust your resolution to 100% on each screen...:) and you ll see the magic!
    úterý 12. listopadu 2019 18:18
  • Not sure if this will help anyone but this was happening for me too, so I right clicked the shortcuts on each desktop to see the file path. The shortcuts that had moved to my second monitor were in a different folder (C:\Users\Public\Public Desktop) instead of the normal folder (C:\Users\[name]\Desktop) 

    Moving them from the public desktop folder to the normal one instead of dragging them between monitors is what helped me :) 
    • Navržen jako odpověď KellyHB pátek 15. listopadu 2019 16:55
    pátek 15. listopadu 2019 16:55