SP3 \WINDOWS\inf\biosinfo.inf is corrupt or missing RRS feed

  • Dotaz

  • Please Help!!!,

    I am a Dell M170 Laptop owner. I had Windows XP Media Center SP2 installed on it.

    I say 'had' because, after I attempted to install SP3, after it claimed to install successfully and require a reboot the following text displayed:

    Windows could not start because the following file is missing or corrupt:


    I have attempted to use the OS disk to enter Repair mode. I have enabled this mode I have executed teh commands:


    Chkdsk C: /r

    and exited. Still the message persists.

    I have copied biosinfo.inf from the windows disk and reboot: Failure
    I have copied biosinfo.inf from a working Windows XP media center SP2 computer and placed it on the C: drive of my PC: Failure
    I found an old HDD from this M170 that had SP2 installed on it. I swapped HDDs, boot up, installed ALL updates, with the exception of SP3. I then copied the biosinfo.inf from this HDD to a flash-drive. Then installed the HDD with the failed SP3 installed on it, I used the OS Disk to boot into repair mode and copied the biosinfo.inf from the flash-drive to C: and rebooted: failure

    I have used the OS disk to install Windows in the existing OS and 'Repair' the OS: Failure.

    I need help!!!

    Also, why on earth would Microsoft release an installer that has been so catastrophic to the Windows OS community.

    I am an IT professional and of the 6 computers that I have attempted to install SP3 5 have failed.

    Dell Dimesion 2350 P4 1 Gig Ram XP Home: Success
    Compaq Presario SR1620NX AMD Sepron 512 meg Ram XP Home: Failure
    Dell M170 XPS Laptop P4 2 Gigs Ram XP media center: Failure
    HP a1710n P4 2 gigs RAM XP Pro: Failure
    HP a1710n P4 4 gigs RAM XP Pro: Failure

    Again, your help would be greatly appreciated.
    pátek 9. května 2008 18:46

Všechny reakce

  • I just ran into the same issue.

    I fixed the issue doing the follwing:

    boot of Bart's PE Builder and enabled disk sharing.

    I then went into the following directory on my boot partition:


    I copied the file biosinfo.inf and pasted it into the c:\windows\inf directory.  I then right clicked on the file and selected install.

    I found that the biosinfo.inf file created in SP3 is a little larger then the original from SP2.


    This should get you fixed.

    pátek 9. května 2008 23:28
  • Here is another microsoft Kb addressing this if the other sugguestion does not work





    sobota 10. května 2008 4:36
  • This seemed like the most promising suggestion.

    However, after I created a boot cd using: Ultimate Boot CD for Windows, I was able to load a version of Windows XP and then browse the C:\ drive of the HDD that has Windows XP SP3 installed on it. I.e. the one that gets the error message when I attempt to load Windows XP Media Center Edition.

    But the following folder:


    Is vertually empty. there is a folder: lang

    But it is also empty. I.e. there are NO files in either of these folders. Yes, I have show hidden files and folders as an option. But there's nothing there.

    Any additional help would be greatly appriciated.

    Thank you.

    pondělí 12. května 2008 17:26
  • Hey Vik

      Hmmm your system is perhaps one of the dual partion disks. Originally designed to be booted from the back incase of emergency. I would check your systems original documentation. Some laptops were designed this way.


      Another way are there any files in the dllcache?

      Copy the biosinf.inf from a floppy disk to your harddrive using the recovery console.


    Only thing I could think of is use another Cd,  then change your key to your original Key as assigned to your computer.

    Not recommended but this would work. As long as you change to your registered version of Sp2. Or original installation key. *Not a Microsoft approved method*




    středa 14. května 2008 3:51
  • I tried a lot of things:

    All the suggestions contained in this tread. Copying biosinfo.inf from

    a similar computer with XP Media Center installed on it that had successfully installed SP3
    my windows OS disk that came with the computer.
    From the above mentioned ServicePackFiles Folder (Which as I said was empty on this PC but not on a similar PC)

    to a flash drive

    From which I copied to the path: C:\WINDOWS\inf\

    I then rebooted and experienced the exact same error.

    I then repeated this process and Using Bart's PE CD-Boot disk I then installed it as mentioned above

    I then rebooted adn experienced the exact same error.

    I compared different versions of the file biosinfo.inf using ultraedit. They are ALL identical. This includes the original file that was on the PC when the error first appeared.

    In short this error message is a RED HERRING. It is a symptom of the problem, NOT the cause. As for what caused it:

    I do NOT have a recovery partition on the PC. It is NOT an AMD processor it is a P4. This is a DELL XPS M170 not an HP or Compaq.

    The problem was, and I'm guessing here, is the anti-virus and/or spyware software installed on it. Namely McAfee and SpywareDoctor.

    However, a user such as myself should NOT be expected to have to uninstall such software to install updates to the OS from Microsoft. That is simply unacceptable. Microsoft needs to t/s known enviroments such as this with off the shell anti-virus and spyware programs.

    I have since re-installed the OS and installed SP3 successfully. This unfortunately has taken from me 7 days of my life which I will never get back.

    I am NOT impressed in the least.
    středa 14. května 2008 14:59
  • Fixed for me by booting the recovery console and copying the file from :




    to C:\Windows\Inf


    The system then booted and, with great humour, asked if I would like to use automatic updates from now on.


    I declined.




    středa 14. května 2008 21:58
  • Hey - just to say - after looking around after my initial panic and borrowing a laptop and a XP CD i found your post - it looked good so i tried it and my PC came up after a couple of hairy reboots but that may be down to me adding new drivers this morning - BIG THANKS sound advice.


    neděle 18. května 2008 13:56
  • THANK YOU!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    Saved my life!!!!!
    středa 2. července 2008 6:21
  • Thank mstanton07. Your post on 10 may 2008 did it for me!

    sobota 18. října 2008 20:50
  •  vikingjay I am having the exact same problem as your last post, I was interested to hear what you ended up doing to resolve it...I feel I have tried everything, I have no interest in saving any information, I just want windows to come back up somehow...If you have any advice please let me know
    sobota 3. ledna 2009 22:16
  • Ok, on a FRESH install of XP SP2, I used Windows update, had it update to SP3, and then I received the '\WINDOWS\inf\biosinfo.inf is corrupt or missing' error. Mine was a bit different as it was '\WINDOWS\system32\\inf\biosinfo.inf'. (the path is weird, wasn't a typo)
    I tried the NTFS4DOS, no go. I tried everything else and nothing worked. Here's what I did to make it work, and I think it's total BS that MS hasn't fixed there SP3 Installer! Since I never give up, after 14 hours of trying to fix it, I got it...

    Completely reinstalled XP (Sp2). Used windows update to install sp3. BEFORE reboot, copy the file from c:\windows\i386\biosinfo.inf  into c:\windows\system32 and
    c:\windows\system32\inf\biosinfo.inf (just in case, and I had to make the inf folder).

    Anyone looking for help won't know this may happen, I understand that, but in all my efforts, if they read my post, it will save them hours of screwing around, compared to a winxp reinstall ;)

    Hope this helps, and I thank everyone for there posts, here and elsewhere.


    neděle 20. prosince 2009 9:13
  • Ok, I had the same problem while doing an XP Windows install.  I tried numerous programs to reset the MBR but nothing worked.  I then thought I would try loading my Kubuntu 9.10 disk to see if the system would run Kubuntu.  Kubuntu loaded without any problems and ran on the Dell laptop.  I then tried reloading XP with a fresh image and low and behold, it went in and worked.  It appears that the error message /windows/inf/biosinfo.inf is a symptom of a corrupt MBR that can not be fixed easily using conventional windows tools or by reloading and formatting the drive prior to installing.  Give the Kubuntu 9.10 a try,, then loading XP.  I am sure you will find that after running kubuntu that this fixes the problem.  As a side note.  I searched for 3 or 4 hours to find someone that has fixed this problem and I could not find anyone with a good fix.  I am sure this works!!!!  It fixed my problem with /windows/inf/biosinfo.inf missing or corrupt.  Be sure to let kubuntu use all of the drive.

    sobota 24. dubna 2010 4:07
  • Good advice rockman777.

    I've use my Ubuntu CD (Hardy Heron to be exactly). I tried various things but this one really works. I first install Ubuntu (almost 15 minutes, up and running) and then reinstall Windows. It works!!!

    čtvrtek 22. července 2010 7:11