Win7 Pro w/XP Mode RC - "auto publish" not


  • Win7 RTM with XP Mode RC installed, and everything works well out of box, including the integrations features that come preinstalled/configured.  However, I can't successfuly run an enapsulated app from the Win7 start menu b/c within the XP Mode settings, the "auto publish" option is greyed out saying it's not available.  Any suggestions?
    5. října 2009 18:18

Všechny reakce

  • That setting is only settable when the virtual machine is in a fully shut down state.  (It defaults to on)

    To have an app autopublish, the easiest is to just put it in the "All Users" Start menu.

    Bob Comer - Microsoft MVP Virtual Machine
    5. října 2009 20:14
  • thank you for your reply.  Unfortunately I've addressed both of your points and still no luck.  In reverse order, the details are:

    I did already put the app shortcut in the "C:\Documents and Settings\All Users\Start Menu\Programs" of the guest OS (the RC of XP Mode downloaded from Tech Net ~10 days ago) and it is indeed visible from the start menu of my host OS (Start > All Programs > Windows Virtual PC > Windows XP Mode Applications), but then I get the following error message when I try to lauch it from Win7: "Cannot start virtual application:  Either the required update is not installed in the virtual machine or virtual machine is running an operating system version which does not support running virtual applications"

    okay so i loaded up XP Mode, went to "Ctrl-Alt-Del" and selected "shut down".  Then, from the Win 7 start menu I went to "Windows Virtual PC" and can see my "XP Mode" is listed as "powered down" in the "Machine Status" column.  From there, I can highlight XP Mode, open settings, but "Auto Publish" is still greyed out.  The error message is the same: 

    - "the feature is not available for the virtual operating system"
    - "required updates are not installed in the virtual operating system"

    I just installed the RC for both Windows Virtual PC and XP Mode in the last two weeks.  If I fire up XP Mode again and go to "tools", only "disable integration features" is an option, "upgrade" is not an option.


    Thanks in advance for any help you can offer.
    5. října 2009 20:42
  • Hi,


    Is there any update or feature removed before the issue occurs? Auto Publish should be available after installing XP Mode.


    Let's test following steps:


    1. Start the Windows XP virtual machine (VM).

    2. If Windows Virtual PC Beta was used with this VM, uninstall the Integration components (Click Start, click Control Panel, click Add or Remove Programs, and then click Virtual PC Integration Components) in the Windows XP VM. (A reboot may be required)


    3. Also uninstall the RemoteApp update (Click Start, click Control Panel, click Add or Remove Programs, and then click Hotfix for Windows XP (KB961742-v3)). Reboot the virtual machine.


    4. Install the latest integration components in the virtual machine from Tools->Install Integration Components.

    5. Download the Update for Windows® XP SP3 to enable RemoteApp™ to the VM.


    6. Double click on the file to start the installation. Follow the instructions on the screen. Restart your virtual machine to complete installation.


    Now test if Auto Publish can be enabled.

    6. října 2009 2:56
  • Shaon,

    Thank you for the suggestions.   I did as you prescribed, including after your "step 6" "enable integration features" from within the rebooted VM (XP Mode).  Still no luck.  I then used "ctrl-alt-del" and shut down the VM.  From within the Win7 host, went to Virtual PC settings of the XP Mode vm and "auto publish" is still not selectable. 


    Thanks again for the suggestions.

    8. října 2009 20:21
  • I'm going on a hunch right now, but I think that perhaps Windows 7 Professional does not allow Auto Publish applications. I installed two virtual machines, one Ultimate and one Professional and the Ultimate VM has no warnings. The professional one has a warning saying the virtual os doesnt support it. Interestingly the only VM that I've gotten to show a virtual application on is the Windows 7 RC build 7100 virtual machine.

    I'll keep experimenting to see if I can get Win 7 Professional to auto publish

    9. října 2009 1:09
  • appreciate the info...although i'm running Win7pro RTM, i would imagine that it didn't change between the RC and RTM.
    9. října 2009 5:42
  • >I'm going on a hunch right now, but I think that perhaps Windows 7 Professional does not allow Auto Publish applications.

    I'm pretty sure it does, but I don't have a W7 Pro install right now to check.

    I do know that the option to auto publish is only available if the VM has the current integration components installed and the VM is shut down properly.

    You might try uninstalling the integration components and reinstalling them, maybe they didn't install correctly the first time.

    Bob Comer - Microsoft MVP Virtual Machine
    9. října 2009 13:00
  • unfortunately I did that in the previous attempt but, alas, no work-o.  any other thoughts? please don't say virtualbox.

    Thanks again for everyone's help.
    13. října 2009 21:00
  • I can't think of anything more right now, but I'll think about it. (and maybe set up a Win7 Pro to test with this weekend...)

    Bob Comer - Microsoft MVP Virtual Machine
    13. října 2009 21:22
  • As said Windows 7 Professional should support Auto Publish as a host system. However all steps we can try is provided in my previous reply. Maybe we can test to remove Windows Virtual Machine, reboot and reinstall it to see the result.
    14. října 2009 9:48
  • I installed Windows 7 Ultimate, then installed VS2010 beta on it and the Auto publish worked fine.

    Not sure about the Windows 7 Professional VM though. It's still saying "Not Available" under the Auto Publish option on settings. I did everything the same so no idea why its behaving different (if it indeed supports Auto Publish)

    14. října 2009 10:14
  • I have installed Windows 7 Enterprise and autopublish option is "Not Available" and I also tried all suggested things mentioned. I hope anyone can help with more options.
    15. října 2009 4:21
  • Auto-publish is not supported on windows 7 professional as guest as mentioned here.
    15. října 2009 9:41
  • hi Mario,

    autopublish should work on Windows 7 enterprise as guest. are you sure that you have windows 7 enterprise and not professional.

    also can you help up with the following information.

    1. have you installed "integration components".
    2. what is the version number of windows 7 that you have installed in the VM?
    15. října 2009 9:47
  • Hi Palash

    I really downloaded WIndows 7 Enterprise from MSDN with an activated license.

    1. I checked and the integration components in the virtual machine are installed.
    2. I have a Windows 7 Enterprise 32 bit edition.

    The error says:
    This feature is not available because one of the following issues:
    - Feature not available on virtual operating system
    - Necessary updates are not installed on virtual operating system

    20. října 2009 4:27
  • My hardware is an HP 6910p with Intel Core 2 Duo T7300@2.00 Ghz, 4Gb RAM (3Gb available)
    20. října 2009 4:29
  • In about info of the operating system says:

    WIndows 7 Enterprise
    Ver 6.1 (7600 compilation)

    My lap has a 3.1 windows experience.

    20. října 2009 4:33
  • Please check the logon account in the guest system is in Administrators group.

    22. října 2009 9:13
  • Can you send the "System Summary" information from msinfo32. Just type msinfo32 on the search box, run it and copy-paste the "system summary" info here.
    23. října 2009 8:21
  • I have same problem with all RTM.  Just installed two days ago in Win7 Ultimate.  Never used RC.  First few apps seem to behave all right and are available in virtual mode in Win7.  After a couple more installations -- not sure if it matters how many -- the auto publish feature becomes unavailable with the same erroneous reasons that you've seen.  Can no longer run virtual apps in Win7 (although can run XP Mode).  In short, it starts out all right but fails at some point.  I've found no way to recover except to uninstall and start over -- very time consuming.  I've done everything according to installation instructions, and I've done it at least four times already and am getting weary.  Don't know if it's significant, but I notice that the icon for auto-publish in settings for the virtual machine on my computer is a generic one, while the icons for all other VM setting functions are explicit.  There's a bug here without any question.  Hope someone fixes it -- sooner rather than later.
    26. října 2009 5:40
  • Okay...just reimaged my laptop, replacing Win7 Pro (32bit) with Win7 Enterprise (32bit)...same problems. 
    26. října 2009 22:02
  • OS Name    Microsoft Windows 7 Enterprise
    Version    6.1.7600 Build 7600
    Other OS Description     Not Available
    OS Manufacturer    Microsoft Corporation
    System Name    OWENSLAPTOP1
    System Manufacturer    Dell Inc.
    System Model    Latitude D630
    System Type    X86-based PC
    Processor    Intel(R) Core(TM)2 Duo CPU     T7250  @ 2.00GHz, 2001 Mhz, 2 Core(s), 2 Logical Processor(s)
    BIOS Version/Date    Dell Inc. A16, 7/14/2009
    SMBIOS Version    2.4
    Windows Directory    C:\Windows
    System Directory    C:\Windows\system32
    Boot Device    \Device\HarddiskVolume1
    Locale    United States
    Hardware Abstraction Layer    Version = "6.1.7600.16385"
    User Name    owenslaptop1\user
    Time Zone    Central Daylight Time
    Installed Physical Memory (RAM)    2.00 GB
    Total Physical Memory    2.00 GB
    Available Physical Memory    1.35 GB
    Total Virtual Memory    4.00 GB
    Available Virtual Memory    3.12 GB
    Page File Space    2.00 GB
    Page File    C:\pagefile.sys
    27. října 2009 2:35
  • I solved my problem by uninstalling windows xp mode and virtual pc, I rebooted the machine and reinstall

    first windowsw xp mode
    Install Virtual PC'
    And reinstall my windows xp applications

    Now i have autopublish option available and working on windows 7 enterprise 32 bit

    27. října 2009 3:22
  • I have done this four times.  For a while it works, but before I'm finished installing everything I need (six applications), the auto publish option becomes available, and virtual apps that once ran don't.  The last time I did it, it was OK until just after the sixth installation -- I almost made it!  I'm completely convinced that there is a bug, that there's nothing I can do to make it work.  I've tried different orders of installation.  I've tried turning off the auto publish until when I'm finished with installation of programs.  I've installed but one program at a time and restarted the VM.  I've deinstalled and reinstalled Windows6.1-KB958559-x64.  (Yes, mine is Ultimate 64 bit.)  I don't know what else to try.  Each reinstallation of XP Mode is very time-consuming, and I have to give up and hope that someone at Microsoft realizes that this isn't working right and fixes it.  I'm wondering if the problem is related only to 64 bit versions.
    27. října 2009 10:42
  • I wonder if it's one of your apps replacing a dll or something is causing this.

    You could try enabling undo disks to see if it's the VM itself or something outside the VM.

    1. Install XP Mode
    2. Enable undo disks
    3. Install first app
    4. shut down VM
    5. check if setting is enabled
    6. shut down VM
    7. merge undo disk
    8. startup and install 2nd app
    9. steps 4,5,6 again.

    Keep doing this until the setting is not enabled, remember the app that did it, then close VM and discard undo disk.  Start VM and check to see if the setting is still not available.  If it's available, then it's the VM, and probably the app you just installed.  Keep installing your other apps (not the one that did it) to see if it reoccurs.

    I know this is time consuming,but maybe we can figure something out and if someone else here has that app, then we can test if it disables it on their PC's.

    Bob Comer - Microsoft MVP Virtual Machine
    27. října 2009 13:13
  • I'm certainly willing to undertake this lengthy process again if it would mean getting this problem solved.  Before I do, however, I'd like to let you know that the app that I had just installed when the Auto Publish became unavailable was an old PIM -- NetManage Ecco Pro 4.0.  Unfortunately I can't get this to install under either Vista or (now) Win7 and I have a lot of old info on it, so I need it.  The Auto Publish and virtual apps in Win7 worked until after I installed Ecco Pro.  Does this tell you what you need to know or do you want me to go through the undo disc routine above?  I'll await your response before I try anything and thanks.
    27. října 2009 14:09
  • I just downloaded Ecco pro, (the installers are downloadable if you register with the site), and I'll do some testing here to see if I can recreate the problem.

    It looks like they have a Vista Installer btw, I'll try that while i'm at it.

    Bob Comer - Microsoft MVP Virtual Machine
    27. října 2009 15:59
  • Although I guess it's not yet proven that the problem is necessarily Ecco Pro 4.0 (actually 4.01 with an upgrade that I have), if there is something available that enables an installation into Vista or Win7, I'd love to have it.  Would be one less app that would depend on XP.
    I really appreciate your effort.  It's beyond what I expected, and I'll await further information from you.
    27. října 2009 16:11
  • Unfortunately it didn't break my XP Mode VM, I was actually hoping it would so we could narrow it down. :(

    I'm still thinking it's a DLL problem on the guest, but it's going to be hard to find.

    I got the installers from

    You have to pay $10 to register for the site to get them though.

    The Vista 64-bit installer worked on my Win7 64-bit laptop, but it's a bit of a pain to install, just make sure to follow their directions and run as administrator.

    An no problem, glad to try and help, I like puzzles like this at times. <g>

    I'll continue to work on it...

    Bob Comer - Microsoft MVP Virtual Machine
    27. října 2009 16:29
  • I was able to find an installer from a different site and now have Ecco installed and running fine on Win7.  Thanks for that tip.  I'm going to remove and reinstall XP Mode and see what happens.  As I said in one of my earlier posts, the little icon next to the name description for Auto Publish in the list of settings for the VM is a Win7 generic icon on my computer, also a Win7 64-bit laptop.  All of the other little icons in the list of settings are descriptive and appear to be designed to the function.  This makes me suspicious that something hasn't registered properly in the installation of the VM -- on my computer.
    27. října 2009 17:36
  • Cool.

    Let us know if it happens again.  Also, are you on a domain joined computer and the VM is domain joined, or just straight workgroups?  That might make a permissions difference.

    It might well be something that's not registered properly.

    Bob Comer - Microsoft MVP Virtual Machine
    27. října 2009 18:07
  • I just finished a complete reinstall of XP Mode and apps.  I left out one app that I didn't consider to be vital.  So far it hasn't crashed and burned, and the virtual apps work as they should in Win7.  I'm going to live with it for a while and see how it goes.  That icon in the settings dialog box is still generic, but I don't have any way of knowing how it appears on other computers.  Thanks so much for your help.
    27. října 2009 20:48
  • You're welcome, I hope it stays working!

    There seems to be no way for me to post a picture of what I have, they prbably should add that capability some time, but mine looks like a page out of a magazine, picture on the left, a thinner shorter picture on the right, a column of text close to the middle on down to middle and right.

    Bob Comer - Microsoft MVP Virtual Machine
    27. října 2009 21:10
  • To others, as XP Mode RTM and Windows Virtual PC RTM are both released, try upgrade the RC on your computer if encoutner similar issue.
    28. října 2009 6:14
  • i resinstalled my machine with Win 7 Enterprise (was 7 pro) and downloaded the "RTM"/official XP mode last week and the problem remains.  it appears as if "auto publish" is available until I copy the application link into the guest OS start folder as directed.  After I test running the app from Win 7, it produces an error message and fails.  Then when I look in the Virtual Machine settings, auto publish is greyed out (even with the guest VM completely shut down).
    4. listopadu 2009 22:42
  • Respectfully, I had the same documented problem with Win7pro & XPmode RC that I did with a fresh install (just last week) of Win7enterprise & XPmode final.  Not sure then how the solution is to reinstall/reboot/retry. 

    XP mode, targeted to move the huge corporate install base off of XP (since hardly any migrated to Vista), needs to work without all this trouble.  Seems that widespread publicity of these problems could scare away that client base or move them from the usual "I'll wait until SP1 is released" to "I'll wait until SP2" or worse yet "Win 8".  Less concerning is that is just emboldens Mac fanbois, fuels their talented marketing team, and becomes fodder for the "upgrade to Mac" campain showing how their Windows XP/Vista/7 virtualization is far simpler (even if not "free").

    I'm not at that guy, but the last think you can expect in today's litigious society is a class action suit.  Can't you just see it coming?

    ...I'm still hoping for a real solution and appreciate the help from everyone.  Don't mistake me pointing out the obvious as anything other than frustration.  For the most part I like Win7 a lot -- much better than Visa and XP!

    5. listopadu 2009 19:49
  • Could it be that when I was in the XP Mode guest and installing the application that I didn't right click on the install package and "Run As" the Administrator?  The default is the guest user profile...could that be the problem?  If so, what is the default password of XP mode for the admin account?  I don't recall setting that up so I'm assuming it's the default.
    9. listopadu 2009 23:04