locked
Remote desktop full screen mode not going full screen RRS feed

  • Frage

  • Hi,

    Running Windows 7 RTM x64 on both my PC at home and my workstation at work.
    My PC at home has a square monitor and my work PC has a widescreen monitor.
    I used webapps (citrix) from home to get into work environment then remoted to my workstation.
    Since doing that, when I am physically at the workstation (at work), I can no longer remote desktop to servers in full screen mode.  Instead, it does a smaller window with "full screen settings".  Basically the full screen remote desktop is about 3/4 size of the monitor, not 100%.

    Any help appreciated.

    -thanks
    Freitag, 20. November 2009 14:25

Antworten

  • Hi,

    -Start "Remote Desktop Connection".
    -Click on "Options".
    -Click on the "Display" tab.
    -On "Display configuation" settings, you can change the "Remote Desktop Connection" display by moving the slider from "Small to Large".
    -By moving the "Slider" all the way to large, the display settings will automatically set to "Full Screen".

    Thanks
    • Als Antwort vorgeschlagen Dale Qiao Montag, 23. November 2009 09:08
    • Als Antwort markiert IT Dad Montag, 23. November 2009 17:01
    Samstag, 21. November 2009 07:05

Alle Antworten

  • Hi,

    -Start "Remote Desktop Connection".
    -Click on "Options".
    -Click on the "Display" tab.
    -On "Display configuation" settings, you can change the "Remote Desktop Connection" display by moving the slider from "Small to Large".
    -By moving the "Slider" all the way to large, the display settings will automatically set to "Full Screen".

    Thanks
    • Als Antwort vorgeschlagen Dale Qiao Montag, 23. November 2009 09:08
    • Als Antwort markiert IT Dad Montag, 23. November 2009 17:01
    Samstag, 21. November 2009 07:05
  • Setting slidebar to full screen did the trick, thanks!
    • Als Antwort vorgeschlagen Rohit Gopidi Donnerstag, 22. März 2012 20:26
    Montag, 23. November 2009 17:01
  • many, MANY thanks - this solved my problem with having to use the scrollbar on an RDP session using Win7 - it was REALLY becoming frustrating - AGAIN THANK YOU
    • Als Antwort vorgeschlagen rightvol Dienstag, 23. November 2010 03:00
    Mittwoch, 1. September 2010 15:10
  • thanks!

    Dienstag, 23. November 2010 03:00
  • Thank you very much.
    Donnerstag, 23. Dezember 2010 18:21
  • Hi,

    -Start "Remote Desktop Connection".
    -Click on "Options".
    -Click on the "Display" tab.
    -On "Display configuation" settings, you can change the "Remote Desktop Connection" display by moving the slider from "Small to Large".
    -By moving the "Slider" all the way to large, the display settings will automatically set to "Full Screen".

    Thanks
    This does not address the fact that this functionality is broken in basically all version of Remote Desktop Connection.  The real problem is that when you switch from RDPing into one machine with a given resolution, and then to another with a different resolution, it always remembers the last resolution, and so you end up with a mismatched RDP window that will not go full screen until you disconnect, then adjust the slider again.  FIX THIS!!! It's incredibly annoying.  The RDP client should re-detect each time it is connecting to any machine what the full screen resolution should be.   God this annoys me every single day.
    Donnerstag, 23. Dezember 2010 19:16
  • I'm with ya @jamieschmidt. Super annoying. For years this has been a problem. If I exit from full screen, I can never get it back, unless I disconnect and reconnect. I need daily counseling because of this. Remote Desktop Team: PLEASE have RD remember your favorite machines and allow you to go back to full screen without an exit. I wish you could also re-size in session, instead of seeing scroll bars.
    • Als Antwort vorgeschlagen IrfanAhmedz Samstag, 23. Januar 2016 09:32
    • Nicht als Antwort vorgeschlagen IrfanAhmedz Samstag, 23. Januar 2016 09:32
    Donnerstag, 23. Dezember 2010 22:36
  • You can - sortof - go back into full screen mode by pressing Ctrl + Alt + Pause/Break.  This allows you to switch without disconnecting and reconnecting, but there are two gotchas:

    1.  It actually doesn't change the resolution, so it may go into fullscreen mode with the blue bar at the top, but still have scrollbars at the side.

    2.  Most of the time when I actually want to do this I'm on a notebook which doesn't have a Pause/Break key!!  Makes it tricky

     

    I agree that it's kind of broken.  I'm often switching between different external monitors with different resolutions and I'm sick of having to always go to the display tab and click full screen.  I ALWAYS want it fullscreen!

    • Als Antwort vorgeschlagen ale_guilamo Donnerstag, 5. Januar 2012 13:11
    Sonntag, 9. Januar 2011 22:49
  • I seem to be suddenly running into this with XP.   Possibly an upgrade was pushed to my desktop while I was away from the office for a week.  In any case, I use Remote Desktop to get to all my lab machines and I used to get a small bar across the top with only pin/min/max/close buttons; no scroll bars needed.  I was at the full screen of the computer I remoted to.  Now my Remote Desktop always opens in an actual window, with borders on 4 sides, and I have to scroll to the bottom to use the START button or task bar, then I have scroll back to the top to fully see what's on the desktop.  This scrolling up and down, left and right, is a pain in the neck.  I read that I can change the saved RDP file, but I don't know what file that is or how to find it.  Do I have to save a different options file for every computer that I remote to? 

    Thank you, Nancy 

    Montag, 14. März 2011 15:20
  • Thank you!
    Mittwoch, 23. März 2011 16:14
  • I  have this problem too ... On Windows 7. 

     

    Dell XPS14 laptop ... No Pause Key ... No Break Key... (ctrl +alt + fn + F12) doesn't work.

     

    The thing that bugs me most is ..... What's changed and WHY?

    I've been using remote desktop for years and maximizing always used to send it to full screen.

    Now suddenly I can't go to full screen without exiting and resetting the screen size with the slide bar in the options!

    WHY ?!?!?!?!?!?


    Seems this has been broken in Windows 7. It still works fine as it used to on my old M65 running Vista.

    Why has this been broken in Windows 7? How come no one at MS noticed?

     

    The marked answer is not acceptable. Sure it works when you initially open the connection but if you minimize or restore the window the problem comes back as before.



    Montag, 4. April 2011 13:39
  • Ctrl-Alt-Pause!  Oh, perfect!  I kept "normalizing" remote desktop, only to find I couldn't go back to fullscreen by maximizing.  Thanks a lot!
    • Als Antwort vorgeschlagen NeosTotem Donnerstag, 22. November 2012 08:51
    Mittwoch, 6. April 2011 00:23
  • You can - sortof - go back into full screen mode by pressing Ctrl + Alt + Pause/Break.  This allows you to switch without disconnecting and reconnecting, but there are two gotchas:

    1.  It actually doesn't change the resolution, so it may go into fullscreen mode with the blue bar at the top, but still have scrollbars at the side.

    2.  Most of the time when I actually want to do this I'm on a notebook which doesn't have a Pause/Break key!!  Makes it tricky

     

    I agree that it's kind of broken.  I'm often switching between different external monitors with different resolutions and I'm sick of having to always go to the display tab and click full screen.  I ALWAYS want it fullscreen!


    The Ctrl + Alt + Pause/Break function worked great for me. Thanks !!!
    Donnerstag, 14. April 2011 15:46
  • For laptop users without a Pause/Break there is usually a function button (Fn) that will give you access to secondary key functions.  (Pause is in blue on my F12 key.)

    Ctrl+Alt+Fn+Pause

    This worked for me.

    Donnerstag, 5. Mai 2011 19:51
  • THANK YOU SO MUCH FOR THIS!!!!!!!!!!!! i was about to throw my brand new laptop out the window after leaving hate mail on my microsofty-friend's facebook wall. :) why would anyone not want to max/"full screen" ??????!!!!!!!!!!!
    Freitag, 6. Mai 2011 04:58
  • The CTRL + ALT + Break works for me too!! You must made my working life less frustrating. Thank you!
    Montag, 23. Mai 2011 05:46
  • I  have this problem too ... On Windows 7. 

     

    Dell XPS14 laptop ... No Pause Key ... No Break Key... (ctrl +alt + fn + F12) doesn't work.

     

    The thing that bugs me most is ..... What's changed and WHY?

    I've been using remote desktop for years and maximizing always used to send it to full screen.

    Now suddenly I can't go to full screen without exiting and resetting the screen size with the slide bar in the options!

    WHY ?!?!?!?!?!?


    Seems this has been broken in Windows 7. It still works fine as it used to on my old M65 running Vista.

    Why has this been broken in Windows 7? How come no one at MS noticed?

     

    The marked answer is not acceptable. Sure it works when you initially open the connection but if you minimize or restore the window the problem comes back as before.



    Hi, I'm on a Dell Inspiron N5010 and for me, the winning combination was Ctrl-Alt-Fn-F6. Toggles full screen and windowed screen.
    Mittwoch, 7. September 2011 00:16
  • Hi, I'm on a Dell Inspiron N5010 and for me, the winning combination was Ctrl-Alt-Fn-F6. Toggles full screen and windowed screen.
    And I'm on a Lenovo ThinkPad Edge, and for me the magic combo was Ctrl-Alt-Fn-P. Thanks!
    Mittwoch, 28. September 2011 01:01
  • Also, make sure the "Use all my monitors for the remote session" box underneath the slider bar is unchecked if you have two differing monitor resolutions, because it will select the smaller of the two in order to make it completely fit on both screens.  Likewise, if you switch from a larger screen height inside of your RDP session, you will still see the scrollbars because the RDP client recognizes the larger of the screens as the "Full Screen" option.

    There is definitely work that can be done to make this process less painful.  Step your game up, MS.

    Dienstag, 4. Oktober 2011 14:20
  • Thanks Buddy, It worked problem solved......
    Hi,

    -Start "Remote Desktop Connection".
    -Click on "Options".
    -Click on the "Display" tab.
    -On "Display configuation" settings, you can change the "Remote Desktop Connection" display by moving the slider from "Small to Large".
    -By moving the "Slider" all the way to large, the display settings will automatically set to "Full Screen".

    Thanks

    Sonntag, 9. Oktober 2011 04:35
  • It did the trick.  Great.  Thanks
    Donnerstag, 13. Oktober 2011 13:18
  • Thanks for the post, it helped me to recall the key combination.

     

     

    Sonntag, 30. Oktober 2011 18:48
  • I find that minimizing (the flat line icon) the remote window versus restoring down (the stacked windows icon) allows me to resume full screen mode.  It requires some retraining but works effectively.  Unfortunately I've been unsuccessful with any of the Alt-Fn-Cntrl solutions :(  Happy Holidays!
    • Als Antwort vorgeschlagen Pooka Head Montag, 28. November 2011 20:44
    Montag, 28. November 2011 20:44
  • thanq so much...
    Dienstag, 6. Dezember 2011 17:42
  • Hi,

    Thanks a lot, this worked for me.

     

    Freitag, 23. Dezember 2011 14:06
  • Please use the color depth of  the remote session as Hghest Quality (32 bit). this will fix it out

    • Als Antwort vorgeschlagen Ravishna Dienstag, 10. Januar 2012 03:42
    Dienstag, 10. Januar 2012 03:31
  • My XPS laptop takes cnt-alt-fn-delete as the combo to toggle full screen remote desktop
    Mittwoch, 22. Februar 2012 02:37
  • Thank you so much. This worked for me like a charm :)
    Dienstag, 13. März 2012 20:14
  • Thanks for information
    Mittwoch, 21. März 2012 07:02
  • Thanks for the information.. That Works !!
    Donnerstag, 22. März 2012 20:26
  • Thank you... it work for me
    Dienstag, 27. März 2012 08:18
  • Thank you very much. This has been an issue for me and that's all it took. Much thanks

    Dienstag, 3. April 2012 15:35
  • Ta muchly
    Montag, 21. Mai 2012 12:51
  • Thanks!

    This post must be marked as answer. ;)

    Mittwoch, 13. Juni 2012 14:13
  • Clutch.  Thanks for nailing that.  I am embarassed to have suffered through the issue so long.
    Freitag, 15. Juni 2012 05:31
  • Thank you, dariomartinezb!!!  After upgrading my VPN, I all of a sudden couldn't get the RD window to maximize, but Ctrl-Alt-Fn-F6 did the trick!!  Thanks for having the same laptop as well :)
    Samstag, 23. Juni 2012 16:40
  • Thank you very much. Today was the first time I used remote desktop in Win7 and I got this problem. I tried to do every other thing and saw the slider too, but never thought that moving it to the extreme will make it go full screen. 

    Thanks a lot, dude. Have a good day!


    Regards, Tan (A Monarch is honored in his own country; a learned man, throughout the world!)

    Mittwoch, 11. Juli 2012 07:28
  • Hi AaronThorpe,

    Thanks for the wonderful findings! I'm having quite a trouble with my RDP sessions if I've accidentally restored to windows mode, but with Ctrl+Alt+Break, this problem is solved :)

    Btw, Microsoft has released a hotfix to address this issue. It seems that this issue occur when running with the resolution of 1366 x 768 pixels. No wonder my home laptop running 1280 x 1024 pixels doesn't experience this problem, but my office laptop does. For those who cannot reset to full mode (eg. your keyboard doesn't have Break), this hotfix should help:

    http://support.microsoft.com/kb/2582172

    • Als Antwort vorgeschlagen WoodJB Montag, 29. Oktober 2012 16:16
    Montag, 30. Juli 2012 05:33
  • Thanks alot.
    Dienstag, 7. August 2012 17:54
  • Thanks ..

    This also works for me...

    Dienstag, 25. September 2012 13:21
  • Hi,

    -Start "Remote Desktop Connection".
    -Click on "Options".
    -Click on the "Display" tab.
    -On "Display configuation" settings, you can change the "Remote Desktop Connection" display by moving the slider from "Small to Large".
    -By moving the "Slider" all the way to large, the display settings will automatically set to "Full Screen".

    Thanks
    Thanks
    Mittwoch, 3. Oktober 2012 05:21
  • Nice one, did this by accident once, But for love or money could not work it out again..
    Dienstag, 23. Oktober 2012 08:15
  • This IS the REAL answer for the above mentioned problem. Thanks.
    Donnerstag, 25. Oktober 2012 08:59
  • Hi shgtss thx for awesome answer now my remote is full screen

    Dienstag, 30. Oktober 2012 04:40
  • Hi Thank for Valuable information
    Samstag, 3. November 2012 16:47
  • Hi,

    Please try the following

    Cntrl + Fn + Alt + insert

    • Als Antwort vorgeschlagen Charmy Vora Donnerstag, 15. November 2012 05:37
    Donnerstag, 15. November 2012 05:37
  • Ctrl + Alt + Pause/Break is exactly what I was looking for - thanks!  Note that on a notebook computer, you'll likely have to do Ctrl + Alt + Pause + Fn, since there's no separate Pause/Break key.
    • Bearbeitet Mark Riordan Donnerstag, 22. November 2012 19:58
    Donnerstag, 22. November 2012 19:57
  • Hi, If you don´t have pause key (Like my vostro 3450 and many others...) we´re screwed up, the only way is double clicking the title bar (windows basics), much for minimize like for full screen back.

    Now, if you have a multi-monitor this trick only works in the display where you started the full screen.

    As last resource you may restart your RDP connection with "mstsc /f" command to avoid reconfiguring your RDP like they said above

    Mittwoch, 5. Dezember 2012 17:33
  • Life saver, connect to up to 100 servers during a normal day and was pulling hair out. Virtual drink on its way to you

    Donnerstag, 4. April 2013 13:40
  • Thanks ...it works.
    Donnerstag, 1. August 2013 03:39
  • Thanks buddy........really helpful
    Dienstag, 27. August 2013 06:16
  • I am on a Lenovo ThinkPad X1, and my winning RDP fullscreen shortcut combination was Ctrl-Alt-Fn-B. Hope this helps someone!

    Donnerstag, 12. September 2013 07:04
  • Thanks
    Donnerstag, 12. September 2013 16:08
  • Great Work

    Thanks

    Samstag, 26. Oktober 2013 04:20
  • Hi Team,

    Currently Use office Windows 7 (32 bit) in my System but i want netmeeting from my Partner System use in Windows XP Service Pack 3 . so I wan't take remote or  trobuleshooting  Partner System Some Issue Citrix issue...

    I don't use Netmeeting  ......

    Windows 7 use  Run MSRA

    Not to take Netmeeting in Windows XP

    Regards,

    Subodh.

    Dienstag, 29. Oktober 2013 19:34
  • Thanks. its help me....
    Dienstag, 3. Dezember 2013 09:02
  • Thank you very much. Solved my problem. :)
    Samstag, 7. Dezember 2013 04:52
  • Thank you. It really helped me a lot.

    Ramesh

    Dienstag, 17. Dezember 2013 03:51
  • Thank You!! :)
    Freitag, 31. Januar 2014 23:46
  • THANK YOU!!! I was going nuts wondering what the heck happened!!! This provided resolution for me :)
    Dienstag, 11. Februar 2014 23:44
  • Thanks for the tip !!!  It helped me a lot .

    Samstag, 15. Februar 2014 18:08
  • Thank you
    Freitag, 9. Mai 2014 02:00
  • Ctrl + Alt + Pause Break works well for me. Thanks
    Donnerstag, 19. Juni 2014 11:22
  • simply perfect thanks for sharing.
    Dienstag, 24. Juni 2014 15:43
  • Try using Fn+Ctrl+Alt+B to switch between FULL SCREEN and Normal mode. I have an LENOVA T430 laptop that does not have PAUSE or BREAK key but using this option works. I believe Fn+B does the same job as that of BREAK.

    -Anil Dubey


    • Bearbeitet AnilDubey Donnerstag, 10. Juli 2014 18:30
    Donnerstag, 10. Juli 2014 18:30
  • EDIT -- Removing my old post, because I discovered it was false.

    I had a similar issue but with using a secondary monitor attached to my laptop (Lenovo T430) that was a higher resolution than the internal panel.  The Terminal Services window would always seem to either max out at the full screen resolution of my smaller panel when full screened on the big monitor... or would launch on my internal panel in full screen mode instead of the second monitor like I wanted.

    Solution to launch full screen on second monitor:

    • Launch terminal services client like normal.
    • Drop out of full screen into windowed mode and drag it over, fully, to the secondary monitor.
    • Close the terminal services client on the second monitor  (This seems to make it save the last position information so it launches on the secondary monitor on the next start)
    • Relaunch and change the Options > Display slider to full screen  (Verify you can also see your secondary screens full resolution  like 1920x1200 in my case)

    That works for me over DisplayPort or VGA.


    • Bearbeitet Phaxmohdem Dienstag, 18. November 2014 19:33
    Montag, 4. August 2014 16:35
  • I have registered here just to pay my thanks to you.

    It was an easy solution yet we search on the internet instead of looking all the available options...LOL!

    Thanks again!

    Sonntag, 28. September 2014 14:28
  • Thank you sir, appreciate it.
    Mittwoch, 29. Oktober 2014 23:38
  • Thank you!

    Solved my problem. 

    Donnerstag, 5. Februar 2015 05:07
  • Thanks

    Helped me a lot 

    Montag, 2. März 2015 18:36
  • Thank you.
    Freitag, 6. März 2015 08:21
  • Very helpful, Thanks
    Samstag, 1. August 2015 23:06
  • Thanks a lot!!!
    Mittwoch, 5. August 2015 05:55
  • Thanks. It worked...got me out of frustration...:)
    Mittwoch, 14. Oktober 2015 04:47
  • Thank you very much for this information KurtFrank. It saves my nerves.

    Donnerstag, 29. Oktober 2015 19:41
  • Hey there, even I felt annoyed everytime time I got the RDP screen back out of full screen, so as Aaron has said below, give it a try.. CTRL+ALT+BREAK/PAUSE(IF u have FN key to use the PAUSE/BREAK, then just hold down CTRL+ALT+FN, and press BREAK to go back to full screen without the hassle of disconnecting/reconnecting !!  let me know if it works for you.)

    There is a catch though with FN key -  first hold down CTRL+ALT, then press FN, then BREAK key.


    • Bearbeitet IrfanAhmedz Samstag, 23. Januar 2016 09:44
    Samstag, 23. Januar 2016 09:36
  • Hey there, even I felt annoyed everytime time I got the RDP screen back out of full screen, so as Aaron has said below, give it a try.. CTRL+ALT+BREAK/PAUSE(IF u have FN key to use the PAUSE/BREAK, then just hold down CTRL+ALT+FN, and press BREAK to go back to full screen without the hassle of disconnecting/reconnecting !!  let me know if it works for you.)
    Samstag, 23. Januar 2016 09:36
  • 

    Hey there, even I felt annoyed everytime time I got the RDP screen back out of full screen, so as Aaron has said below, give it a try.. CTRL+ALT+BREAK/PAUSE(IF u have FN key to use the PAUSE/BREAK, then just hold down CTRL+ALT+FN, and press BREAK to go back to full screen without the hassle of disconnecting/reconnecting !!  let me know if it works for you.)

    There is a catch though with FN key -  first hold down CTRL+ALT, then press FN, then BREAK key.

    Samstag, 23. Januar 2016 09:43
  • Hey there, even I felt annoyed everytime time I got the RDP screen back out of full screen, so as Aaron has said below, give it a try.. CTRL+ALT+BREAK/PAUSE(IF u have FN key to use the PAUSE/BREAK, then just hold down CTRL+ALT+FN, and press BREAK to go back to full screen without the hassle of disconnecting/reconnecting !!  let me know if it works for you.)

    There is a catch though with FN key -  first hold down CTRL+ALT, then press FN, then BREAK key.

    Samstag, 23. Januar 2016 09:45
  • Hey there, even I felt annoyed everytime time I got the RDP screen back out of full screen, so as Aaron has said below, give it a try.. CTRL+ALT+BREAK/PAUSE(IF u have FN key to use the PAUSE/BREAK, then just hold down CTRL+ALT+FN, and press BREAK to go back to full screen without the hassle of disconnecting/reconnecting !!  let me know if it works for you.)

    There is a catch though with FN key -  first hold down CTRL+ALT, then press FN, then BREAK key.

    Samstag, 23. Januar 2016 09:46
  • A comment, if not a solution

    1) Metro apps suck mooseballs. 
    2) RDP worlks just fine, but Local windows 7x maching thinks it's some kind of app that, even in full screen mode, when I mouse to the edge the whole RDP desktop 'slides' to one side, and Windows 8.1 on the local computer peeks it's head out from behind. Fail. Maybe there's a way to turn that off, but WTF- I don't have an (another) hour to chase it down. 

    Not at all helpful to you, thank you for letting me vent. 


    Dienstag, 2. Februar 2016 15:31
  • I know this post is super old, but if anyone out there still hasn't figured out how to solve this...When all else fails, LOWER YOUR SCREEN RESOLUTION, but not too much.. (in your computer, not RD settings) Test it out and see which one will do the trick. It worked for me after trying everything else out there!! I hope this helps someone!
    Samstag, 20. Februar 2016 00:29
  • Hi,

    -Start "Remote Desktop Connection".
    -Click on "Options".
    -Click on the "Display" tab.
    -On "Display configuation" settings, you can change the "Remote Desktop Connection" display by moving the slider from "Small to Large".
    -By moving the "Slider" all the way to large, the display settings will automatically set to "Full Screen".

    Thanks

    This does not address the fact that this functionality is broken in basically all version of Remote Desktop Connection.  The real problem is that when you switch from RDPing into one machine with a given resolution, and then to another with a different resolution, it always remembers the last resolution, and so you end up with a mismatched RDP window that will not go full screen until you disconnect, then adjust the slider again.  FIX THIS!!! It's incredibly annoying.  The RDP client should re-detect each time it is connecting to any machine what the full screen resolution should be.   God this annoys me every single day.
    Indeed.. this bug has been around forever.
    Montag, 22. Februar 2016 17:29
  •  Ctrl + Alt + Break worked for me, thanks.
    Mittwoch, 16. März 2016 16:40
  • thanks you so much !
    Donnerstag, 17. März 2016 06:43
  • Thanks it will works
    Freitag, 10. Juni 2016 07:17
  • Hi, I'm on a Dell Inspiron N5010 and for me, the winning combination was Ctrl-Alt-Fn-F6. Toggles full screen and windowed screen.

    And I'm on a Lenovo ThinkPad Edge, and for me the magic combo was Ctrl-Alt-Fn-P. Thanks!

    Thanks - this one worked for me!!!

    Donnerstag, 21. Juli 2016 14:32
  • That's the resolution of the laptop I have with the problem, will give this hotfix  a try - thanks!
    Donnerstag, 21. Juli 2016 14:53
  • It didn't work for me. None of this crap worked for me. The best I can do is make the taskbar double height on the remote machine and try not to get confused between the two taskbars that are now displayed. Thanks, Microsoft!
    Dienstag, 4. Oktober 2016 07:31
  • I have Windows 10.  This just started happening to me.  After reading all this, and jiggling so many options, I resolved it by unchecking the "Display the connection bar when I use full screen" option.  Was able to connect in full screen.  Next time, I just checked it again, and got my connection bar and the full screen functionality back.
    • Als Antwort vorgeschlagen DWhite42 Freitag, 9. Juni 2017 11:36
    Donnerstag, 27. Oktober 2016 20:04
  • THANK YOU!!!
    Sonntag, 18. Dezember 2016 22:34
  • You Rock!
    Donnerstag, 16. März 2017 22:58
  • HI Thankyou

    Remote Desktop Connection display settings

    Freitag, 24. März 2017 04:24
  • it's working for me.
    Donnerstag, 6. April 2017 17:52
  • I know i am replying to a very old post, but the steps given above worked. Thank you.

    Regards,

    Kranthi

    Donnerstag, 4. Mai 2017 14:27
  • This worked for me on Windows 10.

    Thanks, David

    Freitag, 9. Juni 2017 11:37
  • thanks.
    Freitag, 15. September 2017 17:37
  • Same!
    Mittwoch, 17. April 2019 04:18
  • @oO Z OX 0o - Thank you so, so much for adding this small, very important detail, to uncheck "Use all my monitors for the remote session". I was going nuts trying to find a solution how to solve this issue when RDP to a jump box and then RDP again to a different server. The servers resolution's can't be changed as the it was blocked by IT. 

    It is funny how after 9 years, since you posted the comment, this issue still exist!


    Samstag, 4. April 2020 02:06
  • Finally this helped me switch to full screen. Thanks a Lot!
    Freitag, 7. August 2020 13:44