none
Keine Verbindung zum Updatedienst, Windows 10 Enterprise, Version 1903, Domänenrechner RRS feed

  • Frage

  • Hallo in die (große) Runde

    Nach dem Upgrade auf Version 1903 kommt auf Clients, die Mitglied einer Domäne sind, keine Verbindung mit dem Updatedienst zustande. Es erscheint die Meldung: "Wir konnten keine Verbindung mit dem Updatedienst herstellen. Wir versuchen es später erneut..." Wird der Client aus der Domäne einer Arbeitsgruppe hinzugefügt, funktioniert der Update-Mechanismus. Es handelt sich um Windows 10 in der Enterpriseversion.
    Auch auf einem neu aufgesetzten System wird nach dem Domänenbeitritt der Updatedienst nicht mehr erreicht. Entfernt man den Rechner aus der Domäne, klappt es wieder!
    In der Domäne sind die administrativen Vorlagen für Version 1903 eingespielt. Auch nach Deaktivierung aller Gruppenrichtlinien kommt bei den Domänenrechnern keine Verbindung zum Updatedienst zustande.

    Über Hinweise und Tipps würde ich mich sehr freuen.

    Viele Grüße
    Uwe

    Montag, 30. September 2019 11:34

Antworten

  • Vielen Dank an alle, die sich an der Problemlösung beteiligt haben. Zunächst aber bitte ich um Entschuldigung, dass ich mich erst jetzt auf Eure Zuschriften melde, aber es gab kurz gesagt "unvorhergesehene Zwischenfälle".

    Die vorgeschlagenen Lösungen haben leider nicht zum Erfolg geführt. Die "Basics", die Fabian empfohlen hatte und auch die Empfehlungen von Winfried hatte ich alle schon vorher durchgespielt. Bisher hatte ich keinen WSUS, die Updates wurden also von den Clients direkt bei MS heruntergeladen. Da alle bisherigen Maßnahmen nichts brachten, habe ich einen WSUS aufgesetzt - auch das ohne den gewünschten Erfolgt!

    Mittlerweile habe ich das Problem gelöst:
    Da in der MS-Welt das Problem von keinem weiteren beschrieben wurde, handelte es sich also um kein globales, sondern es musste an einer Einstellung meiner Domäne liegen. Denn nur als Domänenmitglied trat der Fehler auf und auch nur auf den Clients, die das Mai-Upadate (Version 1903) installiert hatten.

    Lösung:
    Nach wirklich langem Suchen bin ich auf die Lösung gekommen: Das "Aufräumen" der Default Domain Policy hat zum Erfolg geführt :)

    Nochmals vielen Dank an alle für Eure Unterstützung
    Uwe


    • Als Antwort markiert bus_dd Mittwoch, 23. Oktober 2019 08:50
    • Bearbeitet bus_dd Mittwoch, 23. Oktober 2019 08:53
    Mittwoch, 23. Oktober 2019 08:50

Alle Antworten

  • Am 30.09.2019 schrieb bus_dd:

    Nach dem Upgrade auf Version 1903 kommt auf Clients, die Mitglied einer Domäne sind, keine Verbindung mit dem Updatedienst zustande. Es erscheint die Meldung: "Wir konnten keine Verbindung mit dem Updatedienst herstellen. Wir versuchen es später erneut..." Wird der Client aus der Domäne einer Arbeitsgruppe hinzugefügt, funktioniert der Update-Mechanismus. Es handelt sich um Windows 10 in der Enterpriseversion.
    Auch auf einem neu aufgesetzten System wird nach dem Domänenbeitritt der Updatedienst nicht mehr erreicht. Entfernt man den Rechner aus der Domäne, klappt es wieder!
    In der Domäne sind die administrativen Vorlagen für Version 1903 eingespielt. Auch nach Deaktivierung aller Gruppenrichtlinien kommt bei den Domänenrechnern keine Verbindung zum Updatedienst zustande.

    Habt ihr einen WSUS im Einsatz? Gibt es GPOs für den WSUS? Probier doch in einer Administrativen Commandline diese Befehle aus:

    net stop wuauserv
    net stop bits
    rd /s /q %windir%\softwaredistribution
    wuauclt /resetauthorization /detectnow
    5 Minuten warten, dann
    shutdown -r -t 0

    Nach dem Reboot erneut Windows Update aufrufen. Funktioniert es jetzt?

    Servus
    Winfried


    WSUS Package Publisher:
    https://github.com/DCourtel/Wsus_Package_Publisher
    HowTos zum WSUS Package Publisher
    https://www.wsus.de/wsus-package-publisher/
    GPO's: http://www.gruppenrichtlinien.de
    NNTP-Bridge für MS-Foren:
    https://github.com/JochenKalmbach/communitybridge
    GP-PACK - PRIVACY AND TELEMETRIE: http://www.gp-pack.com/

    Montag, 30. September 2019 12:05
  • normales Windows Update? kein WSUS?

    was meinen die Logs? (https://docs.microsoft.com/en-us/windows/deployment/update/windows-update-logs)

    schonmal versucht die Firewall total auszuschalten?
    Montag, 30. September 2019 13:18
  • Hallo Uwe,

    Fangen wir sicherheitshalber mit den Basics an:

    Ist der WSUS Server von einem Domänenmitglied aus per Ping erreichbar? nicht das sich mit der Namensauflöung etwas beim Upgrade verändert hat.

    Hast du den GPResult mal nach dem entfernen der Policys geprüft?

    Als letzte variante wäre mal alles Rund um die WSUS Client Config zu entfernen. Dafür nehme ich immer das folgende Script (Verwendung auf eigene Gefahr):

    @Echo off
    Echo ===WSUS Client reset by Fabian Niesen===
    Echo Stopping BITS
    net stop bits
    ECHO =Stopping Windows Update Service=
    net stop wuauserv
    timeout /t 30 /nobreak
    Echo =de-register wuaueng.dll=
    regsvr32 /u wuaueng.dll /s
    echo =Deleting AU cache...=
    del /f /s /q %windir%\SoftwareDistribution\*.* 
    del /f /s /q %windir%\windowsupdate.log
    echo =Registering DLLs...=
    regsvr32 wuaueng.dll /s
    REGSVR32 MSXML.DLL /s
    REGSVR32 MSXML2.DLL /s
    REGSVR32 MSXML3.DLL /s
    regsvr32.exe %windir%\system32\wups2.dll /s
    regsvr32.exe %windir%\system32\wuaueng1.dll /s
    regsvr32.exe %windir%\system32\wuaueng.dll /s
    regsvr32.exe %windir%\system32\wuapi.dll /s
    %windir%\system32\regsvr32.exe /s %windir%\system32\atl.dll 
    %windir%\system32\regsvr32.exe /s %windir%\system32\jscript.dll 
    %windir%\system32\regsvr32.exe /s %windir%\system32\msxml3.dll 
    %windir%\system32\regsvr32.exe /s %windir%\system32\softpub.dll 
    %windir%\system32\regsvr32.exe /s %windir%\system32\wuapi.dll 
    %windir%\system32\regsvr32.exe /s %windir%\system32\wuaueng.dll 
    %windir%\system32\regsvr32.exe /s %windir%\system32\wuaueng1.dll 
    %windir%\system32\regsvr32.exe /s %windir%\system32\wucltui.dll 
    %windir%\system32\regsvr32.exe /s %windir%\system32\wups.dll 
    %windir%\system32\regsvr32.exe /s %windir%\system32\wuweb.dll 
    ECHO =Cleaning registry...=
    reg delete HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v AccountDomainSid /f
    reg delete HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v PingID /f
    reg delete HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientId /f
    reg Delete HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientIDValidation /f
    Echo =Starting BITS=
    net start bits
    ECHO =Starting Windows Update Services=
    net start wuauserv
    Timeout /t 30 /nobreak
    ECHO =Reset Authorisation and Detect now=
    wuauclt.exe /resetauthorization /detectnow
    usoclient StartScan
    Echo =Fertig...=
    
    Danach einmal neustarten und nochmal versuchen.


    Viele Grüße
    Fabian Niesen
    ---
    Infrastrukturhelden.de
    LinkedIn - Xing - Twitter
    #Iwork4Dell - Opinions and Posts are my own

    Sonntag, 6. Oktober 2019 07:40
  • Vielen Dank an alle, die sich an der Problemlösung beteiligt haben. Zunächst aber bitte ich um Entschuldigung, dass ich mich erst jetzt auf Eure Zuschriften melde, aber es gab kurz gesagt "unvorhergesehene Zwischenfälle".

    Die vorgeschlagenen Lösungen haben leider nicht zum Erfolg geführt. Die "Basics", die Fabian empfohlen hatte und auch die Empfehlungen von Winfried hatte ich alle schon vorher durchgespielt. Bisher hatte ich keinen WSUS, die Updates wurden also von den Clients direkt bei MS heruntergeladen. Da alle bisherigen Maßnahmen nichts brachten, habe ich einen WSUS aufgesetzt - auch das ohne den gewünschten Erfolgt!

    Mittlerweile habe ich das Problem gelöst:
    Da in der MS-Welt das Problem von keinem weiteren beschrieben wurde, handelte es sich also um kein globales, sondern es musste an einer Einstellung meiner Domäne liegen. Denn nur als Domänenmitglied trat der Fehler auf und auch nur auf den Clients, die das Mai-Upadate (Version 1903) installiert hatten.

    Lösung:
    Nach wirklich langem Suchen bin ich auf die Lösung gekommen: Das "Aufräumen" der Default Domain Policy hat zum Erfolg geführt :)

    Nochmals vielen Dank an alle für Eure Unterstützung
    Uwe


    • Als Antwort markiert bus_dd Mittwoch, 23. Oktober 2019 08:50
    • Bearbeitet bus_dd Mittwoch, 23. Oktober 2019 08:53
    Mittwoch, 23. Oktober 2019 08:50
  • Am 23.10.2019 schrieb bus_dd:

    Lösung:
    Nach wirklich langem Suchen bin ich auf die Lösung gekommen: Das "Aufräumen" der Default Domain Policy hat zum Erfolg geführt :)

    Was genau hast Du aufgeräumt? Die DDP gelöscht?
    Servus
    Winfried


    WSUS Package Publisher:
    https://github.com/DCourtel/Wsus_Package_Publisher
    HowTos zum WSUS Package Publisher
    https://www.wsus.de/wsus-package-publisher/
    GPO's: http://www.gruppenrichtlinien.de
    NNTP-Bridge für MS-Foren:
    https://github.com/JochenKalmbach/communitybridge
    GP-PACK - PRIVACY AND TELEMETRIE: http://www.gp-pack.com/

    Mittwoch, 23. Oktober 2019 15:24
  • Nachtrag zur Lösung:

    Beim Erstellen einer Kopie der DDP gab es Fehlermeldungen zu Kontennamen und Sicherheitskennungen. Diese habe ich im ersten Schritt behoben, was zu einer fehlerfreien Kopie der Policy führte. Im zweiten Schritt entfernte ich aus der DDP die SSL-Verschlüsselungssammlungen, das dann zum Erfolg führte.

    Beste Grüße,
    Uwe

    Donnerstag, 24. Oktober 2019 13:46
  • Am 24.10.2019 schrieb bus_dd:

    Nachtrag zur Lösung:

    Beim Erstellen einer Kopie der DDP gab es Fehlermeldungen zu Kontennamen und Sicherheitskennungen. Diese habe ich im ersten Schritt behoben, was zu einer fehlerfreien Kopie der Policy führte. Im zweiten Schritt entfernte ich aus der DDP die SSL-Verschlüsselungssammlungen, das dann zum Erfolg führte.

    Danke für den Nachtrag. ;)

    BTW: Bei Mark gibt es einen Artikel, der ganz gut beschreibt, weshalb
    man in der DDP sehr wenig oder gar nichts konfigurieren sollte.
    https://www.gruppenrichtlinien.de/artikel/wiederherstellung-der-default-richtlinien/

    Servus
    Winfried


    WSUS Package Publisher:
    https://github.com/DCourtel/Wsus_Package_Publisher
    HowTos zum WSUS Package Publisher
    https://www.wsus.de/wsus-package-publisher/
    GPO's: http://www.gruppenrichtlinien.de
    NNTP-Bridge für MS-Foren:
    https://github.com/JochenKalmbach/communitybridge
    GP-PACK - PRIVACY AND TELEMETRIE: http://www.gp-pack.com/

    Donnerstag, 24. Oktober 2019 20:58