none
Intune Custom OMA-URI Policy for Windows 10 mobile RRS feed

  • Frage

  • Hello together,

    I need your help!

    I want to create a Custom OMA-URI Policy for Windows 10 mobile devices (Lumia 950) in Intune. With this this Custom OMA-URI Policy I intend to create a App White listening. So I choose this Custom Policy instead of the standard APP White listening Policy, because if I allow APP´s in the standard APP White listening Policy the inbox Apps like “settings” are denied. I can´t allow the inbox App “settings” with an URL in the standard App White listening Policy because there is no URL for the inbox App “settings”. With the Product ID of the inbox App “settings” normally I’m able to allow this App in the custom OMA-URI Policy but I doesn’t works.

     

    My OMA-URI Configuration in Intune : 

    OMA-URI Vendor:

     

    ./Vendor/MSFT/PolicyManager/ApplicationManagement/ApplicationRestrictions

     

    Config:

     

    <AppPolicy Version="1" xmlns="http://schemas.microsoft.com/phone/2013/policy">

    <Allow>

    <!—Allow App - Settings -->

    <App ProductId="{2a4e62d8-8809-4787-89f8-69d0f01654fb}"/>

    <!—Allow App - Camera -->

    <App ProductId="{f0d8fefd-31cd-43a1-a45a-d0276db069f1}"/>

    <!—Allow App - Photos -->

    <App ProductId="{fca55e1b-b9a4-4289-882f-084ef4145005}"/>

    <!—Allow App – Company Portal -->

    <App ProductId="{0B4016FC-D7B2-48A2-97A9-7DE3B5EA7424}"/>

    </Allow>

    </AppPolicy>

     

    This OMA-URI Policy Configuration above should allow only this four App´s (Settings, Camera, Photos and Company Portal) and deny all other App´s  but it doesn’t work´s.

    On my Windows 10 mobile device I can´t see any changes that the Policy is coming to my mobile device.

    Is there any Configuration mistakes in my Configuration ??

    I would be happy about every Answer to solve this Problem.

     

    Thanks!

    Montag, 20. Juni 2016 10:14

Alle Antworten

  • We have the same problem, did you find a solution?
    Donnerstag, 16. Februar 2017 14:40
  • Yes i solve the Problem. What is your Problem?? Do you have any Screenshots or Error Messages so i could help you.

    Donnerstag, 16. Februar 2017 15:12
  • Well we have a few problems here. For example on some devices the "Settings" app is completely missing. On others users can't download anything from the Store, even whitelisted apps. I don't know but these problems came with Windows 10 Mobile. On Win 8.1 Mobile everything was fine. What does your .xml file look like now? You said that you solved the Problem. What did you do?
    Dienstag, 14. März 2017 14:01