none
Sound and mouse choppy after using Remote Desktop in Windows 7 x64 RTM RRS feed

  • Frage

  • I have a peculiar problem that seems to be related to Remote Desktop Connection in Windows 7. Here's the repro:

     

    I connect to my Windows 7 Enterprise x64 RTM box using a Remote Desktop Connection.

    When I return to the console session (I log on to the computer when I' in front of it again), the sound crackles and stutters and the mouse is jerky and non-responsive when I browse the Internet in Internet Explorer (or Firfox).  This problem occurs in any music player (in Windows Media Player, or Winamp), and it seems unrelated to the sound card, because I tried two different USB sound cards and heard the same problem. The problem occurs with any mouse also.

     

    If I log off, or reboot, the problem goes away.

     

     

    Here's what I've tried:

     

    Installed the latest Realtek drivers – a scan from PCPitstop indicates the drivers are up-to-date – no change in the problem.

    Tried disabling the NVIDIA Hi-def components in Device Manager – no change in the problem.

    Tried using 2 different external sound cards – the problem is the same with any sound card or device.

    Installed the Codec lite pack – no change in the problem.

    As per http://www.intel.com/technology/serialata/ahci.htm, I tried setting the Msahci value from 3 to 0   – no change in the problem.

    Disabled speaker effects (enhancements) – no change in the problem.

    Reset the BIOS to the factory default settings – no change in the problem.

    Tried using different apps to play music –the problem occurs in all programs.

    Ran Hijack this to make sure nothing questionable is running.

    use Shell Ex View (http://www.nirsoft.net/utils/shexview.html) and disable all the "Groove" extensions.

     

    Thanks!!

     

     

     

     

     

     

    Specs:

     

    Video: NVIDIA GeForce GT 220 

    Sound: NVIDIA (Relatek) High Definition Audio 

    Processor Intel Intel(R) Core(TM)2 Quad CPU Q8200 @ 2.33GHz 

    Browser MSIE 8.0

    System OS Windows 7 Enterprise x64

    Mobo P5QL PRO  ASUSTeK Computer INC Version Rev 1.xx

    Main Board BIOS American Megatrends Inc. BIOS Date: 03/12/09 10:04:29 Ver: 08.00.14 A_M_I_ - 3000912 20090312

    Processor Clock Speed 2330 Mhz

    Graphics Description NVIDIA GeForce GT 220

    Memory Configuration 2048+2048+2048+2048;DIMM DDR Synchronous

    DVD-RAM Model HL-DT-ST DVDRAM GH22NS50

    Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Controller 
    Montag, 4. Januar 2010 19:05

Alle Antworten

  • Hi Darryl,

     

    I would like to confirm that have you tried to update the BIOS? Please also install all the important Windows Updates.

     

    If update BIOS also cannot fix the issue, you may try to perform the following steps to check the issue.

     

    1.    Start Remote Desktop Connection and click Options.

    2.    Switch to Local Resources tab and click Settings under Remote audio.

    3.    Point Play on this computer and click OK.

    4.    Switch to Experience tab and select Low-speed broadband (256Kbps – 2Mbps).

     

    After that, change the power plan for the host (problematic) computer to High performance to check the issue.

     

    What’s the result?

     

    Regards,


    Arthur Li - MSFT
    Donnerstag, 7. Januar 2010 07:16
    Moderator
  •  

    Thanks Arthur!!

     

    I tried a BIOS flash toe the latest BIOS and that made no difference. :(

    I set the Power plan to high performance but that made no difference either.

    I also compared reports from Hijackthis between the good and bad system states and saw nothing significantly different:

     

     

    I did the other things you suggested with RDP, but actually, now I'm not sure it's Remote Desktop Connection that triggers this. At some point during normal operation without including and Remote Desktop Connection, something on the system glitches out and the problem starts, and then only a reboot fixes the sound. It seems also that when the problem occurs, some programs  – such as Excel are slower (maybe I'm imagining this?)

    Also, I should add that Task Manager shows no high CPU or Memory consuming processes when the problem occurs.

     

    I also tried experimenting with shutting down processes during an episode of the problem to see if the problem would go away when I killed a process, but nothing seemed to resolve the problem – only the reboot restored the sound.

     

    Thank you SO MUCH for reading and considering this!!


    Darryl Gittins
    Sonntag, 24. Januar 2010 17:30
  • Curious how this thread was mared as resolved - it isn't resolved.
    Darryl Gittins
    Sonntag, 31. Januar 2010 16:44
  • Still no resolution.

    The sound crackles and stutters when the CPU is busy.  That is, when I open a Web page, or start a program, I hear pops and garbled sound if I’m playing music. The problem only happens after the system has been running for a while. A reboot fixes the problem, but then it eventually comes back. This isn't a driver problem (for me), because I have the same cracking sound after trying the onboard sound card AND using different USB sound cards. The problem occurs in any music player (in Windows Media Player, or Winamp).

     

    Here's what I've tried:

     

    Installed the latest drivers.

    Tried using 2 different external sound cards - 2 USB and a PCI.

    Installed the Codec lite pack .

    Disabled speaker effects (enhancements).

    Reset the BIOS to the factory default settings.

    Flashed the system BIOS

    Twiddled with every imaginable setting in the Sound panel in Windows 7

    Turned off Aero to use a basic theme
    uninstalled any energy saving software by asus or any software that is made by asus

    Darryl Gittins
    Sonntag, 31. Januar 2010 16:48
  • I found that by using the DPC Latency Checker V1.2.o, I can see that after system startup, latency is good (in the green levels), but after running a day or so, it's perpetually spiking (running in the red). This is when I hear the horrible crackles and stutters in my sound card.

     

     If I then disable the network adapter (NIC), latency immediately drops to green levels and sound is good. However, if I then enable the network adapter, it immediately spikes perpetually into the red and I hear the crackles and stutters.

     

    I have to reboot to reset the condition so that it's running in the green (so that I can listen to music without horrible crackles and stutters).

     

    I tried swapping the network adapter but I have exactly the same issue with both network adapters. I've also swapped several sound cards, video cards and such, updated the BIOS and all drivers and every other imaginable troubleshooting step.  

     

    This is driving me nuts!

     

    Thanks bundles for any suggestions!!
    Darryl Gittins
    Donnerstag, 4. Februar 2010 17:34
  • I have the exact same issue on two of my machines (one is Ultimate x64, other is Ultimate x86). I am sick and tired of trying to find ways to resolve this, so I will probably reinstall the systems some time later. I haven't found the cause of the problem either.
    Freitag, 9. April 2010 16:16
  • Hi,

    Having the same problems with a Q9550 on Gigabyte EP45-DS3P and Windows 7 Pro x64.

    Tested with DPC Latency Checker 1.2 and have > 8000us.

    I've read and tested all sorts of crazy workarounds that didn't work for me.

    Eventually I've reached the conclusion that this happens whenever the CPU switches either frequency or voltage so the power management of the CPU is to blame or maybe whoever controls it(ACPI driver maybe??).

    I've tried disabling various CPU power saving options from the BIOS and I eventually found one that fixed the problem. Disabling EIST drops the latency to more normal levels(<120us) and no spikes. 

    Now, this is just a workaround and I don't particularly like it since it increases power consumption considerably for a quad core CPU. But until a proper solution is found it's better than nothing. 

    I'm afraid this workaround is unusable for notebooks since they don't have that many options in BIOS but I'm sure desktop users will find this useful.

    Regards,

    Fum

    Montag, 19. April 2010 16:32
  • I just wanted to add my experience to this thread.  I've recently noticed this same behaviour with my system, with some exceptions.  My system can run for months on end without being restarted and never suffering from this issue.  After logging into the system with Remote Desktop, the next time I log on physically, the audio is messed up.  I too have even noticed that my mouse will lag a bit for a few minutes.  The only way to fix this is to reboot.

    The really strange part is that I don't ever recall encountering this issue before.  I haven't really spent much time looking into the issue but it happens consistently and seems tied to establishing a Remote Desktop session.

    System specs:

    ASUS P5E3 Wifi-n Premium
    Intel Q9550 @ 2.83 GHz
    8GB of Patriot Viper-series @ 1333MHz
    Windows 7 Ultimate x64 (with all updates applied)
    Using RealTek HD Audio
    NVIDIA GTX280
    LG Blu-ray burner
    Using the onboard Marvell Yukon 88E8056 Gigabit network adapter
    Using two LG monitors (1680x1050)

    Mittwoch, 4. August 2010 01:25
  • Are you logging off from the RDP session properly?

    You should always be going to the start orb and selecting logoff, not disconnect, and not by closing the RDP window.

    I know I'm risking telling you what you probably already know, but since it hasn't been mentioned yet, I thought I should..

    DAS

    Mittwoch, 4. August 2010 13:50
  • Are you logging off from the RDP session properly?

    You should always be going to the start orb and selecting logoff, not disconnect, and not by closing the RDP window.

    I know I'm risking telling you what you probably already know, but since it hasn't been mentioned yet, I thought I should..

    DAS


    That doesn't make any sense.  There should be no need to logoff to end the RD session.  I run VMWare Workstation and use RD to connect and access the VMWare console.  If I logoff instead of disconnecting, all running VMs will be terminated.  That is not an option nor is it necessary.

    Also, logging off and then logging on does not rectify the issue.

    I've never had to logoff to end a RD session to avoid audio issues before until recently.  This is more likely a driver or other issue that is triggered by the RD session.

    Donnerstag, 12. August 2010 02:48
  • Uh, yes, properly ending a session DOES make a difference.

    In the description below, "disconnecting" is accomplished by clicking the red "X" (close) in the terminal services window, or going to the start menu and selecting disconnect.  In fact the difference is by design, and is pretty adequately explained below. 

    Perhaps this applies to your situation, perhaps it doesn't.  All I know for certain is there are bonafide differences that will surprize those who assume the "X" or "disconnect" is equivalent to "LogOff".  This appears to address the OPs post, which was my goal.

    DAS

    Log off or disconnect

    Terminal Services provides two options when closing a client session: you can either log off or disconnect.

    Disconnecting leaves the session running on the server. You can reconnect to the server and resume the session. If you are running a task on the server, such as running a time consuming query on a database, you can start the task and disconnect from the session. Later, you can log back onto the server, reenter the session, and check the results. This is especially helpful when operating over a remote access connection on a long-distance toll line. For information about how to disconnect from a Terminal Services session, see Disconnect without ending a session.

    Network administrators can limit the amount of time a disconnected session is allowed to remain on the server. For more information, see Set time-out settings for disconnected, active, and idle sessions.

    Logging off ends the session running on the server. Any applications running within the session will be closed and unsaved changes made to open files will be lost. The next time you log onto the server, a new session is created. For information about how to log off from a Terminal Services session, see Log off and end the session.

    If printer redirection is enabled for the session, when the session is disconnected or logged off, the printer queue is deleted and any incomplete or pending print jobs are lost.

     

    Freitag, 13. August 2010 14:12
  • Uh, yes, properly ending a session DOES make a difference.

    In the description below, "disconnecting" is accomplished by clicking the red "X" (close) in the terminal services window, or going to the start menu and selecting disconnect.  In fact the difference is by design, and is pretty adequately explained below. 

    Perhaps this applies to your situation, perhaps it doesn't.  All I know for certain is there are bonafide differences that will surprize those who assume the "X" or "disconnect" is equivalent to "LogOff".  This appears to address the OPs post, which was my goal.

    DAS


    No one said there wasn't a difference between disconnecting and logging off.  I'm not sure how you inferred that from my post, as I clearly described the difference and even stated that logging off, which was the first thing that I tried, did not resolve the issue.  In this case, the way you end your session should not matter and initiating a logoff via the Remote Desktop session doesn't make a difference; i.e. tearing down the session and therefore any running user processes, doesn't resolve the sound issue.  The behaviour of the audio stack should not be affected by how you manage the session and it's only been recently that I've noted this audio corruption.  I was suprised to see others have noted the same audio issue after having connected via RD.  The only fix seems to be restarting the machine.

    If the OP's issue is the same as mine (and others that have posted), I can tell you now that logging off does not fix the issue.  This has me wondering if a recent update to Windows 7 (compatibility update, etc) has caused this.  I can reproduce the issue on both my development machines, which are nearly identical hardware-wise as well as patch-level.  I've also tried switching from the Microsoft HD Audio driver to the Realtek HD Audio driver with no change in behaviour.  I haven't tried playing with the RD audio configuration options, which is my next step.

    Freitag, 13. August 2010 15:46
  • Thanks very much for the info, folks! However, I've since concluded that my problem is not related to the RDP sessions. I stopped using RDP and I'm still experiencing the problem.

     

    The sound crackles and stutters when I open a Web page. I hear pops and garbled sound if I’m playing music. The problem only happens after the system has been running for a while. A reboot fixes the problem, but then it eventually comes back.

     

    I found that by using the DPC Latency Checker V1.2.0 (http://www.thesycon.de/deu/latency_check.shtml), I can see that after system startup, latency is good (in the green levels), but after running a day or so, it's perpetually spiking (running in the red). This is when I hear the horrible crackles and stutters. If I disable the network adapter (NIC), latency immediately drops to green levels and sound is good. However, if I then enable the network adapter, it immediately spikes perpetually into the red and I hear the crackles and stutters. I have to reboot to reset the condition so that it's running in the green (so that I can listen to music without horrible crackles and stutters).

     

     It's not a driver issue.  I've tried many drivers and swapped nearly ALL components out of my system and I see the same issue.

     I've swapped several different sound cards, internal and external. All have the same problem.

     I've swapped several different nics, including a USB wireless unit. Some are worse than others, but they all have the same problem. 

     I've swapped the Video Card.

    I even swapped the MoBo with a similar model.

    I tried a BIOS flash to the latest BIOS and that made no difference. :(

    I set the Power plan to high performance but that made no difference either.

    I also compared reports from Hijackthis between the good and bad system states and saw nothing significantly different.

     

    The only think I haven't swapped is the RAM, CPU and Power supply, which don't seem to be likely culprits for a sound problem.

     

    The only thing that affects the popping is a reboot, which resolves it for a few hours, or disabling the network adapter, which resolves the issue 100%, but I sort of need network access.  I'm thinking a reboot script in task scheduler to run each morning at the same time. (a command such as "shutdown -r -f -t 10" in a bat file).

     

    It sure seems inherent to Windows 7. Something to do with the way that Networking and Audio interfere with each other.

     

    Thanks again for reading this.

     

    Specs:

    Mobo P5QL PRO ASUSTeK

    Windows 7 Enterprise x64

    Intel Quad CPU Q8200 @ 2.33GHz

    Memory Configuration 8 GB DIMM DDR Synchronous

    NVIDIA GeForce GT 220 and GeForce 6200


    Darryl Gittins
    Dienstag, 31. August 2010 16:39
  • Good luck getting this resolved. I gave up on my system after replacing every component including the motherboard and Power Supply. So I foolishly went out and bought a new computer. An HP HPE-150f running Windows 7 x64. Guess what? Exactly the same problem. The only common factor is Windows 7 x64. The only workaround is to reboot the computer several times a day.
    Darryl Gittins
    Freitag, 8. Oktober 2010 15:06
  • I'd also like to clear up what's going on, I have all the same symptoms, (mouse glitches and blinks across the screen and sound is glitchy) but none of the same perceived causes. I'm in 32bit windows, and I don't use RDP ever at all. I'm dual booting Linux and windows 7 32bit professional on this machine, and Linux has no issues with the sound or the mouse, so I know the bios and hardware are all intact. I've also done the sound driver reinstall to no avail, restarted the audiodg.exe process, disabled the audiodg settings and such like everyone else. 

    What I ALSO tried that DIDN'T work was a system "upgrade." I stuck in my windows 7 cd and "upgraded" my system from windows 7 professional 32 bit to windows 7 professional 32 bit, hoping that any corrupted files would be eliminated. This did NOT work, and only served to goof up my master boot record.

    I suspect I have a slightly different case because I don't use RDP, I have 32bit windows and the problem doesn't go away after reboot. I have a HUGE processor, so I don't really like the idea of locking it into high gear when I'm not gaming, but I'll try it to see if it works.

    Donnerstag, 14. Oktober 2010 19:08
  • Microsoft virus scanners apparently can contribute to the problem. If you are running Microsoft Security essentials or Forefront, try this:

     

     
    1. Open Microsoft Security Essential or Forefront.
    2. Click the Settings tab.
    3. Click Excluded files and Locations
    4. Click Add.
    5. Select either of the following paths, depending on the scanner you are using:

     

    c:\Program files\Microsoft security essentials\MsMpEng.exe

    C:\Program Files\Microsoft Forefront\Forefront System\Client\AntiMalware\MsMpEng.exe


    6. Click Ok.
    7. Click Save changes.
    8. Close the scanner program, and then restart the computer.

     

    You might also try excluding other network intensive programs like iTunes.exe or iTuneHelper.exe.

     

    For more on this, see the following:

    http://social.answers.microsoft.com/Forums/en-US/msestart/thread/0519ba5e-f3d8-4caa-a193-01fea178aa4f


    Darryl Gittins
    Sonntag, 9. Januar 2011 22:22
  • Thread necro!!

    For anyone having audio/choppiness issues when you have an active RDP session, unload the Realtek driver:

    https://neosmart.net/wiki/fix-realtek-audio-delay-lag/

    Sonntag, 5. Mai 2019 20:22