none
.RDP files won't open (remote desktop) after Win10 Anniversary Update RRS feed

  • Frage

  • After the Windows 10 Anniversary Update was installed on my Windows 10 Pro, .RDP files won't open. Remote Desktop still works if you open it manually and enter in the server info. But my saved .RDP files won't open. Also, right clicking on them and selecting edit also does not work. Nothing happens. I even opened Remote Desktop connection, entered in the server info manually and clicked Save As. That shortcut also won't work. Any ideas on what's wrong? Thanks.
    Mittwoch, 3. August 2016 14:08

Antworten

  • *************************************************************
    WORKING FIX   --  I have received reports that this works:

    If you are experiencing this issue, you should be able to work around it by removing the custom scale factors you have set (a custom scale factor applies across all monitors).

    1. Hit the Windows key and then type "display".

    2. Tap on the "display settings" link that is found.

    You should see the following text in red: "A custom scale factor is set".

    3. Click on the text underneath which states "Turn off custom scaling and sign out". 

    4. Sign back in.

    MSTSC should now work with an RDP file passed as a parameter.


    Microsoft still needs to address this bug:  RDP Files do not run with custom display font scaling.




    Donnerstag, 4. August 2016 15:30
  • I had the same issue, before this solution was posted i had to test one thing.

    I deleted the users profile, logged back in with new profile scaled 125% and RDP worked.

    i know deleting the profile and re-setup new profile is a lot of work, just saying it worked.

    Donnerstag, 4. August 2016 19:52

Alle Antworten

  • Same Problem here ... 

    Mittwoch, 3. August 2016 14:32
  • I'm still investigating the issue to determine if it's a feature removed from Windows Pro (like many others - thanks MS!) or another issue.   FYI, you can edit the .rdp file with notepad to view your connection info.

    Mittwoch, 3. August 2016 15:59
  • I'm still investigating the issue to determine if it's a feature removed from Windows Pro (like many others - thanks MS!) or another issue.   FYI, you can edit the .rdp file with notepad to view your connection info.

    No, I am having the same problem after an Aniversary Update but on a VM with a fresh install of an Aniversary ISO, the above problem does not occur. So it must be the update that broke something.
    Mittwoch, 3. August 2016 18:00
  • Thanks for that info DaVoodoo.  It also broke Maccrium Reflect scheduled tasks.  Removed numerous feaures.  And likely broke more than just Remote Desktop.   I've restored my backup image and turned on defer upgrades in Windows update advanced settings..  This Anniversary update is not ready.  I'll wait 3 months.
    Mittwoch, 3. August 2016 18:19
  • BTW, the Only RDP related software I have installed is Microsoft Remote Desktop Connection Manager v2.7

    Don't know if that is the cause.  Can't test since I restored my image.  If anyone is having this issue AND has Microsoft Remote Desktop Connection Manager, let us know.  Maybe it's related. 

    Mittwoch, 3. August 2016 19:35
  • I have the same problem. I have no specific software installed. I only use the standard mstsc.exe

    It opens if i directly open the program. But if i try to open an .rdp file with saved info it won't open mstsc.exe

    This is very frustrating, because all my users depend on this to open their own computers from home.

    Donnerstag, 4. August 2016 07:47
  • Too damn frustrating. Temporary workaround for users can be loading mstsc, then loading *.rdp file from "Load" button.
    • Als Antwort vorgeschlagen MrHelpman Montag, 22. August 2016 11:27
    Donnerstag, 4. August 2016 08:12
  • *************************************************************
    WORKING FIX   --  I have received reports that this works:

    If you are experiencing this issue, you should be able to work around it by removing the custom scale factors you have set (a custom scale factor applies across all monitors).

    1. Hit the Windows key and then type "display".

    2. Tap on the "display settings" link that is found.

    You should see the following text in red: "A custom scale factor is set".

    3. Click on the text underneath which states "Turn off custom scaling and sign out". 

    4. Sign back in.

    MSTSC should now work with an RDP file passed as a parameter.


    Microsoft still needs to address this bug:  RDP Files do not run with custom display font scaling.




    Donnerstag, 4. August 2016 15:30
  • Sir, if you were any geographically closer, I'd buy you a beer right now.

    That really is the solution, thank you.

    Donnerstag, 4. August 2016 16:46
  • Yeah, indeed great find for a beer, but certanly not a solution, because many of us here need 100% scale factor to work. Let's hope MS will correct this ASAP, because RDP is hi-priority, especially nowadays.
    Donnerstag, 4. August 2016 17:36
  • Great man, you made my day.

    I had problem since update and then I contacted Microsoft Support. Agent reinstalled windows but still had problem but now this fixed it.

    Microsoft support agent should be more educated before they do anything on end user computers.

    Donnerstag, 4. August 2016 17:43
  • I had the same issue, before this solution was posted i had to test one thing.

    I deleted the users profile, logged back in with new profile scaled 125% and RDP worked.

    i know deleting the profile and re-setup new profile is a lot of work, just saying it worked.

    Donnerstag, 4. August 2016 19:52
  • *************************************************************
    WORKING FIX   --  I have received reports that this works:

    If you are experiencing this issue, you should be able to work around it by removing the custom scale factors you have set (a custom scale factor applies across all monitors).

    1. Hit the Windows key and then type "display".

    2. Tap on the "display settings" link that is found.

    You should see the following text in red: "A custom scale factor is set".

    3. Click on the text underneath which states "Turn off custom scaling and sign out". 

    4. Sign back in.

    MSTSC should now work with an RDP file passed as a parameter.






    Hi,

    Great sharing, let's feedback this issue on Windows Feedback.

    In addition, please help to mark your post as answer so that other communities will find this good solution till now more efficiently.


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Freitag, 5. August 2016 09:46
    Besitzer
  • thx, I fix it.

    Sonntag, 7. August 2016 04:56
  • Thanks for the Fix. When running Windows 10 in VMware with thier tools it sets a "A custom scale factor", so I have to do this everytime I load up windows now in it.
    Dienstag, 9. August 2016 18:16
  • Thank you! Works for me 8-} 

    BUT Microsoft SHOULD FIX it - turning "custom scale factor" off messed up my Intel HD graphics settings!!! 

    Mittwoch, 10. August 2016 01:12
  • So, the 2nd cumulative update is out, but still not fixed. A pity.
    Donnerstag, 11. August 2016 06:00
  • No.  The Anniversary update broke it.  This has nothing to do with previous cumulative updates.
    Donnerstag, 11. August 2016 13:53
  • There have been several cumulative updates since Anniversary, and those haven't fixed it either. That's what the_95_vibe was referring to I think.
    Freitag, 12. August 2016 19:32
  • OK.  Let us know when it's fixed. Thanks.  :-)
    As discussed above, turning off custom font scaling is a workaround.
    Freitag, 12. August 2016 20:40
  • Try this:

    1. Right click desktop->display settings

    2. You should see the following text in red: "A custom scale factor is set" (for example - was set to 125%)

    3. Click on the text underneath which states "Turn off custom scaling and sign out"

    4. Sign out and sign back in

    5. Right click desktop->display settings

    6. Scroll it back to whatever you like (like 125%)

    RDP is working like a charm, again from your RDP shortcut...

    In fact has always been working, if you activate it from Start->remote-desktop-connection ...

    Cheers!

    Dienstag, 16. August 2016 13:01
  • Too damn frustrating. Temporary workaround for users can be loading mstsc, then loading *.rdp file from "Load" button.
    Thanks for this! I had the same probleme and don't want to switch between custom and 100% display settings. But your way is a good workaround to stay in custom settings and get the .rdp-files to work. I hope Microsoft will fix this bug since the Anniversary Update soon!

    • Bearbeitet MrHelpman Montag, 22. August 2016 09:25
    Montag, 22. August 2016 09:24
  • Trying to repro this -- is this happening on latest Windows 10 14393.103? Can you provide some repro steps? It's not clear what the problem is. I set my scale factor >100% on the host machine and can use RDP files with no problem.
    Freitag, 26. August 2016 23:23
  • This fix allowed me to make only one successfull RDP session, and then the problem reappeared.

    In my case the real problem was in TMG (Forefront) Client. It has multiple issues with W10 annual update.

    After stopping its service "Forefront TMG Client Agent", RDP client works fine.

    Mittwoch, 31. August 2016 14:29
  • I replaced mstsc.exe and mstscax.dll from C:\Windows.OLD\System32 to C:\Windows\System32 and everything back to normal. 
    Mittwoch, 21. September 2016 17:10
  • This is a Microsoft Windows confirmed bug.  It is solely caused by custom display font scaling.  See the message above by rafid123  (August 16, 2016 1:01) for instructions on how to resolve this issue very easily.
    Mittwoch, 21. September 2016 17:28
  • Currently I have several systems with this issue.  I ran all the updates on several systems to recreate this issue.  not all the fully upgraded system encountered this issue.   the ones that did all had the Display setting set to 100%.   This fix did not resole the issue.   I even set the display to the 125% setting signed out and then set it back without effect.   I did confirm this happened immediately after the anniversary update.   I usually reserve recreating user profiles as a second to last resort.   so I followed the file replacement option without success.  currently working to undo that and recreate profile.
    • Bearbeitet Malwarebane Mittwoch, 21. September 2016 22:24
    Mittwoch, 21. September 2016 21:18
  • Sorry this doesn't work since I have no custom size set or any RED Text... Thanks Microsoft I have 6 Directors that Can't Remote into work now!
    Samstag, 29. Oktober 2016 22:45
  • All 6 of your directors tried this? 

    If you are experiencing this issue, you should be able to work around it by removing the custom scale factors you have set (a custom scale factor applies across all monitors).

    1. Hit the Windows key and then type "display".

    2. Tap on the "display settings" link that is found.

    You should see the following text in red: "A custom scale factor is set".

    3. Click on the text underneath which states "Turn off custom scaling and sign out". 

    4. Sign back in.

    ---------------------

    If the above does not resolve the problem, they can also manually connect to work by following these instructions:

    First, get your settings:

    Open your  .rdp file in notepad. 

    Copy the information after these headings:

    full address:s: 

    username:s:   

    For example, if you see:

    full address:s:  server.com

    username:s:    user

    Then your computer name is:  server.com

    and your user name is:  user

    You will need to already know your login password.

    Then:

    1.    Hit the Windows key and then type "Remote Desktop Connection" and click on it.
    2.    Click on Show options in Remote Desktop Connection
    3.    Copy and Paste the settings for computer and user name into the appropriate fields and click connect.


    Sonntag, 30. Oktober 2016 00:49
  • You can replace the mstscax.dll library and mstsc.exe located in %windir%\System32\ with the "backup" file in "Windows.old\WINDOWS\System32".

    You will need to take ownership of the file and give Administrators Full control access to be able to replace it. Please backup the file you are replacing

    Mittwoch, 2. November 2016 10:49
  • An additional work-around that is easier than opening in notepad:

    1. Open Remote Desktop Connection from Start Menu

    2. Click "Show Options"

    3. Click "Open," select your .rdp file. It will load all settings from RDP file automatically

    4. Click Connect.

    Obviously this is slower than just double-clicking the RDP file, but a lot faster than copying/pasting settings from notepad, at least if you're setting any custom settings like size, resource sharing, etc.

    Mittwoch, 10. Mai 2017 12:46
  • This bug was fixed by Microsoft already.

    But your idea wouldn't work at that time because it wouldn't let you even manually open rdp files with Remote Desktop Connection.
    Mittwoch, 10. Mai 2017 13:46