none
2019 RDSH - not able reconnect to Disconnected session, every time new session (with fSingleSessionPerUser=0) RRS feed

Alle Antworten

  • Hi,

    If possible, please patch your RDS system fully with Windows Update/Hotfix, it would be helpful for resolving some known issues and improving the performance.

    Please open Run, type “winver” and end with enter. Compare the OS build number with the number mentioned in “Windows 10 and Windows Server 2019 update history” to determine current system patch level:
    https://support.microsoft.com/en-us/help/4464619

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Montag, 6. Mai 2019 02:29
    Moderator
  • Hi,

    How things are going there on this issue?

    Please let me know if you would like further assistance.

    Best Regards,
    Eve Wang   

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Mittwoch, 8. Mai 2019 03:18
    Moderator
  • i can only confirm that problem still exist after updating with all available updates from Microsoft.

    That is one of the example servers that was tested (server is Azure based D8sv3 if that is important, but we have same problem in AWS as well).

    Host Name:                 MSNV-RSPHERDS1
    OS Name:                   Microsoft Windows Server 2019 Datacenter
    OS Version:                10.0.17763 N/A Build 17763
    OS Manufacturer:           Microsoft Corporation
    OS Configuration:          Member Server
    OS Build Type:             Multiprocessor Free
    Registered Owner:          N/A
    Registered Organization:   N/A
    Product ID:                00430-00000-00000-AA188
    Original Install Date:     4/20/2019, 5:45:57 PM
    System Boot Time:          5/8/2019, 4:57:23 PM
    System Manufacturer:       Microsoft Corporation
    System Model:              Virtual Machine
    System Type:               x64-based PC
    Processor(s):              1 Processor(s) Installed.
                               [01]: Intel64 Family 6 Model 63 Stepping 2 GenuineIntel ~2397 Mhz
    BIOS Version:              American Megatrends Inc. 090007 , 6/2/2017
    Windows Directory:         C:\windows
    System Directory:          C:\windows\system32
    Boot Device:               \Device\HarddiskVolume1
    System Locale:             en-us;English (United States)
    Input Locale:              en-us;English (United States)
    Time Zone:                 (UTC-05:00) Eastern Time (US & Canada)
    Total Physical Memory:     32,768 MB
    Available Physical Memory: 28,838 MB
    Virtual Memory: Max Size:  37,632 MB
    Virtual Memory: Available: 32,928 MB
    Virtual Memory: In Use:    4,704 MB
    Page File Location(s):     D:\pagefile.sys
    Domain:                    
    Logon Server:              
    Hotfix(s):                 6 Hotfix(s) Installed.
                               [01]: KB4489192
                               [02]: KB4465065
                               [03]: KB4480056
                               [04]: KB4493478
                               [05]: KB4493510
                               [06]: KB4495667
    Network Card(s):           1 NIC(s) Installed.
                               [01]: Microsoft Hyper-V Network Adapter
                                     Connection Name: Ethernet
                                     DHCP Enabled:    Yes
                                     DHCP Server:     168.63.129.16
                                     IP address(es)
                                     [01]: 172.16.16.34
                                     [02]: fe80::a115:e12e:756a:9554
    Hyper-V Requirements:      A hypervisor has been detected. Features required for Hyper-V will not be displayed.

    Mittwoch, 8. Mai 2019 21:19
  • Hi,

    I will try to re-produce this problem on my test environment, if there is any update, I will reply to you.

    Thank you for your understanding. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Donnerstag, 9. Mai 2019 07:27
    Moderator
  • I can confirm that we are experiencing the exact same re-connection issue.  This is not a new issue, it was reported back in the preview builds 2 yeas ago.

    https://techcommunity.microsoft.com/t5/Windows-Server-Insiders/Bug-no-reconnect-to-disconnected-session-with/td-p/218413

    Freitag, 7. Juni 2019 02:11
  • Any progress with testing, @Eve Wang?

    Latest update didnt help..

    Montag, 12. August 2019 16:11
  • We have the same problem and are currently on OS Build 17763.678 on ESXi 6.7.0

    We have to buy additional CALs but we will wait for the solution as this version is useless for remote desktop connections as every time you login you lose all your open applications/files. The second solution would be to downgrade to Win Server 2016 but we spent so many days to install all the needed applications to the new hardware and I would like to avoid it.

    I tried also to force enable the "Restrict Remote Desktop Services to a single Remote Desktop Services session" in Local Group Policy but it does not help.

    Any plan when this will be fixed ?

    S.


    Montag, 19. August 2019 07:27
  • Btw, we solved the issue of limitless open connections and related spending of RAM enabling "Set time limit for disconnected sessions" in Local Computer Policy / Windows components / Remote Desktop Services / Remote Desktop Session Host / Session Time Limits.

     But this is just a workaround that kills the "idle" disconnected sessions and resolves the RAM and resources issue of endless idle connections which are generated by each new session .


    Montag, 19. August 2019 07:32
  • I have solved this issue by going to Local Group Policy Editor >> Computer Configuration >>  Administrative Templates >>  Windows Components >> Remote Desktop Services >>  Remote Desktop Session Host >> Connections.  The setting you want to change is called "Restrict Remote Desktop Services users to a single Remote Desktop Services session"  Set this to "Enabled" and users will automatically be forced to reconnect to their existing open session.
    Montag, 19. August 2019 23:02
  • It does not help, I did the same before.... se my comment above "I tried also to force enable the "Restrict Remote Desktop Services to a single Remote Desktop Services session" in Local Group Policy but it does not help."
    Dienstag, 20. August 2019 12:39
  • We were able to make it work... at the end the problem was the group policy that was overriding local setting (OS Build 17763.678 on ESXi 6.7.0).
    Mittwoch, 21. August 2019 12:13
  • Can you be more explicit on how you resolve the problem ?

    I have the same issue.

    Montag, 26. August 2019 11:43
  • this is a non-solution. The way you solving this users will have no option to have multiple sessions on the same host. I need to have two to three sessions open and I want to be able to re-connect to them when my connection drops or when simply close mstsc app. Windows Server 2012R2 offers a selection to which disconnected session you would like to connect. Windows 2019 has no such option?
    Sonntag, 15. September 2019 21:10
  • Marko, what exact setting are you referring to? Can you elaborate, please?
    Sonntag, 15. September 2019 21:11
  • I confirm that the issue still exists and is main obstacle in moving to Windows Server 2019. Have anyone found a solution other than using Windows Server 2016 or limiting RDP user to a single session?

    It appears that starting from Windows Server 2019 disconnected sessions remain in unlocked state which make them 'active', hence, not reconnectable. If you lock the session before dropping connection, you can reconnect no problem.

    I was looking into a way to lock a session on disconnect - that would solve the issue, but I did not find a GPO for that. Yes, there is a GPO for locking based on time limit of inactivity. I presume it could be a 'better-than-nothing' workaround, but it is a half-measure because:

    1. It will lock RDP sessions in connected state, which may be annoying to users.
    2. It will not solve issue of disconnect/reconnect on unreliable link, as you would need to wait whatever timeout you set to be able to reconnect.

    I recall that Microsoft had very similar issue in early days of Terminal Server, which persisted for years, making solid case for using Citrix, as it was working perfectly. Hate when this happens...

    Would appreciate if anyone has any update/solution.


    • Bearbeitet SQL-ER Donnerstag, 19. September 2019 19:52
    Donnerstag, 19. September 2019 19:48