Bug with Windows Media Player 12 not correctly buffering streaming audio (64 bit Windows 7)


  • I'm running a new (high spec) Sony Vaio Z series laptop (64bit Windows 7 professional) and am experiencing stutttering (a 'tick' sound) about once a second in audio playback using Windows Media Player 12 (for streaming internet radio only ie. no stuttering occcurs if I play an MP3 file locally).

    Having read around e.g. I have tried:

    1. reinstalling the Realtek sound driver
    2. updating the Dell storage driver which a few threads have identified fixed a similar problem
    3. progressively disabling Services e.g.
    4. telling WMP that I am running a slow (eg. dialup) connnection rather than a fast connection

    The problem occurs on any streaming radio station at different bit rates e.g. 128 or 96 kbps

    9 out of 10 times WMP starts playing the stream immediately (even though I have set WMP to buffer 60 seconds on the Performance tab) in which case I will get the once-a-second stuttering effect. 1 in 10 times it will buffer properly (e.g. the status line at the bottom left of WMP shows it is buffering and the percentage increasing until the stream starts and then there will be no problems in WMP playing the stream until I close WMP and re-open it or change to a different station).

    Microsoft tech support tells me I cannot report this as a bug (they wouldn't even accept a paid tech support incident on it) I think because the tech support guy I spoke to labeled it a network connectivity problem which it definitely isn't as it happens on any network I'm on and it's a metronomically regular stutter/tic!

    It looks like a bug and smells like a bug in Windows Media Player to me. So the conclusion is ... it's a bug ...



    [wondering if MSFT might accept it was a bug if I install something like Winamp and the same streams work perfectly ... (-: ]

    Postscript: ... yes Winamp functions perfectly with none of the stutter problems with WMP 12 and without having to play around with the buffering settings either. Yeah I know I could stick with Winamp - but I would actually prefer to use WMP because it automatically mutes during my Skype calls.

    Apologies that this is also a cross-post from Microsoft Answers here

    The problem with having an open mind is people wanting to put drivel in it.

    Donnerstag, 16. Februar 2012 05:43

Alle Antworten

  • Did you also try a full Clean Boot according to KB929135, e.g. disabling all services *and* startup items?

    Also, please post the URLs to a few of the radio stations on which the problem occurs, so we can check if it also occurs on other PCs.

    Tim De Baets

    Montag, 20. Februar 2012 14:19
  • Hi Tim,

    Thanks very much for the reply. Yes, if I perform a clean boot as per the instructions without non-MSFT services or startup items I still get the same stuttering effect in WMP 12. After I follow the KB clean boot procedure Kaspersky still seems to load so I even paused it and still have the same problem.

    Here are a few urls for which I get this bug (apologies in advance for my music choices):

    (for this first one my ISP is iiNet so this stream may be specific to them and not available outside their network)

    (Nothing in common that I can see beyond their being played WMP 12 or perhaps being relatively higher bitrate streams.) All play absolutely fine on Winamp.



    The problem with having an open mind is people wanting to put drivel in it.

    Dienstag, 21. Februar 2012 01:15
  • I have just tried all three URLs in WMP 12 on my Windows 7 system. The first URL indeed didn't work, but for the other two I didn't hear any ticks or stutter. So it seems to be a problem local to your own PC and not a bug in WMP itself.

    If you create a new user account in Control Panel, log in on that account, and play the radio streams in WMP there, do you get the same issue?

    Also, do you still get the issue when you (temporarily) uninstall Kaspersky?

    Tim De Baets

    Sonntag, 26. Februar 2012 20:54
  • Just another user chiming in, the first link doesn't seem to function at all, but the other two play seemlessly with no artifacts of any kind.


    Montag, 27. Februar 2012 18:47