none
Exchange Server 2016 CU14 Neuinstallation - Stop bei Bereitschaftsprüfung RRS feed

  • Frage

  • Gruß an Euch!

    Die Bereitschaftsüberprüfung bleibt stehen mit folgenden 2 Fehlermeldungen
    Fehler:
    Auf allen Exchange 2007-Servern in der Organisation muss ein Upgrade auf Exchange 2010 Service Pack 3 oder höher durchgeführt worden sein. Die folgenden Server erfüllen diese Anforderung nicht: SERVER.
    Weitere Informationen finden Sie unter: http://technet.microsoft.com/library(EXCHG.150)/ms.exch.setupreadiness.E16E12CoexistenceMinVersionRequirement.aspx

    Fehler:
    Für die Active Directory-Gesamtstruktur-Funktionsebene in der Organisation muss ein Upgrade auf Windows Server 2008 R2 oder höher durchgeführt werden.
    Weitere Informationen finden Sie unter: http://technet.microsoft.com/library(EXCHG.150)/ms.exch.setupreadiness.MsDSBehaviorVersionRequirement.aspx

    - - - - - - - - - - - - - - - - - - - - -

    Es gab vor ca. 2 1/2 Jahren mal ein Windows 2008 Server auf dem Exchange 2007 lief, der ist physikalisch nicht mehr existent.

    Es wurde als Ersatz ein neuer Server 2016 Standard als primärer DC in Betrieb genommen, vom alten Server wurden die

    Konten, Freigaben usw. auf den neuen migriert und alles läuft bisher einwandfrei.

    Exchange kam in den 2 1/2 Jahren nicht mehr zum Einsatz bzw. wurde nie installiert, da ein anderes nicht Microsoft Produkt installiert wurde.

    Durch die Unzufriedenheit der Anwender zu diesem Produkt soll wieder Exchange (Version 2016) zum Einsatz kommen.

    Gesagt, (fast) getan.

    Neuen (zweiten) Server 2016 Standard in Betrieb genommen, auf dem nur Exchange 2016 laufen soll.

    Wird das Setup von Exchange gestartet kommen bei der Bereitschaftsprüfung die oben beschriebenen Fehlermeldungen.

    Dabei ließt er wohl aus dem 2016er PDC Server alte Exchange 2007 Einträge, die bei der Migration vom alten 2008er Server höchstwahrscheinlich mit eingelesen wurden.

    Wie kann man diese alten Einträge löschen? Oder kann ich das Exchange 2016 Setup beibringen, das nirgendwo ein anderes Exchange im System existiert?

    Vielen Dank!

    LG von Malte


    • Bearbeitet MKW57 Freitag, 8. November 2019 21:16
    Freitag, 8. November 2019 21:10

Antworten

  • Moin,

    gleich vorab: Die AD-Vorbereitungsbefehle bei Neuinstallationen und CUs immer vorher separat eingeben!

    Am besten ist es, Du entfernst die gesamte Exchange-Organisation: https://msexperttalk.com/remove-exchange-server-using-adsi-edit/ und legst sie bei der AD-Vorbereitung neu an.

    Ich würde auch empfehlen, bei allen Benutzern und Gruppen die Exchange-Attribute zu löschen, übrig gebliebene Exchange-Objekte wie öffentliche Ordner zu entfernen und auch die AD-Accounts der Exchange System-Postfächer. Das alles noch vor der Organisationsvorbereitung.

    Dann den Domain- und Forest-Functional Level auf 2008R2 hochdrehen, AD-Vorbereitung durchführen und, wenn alles sauber durchläuft, wirst Du auch Exchange installieren können.

    Denk daran: .NET Framework 4.7.2, nicht 4.8!


    Evgenij Smirnov

    http://evgenij.smirnov.de

    Freitag, 8. November 2019 22:25

Alle Antworten

  • Moin,

    gleich vorab: Die AD-Vorbereitungsbefehle bei Neuinstallationen und CUs immer vorher separat eingeben!

    Am besten ist es, Du entfernst die gesamte Exchange-Organisation: https://msexperttalk.com/remove-exchange-server-using-adsi-edit/ und legst sie bei der AD-Vorbereitung neu an.

    Ich würde auch empfehlen, bei allen Benutzern und Gruppen die Exchange-Attribute zu löschen, übrig gebliebene Exchange-Objekte wie öffentliche Ordner zu entfernen und auch die AD-Accounts der Exchange System-Postfächer. Das alles noch vor der Organisationsvorbereitung.

    Dann den Domain- und Forest-Functional Level auf 2008R2 hochdrehen, AD-Vorbereitung durchführen und, wenn alles sauber durchläuft, wirst Du auch Exchange installieren können.

    Denk daran: .NET Framework 4.7.2, nicht 4.8!


    Evgenij Smirnov

    http://evgenij.smirnov.de

    Freitag, 8. November 2019 22:25
  • Hallo Evgenij !

    Habe alles wie du beschrieben hast durchgeführt.

    Installation hat einwandfrei geklappt.

    Ohne deine Hilfe hätte ich es nicht geschafft.

    Vielen Dank!

    LG Malte

    Für Mitlesende:

    Domain- und Forest-Functional Level auf 2008R2 hochdrehen:

    Powershell starten:

    (Get-ADDomain).DomainMode (damit Level Zustand anzeigen)
    (Get-ADForest).ForestMode    (damit Level Zustand anzeigen)

    Set-ADDomainMode -Identity xxx.de -DomainMode Windows2008R2Domain (Level setzen)
    Set-ADForestMode -Identity xxx.de -ForestMode Windows2008R2Forest      (Level setzen)

    xxx.de natürlich eigene Domäne eintragen.

    Alle Domänencontroller der Domäne mit Betriebssystemversion ausgeben:

    Get-ADDomainController -Filter * | Select-Object Hostname,Operatingsystem

    Alle Domänencontroller aller Domänen ausgeben:

    (Get-ADForest).Domains | %{ Get-ADDomainController -Filter * -Server $_ } | Select-Object Domain,Hostname,Operatingsystem

    Mittwoch, 13. November 2019 13:33