none
Streaming video causes 100% CPU usage -any browser

    Question

  • Hello; I can reproduce freezes - 100% CPU usage, which occasionally lead to crashes pretty consistently just by viewing any video, say bloomberg.com/tv/.   CPU usage quickly runs up to 100% on Task Manager and the freeze occurs.   No issues when running all my other programs, including streaming radio.   I can reproduce this on IE9, as well as Chrome and on Firefox.   I had assumed this was a Shockwave Flash item only, but I notice it freezes on Skype video.   The only changes I can point to recently are a ton of Windows updates in the last 2 months including SP1.   At the time, SP1 failed a couple of times, until I applied a hotfix, now it's on, but I still have the video issues. 

    I'll be happy to participate in any resolution - just tell me how I can assist.

    I have also by the way downloaded the latest video drivers (accelerated media), bios, and chipset drivers, but this has not helped.

    I run Windows 7 64-bit SP1.   I have application hang errors in the windows event logs, but not crashes, so I don't see any crash id's

    Thanks so much for any assistance!

    Tuesday, June 07, 2011 7:01 PM

Answers

  • This issue can be caused by confliction from one of the background programs. You may troubleshoot in Clean Boot Mode.

    How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7
    http://support.microsoft.com/kb/929135

    However if the issue persists in Clean Boot Mode, I suggest you click the Start Button, All Programs, Accessories, System Tools, and then click Internet Explorer (No Add-ons).  If the issue does not reoccur, it may be caused by an IE Add-on. In that case, let’s continue to perform the following steps to narrow down the cause.
     
    Check Internet Explorer Add-Ons
    =========================
    1. Click Tools, and then click Internet Options.
    2. Click the "Programs" tab, and then click Manage Add-ons.
    3. Select an add-on in the Name list, and then click Disable.
    4. Restart IE with Add-ons and check the issue again.
     
    If the issue is resolved, the disabled Add-on was the cause of the issue. If the issue reoccurs, continue to disable the next Add-on using the same method.
     
    By doing so, we could determine which Add-on contributed to the issue.
     
    If it does not help, please reset IE and see if it works.

    How to reset Internet Explorer settings
    http://support.microsoft.com/kb/923737


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, June 09, 2011 9:19 AM
    Moderator

All replies

  • about the only thing I can think of for you to try is open Internet Explorer (I know what does this have to do with video but bare with me)...

    Go to internet options

    click the advanced tab

    the very first entry is us software rendering instead of GPU rendering (make sure this does NOT have a check in it)


    Please remember to flag a post that helps you as "answer" so that it may help others with same problems.
    Wednesday, June 08, 2011 4:45 PM
  • Thanks for your reply, Yep, just took a look.  "use software rendering" is unchecked.    Hard for me to put an exact date on it, but it seems I started having these issues coincidentally with the first failed SP1 attempted update (mid April).   I've lost all my restore points once I succeeded in putting SP1 on, so I can't go back that way.   I'm considering a "clean" reinstall of the OS - given the limited information I'm able to give you, (and the pain this would imply for me!) would you think this is my next step? 
    Wednesday, June 08, 2011 8:35 PM
  • lets not go there yet if we don't have to

    try this: http://support.microsoft.com/mats/video_freezes_or_crashes/

    its Microsoft's auto-repair for browser video issues... it might help


    Please remember to flag a post that helps you as "answer" so that it may help others with same problems.
    Wednesday, June 08, 2011 10:50 PM
  • This issue can be caused by confliction from one of the background programs. You may troubleshoot in Clean Boot Mode.

    How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7
    http://support.microsoft.com/kb/929135

    However if the issue persists in Clean Boot Mode, I suggest you click the Start Button, All Programs, Accessories, System Tools, and then click Internet Explorer (No Add-ons).  If the issue does not reoccur, it may be caused by an IE Add-on. In that case, let’s continue to perform the following steps to narrow down the cause.
     
    Check Internet Explorer Add-Ons
    =========================
    1. Click Tools, and then click Internet Options.
    2. Click the "Programs" tab, and then click Manage Add-ons.
    3. Select an add-on in the Name list, and then click Disable.
    4. Restart IE with Add-ons and check the issue again.
     
    If the issue is resolved, the disabled Add-on was the cause of the issue. If the issue reoccurs, continue to disable the next Add-on using the same method.
     
    By doing so, we could determine which Add-on contributed to the issue.
     
    If it does not help, please reset IE and see if it works.

    How to reset Internet Explorer settings
    http://support.microsoft.com/kb/923737


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, June 09, 2011 9:19 AM
    Moderator
  • I've run the codec crashes troubleshooter - it's identified no issues.   I'll Arthur's suggestions a try tomorrow and let you guys know.   Thanks a bunch for your help 
    • Proposed as answer by techjuniorgani Monday, January 20, 2014 7:17 PM
    • Unproposed as answer by techjuniorgani Monday, January 20, 2014 7:17 PM
    Thursday, June 09, 2011 8:08 PM
  • Hi,

    I tried all sorts of troubleshooting steps including the addons disable to uninstall and upgrading flash players, but of no use. Then I have reinstalled my windows using recovery cd, it completely formatted my windows. after that it was working fine.

    I have installed norton internet security and while streaming videos, it gave me error that audiodg.exe was utilizing 100%cpu, then i have disabled enable all enhancements from playback devices.Now its working good for me. People who are even ready to reinstall please try this before formatting your windows.

    Monday, January 20, 2014 7:23 PM
  • ..then i have disabled enable all enhancements from playback devices.....

    Dear techjuniorgani,

    Would you please explain what you mean by this?  Where do I start?  Control Panel?  somewhere else?

         - Rich

    Friday, January 24, 2014 7:02 PM
  • Rich: techjuniorgano is probably referring to the speaker audio enhancements. To disable all enhancements, see

    http://windows.microsoft.com/en-us/windows/stop-music-skipping-breaking


    Tim De Baets
    http://www.bm-productions.tk


    Monday, January 27, 2014 9:16 PM
  • I had the same problem (100% CPU after playing video) in my Dell Studio 1558.  Monitoring temperatures with SpeedFan, I was able to significantly reduce the operating temperatures by vacuuming the dust out of my system, even without disassembling it.  I just held the hose of my home's central vacuum system up against each of the vent openings on the sides and bottom of the machine for several minutes.  Then I put the vacuum away and returned the machine to normal service.  This reduced the operating temps of Core 0 and Core 1 from 80 C down to 45 C during normal web surfing.  So far I have watched a few videos without the 100% CPU slowdown problem I had previously experienced.

    Monday, July 07, 2014 5:06 AM