none
Run the Task Manager on startup. How? RRS feed

  • Question

  • Hi

    I installed the final windows 8 from dreamspark. Now i always started the task manager automatically at the start up. I tried to do the same with windows 8 by adding a taskmgr.exe shortcut (located at c:\windows\system32) at the startup folder (c:\users\"username"\appdata\roaming\microsoft\windows\start menu\programs\startup). Now the task manager can be seen in the startup tab in the taskmanager, but when i restart my computer, the task manager doesn't start.

    Does anybody here know the solution to this problem?
    Sunday, August 26, 2012 8:44 PM

Answers

  • the new Taskmgr requires elevated rights (because it sues ETW to measure the disk and network data). use the old task scheduler trick to workaround the UAC prompt.

    "A programmer is just a tool which converts caffeine into code"

    Friday, June 7, 2013 7:55 PM

All replies

  • Try use MSCONFIG to add task manager, in start screen search for MSCONFIG.msc or MSCONFIG and then in starup add the location for startup task manager.
    Monday, August 27, 2012 10:54 AM
  • unfortunately this doesn't work. when I go to the "Startup" tab in MSCONFIG, there's just a link referring to the task manager, where i already added the "task manager"-shortcut and it appears as a auto started program. but it doesn't start anyway.

    in windows vista and windows 7 my method always worked, but not in windows 8. does anybody else have a suggestion?

    Monday, August 27, 2012 2:37 PM
  • Create a task in the Task Scheduler to start Task Manager at logon.
    Monday, August 27, 2012 9:03 PM
  • or run it from here.

    C:\WINDOWS\system32\GroupPolicy\User\Scripts\Logon


    Don't forget to mark your posts as answered so they drop off the unanswered post filter.

    Tuesday, August 28, 2012 10:51 AM
  • I tried this, but unfortunately this doesn't work either. Did you test it and did it work for you? If yes could you explain how you achieved to make it start?

    @Knuckle-Dragger: This folder doesn't even exist in my Windows 8, GroupPolicy exists, but from then on it's just an empty folder... Should I create the remaining three folders by myself and put a shortcut in there, or are you still working with a Windows 7 machine? ;)

    there's got to be a way!

    Tuesday, August 28, 2012 12:19 PM
  • Yep, or can possibly use the local group policy editor to create a logon script, it should auto-create the folders for you when you apply your logon script.

    search for 'gpedit.msc'

    http://www.computerperformance.co.uk/win8/windows8-gpedit-msc.htm

    EDIT:  Not sure which edition of Windows 8 you are on, if you cannot find gpedit.msc (even by searching) then it might not be there and you'll have to create the folders manually.  It's usually only available in the non-home versions, not sure what dreamspark is pushing on students.

    EDIT EDIT:  If using a short-cut don't work, use a batch file that opens TaskMgr, maybe that is the real problem.   Call it from an actual '.cmd' batch file instead of via a shortcut.


    Don't forget to mark your posts as answered so they drop off the unanswered post filter.











    Tuesday, August 28, 2012 12:23 PM
  • I'm running Windows 8 PRO, i found the 'gpedit.msc' via search.

    What I did now, is i went to the Local Group Policy Editor (i had never used this program before) then there to "User Confituration/Windows Settings/Scripts (Logon/Logoff)".

    Now, should i create a general script or a "powershell" script? And do i have to fill in something in the field "parameters"?

    Tuesday, August 28, 2012 1:51 PM
  • Create a simple .cmd batch file.   Paste this into.   No parameters needed.   Let me know if that don't work.

    C:\Windows\System32\taskmgr.exe

    Don't forget to mark your posts as answered so they drop off the unanswered post filter.


    Tuesday, August 28, 2012 1:58 PM
  • Ok so we drop the "Local group policy editor" i assume. ;)

    Alright i created a .cmd batch file and put it in the 'C:\Users\lefreeman\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup" folder. Now it's great, the task manager starts. Only two problems are left:

    1) The cmd window stays open

    2) the task manager doesn't start minimized in the tray.

    What commands do i have to add in the .cmd file so these two problems are removed? I'm sorry i haven't much experience with these kind of problems. ^^

    Tuesday, August 28, 2012 2:13 PM
  • It does not seem to respect the option to 'Minimize on Use' so we might need to go into powershell after all.   But I doubt you'll be able to drop it into your start menu folder, back to group policy if you need .ps1.   Good luck.

    From batch try this, it will close the batch window, but not handle minimizing, or the second snip is powershell and it will minimize your taskmgr (along with everything else)

    start C:\Windows\System32\taskmgr.exe
    exit
    start C:\Windows\System32\taskmgr.exe
    [void] [System.Reflection.Assembly]::LoadWithPartialName("'Microsoft.VisualBasic")
    $shell = New-Object -ComObject “Shell.Application”
    $shell.MinimizeAll()


    Don't forget to mark your posts as answered so they drop off the unanswered post filter.






    Tuesday, August 28, 2012 2:30 PM
  • I'm sorry but i don't quite understand. What do i have to do now? Just explain from scratch, because i never used gpedit.msc, power shell scripts and not even .msc files... :(

    Edit: Ok i almost got it.

    I created a .ps1 file where I put in the four lines of code you got me. This file i put in the "C:\WINDOWS\system32\GroupPolicy\User\Scripts\Logon" folder. Then, in the gpedit.msc program, i chose to run this new script on logon as a powershell. :)

    Now, the only problem remaining, is that the task manager still isn't minimized when i start it, but now the window of the task manager is blinking. ^^


    Edit2: Actually there are two problems with this configuration:

    1) When I startup the computer, the task manager will start, and even minimize. but it takes more than one minute after the startup for the task manager to start, ans beause of this the script will then minimize all my programs which is annoying.

    2) When i simply sign out and sign in again, the task manager will start very quicky, but it won't start minimized, but just with the window blinking. -.-

    So is there any way to solve these two problems?


    • Marked as answer by lefreeman Tuesday, August 28, 2012 4:05 PM
    • Unmarked as answer by lefreeman Tuesday, August 28, 2012 4:05 PM
    • Edited by lefreeman Wednesday, August 29, 2012 8:21 AM
    Tuesday, August 28, 2012 2:49 PM

  • Base on my test, creating a Scheduled Task for “C:\Windows\System32\taskmgr.exe” with the following options works:

    Select “Run with highest privileges”.
    Trigger set to “At log on”

    Please have a try.

    Thanks.


    Nicholas Li

    TechNet Community Support

    Wednesday, August 29, 2012 9:27 AM
    Moderator
  • Do you really have tested it? Because it doesn't work for me. :( There are two problems:

    1) The task manager won't be minnimized to the tray when doing it this way. But at least the tray icon is shown.

    2) When i sign out my account and then sign in again, the tray icon won't even show up, even not when i minimize the task manager. This means when i minimize the task manager it will just be hidden.

    .

    .

    .

    For everyone, i just want my screen to look like this when I 1) start my computer or 2) when signing in after having signed out (This was so simple to achieve in windows 7 ^^):

    .

    .

    .

    Any ideas?

    • Edited by lefreeman Wednesday, August 29, 2012 12:42 PM
    Wednesday, August 29, 2012 9:46 AM
  • I'm not having any problem getting the Windows 8 Task Manager to start Minimized when I log in just by adding a shortcut to TaskMgr.exe into the Startup folder and setting its Run: attribute to Minimized.

     

     

    I did notice that it went into the hidden portion of the System Tray by default, and I had to change it to Show icon and notifications.

     

     

      

    Only issue is that when it starts minimized, it makes a button in the Taskbar, vs. minimizing to the system tray, even though I have the option for "Hide When Minimized" set in the Task Manager itself. 

    Is this more than what you've managed to get it to do?

    I do have ClassicShell installed, which immediately takes me to the Desktop after logging in.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options



    Thursday, August 30, 2012 2:24 AM
  • In which folder did you put the shortcut exactly?

    And why did you add the "/4" in the target path?

    .

    .

    .

    I did try something similar, actually this was my first attempt but then it didn't work. Try signing out your account and signing in again, does it still work? Because when i was trying out a similar attempt it dit just work for starting up and then logging in, but not when signing out without shutting down and then signing in again.... :/

    Thursday, August 30, 2012 7:32 AM
  • I still haven't figured it out. Did anyone here succeed?
    Friday, August 31, 2012 9:28 AM
  • I added the /4 because that's the command line that right-clicking the Taskbar and choosing Task Manager sends to it, as referenced by Task Manager itself:

    I don't know what else to suggest.  It comes up for me when I set it up in the Startup group, whether I reboot or I log off/on.

    I should mention that I run Windows 8 with UAC completely disabled.  I suppose that could matter in this case.

    Maybe you should just try to just get used to right-clicking the Taskbar to start Task Manager?  Having it running all the time does soak up some resources...

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Friday, August 31, 2012 11:41 PM
  • Hi,

    The only one way to run the Task Manager on startup successful is You must use built-in Administrator account (you must enable it first) to sign in then drop the shortcut of Task manager to startup folder, restart/sign out; sign in again using built-in Administrator account on your pc..

    it's work for me.. :)

    sorry for my bad english..



    • Edited by A'bana Idank Saturday, September 1, 2012 1:49 AM
    Saturday, September 1, 2012 1:39 AM
  • @Noel Carboni: Thanks for your help, but as menstioned this is still not the way i wanted it.

    .

    I give up guys. Thanks for all that tried to help, i'm kind of disappointed that it simply isn't possible to just have the task manager start minimized in the tray, as it was possible in Windows 7 and before. I hope it's going to be fixed, but most probably it won't. ^^


    • Edited by lefreeman Saturday, September 1, 2012 11:17 AM
    Saturday, September 1, 2012 11:16 AM
  • lefreeman wrote:

    I give up

     

    Unfortunately this seems to be happening more and more lately as people realize critical functionality is really missing and there's no secret grand plan that makes it all work out okay.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Saturday, September 1, 2012 2:41 PM

  • Hi,

    The Task Manager in Windows 8 is a new version and I would like to share the following with you:

    The Windows 8 Task Manager
    http://blogs.msdn.com/b/b8/archive/2011/10/13/the-windows-8-task-manager.aspx

    Thanks.


    Nicholas Li

    TechNet Community Support


    Monday, September 3, 2012 6:41 AM
    Moderator
  • The Windows 8 Task Manager
    http://blogs.msdn.com/b/b8/archive/2011/10/13/the-windows-8-task-manager.aspx

    Nicholas, I know your intentions are good here, but reading fluff like that from the man who's killing Windows just makes my blood boil.  It comes across as all marketing BS.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Monday, September 3, 2012 10:58 AM
  • I've noticed the same problem.  I created the shortcut in the all-users startup folder, set to run minimized and hiding the taskbar button, as I've been doing for a decade.   After logging on, I can navigate to the startup folder and open the shortcut, and it works as expected.   The shortcut is definitely residing in the "real" all-users folder.

    Hard to imagine there isn't some developer at Microsoft who doesn't also want taskmgr.exe running automatically in the tray when they turn on their everyday work machine.    Certainly they know about this.

    Microsoft, this is a bug.  Fix it please.

    Wednesday, October 17, 2012 5:38 PM
  • OK, I solved it, with the same side-effect mentioned by Noel where it the taskbar button remains until taskmgr is minimized by the user.  However, I have UAC turned on (set to "quiet" mode).  Logging off/on, it still works.

    I use the elevate powertoy to start it, and this works either from a Local Machine Run key, or the all users Startup folder.  To get the "run minimized", I edited the powertoy files to start the program minimized.  Howto:

    1. Copy elevate.cmd to elevatemin.cmd.  There are no changes to this file, it just needs to exist with a same changed name as the next file.

    2. Copy elevate.vbs to elevatemin.vbs.  Change one line in elevatemin.vbs as follows:

    Comparing files elevate.vbs and ELEVATEMIN.VBS
    ***** elevate.vbs
        Else
            objShell.ShellExecute strApplication, strArguments, "", "runas"
        End If
    ***** ELEVATEMIN.VBS
        Else
            objShell.ShellExecute strApplication, strArguments, "", "runas",2
        End If
    *****

    3. From an elevated command prompt, copy both to c:\windows (or wherever you like).

    4. Command line of the shortcut or Run key is then (when elevatemin.* is in the path):

        elevatemin.cmd taskmgr.exe

    If you do this with a shortcut in the Startup folder, changing the shortcut to run minimized keeps the momentary cmd window from appearing on the screen.


    Wednesday, October 17, 2012 6:15 PM
  • start C:\Windows\System32\taskmgr.exe
    [void] [System.Reflection.Assembly]::LoadWithPartialName("'Microsoft.VisualBasic")
    $shell = New-Object -ComObject “Shell.Application”
    $shell.MinimizeAll()

    Hi,

    I am getting the following error when I try to run the code above in a Windows Powershell script.

    New-Object : A positional parameter cannot be found that accepts argument 'start'.
    At line:1 char:10
    + $shell = New-Object -ComObject "Shell.Application"start C:\Windows\System32\task ...
    +          ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidArgument: (:) [New-Object], ParameterBindingException
        + FullyQualifiedErrorId : PositionalParameterNotFound,Microsoft.PowerShell.Commands.NewObjectCommand

    I hope you can help me because I don't get any errors when I just paste the four lines of code into a Powershell window, only when I try to run it as a script.

    Cheers,

    MusicBuddha


    Don't forget to mark your posts as answered so they drop off the unanswered post filter.







    Friday, June 7, 2013 6:36 AM
  • the new Taskmgr requires elevated rights (because it sues ETW to measure the disk and network data). use the old task scheduler trick to workaround the UAC prompt.

    "A programmer is just a tool which converts caffeine into code"

    Friday, June 7, 2013 7:55 PM
  • I just ran into this problem moving from XP to Win7 64-bit.

    I solved it by simply:

    1) Making a copy of the taskmgr.exe file into a non-system directory

    2) Created a shortcut to it

    3) Set the shortcut to "run minimized"

    4) Dropped the shortcut into "Startup" folder

    5) Whola...Runs in system tray minimized when boots up :)

    The only issue is that it only shows the processes for the current user. You can easily click the "Show processes for all users" when you open the taskmgr window. Normally you could mark the shortcut as "Run as an admin" and it will allow taskmgr to run with "All processes" shown when it starts, but doing this will cause the shortcut to not run upon bootup.

    Hope this is a workable solution for some of you.

    Thursday, April 3, 2014 7:23 PM
  • Doesn't work me after these setting...............I don't know why? Can someone help me please?

    Running Windows 8.1 with 4go DDR2 ram.

    First, start Task Manager manually (Start, taskmgr, Enter) and enable Options-> Hide when minimized.

    Then, in Windows Explorer, open following folder:

    C:\Users\<username>\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
    

    If you want this to be active for all users, open this folder instead:

    C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup
    

    Now, right click on empty space, select New-> Shortcut. Type in taskmgr, click OKand Finish.

    You are not done yet! Right click on new taskmgrshortcut, select Properties. Now, in Shortcuttab, configure Run-> Minimized.

    Now, reboot. After you switch to desktop again, make sure you configure Control Panel-> Notification Area Iconssuch that Windows Task Manageris set to Show icon and notifications(default setting is Only show notifications).

    Doesn't work me after these setting...............I don't know why? Can someone help me please?





    • Proposed as answer by deaf-nf2 Monday, May 26, 2014 1:34 AM
    • Edited by deaf-nf2 Monday, May 26, 2014 1:37 AM
    Sunday, May 25, 2014 8:30 PM
  • Doesn't work me after these setting...............I don't know why? Can someone help me please? Windows 8.1
    Monday, June 2, 2014 10:55 PM
  • Excellent instructions that worked for me and my non Professional or Enterprise version of Windows 8 (whatever version ships with the Asus T100TA Transformer Notebook) can be found here:

    http://www.sevenforums.com/tutorials/67503-task-create-run-program-startup-log.html

    I followed the instructions detailed in that link, replacing

    "C:\Program Files (x86)\CoreTemp 0.99.5.27\Core Temp.exe"

    with

    C:\Windows\System32\Taskmgr.exe /7

    by doing the following in the Actions tab:

    Press the New... button

    Press the Browse... button

      then, in the Open dialogue box that appears, navigate to

        > This PC > OS(C:) > Windows > System32 >

          and choose Taskmgr.exe and press the Open button

    In the Add arguments (optional): field: add 

      /7

    Note: The only step you don't need to follow is to create the trigger 'At startup'.

    You only need the 'At log on' trigger.

    Kind regards,

    Ant

    Saturday, July 19, 2014 10:24 AM
  • Does /7 perform the "run minimised" work, or does one need a different argument?
    Wednesday, December 10, 2014 10:12 PM
  • bro u've the 2nd best answer
    Tuesday, December 23, 2014 8:22 PM
  • FORGET ALL BRO I'M here :)

    I've used all methods to automatically start the task manager in windows 8 & windows 8.1 but I failed now I'm telling you below this is the best tech you can use...

    just create a shortcut of task manager on your desktop by right click context menu select "shortcut" then open its properties then set minimize option for it. now move that shortcut where you wanna move in your drive.  The last step is you just open the "Task Scheduler" from the start menu in windows 8,8.1 & create a schedule start-up and link to that shortcut. now save and exit... its DONE bro Note that create schedule for system startup when you edit that... now restart your pc & watch ....

    Right-click your desktop, go New -> Shortcut. Point the shortcut to the executable then drag it into the startup folder in the Start menu

    I've always done this, and then I change window to minimized in the shortcut's property to put it in the system tray directly. –.

    after that set a scheduled task that is set to execute the chosen program upon system start-up or user login.

    give me reply if you find that :)

    Assalam-O-Alaikum 

    • Proposed as answer by tECh uc Tuesday, December 23, 2014 8:39 PM
    • Unproposed as answer by tECh uc Tuesday, December 23, 2014 8:39 PM
    • Proposed as answer by tECh uc Tuesday, December 23, 2014 8:39 PM
    Tuesday, December 23, 2014 8:37 PM
  • Wa alaykumu s-salam

    That was a re-hash of an old answer that might work for for Win7 and earlier, but not for Win8x.  Please don't fish for votes.

    Khuda Hafez.



    Monday, January 12, 2015 10:35 AM
  • A little related tip about something that has been driving me crazy ever since updating to Win8 - when the system crashes, TaskMan resets all its GUI settings.  I guess this is meant as a fail-safe to avoid setting corruption - but I've spent FAR too much time changing back to the Advanced view & resetting my View prefs, CPU core views and Process column orders.  Today after 2 power cuts in a row, I finally snapped : ).

    The settings are saved in

      HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\TaskManager.

    Find and export them from RegEdit.exe (make sure only the key with the hex values is exported).

    Then create a task in TaskScheduler to run at login:

      cmd: regedit.exe  (no path required)

      args: -s "<full path to saved .reg file>".  (don't forget the quotes)

    Make sure that 'Run with highest privileges' is ticked or it won't do anything
    (if you used the basic view to create the task, it's in its Properties).

    Works great here.



    • Edited by a2B Saturday, January 17, 2015 3:08 PM
    Saturday, January 17, 2015 3:05 PM
  • Not here.
    Tuesday, February 3, 2015 4:26 PM
  • I've found a fix for this. It isn't pretty, but hey at least taskmanager will launch properly minimized so you get the nice CPU-usage in your tray area.

    First of all make sure you can run Powershell scripts by changing the execution policy:

    Set-ExecutionPolicy -unrestricted

    Next create the following powershell script and put it in a easy to find location:

    start-process taskmgr.exe
    Start-Sleep -s 1
    $shell = New-Object -ComObject "Shell.Application"
    $shell.minimizeall()

    For good measure you should probably test if it works ;)

    After that create a new Task to run at log-on using Taskmanager with the "Start a Program/Script" action. Put Powershell as the program to run and ad the following as argument: -file "[Foldercontainingscript]\[script].ps1". 

    And presto... One taskmanager starting in the tray only

    It takes a few seconds to run the script because Powershell needs to start first, that's a bit of a bummer. Also, if you want to prevent your other startup items from being minimized, it is probably best to include them in the script, after $shell.minimizeall(), that way they won't get minimized. Downside: you'd have to edit the script to change startup programs...

    Feel free to share it around the net :D

    Monday, September 14, 2015 2:59 PM
  • That might work but I'm sorry, I won't be using it.

    For me Task Manager on startup isn't worth having scripts running before I try and actually do something.  This is something that Microsoft should have made easy.  And had plenty of time to do it.  It did not.  I now use a different non-Microsoft solution.

    Saturday, September 19, 2015 12:02 PM
  • Agreed. I have been puzzled by this change in behavior (regression) ever since it was first broken in Windows 8.0. I had hoped it might be fixed in Windows 10, but unfortunately that hasn't yet happened (I'm still hopeful).

    Like other folks, I initially created a Task Manager shortcut in the Startup folder. But it never seemed to be executed during a reboot. So I've found the following to be a reasonably simple workaround:
    1) In File Explorer, navigate to "shell:Startup"
    2) Using Notepad, create a new batch file, for example, "Taskmgr.cmd". Paste in the following:

            start /min taskmgr.exe
    3) Save the new file

    One problem with this approach is that the Task Manager button appears initially in the taskbar, even though I specified Options | Hide when minimized. So after a reboot, I always wind up clicking the button two times (not a double-click); one click restores the window, and the second click minimizes Task Manager to the system tray where I want it. And the second problem is that the window size and position are still different each time I restart. I really wish Microsoft would fix this.

    I tested this approach in a Windows 10 VM, a Server 2012 VM, and also in a Windows 8.1 workstation.

    At any rate, if other approaches haven't worked for you, this might be worth a try. Or you can do what I often do immediately after logging in: Press Ctrl+Shift+Esc to launch Task Manager, then press Alt+Spacebar, N to minimize it. It's not automatic, but it's pretty quick and easy to do.

    Wednesday, September 30, 2015 9:41 PM
  • No, the /7 opens it with the seventh tab (services) opened.
    Saturday, March 12, 2016 5:48 AM
  • Like you, I've read this whole thread, and looked elsewhere on the Web, and tried all sorts of attempts using various batch files and/or using Task Scheduler to run things like "cmd /c start /b /min taskmgr", etc... but I finally just gave up on it, too. Because no matter what I tried, I was still initially getting its icon appearing in the taskbar. Yes, you can just open it up then minimize it once again, and the icon will go away... but all of this just irritates me to no end, because before Win8, this was just SO easy to do. Grrr.

    Therefore now, as soon as I login, I simply press Ctrl-Shift-Esc, then minimize it.     Done!


    • Edited by theColdest Saturday, March 12, 2016 8:33 AM
    Saturday, March 12, 2016 8:23 AM
  • 3rd-party jack-of-all-trade utilities like nircmd can do this via Task Scheduler:

    nircmd exec hide taskmgr

    No appearance in taskbar that way. The only negative is that the first time after boot, you can't simply double-click Task Manager on the tray and have it appear. You either have to right-click it and select "Restore" first or use Ctrl-Shift-ESC. Not a big deal.

    There's another similar utility that I also tried for this (the name escapes me at the moment), but it does the same thing, so it's just a function of the "hiding" that's being done.

    Sunday, December 4, 2016 8:12 PM
  • Hello, Moozul Tech:  In Windows 10, when you say "Elevated Rights" is this the same or different than running a shortcut as Administrator? 
    Wednesday, May 24, 2017 8:32 PM
  • Same
    Tuesday, May 30, 2017 11:18 PM