none
KB958559 fails to configure in Windows 7 Professional

    Question

  • Hello,

    I have a brand-new Dell Inspiron with a virtually-enabled AMD proc and 6GB of RAM. I literally unboxed this machine 11-12 days ago. I've barely begun loading my apps, so other than Office '03, Roxio, and A/V, the 320GB HD is pretty much empty. The machine was loaded at Dell with Windows 7 Professional (not updated from a Vista machine).

    Without getting into an extremely long story, I bought this machine/OS specifically to be able to use XP Mode for current schoolwork I am doing, and I need it to function.

    I have downloaded the packages from Microsoft, and followed their install instructions of XP Mode first, then the new VPC. However, no matter what I so or attempt, the installer will install - restart - and then at 97-98% of configuration it will fail and roll everything back out again. This of course leaves me unable to use XP Mode.

    I have scoured the Internet looking for help/tips/etc and have found out that this update seems to have been a problem for Vista users also for over a year now - and here I thought 7 was supposed to debut without the issues that Vista had. Worse still, I can find no place where anyone seems to have come to a final answer in dealing with this problem either.

    After having read all I did find, I have attempted a number of things from reversing the install order to literally giving all groups Full Control over the whole system temporarily while I tried to install. Nothing has worked. I am desperate - I NEED this resolved, and fast.

    I greatly appreciate any and all help anyone can offer me.
    Thursday, November 19, 2009 6:47 PM

All replies

  • Problems related to patches, security updates, service packs, feature packs and so on to fail is if there is something corrupt in the servicing store. Download and run the System Update Readiness Tool which scan for inconsistencies in the servicing store. Look at the log files checksur.log and checksur.persist.log in %SYSTEMROOT%\Logs\CBS when you have run the tool.
    http://support.microsoft.com/default.aspx/kb/947821
    Thursday, November 19, 2009 7:30 PM
  • I recommend installing Virtual PC first. It doesn't make any difference if XP Mode or Virtual PC is installed first. The reason the product team recommends installing XP Mode first is because it doesn't require a reboot. By installing Virtual PC last, the reboot is saved for the end. That is the reason for the recommendation.

    But for the people who have problems, it is better to start with Virtual PC. That way you know right away there's a problem. There's no point in having XP Mode installed if you can't get Virtual PC installed.

    Check the logs as suggested and post what you find here.
    Thursday, November 19, 2009 7:49 PM
  • I am out of town at the moment and checking emails etc.

    This is a route that I have not tried as yet, but will look further into it when I return home (something to do Thanksgiving day<g>). From what I've mentioned, any clues what I may be looking for once I run the scans you suggest?

    Thanks a bunch! Have a wonderful Thanksgiving!

    serloren
    Saturday, November 21, 2009 3:42 PM
  • I did actually try to do it with VPC being the first install (this direction was laid out on a Windows 7 forum), and the error still occurs. If that is the reason that Microsoft says to install XP Mode first, I wholeheartedly agree with you! 60 seconds spent on one reboot? Oh the horror :-)

    Thanks for offering your suggestions.

    Have a great Thanksgiving!

    serloren
    Saturday, November 21, 2009 3:47 PM
  • Serloren,
    Could you please zip and mail C:\Windows\Logs\CBS\CBS.log to wcvdata@microsoft.com?
    Please mention this thread id, you email id and screen name in the mail.
    Sunday, November 22, 2009 7:20 PM
  • Thayu,

    I read and replied to your response on the other post about this issue first, and I emailed you a zipped copy of the CBS log.

    Having read the replies through here, I have just downloaded and installed the Readiness Tool Update (KB947821_v2-x64) via:http://support.microsoft.com/default.aspx/kb/947821 .

    After it installed, I followed the Microsoft instructions and ran Windows Update - the only thing that showed up at all was an update for Office compatibility ('03 to '07) which I did install. Nothing else showed up at all - the "tool" did not pop up and notify me of any issues, etc.

    As I see nothing to lose at this point - I am going to attempt to install the VPC again, if iflies I'll let you know. If not, I will send you a new copy of the CBS log in case it shows any changes.

    Thanks for all the help!!

    serloren

    Monday, November 23, 2009 3:51 AM
  • Re-attempt failed in exactly the same way as all others. A new copy of the CBS log has been emailed to you. Thanks!
    Monday, November 23, 2009 4:11 AM
  • I haven't had any contact with Thayu for quite a while now; I would think that if he were out of ideas he would tell me so - so I suppose he must be too busy to respond further at this time.

    By our exchange back-n-forth, Thayu targeted a failed install of another update as being the problem: that it not installing was somehow blocking this install even though they are unrelated items. The failed install was for a Realtek Nic Driver via Microsoft downloads. In the time since then, I located the install on Realtek's site and attempted to install it - failed. I located a newer driver on their site - installed. And since then, have an even newer driver provided by Dell that also installed fine. At no time did I have any functional probs with my NIC etc, and Windows always listed me as being Up To Date. Also, since then, Windows also offered the driver again in my updates - and it refused to install (as I figured it would). With all of this, and MANY attempts, changes, turning off and on various services etc ...Virtual PC still refuses to install.

    I did in all of this wrangling figure out that the reason the Realtek driver (which was supposed to be optional anyway) fails to install is that it recognizes the newer driver(s) on the system - including the one that the system shipped with almost 6 weeks ago.

    That said, I have an idea, but no idea where to look-how to do it to accomplish it.

    IF I can remove/delete that failed entry of the Realtek-Network-Realtek PCIe Family Controller from the listings in my Windows Update: meaning removing whatever files store the information that says an install of that was attempted...THEN....run Windows Update and when it reappears to install, I'll choose to hide it.

    So if Thayu is correct, my system wouldn't show that failure in the "list of" whatever, and the Virtual PC update wouldn't see a failed install, and should run. If this sounds like complete lunacy/stupidity let me know, but it seems to make logical sense to me. The only thing that keeps me hanging is...no clue how to remove that entry,or where to even find it.

    If anyone has any clues or advice on this (or on any other ways to correct this), I would be extremely grateful. Tomorrow is my last class until Christmas, but if I don't get this up and running to do my Server 2003 Virtual coursework with over the holiday...I'll be totally 100% screwed when I go back after Christmas, and my 70-290 & 291 are coming up fast!

    Thanks all, and have a very blessed and wonderful Christmas!!!

    serloren (loren sanders)
    Monday, December 14, 2009 9:05 PM
  • Hi Serloren,

    I have the same problem, and i have identified log files in the Event Viewer > Setup logs relating to the problem. I dont know if you have the same entries in your log files? I have outlined the problem below, which sounds identical to yours (except for my windows version is ultimate).

    I am running Windows 7 Ulimate 32bit edition and cannot install XP Mode.

    I have succesfully enabled virtualisation in BIOS and succesfully installed the first download, 'Windows XP Mode', the 500Mb download.

    The problem occurs when trying to install the second download, 'Windows Virtual PC'. Here is the problem:

    - I install the file Windows6.1-KB958559-x86.msu with no issue and i am prompted to restart windows.

    - Windows starts to load and presents a message, "Please wait while Windows configures Windows updates"

    - This process reaches 98% and i recieve a message, "Failure configuring windows updates, reverting changes".

    - Windows reverts, restarts and XP Mode has not been installed. 

    Having checked the setup logs in event viewer, there are the following logs:

    Windows update "Update for Windows (KB958559)" was successfully installed. (Command line: ""C:\Windows\system32\wusa.exe" "C:\Users\MyProfile\Desktop\Windows6.1-KB958559-x86.msu"")

    ...followed by a log after reboot time stating:

    Package KB958559 failed to be changed to the Installed state. Status: 0x8007054f.

    Any further help for Sorloren or myself in regards to this issue would be greatly appreciated.

    Many thanks,
    Luke.
    Wednesday, December 16, 2009 11:41 PM
  • Whoops! I had assumed serloren's problem had been solved... Been working with him again over the last couple of days to get things working...

    @Demus01:
    Your issue seems to be different from serloren's
    Could you please zip and mail C:\Windows\Logs\CBS\CBS.log to wcvdata@microsoft.com?
    Please mention this thread id, your email id and screen name in the mail.
    Saturday, December 19, 2009 2:50 PM
  • This is my latest per Event Viewer and the last attempt I made to install it after deleting the folders from Windows Update a Microsoft online chat tech told me to:

    <!-- [if gte mso 9]><xml> <w:WordDocument> <w:View>Normal</w:View> <w:Zoom>0</w:Zoom> <w:PunctuationKerning/> <w:ValidateAgainstSchemas/> <w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid> <w:IgnoreMixedContent>false</w:IgnoreMixedContent> <w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText> <w:Compatibility> <w:BreakWrappedTables/> <w:SnapToGridInCell/> <w:WrapTextWithPunct/> <w:UseAsianBreakRules/> <w:DontGrowAutofit/> </w:Compatibility> <w:BrowserLevel>MicrosoftInternetExplorer4</w:BrowserLevel> </w:WordDocument> </xml><![endif]--><!-- [if gte mso 9]><xml> <w:LatentStyles DefLockedState="false" LatentStyleCount="156"> </w:LatentStyles> </xml><![endif]--> <!-- /* Font Definitions */ @font-face {font-family:"Bookman Old Style"; panose-1:2 5 6 4 5 5 5 2 2 4; mso-font-charset:0; mso-generic-font-family:roman; mso-font-pitch:variable; mso-font-signature:647 0 0 0 159 0;} /* Style Definitions */ p.MsoNormal, li.MsoNormal, div.MsoNormal {mso-style-parent:""; margin:0in; margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:12.0pt; font-family:"Bookman Old Style"; mso-fareast-font-family:"Times New Roman"; mso-bidi-font-family:"Times New Roman";} @page Section1 {size:8.5in 11.0in; margin:.75in .5in .5in .5in; mso-header-margin:.5in; mso-footer-margin:.5in; mso-paper-source:0;} div.Section1 {page:Section1;} --> <!-- [if gte mso 10]> <style> /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;} </style> <![endif]-->

    12-18-2009 1:11:42pm           WUSA

     

    Windows update Update for Windows (KB958559) requires a computer restart to complete the installation. (Command line: ""C:\Windows\system32\wusa.exe" "C:\Users\seloren\Desktop\XP Mode\NEW_Windows6.1-KB958559-x64.msu"        ")

     

    12-18-2009 1:11:42pm          WUSA

     

    Windows update "Update for Windows (KB958559)" was successfully installed. (Command line: ""C:\Windows\system32\wusa.exe" "C:\Users\seloren\Desktop\XP Mode\NEW_Windows6.1-KB958559-x64.msu"        ")

     

    12-18-2009 1:15:50pm          Servicing

     

    Package KB958559 failed to be changed to the Installed state. Status: 0x80004005.


    Saturday, December 19, 2009 10:13 PM
  • Please ignore the stupid Word tags that crept in...
    Saturday, December 19, 2009 10:14 PM
  • Hi Serloren,

    Thanks for the reply. I see you have the same error description as me in your event viewer:

    Package KB958559 failed to be changed to the Installed state. Status: 0x800...

    I see Thayu has also commented (thanks Thayu!), and asked me to send my CBS.log file to him. I am sending this now, and will let you know of any further information i gain on the issue.

    Thayu, do you think these issues could be related to the same problem?

    Many thanks,
    Luke.


    Monday, December 21, 2009 10:48 PM
  • @Demus01:
    Hi Luke,
    At first glance, it looks like some part of your registry is corrupt, and the installer is complaining about that. I'll have to dig a little deeper though to try to pinpoint the issue. I'll try to get back to you sometime tomorrow. Before I do that though, could you please try another install of VPC and send me the new logs as well? If you hit an error again, and if the logs say the same, it pretty much means something is corrupt; we can then look at how best to fix it.

    Another thing I would like to know is if other Windows updates have installed successfully on your system - the logs you sent me seem to be truncated and contain only the VPC installation part...

    Regards,
    Thayu
    Tuesday, December 22, 2009 3:48 PM
  • Microsoft Support called this afternoon - gave him control of the system, first thing he does is run the tool to see if I can handle virtualization. This was immediately after my telling him that this was brand-new (6 weeks old) system with more than enough firepower to do it, AND that I had already run the tool previously just to double-check that the hardware was in fact ready to rock.

    This of course altered my own perception of who..er..what is a Microsoft Tool...

    He had me uninstall VPC 2007 which I was working on using as a workaround, and he then proceeded to shut down all my non-Microsoft services, reboot clean, and try to install VPC. This of course did not work, and I had already told him that not only had this been tried, but that I had even tried opening permissions on every folder on my machine temporarily and that didn't help either.

    I had to get off the phone as my baby was waking up and my wife wasn't home yet. When we hung up he intends to call me back tomorrow - he ended the conversation with a suggestion to reinstall Windows.....NOT!

    If he thinks of something less drastic before tomorrow - I'll hear it, but I am not going to do a complete reinstall on a new Dell on his say-so as his second idea of a fix.

    Corruption...

    You know I had thought about file/registry corruption somehow being the issue, but wasn't sure if I should pursue that line or not. I was also thinking about files just being somehow 'missing', and was trying to think how I could best check for missing files and replace them....

    How about you guys?
    Wednesday, December 23, 2009 1:25 AM
  • Hi Thayu,

    Thanks for the response.

    I have re-tryed the VPC install, and received the same errors.

    I have checked the Windows Update history and some updates have installed succesfully and others have not. I have included a jpg screenhot of the update history in the zip file i have just emailed you. Some updates failed first time, but installed succesfully at a later date. This has never been the case with the VPC install though.

    I have sent the latest CBS.log file to you now.

    Many thanks,
    Luke.
    Tuesday, December 29, 2009 9:30 AM
  • Hi Serloren,

    Yes i have also considered the registry, but am also unsure how to persue the investigation. I did run the Microsoft Windows 7 registry checker tool from the command line, but it returned no faults.

    Ive sent another CBS.log to Thayu, i will let you know of any further information.

    Thanks,
    Luke.
    Tuesday, December 29, 2009 9:48 AM
  • Hello all,
    Seems that I have the same issue, and am looking for ways to resolve it.

    I have, in an attempt to run photoshop CS3 in XP Mode, tried to install both XPMode and the VPC packages. The XP Mode package loads fine, but the VPC packages failes every time I try to load it. I have run the HAV and am running a compatible and enabled system.

    I have not tried to install this in inverse order yet, and may give that a shot.

    Thayu, is there any way I can send you a CBS.log for you to take a look at ?

    Please advise.

    Michael
    Tuesday, December 29, 2009 11:10 PM
  • Hi everyone (or anyone who is still checking this thread at least),

    To update, after Microsoft's phone support (NOT Thayu) screwed around with this a while, we ended up with a system that no longer functions, and after a mildly "heated" exchange over the phone between him and a Dell tech, Dell attempted to get the system going. I called back at 2am this morning to finish up where I knew the whole thing was heading...

    After my 2am call, and time spent explaining for the zillionth time, and yet again making some attempts to boot the system - they finally got the point: something in the hardware is royally screwed! Think of every single way that you know to boot or attempt to boot a freezing system - including ones to do a reinstall etc - and double that, and you'll have an idea of how many things were tried (all of them several times).

    As of right now, my Inspiron is sitting upstairs at my desk, its guts laid open for all to see - dead. Just so you understand, it does power up, but nothing can get the system to load past "Windows is loading files" without a complete freeze-lockup.

    Dell said "You've been through enough (Tell me about it!), we are going to swap out the RAM, the motherboard, and the HD for you, I just have to set up a ticket for the tech to come out".

    I told him that this was silly - and lacked was not efficient nor cost effective. When he asked why, I said it made no sense to contact a tech (who they job out of course), ship him parts, and then have him spend 3 hours (possibly much more) including travel time to come to my home, pull the system apart and swap those items when they could far more easily ship me a new system, and me ship this one back since all that's really left is $10 of parts for a case/power (Dell cost not retail<g>).

    He said that he going to leave the processor, video and audio cards too - so much more than $10 parts. I told him that the system uses onboard audio and video - no add-ins, and since we have no idea this point what the hardware issue is, how much sense did it make to leave a proc that could *possibly* be at fault, to have the problem re-emerge in a week and be back at square one with another in-house service call. Given that the system is 5-6 weeks old, stock is not an issue, so better (and much cheaper) to send out an entirely new system, and take this one back in-house. Wham bam no sweat and that's all folks!

    He put me on hold for about 10 minutes, then 5, then 10, then said he had gotten approval to do a full system swap. We went through a bunch more gunk, but I am now awaiting (VERY unhappy that it may be more than 2 weeks to delivery!!) a new system from Dell to replace the new system I took delivery of the 8th of November.

    I am so screwed in so many ways because of all of this that I can't begin to describe what it has and is costing me dealing with this. My darling wife ordered me a new Dell 23" monitor for Christmas which isn't here yet....it may very well be the very last thing we ever order from Dell.

    However, your mileage may vary! ;-)

    Happy New Year all (I think I'll go slash my wrists now...)

    serloren
    Wednesday, December 30, 2009 4:18 PM
  • @MYKLIV:
    Sure! Please zip and mail C:\Windows\Logs\CBS\CBS.log to wcvdata@microsoft.com
    Please mention this thread id, your email id and screen name in the mail.

    @Luke:
    I'll take a look at the logs and get back to you in some time...

    @serloren:
    Ouch! Painful!
    I hope you don't hit the VPC installation issue again in your new machine! I'll get this issue root-caused anyway, just in case someone else hits it in the future...

    Wish all of you a very happy new year! :)
    Monday, January 4, 2010 7:03 AM
  • Hi All,

    @Thayu:
    Many thanks for your continued support.

    @Serloren:
    Very sorry to hear you have been through that process, it must have been very frustrating and disheartening. At least, you will get a fresh system that should provide you with a fresh start and hopefully, no more problems. Good Luck!

    Thanks,
    Luke.

    Monday, January 4, 2010 11:28 AM
  • @demus01:
    The problem was a few corrupted registry keys. I've sent you a mail with the "fix". However, we're just addressing the symptom here - the real fix would be to identify who corrupted the registry keys and fix that particular update/software.

    @MYKLIV:
    Sorry, I've been a bit busy this last week, so I didn't have much time to dig into your logs. I'm getting started on them now... I'll let you know once I have some solid suggestions or need some information.
    Saturday, January 9, 2010 2:19 PM
  • @MYKLIV:
    I see a lot of "ERROR_NO_SYSTEM_RESOURCES" errors in your logs... And this is for all installation attempts for VPC. I would like to know if you have been able to successfully install any other updates on your machine. Also, could you please send me your system config and free hard disk space on your system drive (typically C:\). You can identify the systemdrive as the one with a small "Windows" icon on it when you open "Computer" in explorer.
    Monday, January 11, 2010 5:48 PM
  • Hi all,

    After looking hours and hours on the internet, I finally found this thread. I have exactly the same symptoms as described here. I desperately need access to the XP mode so it would be great if I could get an answer to these problem.

    @Thayu
    You're talking about a workaround in regards to the corrupt registry keys. Is it possible to send me the fix too please, so that I can try it out. Thank's
    If you need some more info, please let me know

    Thank's

    Frank.
    Tuesday, January 12, 2010 3:54 PM
  • @Frank_Verheyen:
    There are multiple reasons why installation could be failing. In the case of demus01, it was a bunch of corrupt registry keys. It is different in Serloren's and MYKLIV's case; and I can't say what is the cause of failure in your case before taking a look at your logs. The reason that fix was sent to demus01 and only to demus01 was that the fix would help him, but might corrupt someone else's registry.

    A belated realization from my side, but opening a new thread for your problem will probably make it easier for other people who hit a similar problem to find a solution (rather than read through a whole page of confusing information, most of which won't apply to them). I probably should've asked demus01 and MYKLIV to do the same, but oh well...

    So could you please create a new thread and zip and mail C:\Windows\Logs\CBS\CBS.log from your machine to wcvdata@microsoft.com
    Please mention this thread id, your email id and screen name in the mail.

    And an update:
    Demus01 has Windows VPC and XP Mode up and running now!
    Wednesday, January 13, 2010 5:50 AM
  • Hi Everyone,

    Yes i can confirm I am now up and running after installing a reg fix for some corrupt registry keys.

    Thank you all for your help and support, as i was starting to consider a complete windows re-install, and i really didnt want to do that!
     
    Also, I am very impressed with the level of support and professional service you have provided Thayu.

    Peace,
    Luke.


    Thursday, January 14, 2010 12:47 PM
  • I too have the same problem installing this update.  I email my log files to the above address.  Could you take a look and reccomend registry fixes?  Many thanks!
    Saturday, January 16, 2010 3:10 PM
  • Post deleted.  Following Thayu's instructions to create a new thread
    Saturday, January 16, 2010 7:29 PM
  • @overlook2k:
    From your logs, the error is 0x8004a029, which basically indicates that the maximum number of network filter drivers has been reached.
    Could you uninstall any other network filter driver that you think is not necessary and try installing VPC again?

    Tuesday, January 19, 2010 5:49 AM
  • Hi Thayu and all,

    I'm another Windows 7 XP mode candidate with exactly the same problem.

    I know a new thread has been started, please provide its URL so we can use it.

    Sunday, April 25, 2010 8:10 AM
  • @BygByrd:

    I have looked at your logs and the error is  0x8004a029, which basically indicates that the maximum number of network filter drivers has been reached. Could you uninstall any other network filter driver that you think is not necessary and try installing VPC again?

    Monday, April 26, 2010 8:17 AM
  • Hi Narayanan,

    Thanks for responding, but as I'm a novice in this area I'm not familiar with "Filter drivers". Where do I find them?

    Checking My Network Connections I have 6 devices: 3G Connection, Bluetooth Network Connection, Intel Gigabit NIC, OpenVPN-TAP_1, TeamViewer VPN, and Wireless Network Connection. I don't use Bluetooth Networking so could delete it, but before doing so would like to know that that is a "Filter Driver" and that if I need it again in future I can re-instal it without too much trouble. I use the other devices quite frequently soo do not wish to delete them.

     

     

    Saturday, May 1, 2010 3:48 AM
  • Check if you are using any other virtualization software like Oracle/Sun's Virtual box or VMware.

    If you are using another virtualization software, then uninstall it, reboot & install virtual pc (KB958559), Should install fine.

    I am not sure of the reason here, but this worked out perfectly fine for me on more than 2 occaions.


    Sólo la verdad triunfa
    Thursday, July 22, 2010 3:03 PM
  • I have the same type of problems related here. PC restarts to install the windows virtual pc, then after going to XX % says it failed and rollsback (tried multiple times).

    I uploaded my logs from CBS folder here:

    http://cid-662594af1ed7e330.office.live.com/browse.aspx/.Public

     

    (also ran  System Update Readiness Tool with no luck)

     

    any idea how to fix this?

    Friday, November 12, 2010 3:51 AM
  • Hi

    i have had the same problem on Windows 7 64 professional, i am unable to install some important updates and not able to install VPC for XP.
    Getting a bit desperate i have finally cracked it after 8 hours, i used a fix on a vista forum.

    "I already fixed it. None of your suggested courses of action worked. You could not run the net stop commands as Vista stated I did not have permissions on the system. Strange, since I am a member of the administrators group on the local machine? Anyway, what I did to correct the problem was go into the MMC and stop the Cryptographic Services. Then renamed the Windows\system32\catroot2 folder to \catroot2old. Rebooted the system and it forced windows to regenerate a new catroot2 folder. On reboot I forced windows update to look for updates, this may take a long time, up to 3-5 mins in my case. Windows update presented me with the missing updates and this time they installed correctly. Rebooted again after updates.  It took a long time for the system to shut down, but you must let it shut down by itself. Upon reboot, everything now works fine. I suspect this is a Windows Vista Service Pack 2 problem as I did not have any problems until after I installed it. I remembered some clients of mine had this same problem with Vista SP1 and that was how I fixed it.

    the above fix worked fine and now all updates load and XP works fine, see forum on

    http://social.answers.microsoft.com/Forums/en-US/vistawu/thread/0f0fa69f-f984-4a9f-a08b-5becd0f75fe6

    Tuesday, November 23, 2010 11:29 AM
  • Hi,

    I was stuck with the same issue on Win7 -64 bit. What helped me resolve the issue was 3 things I got from this thread.

    1. Removed the Windows Process Activation Service rebooted then removed the IIS service.

    2. Installed the System Update readiness tool - http://support.microsoft.com/kb/947821/en-us

    3. Repaired my .Net platform 4. Rebooted.

    4. Re-installed the IIS service with the relevant bits (rebooted) and it worked this time around.

    Thanks for the information on this thread, it saved me having to rebuild my machine as the worst case scenario.

    Tuesday, April 24, 2012 12:22 PM