Driver Power State Failure - I'm stuck


  • So I have had my Amilo Pi 3560 Laptop since a while, Windows 7 Ultimate 64 bit version working like a charm for about 1,5 years or so. Since september however, it randomly (about 5-10 % of the time) produces the infamous Driver Power State Error (stating that it's caused by ntoskrnl) after waking up from sleep or resuming from hibernation. I tried to investigate with Bluescreenview and Windbg, but got stuck. I'm attaching the two last minidumps so you can examine it, hope you'll have more luck finding the clue.

    Some further infos:

    - event viewer doesn't give any relevant info

    - bsod happens relatively soon (less than 15 minutes, but always more then 2-3 mins) after resuming system, or not happens at all

    - bsod happens plugged in or from battery too, online and offline, wifi on and wifi off too

    - bsod happens regardless of any external device (usb, monitor, etc) attached or not

    - driver configuration hasn't been changed, windows system files hasn't been updated  (at least not on purpose, since it was running flawlessly for 1,5 years since installation). After bsods started to appear, I updated the Realtek NIC driver, to no avail.

    - I'm using Avast (keeping it up-to-date), and also checked for spyware and other noob-related trivial errors

    - The only suspicious thing I've found so far is that sometimes, the Fn keys for monitor switching, Wifi, Volume, Mute etc stop to function after system resume. However, idk if bsod is necesseraly happening in this case because I usually use my rig with external peripherials attached, hence not using these keys very often.

    - maybe relevant: I'm sometimes using Virtualbox and Cisco VPN client is also installed/used. But they were used since the beginning so...

    I would normally not give a fck and just return to a previous (ca. 1 year old) disk image of c: using Norton Ghost and check if it's a hardware error (I'm pretty sure it's not), but I've found a challenge in solving this problem without doing that. It looks to be similarly complicated and unique as what I've had with my old pc. So any help is welcome.

    The minidumps are here:

    Edit before I seem to lazy: Bug-check code: 0x0000009f

    parameter 1: 00000000`00000003

    parameter 2-4: fffffa80`05654d40; fffff800`04a934d8; fffffa80`02899780

    File version: 6.1.7600.16385 (win7_rtm.090713-1255)

    • Edited by mborsik Tuesday, January 03, 2012 6:02 PM
    Tuesday, January 03, 2012 5:55 PM

All replies

  • Ok, nevermind the attached files: these were the two last dumps, and I haven't run windbg on exactly these two ones yet. Interestingly enough, it itentified the culprit this time:HDAudBus.sys


    ALL the previous minidumps were however similar to this one, and I couldn't really interpret windbg's results:


    I wonder if it's still caused by the same sysfile somehow? Now I'm investigating what this file does/where it belongs...

    Tuesday, January 03, 2012 6:21 PM
  • *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    A driver is causing an inconsistent power state.
    Arg1: 0000000000000003, A device object has been blocking an Irp for too long a time
    Arg2: fffffa8005654d40, Physical Device Object of the stack
    Arg3: fffff80004a934d8, Functional Device Object of the stack
    Arg4: fffffa8002899780, The blocked IRP
    Debugging Details:
    DRIVER_OBJECT: fffffa80043dc060
    IMAGE_NAME:  HDAudBus.sys
    FAULTING_MODULE: fffff880041a0000 HDAudBus
    PROCESS_NAME:  System
    fffff800`04a93488 fffff800`034e5e23 : 00000000`0000009f 00000000`00000003 fffffa80`05654d40 fffff800`04a934d8 : nt!KeBugCheckEx
    fffff800`04a93490 fffff800`03482fa6 : fffff800`04a935f0 fffff800`04a935f0 00000000`00000001 00000000`00000000 : nt! ?? ::FNODOBFM::`string'+0x29330
    fffff800`04a93530 fffff800`03482326 : fffffa80`027a3168 fffffa80`027a3168 00000000`00000000 00000000`00000000 : nt!KiProcessTimerDpcTable+0x66
    fffff800`04a935a0 fffff800`03482e7e : 000004a1`27b66004 fffff800`04a93c18 00000000`01f1e22e fffff800`035f2848 : nt!KiProcessExpiredTimerList+0xc6
    fffff800`04a93bf0 fffff800`03482697 : 000000fe`910100c8 000000fe`01f1e22e 000000fe`91010004 00000000`0000002e : nt!KiTimerExpiration+0x1be
    fffff800`04a93c90 fffff800`0347f6fa : fffff800`035efe80 fffff800`035fdc40 00000000`00000001 fffff880`00000000 : nt!KiRetireDpcList+0x277
    fffff800`04a93d40 00000000`00000000 : fffff800`04a94000 fffff800`04a8e000 fffff800`04a93d00 00000000`00000000 : nt!KiIdleLoop+0x5a
    FOLLOWUP_NAME:  MachineOwner
    FAILURE_BUCKET_ID:  X64_0x9F_3_IMAGE_HDAudBus.sys
    BUCKET_ID:  X64_0x9F_3_IMAGE_HDAudBus.sys
    Followup: MachineOwner
    ** The Blue Screen Caused By ( HDAudBus.sys ) :

    HDAudBus.sys file information

    The process High Definition Audio Bus Driver (version v1.0a, v1.0) belongs to the software Microsoft UAA Bus Driver for High Definition Audio or Microsoft Windows Operating System by Windows (R) Server (version 2003 DDK provider) or Microsoft Corporation (

    Description: HDAudBus.sys is located in the folder C:\Windows\System32\drivers.

     The following actions might prevent an error like this from happening again:

    1. Download and install updates and device drivers for your computer from Windows Update.
    2. Scan your computer for computer viruses.
    3. Check your hard disk for errors.




    Tuesday, January 03, 2012 6:33 PM
  • Hi,
    There's a little more to DRIVER_POWER_STATE_FAILURE, the IRP may not
    actually be hanging in the HDAudBus.sys driver, see here for more
    details on looking at the IRP,

    -- Mike Burr
    Tuesday, January 03, 2012 6:36 PM
  • Thanks, I've already seen your article but wasn't reading it carefuly enough, I'll take a closer look on the IRP. I'll report back if I'm stuck or if I find the solution!
    Tuesday, January 03, 2012 6:52 PM
  • Well, it still sounds quite chinese to me. Here are the results of the irp queries from the two typical bsod-dumps I've had. The first is the one where hdaudbus.sys have been identified, the second is the one which is referenced to ntoskrln.

    Needless to say the audio driver's haven't been updated since install, and I've had no problems with audio whatsoever, apart from some very rare occasions when directsound hanged and a restart was needed to get sound again (but as far as i know it's a known issue and just happens sometimes).

    0: kd> !irp fffffa8002899780
    Irp is active with 8 stacks 5 is current (= 0xfffffa8002899970)
     No Mdl: No System Buffer: Thread 00000000:  Irp stack trace.  
         cmd  flg cl Device   File     Completion-Context
     [  0, 0]   0  0 00000000 00000000 00000000-00000000    
    			Args: 00000000 00000000 00000000 00000000
     [  0, 0]   0  0 00000000 00000000 00000000-00000000    
    			Args: 00000000 00000000 00000000 00000000
     [  0, 0]   0  0 00000000 00000000 00000000-00000000    
    			Args: 00000000 00000000 00000000 00000000
     [  0, 0]   0  0 00000000 00000000 00000000-00000000    
    			Args: 00000000 00000000 00000000 00000000
    >[ 16, 2]   0 e1 fffffa8005654d40 00000000 fffff88004b62510-fffffa80045d9470 Success Error Cancel pending
    	       \Driver\HDAudBus	portcls!PowerIrpCompletionRoutine
    			Args: 00051100 00000001 00000001 00000002
     [ 16, 2]   0  1 fffffa80045d9320 00000000 00000000-00000000    pending
    	      Unable to load image \SystemRoot\system32\drivers\RTKVHD64.sys, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for RTKVHD64.sys
    *** ERROR: Module load completed but symbols could not be loaded for RTKVHD64.sys
    			Args: 00051100 00000001 00000001 00000002
     [ 16, 2]   0 e1 fffffa8005ec8e30 00000000 fffff800034618e0-fffffa8002e24ae0 Success Error Cancel pending
    	       \Driver\ksthunk	nt!IopUnloadSafeCompletion
    			Args: 00051100 00000001 00000001 00000002
     [  0, 0]   0  0 00000000 00000000 00000000-fffffa80081a68a0    
    			Args: 00000000 00000000 00000000 00000000
    0: kd> !irp fffffa8002b0ce10
    Irp is active with 3 stacks 2 is current (= 0xfffffa8002b0cf28)
     No Mdl: No System Buffer: Thread 00000000:  Irp stack trace.  
         cmd  flg cl Device   File     Completion-Context
     [ 16, 0]   0  0 fffffa800250d700 00000000 fffff880018bb460-fffffa800435b1a0    
    	       \Driver\PnpManager	ndis!ndisSetDevicePowerOnComplete
    			Args: 00000000 00000000 00000000 00000002
    >[ 16, 2]   0 e1 fffffa800435b050 00000000 fffff800034798e0-fffffa8002c81160 Success Error Cancel pending
    	       \Driver\tunnel	nt!IopUnloadSafeCompletion
    			Args: 00041100 00000001 00000001 00000002
     [  0, 0]   0  0 00000000 00000000 00000000-fffffa8007ec3e40    
    			Args: 00000000 00000000 00000000 00000000

    Sunday, January 08, 2012 11:40 AM
  • RTKVHD64.sys appears to be the Realtek audio driver. tunnel.sys is a
    Microsoft driver thta is involved in the networking stack. Are there any
    available updates for the audio/network drivers for your system on the
    manufacturer's site?

    -- Mike Burr
    Monday, January 09, 2012 2:38 AM
  • I've already updated the ethernet driver, did the same for wlan and audio now, just to make sure. Although logic dictates that if my system was functioning properly with the very same drivers for 18 months, the new error couldn't be caused by faulty drivers. But if this solves my problem, I don't care.

    I can think of maybe one more thing: I had to play quite a lot with settings (Magic Packets etc) to eliminate random wakeups from sleep. Now that i tell it, looks like the driver updates reset these settings to default. Anyway, we'll see what happens now.
    Monday, January 09, 2012 8:20 AM
  • I can understand that, but the issue is that the drivers become out of
    date relative to the rest of the system (due to updates, etc).

    -- Mike Burr
    • Proposed as answer by auggyMVP Monday, January 16, 2012 3:18 PM
    Monday, January 09, 2012 3:47 PM
  • Ok, so update on the issue. As it turned out, I only downloaded the audio drivers, but somehow remembered that I've already installed them. Nope, I only did that for networking. This however helped, as now we can safely assume that the networking drivers in itself cannot be the issue. Afteir their update however, I'm now able to predict bluescreens, because now, the whole network adapter dies after waking up (but again, this happens randomly, not always), and they cannot be reinitialized with troubleshooting whatsoever. At the same time, the monitor output switch also ceases to function, and when trying to reboot, windows hangs at logging out, until it gets the bsod.

    The last minidump was the same as the previous, referring to the same files. So now I've updated the audio, let's see what happens...

    If this doesn't resolve it, I'll just return to my old ghost image once I'm at home where i have a desktop computer, in case anything goes wrong.

    Monday, January 16, 2012 9:15 AM
  • Ok, just as I suspected, it has nothing to directly with these drivers. The only difference after updates now is that I can predict the upcoming bluescreen, because the ethernet network adapter dies completely, even the usual icon from notification area is missing, and is replaced by the "no available wireless network" icon. This doesn't mean however that wireless is working, although there is a working wireless backup network in the building (but i use cable), so even that state is incorrect.

    I tested the system in the short time before bsod. Sound (both directsound and waveout from analog lineout) and video is working, all the function keys belonging to the laptop however seem to be dead. A short search for fujitsu osd utility and bluescreen however doesn't bring any meaningful results, so I guess it's just a symptom, not the underlying issue. Last minidump, for your pleasure:

    0: kd> !analyze -v
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    A driver is causing an inconsistent power state.
    Arg1: 0000000000000003, A device object has been blocking an Irp for too long a time
    Arg2: fffffa80024f3980, Physical Device Object of the stack
    Arg3: fffff80004a9c4d8, Functional Device Object of the stack
    Arg4: fffffa8002bcee10, The blocked IRP
    Debugging Details:
    IMAGE_NAME:  ntkrnlmp
    FAULTING_MODULE: fffff88004145000 tunnel
    IRP_ADDRESS:  fffffa8002bcee10
    DEVICE_OBJECT: fffffa80042e4050
    DRIVER_OBJECT: fffffa800429cad0
    PROCESS_NAME:  System
    fffff800`04a9c488 fffff800`034f1e23 : 00000000`0000009f 00000000`00000003 fffffa80`024f3980 fffff800`04a9c4d8 : nt!KeBugCheckEx
    fffff800`04a9c490 fffff800`0348efa6 : fffff800`04a9c5c0 fffff800`04a9c5c0 00000000`00000001 00000000`00000000 : nt! ?? ::FNODOBFM::`string'+0x29330
    fffff800`04a9c530 fffff800`0348e326 : fffffa80`07117448 fffffa80`07117448 00000000`00000000 00000000`00000000 : nt!KiProcessTimerDpcTable+0x66
    fffff800`04a9c5a0 fffff800`0348ee7e : 0000010d`d905a3d5 fffff800`04a9cc18 00000000`00715ced fffff800`03600028 : nt!KiProcessExpiredTimerList+0xc6
    fffff800`04a9cbf0 fffff800`0348e697 : 0000003a`40b88dc2 0000003a`00715ced 0000003a`40b88dd0 00000000`000000ed : nt!KiTimerExpiration+0x1be
    fffff800`04a9cc90 fffff800`0348b6fa : fffff800`035fbe80 fffff800`03609c40 00000000`00000001 fffffa80`00000000 : nt!KiRetireDpcList+0x277
    fffff800`04a9cd40 00000000`00000000 : fffff800`04a9d000 fffff800`04a97000 fffff800`04a9cd00 00000000`00000000 : nt!KiIdleLoop+0x5a
    FOLLOWUP_NAME:  MachineOwner
    MODULE_NAME: ntkrnlmp
    FAILURE_BUCKET_ID:  X64_0x9F_3_IMAGE_ntkrnlmp
    BUCKET_ID:  X64_0x9F_3_IMAGE_ntkrnlmp
    Followup: MachineOwner
    0: kd> !irp fffffa8002bcee10
    Irp is active with 3 stacks 2 is current (= 0xfffffa8002bcef28)
     No Mdl: No System Buffer: Thread 00000000:  Irp stack trace.  
         cmd  flg cl Device   File     Completion-Context
     [ 16, 0]   0  0 fffffa80024f3980 00000000 fffff880016ee460-fffffa80042e41a0    
    	       \Driver\PnpManager	ndis!ndisSetDevicePowerOnComplete
    			Args: 00000000 00000000 00000000 00000002
    >[ 16, 2]   0 e1 fffffa80042e4050 00000000 fffff8000346d8e0-fffffa8007c89090 Success Error Cancel pending
    	       \Driver\tunnel	nt!IopUnloadSafeCompletion
    			Args: 00041100 00000001 00000001 00000002
     [  0, 0]   0  0 00000000 00000000 00000000-fffffa8004490530    
    			Args: 00000000 00000000 00000000 00000000
    0: kd> !devobj fffffa80042e4050 f
    fffff80003631790: Unable to get value of ObpRootDirectoryObject
    Device object (fffffa80042e4050) is for:
     InfoMask field not found for _OBJECT_HEADER at fffffa80042e4020
     \Driver\tunnel DriverObject fffffa800429cad0
    Current Irp 00000000 RefCount 0 Type 00000017 Flags 00002050
    DevExt fffffa80042e41a0 DevObjExt fffffa80042e58a0 
    ExtensionFlags (0x00000800)  
                                 Unknown flags 0x00000800
    AttachedTo (Lower) fffffa80024f3980 \Driver\PnpManager
    Device queue is not busy.
    0: kd> !drvobj fffffa800429cad0 f
    fffff80003631790: Unable to get value of ObpRootDirectoryObject
    fffff80003631790: Unable to get value of ObpRootDirectoryObject
    Driver object (fffffa800429cad0) is for:
    Driver Extension List: (id , addr)
    Device Object list:
    fffffa8004965690: Could not read device object
    DriverEntry:   fffff88004162064	tunnel!GsDriverEntry
    DriverStartIo: 00000000	
    DriverUnload:  fffff88001750830	ndis!ndisMUnloadEx
    AddDevice:     00000000	
    Dispatch routines:
    [00] IRP_MJ_CREATE                      fffff880016a9c30	ndis!ndisCreateIrpHandler
    [01] IRP_MJ_CREATE_NAMED_PIPE           fffff88001740490	ndis!ndisDummyIrpHandler
    [02] IRP_MJ_CLOSE                       fffff880016aa010	ndis!ndisCloseIrpHandler
    [03] IRP_MJ_READ                        fffff88001740490	ndis!ndisDummyIrpHandler
    [04] IRP_MJ_WRITE                       fffff88001740490	ndis!ndisDummyIrpHandler
    [05] IRP_MJ_QUERY_INFORMATION           fffff88001740490	ndis!ndisDummyIrpHandler
    [06] IRP_MJ_SET_INFORMATION             fffff88001740490	ndis!ndisDummyIrpHandler
    [07] IRP_MJ_QUERY_EA                    fffff88001740490	ndis!ndisDummyIrpHandler
    [08] IRP_MJ_SET_EA                      fffff88001740490	ndis!ndisDummyIrpHandler
    [09] IRP_MJ_FLUSH_BUFFERS               fffff88001740490	ndis!ndisDummyIrpHandler
    [0a] IRP_MJ_QUERY_VOLUME_INFORMATION    fffff88001740490	ndis!ndisDummyIrpHandler
    [0b] IRP_MJ_SET_VOLUME_INFORMATION      fffff88001740490	ndis!ndisDummyIrpHandler
    [0c] IRP_MJ_DIRECTORY_CONTROL           fffff88001740490	ndis!ndisDummyIrpHandler
    [0d] IRP_MJ_FILE_SYSTEM_CONTROL         fffff88001740490	ndis!ndisDummyIrpHandler
    [0e] IRP_MJ_DEVICE_CONTROL              fffff88001740020	ndis!ndisDeviceControlIrpHandler
    [0f] IRP_MJ_INTERNAL_DEVICE_CONTROL     fffff88001740490	ndis!ndisDummyIrpHandler
    [10] IRP_MJ_SHUTDOWN                    fffff88001740490	ndis!ndisDummyIrpHandler
    [11] IRP_MJ_LOCK_CONTROL                fffff88001740490	ndis!ndisDummyIrpHandler
    [12] IRP_MJ_CLEANUP                     fffff88001740490	ndis!ndisDummyIrpHandler
    [13] IRP_MJ_CREATE_MAILSLOT             fffff88001740490	ndis!ndisDummyIrpHandler
    [14] IRP_MJ_QUERY_SECURITY              fffff88001740490	ndis!ndisDummyIrpHandler
    [15] IRP_MJ_SET_SECURITY                fffff88001740490	ndis!ndisDummyIrpHandler
    [16] IRP_MJ_POWER                       fffff880016f47c0	ndis!ndisPowerDispatch
    [17] IRP_MJ_SYSTEM_CONTROL              fffff880017148f0	ndis!ndisWMIDispatch
    [18] IRP_MJ_DEVICE_CHANGE               fffff88001740490	ndis!ndisDummyIrpHandler
    [19] IRP_MJ_QUERY_QUOTA                 fffff88001740490	ndis!ndisDummyIrpHandler
    [1a] IRP_MJ_SET_QUOTA                   fffff88001740490	ndis!ndisDummyIrpHandler
    [1b] IRP_MJ_PNP                         fffff88001745220	ndis!ndisPnPDispatch

    link to file:

    Thanks for any feedback!

    Tuesday, January 17, 2012 5:39 PM
  • I had something similar with a really cheap network card that I bought
    before, have you tried a replacement card? Also, if you disable the
    network card through device manager, does a crash still occur?

    -- Mike Burr
    Interesting Reading on Technology and Finance
    Saturday, January 21, 2012 11:51 PM
  • At it is a notebook, you cannot really replace it :( Maybe install an external usb-to-ethernet device. I will try to disable it, we will see. Another symptom which i have identified: after a faulty wakeup (ie. when you can already predict the bsod), you cannot put back the computer to sleep. The start menu button doesn´t do anything.
    Sunday, January 22, 2012 10:11 AM