none
Windows 7 RC x32 Intel GM965 Driver issues with HDMI Audio

    Question

  • I have a Dell 1525 inspiration laptop with Intel GM965 Express Chipset Video.
    I was running Windows Vista Ultimate on it befor upgrading to Windows 7 RC
    Now However the HDMI Audio nolonger functions or shows up under audio devices.
    I was using intel driver 7.14.10.1409,A03  but windows 7 upgrade rolled the driver back to a older one.
    I tried installing the newer driver but it says its not compatible with the operating system and won't install.
    I tried the latest driver from the Intel website 15.12.4.1666 (7.15.10.1666) but the screen goes black or flashes.
    I guess this is why Windows 7 is using a much older driver that is stable with the operating system.
    Anyone know a work around to get the HDMI Audio working?
    Sunday, May 10, 2009 11:22 AM

Answers

  • I have a Dell 1525 inspiration laptop with Intel GM965 Express Chipset Video.
    I was running Windows Vista Ultimate on it befor upgrading to Windows 7 RC
    Now However the HDMI Audio nolonger functions or shows up under audio devices.
    I was using intel driver 7.14.10.1409,A03  but windows 7 upgrade rolled the driver back to a older one.
    I tried installing the newer driver but it says its not compatible with the operating system and won't install.
    I tried the latest driver from the Intel website 15.12.4.1666 (7.15.10.1666) but the screen goes black or flashes.
    I guess this is why Windows 7 is using a much older driver that is stable with the operating system.
    Anyone know a work around to get the HDMI Audio working?

    I was able to resolve this same issue with my Dell Inspiron 1525 by using the following drivers on my Windows 7 Pro RC Version 6.1.7600

    Audio driver found here Vista 32 bit
    http://support.dell.com/support/downloads/driverslist.aspx?c=us&l=en&s=dhs&catid=&impid=&os=WLH&osl=en&SystemID=INS_PNT_PM_1525
    R218148.exe
    SIGMATEL STAC 92XX C-Major HD Audio
    6.10.0.5866

    and

    Video drivers found here Windows 7 Professional 32 bit
    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=17803&ProdId=2800&lang=eng
    win7_1512753.zip
    Intel GM965 Express Chipset Family
    15.12.75.3.1912

    here is a screen dump of my working driver properties
    http://home.roadrunner.com/~traneross/Capture.PNG

    Tested and verified using a Dynex Audio/Video HDMI cable out to a Toshiba 46rv535u.  Please note that I'm using the onboard Intel video card which is what is being used for the HDMI audio and video output.

    Prior to me using the above drivers I was not able to see Digital Output Device (HDMI) in the Sound-Playback settings.  After having installed the above drivers I was able to see and select Digital Output Device (HDMI) as the default and everything works fine now.  Let me know if this helps.
    • Proposed as answer by TraneR Tuesday, September 29, 2009 12:34 AM
    • Marked as answer by JKhilburger Wednesday, October 07, 2009 12:34 AM
    Tuesday, September 29, 2009 12:34 AM

All replies

  • You need to get the audio and video drivers from dell and run them in compatibility mode for windows vista.
    Friday, May 15, 2009 1:19 PM
  • I tried Windows 7 RC1 x64 ... and no longer get HDMI Audio... when I was with Windows 7 beta 7077 x64 , audio worked fine after installing the drivers from motherboard's website (Gigabyte). However, since moving to RC1, the drivers dont seem to work... they appear to be working properly in the device manager, and is selectable from the "Sound" panel.. I can even set the default to HDMI audio... but there is simply no audio emitting from the HDTV

    I've tried reinstalling realtek drivers, ati drivers, and what not.. all no help...
    Wednesday, May 27, 2009 4:20 PM
  • Are you the original poster or sharing the same issue?

    Wednesday, May 27, 2009 6:51 PM
  • I am having the same issue as the OP. I have the same model but am running 32-bit RC.
    It worked fine after install but then a few reboots later suddenly stopped working.
    (Inspiron 1525)
    Tuesday, July 28, 2009 9:25 PM
  • I have a Dell 1525 inspiration laptop with Intel GM965 Express Chipset Video.
    I was running Windows Vista Ultimate on it befor upgrading to Windows 7 RC
    Now However the HDMI Audio nolonger functions or shows up under audio devices.
    I was using intel driver 7.14.10.1409,A03  but windows 7 upgrade rolled the driver back to a older one.
    I tried installing the newer driver but it says its not compatible with the operating system and won't install.
    I tried the latest driver from the Intel website 15.12.4.1666 (7.15.10.1666) but the screen goes black or flashes.
    I guess this is why Windows 7 is using a much older driver that is stable with the operating system.
    Anyone know a work around to get the HDMI Audio working?

    I was able to resolve this same issue with my Dell Inspiron 1525 by using the following drivers on my Windows 7 Pro RC Version 6.1.7600

    Audio driver found here Vista 32 bit
    http://support.dell.com/support/downloads/driverslist.aspx?c=us&l=en&s=dhs&catid=&impid=&os=WLH&osl=en&SystemID=INS_PNT_PM_1525
    R218148.exe
    SIGMATEL STAC 92XX C-Major HD Audio
    6.10.0.5866

    and

    Video drivers found here Windows 7 Professional 32 bit
    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=17803&ProdId=2800&lang=eng
    win7_1512753.zip
    Intel GM965 Express Chipset Family
    15.12.75.3.1912

    here is a screen dump of my working driver properties
    http://home.roadrunner.com/~traneross/Capture.PNG

    Tested and verified using a Dynex Audio/Video HDMI cable out to a Toshiba 46rv535u.  Please note that I'm using the onboard Intel video card which is what is being used for the HDMI audio and video output.

    Prior to me using the above drivers I was not able to see Digital Output Device (HDMI) in the Sound-Playback settings.  After having installed the above drivers I was able to see and select Digital Output Device (HDMI) as the default and everything works fine now.  Let me know if this helps.
    • Proposed as answer by TraneR Tuesday, September 29, 2009 12:34 AM
    • Marked as answer by JKhilburger Wednesday, October 07, 2009 12:34 AM
    Tuesday, September 29, 2009 12:34 AM
  • thanks,
    Tried the driver and it works.
    Wednesday, October 07, 2009 12:35 AM
  • Yep, that's the ticket...if your using the GM 965 chipset, just install the above driver found in intel's download center.

    Inspiron 1525
    Windows 7 home premium
    GM 965 express chipset
    Wednesday, October 28, 2009 6:30 PM
  • That worked for me as well.  The chipset I downloaded was newer, but worked the same.

    Thank You!
    Monday, November 16, 2009 6:43 AM
  • I am late into this issue......but none the less, I experience the same issue....great Video and no Audio connecting my Laptop via HDMI Cable to my TV.

    Win7 Home Prem 32bit

    I viewed your screen dump......My Mobile Intel (R) Express Chipset Family Properities shows

    Driver date 9/23/2009  

    Version  8.15.10.1930

    I went out to Intel and did a search for 8.15.10.1912....it came back Not Found.  The only driver version available at Intel was the 8.15.10.1930

    My Intel...High Def Audio HDMI shows

    6/6/2007  and Version 6.10.2035 (your 7/10/2009  Ver 6.10.1.2077....did a search could not locate at Microsoft or Intel)

    My Sigma High def Audio COCDEC is the SAME as shown in your screen dump.

    It appears both my 965 Chipset and Audio HDMI drivers are newer version

    However, I don't have HDMI selection in my Sound properities and as I wrote, when I connect via HDMI to my TV I get NO Audio

    Thoughts?  Suggestions?

     

     

     

     

     

     

    Monday, June 07, 2010 3:40 PM
  • I had been researching this issue on my inspiron for a long time, and at long last the above solutions worked.  So, thanks to all of you above...nice to have HDMI audio/video to my bravia with better video and audio quality (and less messy cables)
    Saturday, January 01, 2011 3:11 AM