none
Can't access NAS drive after Windows 10 build 1803 installed RRS feed

  • Question

  • Hello,

    After the 1803 Update that turned off SMBv1, I can no longer access the NAS drive on one system. Other computers (Windows 10) and devices (phones and tablets) can access the NAS drive.

    I have done the following:

    Network Profile is set to Private.

    I altered these services to Automatic (Delayed Start)
    - Function Discovery Provider Host
    - Function Discovery Resourse Publication
    - SSDP Discovery
    - UPnP Device Host

    Now, when I click on Network in Explorer, I can actually see my computer and the shared folders, but still can't see the NAS drive. Every oher Win 10 computer can see it. Including, a Win 10 VM I set up on the computer that CAN'T see the NAS drive. So, there is something set on this computer that is preventing it from seeing this drive. I would rather get some suggestions of what might need to be changed, than Resetting the OS and start over. I have done a Network Reset for both the Ethernet adapter and the WiFi adapter. No such luck. 

    Thank you,
    Mike
    Tuesday, September 18, 2018 1:32 PM

Answers

  • Hi

    Let me rephrase, In the hosts file type for example

    192.168.0.10  pc1 # this is the computer where the shared  folder is located and access denied

    192.168.0.13  pc2  #this is the computer where the shared  folder is located and access denied


    192.168.0.25  yourNASname  #this is the NAS where the shared  folder is located and access denied


    Save the files and please use your own IP addresses


    Momominta

    • Marked as answer by Mike_1369 Sunday, September 23, 2018 3:32 PM
    Sunday, September 23, 2018 8:07 AM

All replies

  • Go to the Control Panel and select Programs ans Features

    Select Turn Windows features On or Off

    Go down to SMB 1.0/CIFS file sharing support

    Expand the entry and check SMB 1.0/CFIS client

    Select okay and reboot.

    This will enable SMB 1.0 needed for a  NAS that requires it.

    Tuesday, September 18, 2018 4:24 PM
  • Hi,

    What type of NAS? some of them have utilities you can install to make it easier. Have you tried their support page for a guide to setting up windows 10?

    How was it accessed before? The IP address and then a mapped drive letter?

    To get the best solution to your concern, we suggest contacting the manufacturer of your NAS device to address the issue properly.

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, September 19, 2018 2:04 AM
    Moderator
  • I am using an old laptop with Turnkey Fileserver installed.

    I would click on the Network folder, and it would appear, click, click, click, to designated folders.

    The weird thing is, I have a Windows 10 VM installed on the laptop that \\NAS does not show up on. But, inside the VM, it shows up, any other Windows 10 device, it appears (all latest build), and my android, amazon kindle fire, and Windows Phone devices. They all can access the drive as well. 

    Every time MS updates Windows 10, it breaks something else that used to work, then didn't work, then worked again. It is like they are compiling with wrong versions of the code or something.

    Saturday, September 22, 2018 1:48 AM
  • I switched to "Automatic Start" like you suggested. The File and Printer sharing was already set to "on", network discovery set to on, etc.

    It is a setting in my computer. I think it is a registry issue. The items are checked and showing "on", but the registry entries are not changing. This is my first thought.

    Because, all other computers and devices can access the \\NAS folder. AND, like I have stated in my previous posts, I have a VM running Windows 10, just to test this, and it can access the \\NAS folder as well.

    Sigh

    Saturday, September 22, 2018 4:01 AM
  • No error messages, because \\NAS doesn't even display.

    If I try "Map Network Drive" and manually put \\NAS, that will return "The Network Path Wasn't Found"

    All other things were already set or in the registry, as per the pages you sent.

    My guess is that some kind of setting in a firewall, but, I have disabled the firewalls (Windows Defender and Norton), rebooted, still the same issue.

    Thank you for the help.

    Saturday, September 22, 2018 12:59 PM
  • Interesting. Now, using \\nas\storage  and  \\10.0.0.238\storage, now works to map the drive. But, it still does not show up when I click on Network in Windows Explorer. 

    Progress at least. :)

    Saturday, September 22, 2018 9:01 PM
  • Thank you for your help. For now, I am going to Map Drive manually -- 10.0.0.238\storage\Mike....etc  for this system, until I get the desire to do a Windows 10 reset :)

    Sunday, September 23, 2018 3:31 PM
  • Thanks a bunch! I tried more or less every other solution I found,  all from enabling SMB1, trying to force SMB3, changing registry stuff, disabling hardware, you name it. And in the end the stupid little hosts file solved it :o

    Thanks again!

    Monday, November 19, 2018 12:40 AM
  • 'Hosts' doesn't exist on my installation
    Friday, December 28, 2018 4:27 PM
  • Thanks for the advise

    I have found the setting and switched it on.

    My Normal build and my insider build are now showing my network drives

    Strange part i could map manually

    Evan my Divx programme can see the network drive

    Why Would Microsoft switch the flag off ????

    Sunday, February 17, 2019 7:22 AM
  • This did the trick after looking around the internet and trying out many solutions

    Under media devices on Network I could see the devices but under computer on Network the drives were not displayed. As soon as I made the changes, all my media drives appeared after the reboot.

    Thanks very much

    Sunday, May 5, 2019 9:23 AM
  • I was so hopeful finding this tread (after trying so many different suggestions and failing) but alas - I still cannot see my NAS drive in Network after changing host file.   Any other suggestions maybe? 

    I have  SMB1 enabled... 

    In the past, NAS (DLink-23FD51) used to disappear after every new Windows update but then eventually it would show up, but later its appearances were more and more seldom and now it looks like it might've disappeared for good.  I still can access the mapped drive, but I need to see the NAS in Network in order for the backup program to work.  

    Thank you

    Sunday, May 26, 2019 2:44 AM
  • I had the same problem under the V1803 with a NAS synology DS214se in private local network. Microsoft support obviously required that I switch to V1903, before any further investigation. After all the disturbances created by the update, no improvement.

     

    The NAS is always accessible from its browser-based administration interface, a laptop V1803 and TV via my mediabox SFR.

    I compared the services activated on my laptop with those of the desktop PC: they are identical for the functions of the networks.

    When I want to connect a network drive the "network" folder is empty.

     

    Also from time to time after a reboot the explorer sees some of the NAS files on the T: drive connected but they are incomplete. Recent additions at a time when the NAS was accessible do not appear, while folders deleted from the NAS (and emptied trash) still appear.

     

    It's the same with a new local administarteur account.

     

    This instability of access seems known by synology that refers to Microsoft.

     

    It would be that Microsoft is concerned about this instability. It comes from purchased software. We have the right to demand a solution to this recurring problem for a long time.

    Sunday, June 23, 2019 4:47 PM
  • Unbelievable!  After doing a clean install of Windows 10 1809, I came to this issue as well.  Something so widely used, why would they hide such an option...  Perhaps for security.  In any case, THANK YOU so very much for getting us this solution.  It worked perfectly.
    Sunday, December 8, 2019 11:14 AM