none
SearchFilterHost.exe Process running CPU at 100% RRS feed

  • Question


  • Dual booting a 32bit 2Ghz, 2GB RAM laptop with Vista Business and Windows 7 RC1, No issues under Vista (hard to believe I know) but under 7 the SearchFilterHost.exe consistently churns my CPU at 100%, I can only temporarily suspend the service but can't stop it or remove it, any idea to stop the churning of my CPU?
    Thursday, May 21, 2009 5:43 AM

Answers

  • Try disabling the Windows Search service. SearchFilterHost.exe is the process for Windows Search. It is involved in indexing, caching, etc. Or try to change the priority to below normal or lower.
    Friday, May 22, 2009 7:31 PM

All replies

  • Try disabling the Windows Search service. SearchFilterHost.exe is the process for Windows Search. It is involved in indexing, caching, etc. Or try to change the priority to below normal or lower.
    Friday, May 22, 2009 7:31 PM
  • I have the same problem.  The process runs at 100% on one CPU.  It cannot be successfully killed by the Task Manager and stopping the Windows Search service will only keep it stopped for <30secs.  It apparently has a watchdog process that automatically restarts it whenever it is not running.

    While the process runs at low priority and thus does not badly affect system performance, it does wreck my laptop's power management system - the high CPU utilization keeps the clock rate high, creates heat, and runs the battery.

    The process obviously has a bug that needs to be fixed ASAP.
    Tuesday, June 2, 2009 11:52 AM
  • Tuesday, June 2, 2009 12:32 PM
  • For more information, I am running Windows 7 rc1  (7100) x86 upgraded from Vista SP1 on a Dell Inspiron 2ghz, 2GB system.  I don't see the problem on my clean Windows 7 installs.
    Tuesday, June 2, 2009 1:56 PM
  • I went into services via the search ( ironically) typed in services, went down to Windows Search, stopped the process then changed it's properties to Manual Startup Type. My CPU dropped immediately.
    • Proposed as answer by Ginx77 Sunday, May 13, 2012 2:14 AM
    Friday, June 5, 2009 9:11 AM
  • I wish that worked.  Windows 7 clearly has a watchdog for SearthFilterHost.exe.  When I manually kill it, the process is immediately restarted.  When I stop Windows Search, it is automatically restarted.  When I set the service to disabled or manual, it is still restarted.  When I do all of this and reboot, there it is running.  Nothing successfully stops it - it is always running and consuming 100% of one core.

    Until the bug of (unproductive) runnaway CPU use is fixed, I would love a circumvention that would allow me to successfully kill/disable the process, especially when I am on battery.  Ideas?
    Friday, June 5, 2009 11:16 AM
  • I would love a circumvention that would allow me to successfully kill/disable the process,
    Well... Set up an image file redirect for searchfilterhost.exe, that causes it to launch e.g. services.exe or svchost.exe (which will immediately exit since they're not supposed to be run this way).

    Create the key:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\searchfilterhost.exe]
    Add a REG_SZ value named Debugger and give it data of c:\windows\system32\svchost.exe

    You shouldn't notice searchfilterhost.exe running anymore...

    To remove, just delete the Debugger value, or delete the searchfilterhost.exe key.
    • Proposed as answer by Curt Paw Monday, April 28, 2014 9:20 AM
    Friday, June 5, 2009 11:28 AM
  • Thanks.  I just set the registry.  I assume I need to kill the process or reboot the system to take effect.

    Before I reboot, here is my fear:  the watchdog will keep on trying to restart it as the restart continually fails and this result might be far worse than the present situation.  Have you tried this solution?
    Friday, June 5, 2009 11:39 AM
  • In this context? No.  In general, I've used image file redirects for many things.  If the process is currently running, it will need to be stopped.  Future attempts to start it will result in svchost.exe being started, and it will quickly exit.  If you're (rightly) concerned about the implications of making the change, back the system up first or at least make a restore point.  If you have access to an off-line registry editor, you should also be able to load the SOFTWARE hive and remove the value, to restore things to the way they were (or, restore the restore point).
    Friday, June 5, 2009 1:00 PM
  • Thanks. It works.  I hope the bug gets fixed before release.  I guess an alternative for me would be to do a clean install, but I hate the thought of having to reinstall and reconfigure everything.  Ugh!
    Friday, June 5, 2009 5:24 PM
  • That should keep CPU usage down, until something can be done to address the root cause...
    Friday, June 5, 2009 6:06 PM
  • Note that in the aforementioned similar topic, two participants were able to (apparently) resolve the issue, by removing multimedia decorders...
    • Proposed as answer by No.Compromise Monday, June 8, 2009 2:21 PM
    • Unproposed as answer by Adam M MCP Monday, June 8, 2009 2:22 PM
    Monday, June 8, 2009 12:41 PM
  • I just renamed  "C:\Program Files\Common Files\Sonic Shared" to "C:\Program Files\Common Files\Sonic SharedX", reset my previous registry circuvention, and rebooted.  The problem appears to be resolved.

    Thanks.
    Monday, June 8, 2009 2:02 PM
  • Interesting - thanks for confirming! Yet another case of a decoder seeming to cause the issue...
    Monday, June 8, 2009 2:21 PM
  • My bet is that searchfilterhost needs to extract metadata to index, and that the codec DLL replaces the data access functions.  It's likely that there is a bug in the data access overload that causes searchfilterhost to stick and effectively lock up.
    Monday, June 8, 2009 7:22 PM
  • As SearchFilterHost is a hosting process (not necessarily unlike svchost and dllhost), it is not a surprise that it is susceptible to the whims of the elements it hosts (components that implement the capability to extract indexable content)...
    Monday, June 8, 2009 7:30 PM
  • That makes sense,  and also why it has a watchdog to restart it in the event that one of its hosted elements brings it down.  The watchdog obviously needs to be enhanced so that it not only looks for crashes, but also for these pathological CPU lock situations, removes the offending element from its trusted list, and automatically submits a bug report that ultimately gets routed to the relevant vendor.
    Monday, June 8, 2009 7:59 PM
  • Such a concept would seem to apply generally, to include similar cases like the aforementioned svchost, dllhost processes... and the Sidebar instance that hosts third-party gadgets...
    Monday, June 8, 2009 8:05 PM
  • It is located in C/Windows/System32. It is important to know the location of searchfilterhost.exe
    Saturday, April 2, 2011 11:20 PM
  • to permenently stop the indexing service you need to:

    double click My Computer

    right click on your C: drive

    Click properties

    Under the General Tab, Uncheck "Allow Indexing Service to index this disk for fast file searching"

    If asked, allow to stop indexing for C: and all subfolders. Click Apply and Ok (this will take a couple of minutes)

    Repeat on any other drives you have.

    Next, go to services (Start|Run and enter “services.msc”.),

    find "Indexing Service"

    right click for properties, click "Stop"  then chose "disable" or "manual"

    Voila! You are done

     

    Friday, August 19, 2011 3:56 PM
  • You can also go to indexing options, and uncheck things you don't want to index, like c:\users.

     

    Saturday, August 20, 2011 4:55 PM
  • Access the option in the control panel named "Change how Windows searches".  This can be easily found in Windows 7 by typing "search" in the start menu.  You should reach the "Indexing options".  Here, I clicked pause.  CPU usage immediately dropped to acceptable levels.
    Monday, August 22, 2011 6:00 AM
  • Gud! I created key in registry, added Debugger name to 'REG_SZ value', then set data value to "C:\windows\system32\svchost.exe", and just rebooted the sytem.

    It killed the searchfilterhost.exe and System speed drasticaly increased.

    It works well even in XP. Thanks for valuable suggestion.


    • Edited by Sathum Monday, April 9, 2012 7:09 AM jsut
    Monday, April 9, 2012 7:00 AM
  • I had a similar problem on Windows 8.1. The search filter host was using constantly 14-24% of my 8 cores on my Toshiba notebook.

    I excluded XML from being indexed, and it dropped immediately down to 0.8-1%

    Friday, October 18, 2013 11:40 PM
  • i had the same problem on win7 and now on win8.1. The search filter is using 25 % of my cpu on sony vaio f series but, i noticed that when i unpluged the battery is droping down at 5% !!
    Tuesday, October 22, 2013 11:55 AM
  • thanks   that was worked for me  .... i changed Windows search service to manually  then it is fine  
    Monday, December 30, 2013 11:08 PM
  • For Windows XP, your tip worked perfectly!

    Thank you!

    Mr. Urman

    Thursday, March 20, 2014 3:45 PM
  • I know this post is a couple years old but I figured out how to stop the auto-startup once you stop the service. I went in to the recovery tab, there is a setting to automatically restart the service upon first failure and so on. Change them all to take no action and apply.
    Thursday, March 20, 2014 3:55 PM
  • Sorry for the dumb question, I am having the same issue.  When I turn my laptop on it appears that 73 processes are running utilizing up to 100% of my CPU, and that before I try to get onto the internet.  One thing I noticed in the task manager is that both the internet explorer and Chrome are running using 100's of KB's. is this normal, do I need both search options?

    Here's the dumb question:

    I tried your recommendation however, I can't find Windows Search Services/SearchFilterHost.exe, to disable.  

    UPDATE>>> I found it and disabled it, thanks.  The CPU use went way down.  It now shows 79 processes, however most of them say CPU 00, however it also shows a ton of memory being used and things like Chrome and Internet Explorer listed many times.  Is that necessary? 

    I would appreciate your direction.

    Thank you,

    Manuel


    • Edited by 38Manny Friday, April 3, 2015 5:57 PM I found the searchfilterhost
    Friday, April 3, 2015 4:50 PM
  • Thanks, it solved my problem, too.

    Wednesday, June 13, 2018 1:59 PM