Failed to connect to a windows service. - System Event Notification Service


  • Hello.  I  have an HP Pavilion 6815 series with Vista Ultimate loaded, and norton internet security 2010.

    Before my issue occurred: 

    1. Yesterday I Loaded and ran the free Wise Registry Cleaner from

    2. 4 days ago Norton Internet Security found and removed two Trojan viruses, both called ‘vload.class’  No issues after deleted, just thought I’d note that.

    Now the Vista Ultimate machine:

    1. Starts up very very slow.  It now takes 10-15 minutes to start

    2. When started, gives the error message:

    "Failed to connect to a windows service. Windows could not connect to the System Event Notification Service service. This problem prevents limited users from logging on to the system. As an administrative user, you can review the System Event Log for details about why the service didn't respond."

    I have tried:

    1. System restore to several points – no success
    2. Wise Registry Cleaner RESTORE  to undo registry file fix.  I tried 4 times – no success at fixing the issue.  I still get the error message
    3. Start > cmd > ctrl+shift+enter > (no elevation shows) so I couldn’t type netsh winsock reset
    4. I ran Norton full scans
    5. Ran Malwarebytes scan
    6. Used the windows vista ultimate disk to try a ‘startup repair’

    Have a system Event Log but can't upload it on this forum.  Still, does anyone have a fix?

    Thursday, February 10, 2011 1:32 AM


All replies

  • Hi,

    You are using Windows Vista, so I suggest to post the thread at for help.

    You may perform system scan to check whether the system files are damaged and repair it. 

    Meanwhile, please refer to the following links.

    How to improve the computer performance. 



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, February 11, 2011 5:53 AM
  • Hi,


    Same problem, although I managed to get through one part, here.

    I noticed that you had trouble elevating the cmd prompt to administrator.

    I had the same trouble. Apparently, from Vista onwards (I have windows 7) it gives us a new feature.

    When you right click on a program in your program list (command, being under accessories) it gives you an option to "run as administrator".

    Once you have selected this, you can then run netsh winsock reset, and anything else.

    Its magic!!! You will always open cmd as an administrator from then on.


    Luck with it!!!

    Monday, February 14, 2011 12:48 PM
  • Try disabling the startup of the windows font cache service in services seemed to solve it for me.
    Wednesday, November 23, 2011 11:48 PM