none
net use to share with folder with only read permissions gives access denied error RRS feed

  • Question

  • Hello everybody,

    A customer uses statements like "net use \\fileserver\share\folder1\folder2" to map drives into folders where users need to work frequently. This worked fine in Windows Server 2008 R2, but in 2019 we find that the net use fails when the user has only read permissions in the target folder. net use asks for credentials, and if we pass user name and password again, it nevertheless ends with an access denied error.

    Is this changed by design? Why? Or is there something we can do to re-enable net use to a read-only folder?


    Best Regards, Stefan Falk

    Tuesday, January 28, 2020 3:06 PM

Answers

  • Hello Daniel,

    Thanks for your patience. I just wanted to reproduce the issue - and could not. net use to a read-only folder works - "again" or "why ever it did not work before". I would close this case for now and return here if the problem should re-occur. Thanks again.


    Best Regards, Stefan Falk

    • Marked as answer by Stefan Falk Wednesday, February 12, 2020 2:09 PM
    Wednesday, February 12, 2020 2:09 PM

All replies

  • This is a quick note to let you know that I am currently performing research on this issue and will get back to you as soon as possible. I appreciate your patience.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact



    Wednesday, January 29, 2020 3:07 AM
    Moderator
  • Hi,

    >>net use asks for credentials, and if we pass user name and password again, it nevertheless ends with an access denied error.

    Can you provide the error message about this issue?

    I didn't found any useful information whether it changed in 2019. I will do more research later.

    Best Regards,

    Daniel


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact


    Wednesday, January 29, 2020 5:53 AM
    Moderator
  • Hello Daniel,

    Thanks for your patience. I just wanted to reproduce the issue - and could not. net use to a read-only folder works - "again" or "why ever it did not work before". I would close this case for now and return here if the problem should re-occur. Thanks again.


    Best Regards, Stefan Falk

    • Marked as answer by Stefan Falk Wednesday, February 12, 2020 2:09 PM
    Wednesday, February 12, 2020 2:09 PM