none
My nas devices are not showing in Windows File Explorer - Network, Windows 10 version 1703, build 15063.332

    Question

  • Hello forumers.  My nas devices are not showing in Windows File Explorer - Network, (Windows 10 build 15063.332).  It used to work in previous builds but has now stopped with the latest windows update (again).

    I can access them manually by using their ip names in file explorer but not their ip address.  Using the ip address takes me to the device web page.

    I have read through many forums and tried all suggestions but it still has not fixed the problem. (ticking/unticking/re-ticking SMB 1.0/CIFS File Sharing Support, ipconfig, NetBIOS etc).

    This has occurred with previous Windows builds and sometimes (just sometimes) my NAS devices appear all by themselves in File Explorer for no apparent reason.

    Has anyone found a reliable fix for this problem?

    Cheers,  PG

    Saturday, May 27, 2017 10:01 PM

All replies

  • I seem to have "fixed" the problem.  I systematically unplugged each device from the switch, one at a time, counted to 10, plugged them back in and BINGO there they are in File explorer when I finished (4 x NAS drives, router and PC).

    Now, if someone can find a solution so I don't have to go through this procedure again would be great.

    Cheers,  PG

    Saturday, May 27, 2017 11:56 PM
  • Hi PG,

    Thank you for your share.

    For Windows 1703 network, this is a hot topic issue. I see different problems on different areas frequently and no viable solutions. As you said, under the system, we could only change some settings like re-enable SMB or re-check file print sharing and so on.

    You could try to update the NAS device firmware and ask the manufacturer has tested the device on Windows 10 1703 version.

    Also I will forward this information to the appropriate department through our internal channel. Both the Microsoft Product Team and Development Team take into consideration all suggestions and feedback for future releases.

    Hope it will be helpful to you


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, May 29, 2017 8:01 AM
    Moderator
  • I have same problem with 1607 and 1703, but not resolved by unplugging or power off.  I can't see my Black Armor 440 NAS nor Synology DS1517+.  

    MS.  We need help.

    Tuesday, June 13, 2017 3:31 AM
  • That response was not at all helpful, it is obvious a MS10 problem so get it fixed and then respond.
    Monday, August 14, 2017 7:20 PM
  • I second that: NAS was seen yesterday, right before an update took place. No longer seen today. Definitely a Windows 10 problem that MS must fix for good: what's so hard in pinging devices on a subnet, checking for an open SMB port and listing it as available? Nothing. Version: 10.0.15063, 1703. KB4038788, KB4035543 or KB4022405 broke this functionality. 

    This is the kind of issue you'd expect from free / amateur software, not from a paid-for OS.

    In the meantime, the NAS supports FTP / SFTP as well, so I can still use it. But what's the fun in using UNIX command line on a PC meant to be used for entertainment ;)

    Saturday, September 30, 2017 9:32 PM
  • You can also still use smb 2+ shares, you just can't browse for them.
     
    A business, whether AD or not should have their own DNS server and that's
    how I'd browse, but I agree, it's not the most compatible way of doing
    things be getting rid of the browser service.  At home I use ip address
    rather than browsing as well..
     
     
    Saturday, September 30, 2017 9:45 PM
  • The Computer Browser service is broken in Windows 10 1703 and is gone from future releases of Windows.

    Yes, that's right folks, after 25 years of being able to browse our networks Microsoft have decided Workgroup users don't need this functionality any more.  This article from Microsoft explains:

    SMBv1 is not installed by default in Windows 10 Fall Creators Update 2017 and Windows Server, Semi-annual Channel

    They are getting rid of SMB v1.0, which is fair enough, it has real security issues.  The Computer Browser service relies on SMB v1.0, rather than upgrade the Computer Browser service so Workgroup users are still able to browse their networks they are simply removing it.  From the linked article:

    For home and small business users who use Network Neighborhood to locate Windows computers, you shoud map drives to the computers so that you no longer have to browse for them.

    Not even spell checked and suggesting we only do it to access data we could map drives to, indicating a total lack of understanding as to why we need network browsing.  Network browsing is an essential tool for doing a visual check of which computing resources are available in a Workgroup.  The command "net view" allows us to quickly report which computers are available in the Workgroup and thereby use the information to run system reports and perform various tasks.  Locating and enabling printers becomes far more difficult without Computer Browsing.

    This does not affect AD users, those businesses which need to or have the luxury of being able to invest in server hardware and software.  Users who's data is in the cloud, on the internet have less issue, it may only affect attaching printer resources which can be worked around.  Of course all Microsoft staff fit into these groups so the lack of browsing functionality in Workgroups is probably insignificant to them.

    So what we need now is either a great little tool to browse our networks that doesn't rely on SMB 1.0 or an upgraded Computer Browser service.

    The service is broken in Windows 10 Creators 1703. If a 1703 PC is the Master Browser only that computer has Computer Browsing, if a non-1703 is the Master Browser all the non-1703 PCs have Computer Browsing.  This is the reason why browsing appears to work sometimes and not others, rebooting PCs forces a Master Browser election, which will change which PC is the Master Browser and can introduce the issue.

    To work around the issue involves setting one computer to be the Master Browser.  Some people have third party devices on their network they can set to be the Master Browser, all non-1703 can browse.  To identify which computer is the Master Browser you can run the command 

    nbtstat -a ComputerName

    for each computer in the Workgroup.  The computer that is the Master Browser is the only one that has the value

    __MSBROWSE__

    in the list.

    To set which computer is the Master Browser you need to make registry modifications on that computer.  Browse to the registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters

    Change the value of MaintainServerList from Auto to Yes

    If it is not there, add a new String Value IsDomainMaster and set it to True

    You may need to reboot to activate this.  If you want to be absolutely positive no other PC takes the Master Browser role you can set the value of MaintainServerList from Auto to No on all other PCs in the Workgroup.  You may even find that a non Microsoft third party device on the network attempts to take over the Master Browser role.

    I re-iterate that this is just a short term workaround, Computer Browsing for workgroups is history for Windows 10.  If you know of any great tools for browsing Workgroups that don't rely on the older protocols I'd be happy to hear from you.

    Saturday, September 30, 2017 9:50 PM
  • I too have recently been having this problem.  I have a Synology NAS and it has been working fine.  My desktop is using Windows 7 and my laptop Windows 10.  Recently, the laptop with Windows 10 was not seeing the NAS in the network when using Explorer.  I have been doing extensive Googling and found a solution that I have verified works with three laptops in our house that are using Windows 10. 

    Here is the easy fix ...

    • Get to where you can change the network adapter settings.  There are several ways to get there.  Here is one way.
    • Under the start menu, select SETTINGS, in the Windows Settings window, select "Network & Internet"
    • In the next window (called STATUS), select "Change Adapter Options"
    • The next window should show all the network adapters on your system.  For example, my laptop shows three ... a Bluetooth Network Connection, an Ethernet adapter and a Wi-Fi adapter.  The following needs to be done for each adapter that you use to access the NAS over your network
    • Right click the adapter and select "Properties"
    • Highlight the connection, "Internet Protocol Version 4 (TCP/IPv4)" ... then click the button labeled, "Properties" ... make sure that the connection remains checked before selecting Properties
    • In the Properties window, click "Advanced" button
    • In the Advanced TCP/IP Settings window, go to the WINS tab
    • At the bottom of the WINS window, click the radio button to select "Enable NetBIOS over TCP/IP"  .  The default is to use the NetBIOS setting from the DHCP server.  For reasons unknown to me, this does not work with Windows 10 on my Synology NAS ... although works fine on Windows 7.   Now click OK and back out of all these open windows. 

    That is it.  Works for me and hopefully will work with you too.

    Steve

    • Proposed as answer by ennui101-2 Tuesday, January 30, 2018 2:49 PM
    Thursday, November 30, 2017 4:33 PM
  • Hi Steve, ya lost me there. 

    At first you're saying that this is a fix for the Windows 10 laptops in your house. But then you say this works "fine on Windows 7" but not Windows 10. 

    I'm working on the problem in Windows 10. Unfortunately, this change doesn't seem to have helped me. Perhaps it only works if you're still running Win7? 


    • Edited by Northstar702 Wednesday, December 27, 2017 7:07 AM
    Wednesday, December 27, 2017 7:06 AM
  • I think he's saying that Windows 7 works ok when set to use settings from the DHCP server on his router but Windows 10 doesn't.

    It seems that his Windows 10 laptops work if he manually sets them to use NetBIOS over TCP/IP.

    Unfortunately, whether it works for him or not, it doesn't resolve my problem.



    Wednesday, December 27, 2017 4:01 PM
  • This worked like a champ for me. Thank you, Steve.
    Tuesday, January 30, 2018 2:51 PM
  • Steve,

    Not sure if you meant this as a Win 7 or Win 10 fix, in any event it did not correct my identical situation with W10, still cannot see my NAS.

    Thursday, April 12, 2018 3:36 PM
  • I am still having this issue. Seagate Back Armor NAS. And here's the weird thing...if I rebuild with a clean, current copy of Windows, it will work for a while and then it stops. 
    Tuesday, June 26, 2018 3:17 PM
  • Immediately after changing as indicated by Steve  "Enable NetBIOS over TCP/IP"  I could see my Synology NAS. Then 30 minutes later I cannot see any other computer on my network.
    Wednesday, July 11, 2018 9:02 PM
  • Hello, I have been round and round with this and the only way to consistently  map My synology NAS drive is to  Map  the drives  using the IP address VS the DNS\work group names. 

    If you map with the IP addresses the connection is hard set. 

     
    Thursday, July 12, 2018 1:21 AM
  • Hi

    You need to map your NAS


    Momominta

    Hey smartass....bit hard if you can not browse to the device ain't it, i know how to set up a drive mapping  but sometimes its just handy to browse.
    • Edited by BarbaBas77 Tuesday, July 17, 2018 4:00 PM
    Tuesday, July 17, 2018 4:00 PM
  • Hi BarbaBas77

    Be polite.


    Momominta

    Wednesday, July 18, 2018 2:18 AM
  • I had same problem and required reboot a couple of times before it appeared in File Explorer. However once I have the NAS recognised in Explorer I created a shortcut thru the File Explorer of the NAS (in my case its called Server#) on my desktop. I can now access the NAS in File Explorer even when its not showing in the File Explorer. I hope this makes sense.

    • Edited by stinger9 Wednesday, July 25, 2018 10:28 PM
    Wednesday, July 25, 2018 10:27 PM
  • Having the same issue in Windows 10.

    Contacted Microsoft support by chat. They advised a bug in v1803 causes the 2 Function Discovery services (see services.msc) to have the wrong startup setting. They changed it to Automatic.

    That fixed the problem for a week or so then it returned, even though the services are starting correctly.

    A workaround that works for me is to enter \\yournasname in the Explorer navigation bar, then pin to Quick Access. The NAS name then appears in the Quick Access list and I can click it to browse the NAS folders.

    It still doesn't appear as a network device if you click Network in the left hand Explorer pane.

    Saturday, August 4, 2018 9:32 AM
  • Hi David

    Here is  the workaround , open windows services > winlogo + R> services.msc

    In the list take a look at if these services are started on all your pcs. If not start them and put them on automatic.

    Function Discovery Resource Publication service

    UPnP Device Host service

    Function Discovery Provider Host

    Now if you can't access from file explorer,  open command prompt then type

    Start \\thecomputerIPaddress\sharedfoldername

    Or Start \\thecomputername\sharedfoldername

    If that does not work,

    In Command prompt ping the computer IP address you want to access the shared folder  then type again

    Start \\thecomputerIPaddress\sharedfoldername

    Or Start \\thecomputername\sharedfoldername

    It is not allowed to enable smb1 then if you get a NAS goto your NAS control panel  then enable the smb2

    Read your NAS manual to help yourself.


    Momominta

    Saturday, August 4, 2018 12:55 PM
  • I'm running Windows 10 and this resolved my issue.  Thanks!
    Tuesday, September 18, 2018 12:55 PM
  • Another workaround is to try every setup from this link

    https://support.microsoft.com/en-us/help/2696547/how-to-detect-enable-and-disable-smbv1-smbv2-and-smbv3-in-windows-and


    Momominta

    Wednesday, September 19, 2018 10:05 AM
  • I found this link with a solution that corrected my inability to access NAS:

    https://social.technet.microsoft.com/Forums/windows/en-US/f0a9ad80-d940-4483-818b-ec943f1dc420/network-discovery-not-working-after-win10-1709-update?forum=win10itpronetworkinghttps://social.technet.microsoft.com/Forums/windows/en-US/f0a9ad80-d940-4483-818b-ec943f1dc420/network-discovery-not-working-after-win10-1709-update?forum=win10itpronetworking

    Monday, October 8, 2018 4:25 PM