Windows 7 Diagnostic Policy Service won't start - Error message 5 : Access Denied


  • Hi, was wondering if anyone can help me with this problem.

    Have just installed the latest updates for Windows - had to do each manually as they wouldn't update when closing computer down. Since then I haven't been able to get on to the internet as I can't get the Diagnostic Policy Service to start. I have read other threads and have tried what they have said but am not having any luck. The forums were helpful in figuring out that I needed to install the updates individually and reboot after each one. Tried statting  the DPS in services but got Error 5: Access Denied.

    My laptop is working fine with the wireless connection as is my iphone.

    I am running Windows 7 Professional on the computer that I am having trouble with. Can someone please HELP!

    Thank you

    Saturday, April 30, 2011 10:26 AM


  • Hi kazbro,

    Thanks for the post!

    Refer to the KB: Some services do not start in Windows Vista. (Windows 7 also applied)

    Then go to your Device Manager, uninstall the network device. Reboot the computer then automatically install the network device again.

    Meanwhile, do a disk check, run cmd as administrator, input the command: chkdsk /f



    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, May 03, 2011 8:41 AM