none
WDS Reimage query RRS feed

  • Question

  • Hi,

    I've just setup WDS on Server 2008 R2 to deploy windows 7 into my environment. Initally I got the error "WdsClient: An error occurred while communicating with the Windows Deployment Services server. Please check to ensure that the server is operational and that the necessary ports are open on the server's firewall." so after checking the firewall and everything looking like it should be ok, I eventually turned it off and and tried again. It worked and I when through the prompts and my custom WIM got pushed down to the client machine.

    After I let the WIM intstall and confirmed the machine booted ok I reenabled the firewall to start looking at what ports weren't open that needed to be, enabled logging and rebooted the client machine to initate the PXE boot again and got hit with the error "PXE-E55: proxyDHCP service did not reply to the request on port 4011".

    So after doing some digging and following the steps to enable options 066 & 067 on the DHCP server (The WDS server is standalone in the domain, DHCP on a separate server), it still wasn't working. I was asking myself why I needed to follow these steps when it was working before applying them so tried to PXE Boot another machine and it worked. went back to my first machine and the same error.

    So now I'm really confused, does anyone else know if there is some setting in WDS that flags a machine and has a stand down period of how often an image can be deployed to it, or somewhere else that's logged the machine to stop an image from being redeployed to it?

    Friday, November 6, 2009 2:21 AM

All replies

  • Ok more randomness. After having a nice weekend off, first thing I did today was plug the box in, and it gave a pending request to my WDS server again.
    So I approved it and started pushing down the WIM.

    I'm going to keep looking at this, but does anyone know with WDS how to revoke approval for a machine so it can be prompted again?

    I'll try and provide some more details after I'm done some more testing.
    Monday, November 9, 2009 5:57 AM