none
How do you disable virtual/multiple desktop feature? RRS feed

  • Question

  • I would like to disable the virtual/multiple desktop feature in Windows 10. It has become an issue when using my computer.  use a touch pad mouse. every time I swipe to the right in a certain pattern or speed it brings up the virtual/multiple desktop interface or shrinks my current working window. I want this to stop NOW! How do I disable this garbage?
    • Edited by smills99357 Monday, March 5, 2018 8:32 AM typo
    Monday, March 5, 2018 8:31 AM

All replies

  • Hi smills99357.

    As far as I know, there is no way to disable Virtual Desktops in Windows 10: that's by design.
    You can hide the Task View button on the taskbar or disable certain shortcuts that use the Win key, but the whole Virtual Desktop feature cannot be deactivated.

    Bye.


    Luigi Bruno
    MCP, MCTS, MOS, MTA

    Monday, March 5, 2018 9:15 AM
  • Hi,

    Please refer to this similar thread:

    https://social.technet.microsoft.com/Forums/en-US/70ddfdb0-a161-4ba6-9033-04fdc51b1196/removedisable-virtual-desktop-manager?forum=win10itprogeneral


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, March 6, 2018 7:58 AM
    Moderator
  • How about a better Answer?
    Wednesday, September 19, 2018 2:02 AM
  • By design, no way to disable? Why would it be PURPOSELY impossible to turn off this annoying feature? 

    It keeps triggering accidentally. It is a pain in the ass.

    I want it off, I should have it off.

    How about I break your operating system without your permission?


    • Edited by ThomasKing1 Friday, October 26, 2018 6:02 PM
    Friday, October 26, 2018 6:01 PM
  • By design, no way to disable? Why would it be PURPOSELY impossible to turn off this annoying feature? 

    It keeps triggering accidentally. It is a pain in the ass.

    I want it off, I should have it off.

    How about I break your operating system without your permission?


    Breaking the OS would make it unsupported, therefore you'll be the only responsible for any kind of problem (including data loss) that could result from your action.
    You could use the Windows 10 built in Feedback Hub app to submit your suggestion about the possibility to disable the virtual desktops feature.

    Bye.


    Luigi Bruno
    MCP, MCTS, MOS, MTA

    Saturday, October 27, 2018 8:08 AM
  • This has drove me insane, it seriously has tested my already poor temper. I'm at a loss. Have you made any progress? I'm going to go hack up the reg. next till I find the issue..I really could care less if I grenade this new laptop at this point. -----PS.. it's a terrible solution but if i uninstall the Elan driver and delete the touchpad drivers from windows,  it will stop, however scrolling and everything else will go as well. I would be ok with that if this unit was a touchscreen.
    Tuesday, November 20, 2018 9:06 AM
  • Same for me - browsing in Chrome & I slide my finger on the trackpad to a button & the screen collapses. Really annoying - why can't it either be switched off, or at least behave properly?
    Saturday, December 1, 2018 8:49 PM
  • I agree, this is a pretty big issue, and for someone to say it is supposed to be like that is like Steve Jobs saying "Don't hold it that way".  If you open a window with the cursor on the left of screen then swipe your cursor to the right (to use the scrollbar) at least half the time it minimizes the screen and enters the multi desktop view. This is not only super annoying, but makes the entire OS experience horrible. This does not happen on all laptops though. It happens on my Toshiba Satellite, but not either of my Dells. I've also experienced it on other people's computers. I think it may be a driver issue with certain trackpads.


    Tuesday, December 18, 2018 10:41 PM
  • Problem: Touchpad "Edge Swipe" gesture is by default enabled as shortcut for win+tab (itself a keyboard shortcut) => Task View is mapped to the edge swipe ->... Most annoying double shortcut mapped to such a common touchpad gesture.

    Easily disabled as in https://kb.parallels.com/en/123659

    Just find your touchpad swipes / gestures and disable the whole EdgeSwipe thing. Unfortunately this kills plenty of potentially other useful swipes too.

    MS: The keyboard win+Tab shortcut is already sufficient. Please don't enforce yet another default swipe on it, since the touchpad is key for many other apps - more important than v-desktop mgnt. Thanks, Mitch-

    Thursday, December 27, 2018 5:11 PM
  • Hello,

    I agree: it is horrible; I have the same thing. Everytime I try or make a gesture on my touchpad for longer than a few seconds, virtual/multiple desktop appears. I am really fed up with it; windows has the monopoly in the market, so they just introduce whatever not-so helpful feature they like, without the consent of the users. 

    I have a solution for this virtual/multiple desktop feature: another operating system. I just downloaded Ubuntu (it is free).

    Have a nice day.

    Kindest regards, 

    Owan

    Sunday, January 6, 2019 12:31 PM
  • I disabled this behavior on my Dell XPS laptop by opening the native Windows "Settings > Devices > Touchpad Settings" and then setting the actions for the three-finger and four-finger gestures to "Nothing".
    Wednesday, February 13, 2019 2:47 PM
  • hi, I have 6 pc's all having this problem to varying degrees.  My solution (after a year of hair pulling) is to change mouse drivers/software--Microsoft intellipoint, Logitech, and most of all if you use a touchpad or specialty wheeled mouse: change mousepad settings far down on the taskbar settings page.  Apparently most users love multiple desktops and horizontal scrolling--alas I do not.  FYI registry, group policy, & control panel are not the solution, play with diff mouse/pad software/driver settings--it worked for me.
    Thursday, February 14, 2019 5:57 AM
  • Exactly my problem!!! 
    Saturday, May 25, 2019 2:16 AM
  • The best solution I have found is disabling all multi-finger gestures.

    Windows > Settings > Touchpad > Advanced Gesture Configuration > Set all options to "Nothing"

    Tuesday, July 23, 2019 8:32 PM