none
Windows 7 RC - WPA and WPA2 will not connect with any router for Lenovo T60's

    Question

  • We've tried several of our Windows 7 test machines (MSDN download) with various routers (Netgear, Sonicwall TZ150W, etc.) in an effort to test the WIFI.  We can ONLY CONNECT to WAPs that do *NOT* have WPA or WPA2 enabled. 

    We downloaded the latest Vista drivers and tested these too.

    I spoke with colleagues at another company down the street who are ALSO experiencing issues w/ Windows 7 Wifi w/ WPA or WPA2 enabled.

    Not sure how this one slipped, seems to be widespread while searching the net.
    • Edited by itadminSPM Wednesday, August 05, 2009 5:20 AM
    Wednesday, August 05, 2009 5:19 AM

All replies

  • Did you input similar ssid and passphrase on both the router config page and wireless side? I suggest you to to disable wpa or wpa2 first and once the input and configuration is done as what i mention above then have the security enable again

    Btw if you're using window 7, by default Wireless Auto Configuration is enabled. You would need to disable Wireless Auto Configuration say if you intend to use third-party utility and vice versa

    Wednesday, August 05, 2009 5:47 AM
    Answerer
  • Thanks for the reply Daniel.  Yes, we manually added the access point and all the information matches on both sides.  Disabling WPA and/or WPA2 resolves the issue. 

    We're not using any third party software to manage our wireless connections.  I just spoke to another coworker today who was experiencing the same issue with his T60.

    I've tried the latest drivers from Lenovo to no avail... I'll keep searching.  Any other knowing WPA issues?
    Friday, August 07, 2009 7:55 AM
  • Thanks for the reply Daniel.  Yes, we manually added the access point and all the information matches on both sides.  Disabling WPA and/or WPA2 resolves the issue. 

    We're not using any third party software to manage our wireless connections.  I just spoke to another coworker today who was experiencing the same issue with his T60.

    I've tried the latest drivers from Lenovo to no avail... I'll keep searching.  Any other knowing WPA issues?

    Ensure that your router or wireless access pointst support WPA, WPA2 or else you may need to replace yours. If necessary, upgrade the firmware on the access point according to the manufacturer's directions to enable WPA on it. Care to share which exact router you guys are trying to get wpa or wpa2 working with?

    Did you ensure wpa/wpa2 is enable in the router config page?

    Fyi to Configure WPA wireless security on the router, first you need to logged into your router config page, i would suggest it to set the router setting back to default as in no security and use cable connection first, once the input setting and wpa/wpa2 has been set accordingly for both router/ap and wireless and the wireless is detected  (also if u uses a ssid and passphrase for the wpa or wpa2 u need to ensure is the same ssid and passphrase for both router/ap and the wireless say if is a notebook. Once done and the setting is save on the router config page, same goes to the window wireless setting on the notebook, verify it whether the wireless is detected with the wpa on if is detected, then u can try taking off the cable

    Following are step on How to configure wpa on a linksys router, it should work if you follow the instruction. Due to different router or ap having different setting so it would helps if you could give us the make and model of the exact router/ap

    Hope the above helps

    Friday, August 07, 2009 8:55 AM
    Answerer
  • itadminSPM,
    Windows 7 will load the drivers for the Intel wireless device. See the Intel note here. Windows 7 update will provide newer if available. So, probably not drivers.

    I don't wish to insult your knowledge, but WEP must be disabled for WPA or WPA2 to be enabled/configured. See Netgear info here. Perhaps that was overlooked. I suspect router configuration is the issue.

    I have had no issues with WPA2 on tested notebooks (all had Intel WiFi wireless adapters).

    Any success? Perhaps you would provide the WiFi adapter and router model information/version number if the problem persists.
    The problem with troubleshooting is that trouble shoots back.
    • Edited by Nano Warp Saturday, September 26, 2009 10:14 AM bold type potential cause
    • Proposed as answer by Nano Warp Saturday, September 26, 2009 10:15 AM
    Friday, August 07, 2009 11:15 AM
  • Hi Guys,

    Thanks for the responses.  Def. not an issue w/ any of our routers.  Only an issue w/ Win7, none of the Vista or XP machines have experienced Wifi problems. 

    We've experienced this issue with:

    Sonicwall TZ150W (latest firmware)
    Netgear WAG302 (latest firmware)

    Just REINSTALLED RETAIL release on the same T60 and another.  Same issue.  All keys are free of special characters, only alpha-numeric.

    ONLY WPA is enabled, nothing else (not WPA2 or WEP). 

    I spoke with two colleagues who use T60's and they too have the same issue with their T60's.  Very odd.  Thanks.

    Tuesday, August 11, 2009 1:38 AM
  • Hi

     don't wish to insult your knowledge, but WEP must be disabled for WPA or WPA2 to be enabled/configured

    As what someone mention above, you need to disable wep, regardless whether is wpa or wpa2. Just set everything back to default on the router setting, your notebook should be able to detect the wireless. Next input the ssid and passphrase on both router config page and the wireless connection on the notebook and remember to save before exiting
    Tuesday, August 11, 2009 1:51 AM
    Answerer
  • Hi Daniel,

    Your comment "Just set everything back to default on router setting" doesn't make sense to me.  Are you implying to reset the router back to factory defaults?  WEP is *not* enabled on the router only WPA is (not WPA2). 

    It detects the WAP no problem and starts to connect but just hangs.  If we disable WPA on any of the routers, Win7 connects without any issues. 


    Friday, August 14, 2009 7:22 AM
  • itadminSPM,

    Which wireless card do the T60's have installed? From the specs at Lenovo it's an unidentified mini pci (Intel) or an Intel 3945.


    Ok. One other item to check. Right-click the wireless network icon at the lower right notification area and select properties. It should be WPA in Security type, AES for encryption type, and your passphrase should be there.

    AES encryption type must be enabled for WPA.

    You should be using driver version 12.1.0.14 with the 3945.

    Any success?


    The problem with troubleshooting is that trouble shoots back.
    Friday, August 14, 2009 10:10 AM
  • Nano,

    Thanks for the reply.  I'm using TKIP for WPA.  I have WPA-Personal with TYPE: TKIP selection

    It is a 3945ABG, and I've tried obtaining VISTA drivers from Lenovo (just for kicks). 

    I'm running DRIVER VERSION: 12.4.1.4 signed by Microsoft dated 3/26/2009


    You mentioned AES specifically above.  Are there known issues w/ TKIP in Win7?

    Thanks.
    Monday, August 17, 2009 7:05 AM
  • itadminSPM,

    What I meant to suggest is to try the AES. It's only on my network that I must use AES. The router /WAP didn't like WPA/TKIP.   

    I must admit, I am stumped here. Had a rant going and deleted it. :-)

    From your 8/14/09 post "It detects the WAP no problem and starts to connect but just hangs"

    I started thinking FIREWALL- Win 7's firewall is different -and I am not using Win 7's firewall- I have Kaspersky Technical Preview 8.0 for Win 7 with a firewall. Are you using Anti-virus software with or without a firewall? Is it Win 7 compatible? List here. Vista versions of AV software have known incompatibility issues in Win 7.

    Without getting deeply into firewall issues, temporarily turn it off and attempt the wireless connection from the affected computer. If it connects you can look further. If not, that's ruled out.

    Some basic references here (WIKI)and here(Intel) confirm that the WPA/TKIP configuration should work, although not as secure as it could be. 

    Are you now running Win 7 RTM from your 8/11/09 post?
    The problem with troubleshooting is that trouble shoots back.
    Monday, August 17, 2009 11:47 AM
  • Nano,

    Tested on another FRESH T60 that I have here.  Same thing.  This time NO AV installed and firewall off.  I consulted with another colleague of mine who confirmed the same behavior on his T60 w/o Antivirus installed and Firewall off. 

    Looks like it must be a driver issue. 

    I'll keep running Win Updates and scouring the net.  Hopefully find something soon!

    Thanks.
    Wednesday, August 19, 2009 7:50 AM
  • itadminSPM,

    Have you tried the AES encryption with WPA on both ends?
     
    Hmmm- what does the system interface driver do? here 
    "WHAT THIS PACKAGE DOES

      Lenovo System Interface Driver works as the programming and data interface
      which is commonly used for Lenovo drivers, utilities and application programs
      for Microsoft Windows Vista/XP.

      If this package has been installed, updating (overwrite-installing) this
      package will fix problems, add new functions, or expand functions as noted
      below."

    It's vague, but it may contain some hardware interoperability instructions.
    The problem with troubleshooting is that trouble shoots back.
    Thursday, August 20, 2009 10:16 AM
  • Nano,

    Thanks for staying with me on this.  Apologies for the delayed reply, I was out on business.  I spoke to a Microsoft engineer when we were working on a SQL issue and he mentioned hearing of issues w/ WPA and that with his own laptop, only WPA2 worked with Win7 on some routers.  He also mentioned that Win7 likes "wpa2 better than wpa."  I took it all with a grain of salt, but he has been working on a case with us for three months and is in engineering, so I can't completely discount what he's saying!

    Next step - We're going to start playing with new version WAP's, though I am shocked it won't work with the business products we have (Netgear WG302 and Sonicwall).
    Saturday, August 29, 2009 7:27 PM
  • Hi Daniel,

    Your comment "Just set everything back to default on router setting" doesn't make sense to me.  Are you implying to reset the router back to factory defaults?  WEP is *not* enabled on the router only WPA is (not WPA2). 

    It detects the WAP no problem and starts to connect but just hangs.  If we disable WPA on any of the routers, Win7 connects without any issues. 



    Is obvious that the wireless can't get connected due to the WPA being enable as i mention earlier on, ensure NO security like WPA or stuff is enable or set for the time being and the ssid and passphrase on both router config page and the wireless connection on the notebook is the same.

    Once you get the above iron out try connecting again with wpa on/enable

    Sunday, August 30, 2009 2:03 AM
    Answerer
  • Daniel,

    Please read my comments.  It does not work with any of the T60's in our fleet nor those of a another shop down the street.  We'll wait for driver updates from Lenovo for the time being.  I'm sure it will be worked out soon enough.

    W/o WPA or WPA2 it works fine. 
    Saturday, September 05, 2009 3:44 AM
  • Hi All,

    We re-flashed a newer model of a Linksys in our lab and, while WPA2 still doesn't work, we now have WPA working.

    Thank you everyone for your support and comments! 

    Next up... resolving the WPA2 issue!
    Saturday, September 26, 2009 8:22 AM
  • itadminSPM,
    I noticed Lenovo is beginning to post some drivers for Win 7, T60. At this point in time, they have only posted firmware updates for the HDD and CD/DVD. You may want want to apply those for system stability.

    That implies that whichever drivers Win 7 supplies are sufficient.  Win7 and T60 are stable?

    The answer was incompatible Wireless Access Point/Router? 
    The Netgear WG302v.1 appears that it only supports WPA-PSK and has some known issues with the latest firmware version 4.2.17 here. The WG302v.2 looks to be a better router/wap with some connectivity bug fixes also with firmware version 5.2.3. here. Both had DHCP issues and connectivity issues with older versions.


    ASUS P4PE-P4 Extreme 3.4gHz-2gb G.Skill PC3200-XPSP3:55gb-Win7RC:17gb-DATA:500gb-ASUS N6800GT
    Saturday, September 26, 2009 10:13 AM
  • All, We have HP laptops with Intel WiFi Link 5300 AGN with MS driver 12.4.1.4 on Windows 7 Enterprise (release not RC). We can connect to WPA without issue, but WPA2 "connects" but just hangs at "Identifying..." . I have tried disabling firewall, AV, etc to no avail. There does not appear to be an updated driver at this time. Connecting to Cisco APs running the latest firmware. We have about 500+ of these machines that all worked fine on Vista, now with Windows 7, no WPA2 love.... Hoping that someone finds a resolution soon, this is kind of a showstopper :(
    Wednesday, September 30, 2009 4:02 AM
  • eduadmin,
    It probably would have been more appropriate to start your own thread as your issue is different. You know that Cisco support took some in Vista. As Intel partners with Cisco, the solutions most likely can be found there or on the Cisco forum or contact their support center directly. A new topic specific to Cisco may also attract someone's attention experiencing the same issue.

    HP support is giving "no support answer until 10/22". Have you received a better answer as a large client? It seems they would be your first stop as you have HP computers.

    Here is one response that I was able to locate quickly. Read the Intel statement here. 

    The Win 7 drivers for the Intel WiFi cards work fine. As for Cisco support, that's another issue.

    Another search returned these results with the Intel forum post here with another fix.

    Sorry, I don't have your specific answer, but there are too many variables for guessing. Win 7 and the 5300AGN are working well together. Configuration with Cisco is another matter. So, if you haven't done so, start a new post. It's only a matter of time before the supported configurations are out there.


    ASUS P4PE-P4 Extreme 3.4gHz-2gb G.Skill PC3200-XPSP3:55gb-Win7RC:17gb-DATA:500gb-ASUS N6800GT
    Wednesday, September 30, 2009 9:52 AM
  • I dunno if this help. But I spend the last six hours trying to get my daughters pc to log to the network. I even called Gateway
    but nothing. the guy told me to call my internet service provider ( dunno what their are going to do if my other  three laptops are connected except this one) (the only one with windows 7 is not) well I went and created a home network ( fake the pc) and whalla is now on with WAP2 personal security. hope this helps someone.
    Monday, October 26, 2009 1:50 AM
  • seems to me that the issue is going to be with windows 7 security features and does not let you log to a public network.
    Monday, October 26, 2009 1:51 AM

  • WPA2 with AES works fine on XP in our environment.  It validates the PKI certificates and works fine.  Windows 7 however doesn't work.  The root cert is loaded, user cert is correct... I don't see any reason why this is failing. 

    Any word on a resolution?
    Thursday, November 12, 2009 3:09 PM
  • Just upgraded to Windows 7 today and of course the first problem was that I couldn't connect to my network. I was connected fine with Vista on same machine and on my XP machine next to it. I realized after several hours futzing with it that WPA and WPA2 just simply DO NOT WORK with Windows 7. I spent time with Linksys about it and they could not figure it out. I sent them this forum thread. Does anyone know when a fix will be in place? Please direct me to a download if any. Thank you!

    Friday, November 13, 2009 8:48 AM
  • Well I actually was able to fix the problem by upgrading my wireless card drive via the internet and I now have success with WPA2.
    Friday, November 13, 2009 9:04 AM
  • This configuration works for me with Cisco AP and a Dell Latitude D620, with default drivers from Windows 7 RTM:

    Security Type - WPA2-Enterprise
    Encryption: AES
    Authentication: Microsoft Protected EAP (PEAP)
        - WILL validate server cert
        - Trusted root is my root cert (we have a intermediate issuing CA)
        - Authentication Method EAP-MSCHAP v2
        - ONLY Enable Fast Reconnect is selected
    802.1x  User or Computer Authentication
    Friday, November 13, 2009 6:43 PM
  • Glad I am not the only one having trouble with WPA2 networks and windows 7.

    For me as soon as I hit next after selecting WPA2 in the new connection wizard I get a message "An unexpected error has occurred".  No issues at all with non-WPA2 networks.  And I could connect to this network fine with Vista and the same laptop (Dell XPS-M1330).

    If I set it up as an open network so that I can get to more of the settings, I can change it to WPA2-Enterprise, AES, but the network authentication drop down is blank.  This really does not seem like a driver issue at all or a router issue.
    Friday, November 20, 2009 4:41 PM
  • I've posted the answer that worked for me here:

    http://social.answers.microsoft.com/Forums/en/vistanetworking/thread/4665856c-41a2-4b97-96c1-f474ffaeafcf?prof=required

     

    I actually just solved this tonight, so I'm going back through and posting up the possible solution in the threads that I found in my research.

     

    Basically, try this:

     

    Go into 'Power Options' (Control Panel - Power Options)

    There are 3 options: Balanced, Power Saver and (may be hidden) High Performance.

    Whichever plan you have chosen (likely not High Performance, if you have this issue), click "Change plan settings" and the "Change advance power settings". Scroll down, if necessary, to "Wireless Adapter Settings" and click on the + to expand and see "Power Saving Mode". Click the + again to reveal the options for "On battery" and "Plugged in". For both "On battery" and "Plugged in", choose 'Maximum Performance'.

    Any of the other three options ('Low', 'Medium' and 'Maximum Power Savings ') will cause this issue.

    You can also just choose High Performance, presuming the default settings for the Wireless Adapter have not been changed.

    I'd love to know if this resolves anyone's issue.

    -Tim

    • Proposed as answer by th_inc Sunday, April 25, 2010 4:20 AM
    Sunday, April 25, 2010 4:19 AM
  • I just found out how to fix the problem. Go to Control Panel -> Network and Sharing Center -> Manage wireless networks -> Right-click on the network you are trying to connect to which requires your login credentials -> Properties -> Security -> Advanced settings -> 802.1X settings -> Check 'Specify authentication mode' -> then select user authentication. Click 'ok' until you are back to the 'Manage Wireless Networks'.

    Now try to reconnect to the wireless network. Windows should now ask you for login credentials and you should be able to successfully connect.

    I have been trying to fix this problem for weeks and have finally figured it out.

    The problem seems to be that windows does not want to ask you for login credentials for WPA2.

    Friday, May 21, 2010 5:10 PM
  • I just found out how to fix the problem. Go to Control Panel -> Network and Sharing Center -> Manage wireless networks -> Right-click on the network you are trying to connect to which requires your login credentials -> Properties -> Security -> Advanced settings -> 802.1X settings -> Check 'Specify authentication mode' -> then select user authentication. Click 'ok' until you are back to the 'Manage Wireless Networks'.

    Now try to reconnect to the wireless network. Windows should now ask you for login credentials and you should be able to successfully connect.

    I have been trying to fix this problem for weeks and have finally figured it out.

    The problem seems to be that windows does not want to ask you for login credentials for WPA2.

    Friday, May 21, 2010 5:10 PM
  • I've actually tried every remedy known (and suggested) here, with no success.  Then, I tried something radical.

    I went into the Netgear router login online, typed in the admin login/password combo that's listed as the default, then reset the router through that.  Once I did that, I was able to fix everything just fine by setting up my WPA2 preferences directly through that webpage.

    Now I have no trouble with it.  I hope this works for you as well.

    • Proposed as answer by C.Poet Wednesday, May 18, 2011 6:26 AM
    Wednesday, May 18, 2011 6:25 AM