locked
Imaging with Sysprep breaks built-in apps RRS feed

  • Question

  • Hi, I am responsible for creating and managing the Windows 10 image for my organization. I am having a massive problem where the default Windows apps wont load because it is the "built in administrator account." I can't open things like the calculator, photos app, etc. 

    My setup: I am using SmartDeploy to capture and deploy the image once I configure the OS they way I want it. First, I boot into Audit Mode and make the required configurations (install Office, put icons on the desktop and start menu, etc.) After I make all the configurations I use Sysprep with the CopyProfile option to copy the configurations I made to all profiles. I need to do this because when I capture the image without using CopyProfile, the only account that is changed is the administrator account and all my configurations are gone on the other domain accounts that log into the PC. But when I set CopyProfile to being true in the unattend.xml and Sysprep the image, it fails to launch most built-in apps becasue it is the built in admin account. 

    TechNet isnt letting me post links because you cant verify my account for some reason, so I can't give the resources I used. 

    I recently said "forget it" with the new Windows 10 photos app and tried a registry change to get the old Windows 7 photo app back (and it has worked in the past) but it is not working now either and does not add the Win7 photos app to my applications. Did this method get changed/disabled?

    We now have a bunch of computers that cant open the photos app or calculator and it is getting to be extremely frustrating. Can anyone help me figure out why this is happening? 

    Wednesday, August 23, 2017 6:41 PM

All replies

  • Hi,

    If you use own capture tool to capture image rather than Windows Deployment Services, thing will be complex, I don’t know the deploy tool SmartDeploy, maybe it’s easy to capture but we can’t guarantee the image that comes from SmartDeploy is healthy and clean, you use third-party tool to capture and customize image, then use built-in Sysprep feature to generalize this image, there is a possibility that image itself has been broken, not Sysprep break it.

    Now, client users meet with Photo app and Calculator app issue, my advice is re-register Store app, meanwhile, enable GPO: User Account Control: Admin Approval Mode for the Built-in Administrator account (Computer Configuration > Policies > Windows Settings > Security > Security Options

    In fact, you could only use Microsoft product to capture image and deploy it, it will be another wonderful experience.

    Good luck.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, August 24, 2017 2:25 AM
  • Thanks for the response. I am using SmartDeploy because I could not get MDT working for the life of me, and SmartDeploy is so much easier and faster. I'm not exactly sure what else would break the image. I'm using a clean Win10 ISO downloaded straight from the Microsoft volume licenser and only making a few configurations such as installing Office and changing some of the Ethernet sleep settings. 

    I tried re-registering the store app, the photos app, and the calculator in Powershell, but the problem was still present. I then tried enabling the GPO you suggested (although it wasnt in the location you mentioned, it was under Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options. The GPO did not fix my problem either. Do you have any other suggestions as to what I can try?

    Thanks,

    Alan


    Thursday, August 24, 2017 1:53 PM
  • Does it work with new profiles and the original default profile?

    Thursday, August 24, 2017 2:43 PM
  • It does not work with any profiles. Any new domain profile I add has the problem, along with the original default admin profile. It's a very puzzling issue!
    Thursday, August 24, 2017 3:00 PM
  • I mean with the original default profile before ever using copyprofile.

    Thursday, August 24, 2017 4:27 PM