none
Using a subset of multiple monitors

    Question

  • Hi,

    We have a number of computers with triple monitors and what we want to do is to have one monitor on the local machine and use the other two for a dual-monitor setup on an RDP session. These 'client' computers are all running Windows 7 Enterprise and the 'server' computers are running either Windows Server 2008R2 or Windows 7 Enterprise. Here is what I have found:

    • If I mstsc with 'default' settings the remote session appears on a single monitor - as expected
    • If I mstsc and select the 'Use all my monitors for the remote session' the remote session appears on all 3 monitors - as expected)
    • If I change the RDP group policy on the 'server' to 'Limit maximum number of monitors' to 2 whilst keeping the 'Use all my monitors for the remote session' on the client, the remote session appears on a single monitor - not as expected!
    • If I change the 'Limit maximum number of monitors' to 3 whilst keeping the 'Use all monitors for the remote session' on the client, the remote session appears on all 3 monitors which would *indicate* that the setting is effecting the client display.

    Can anyone help me resolve this issue so that I can configure the machines to display a remote session on 2 out of 3 screens?

    Thanks in advance,

    Phil


    • Edited by PhilRuelle Tuesday, February 14, 2012 9:58 PM Added more detail
    Tuesday, February 14, 2012 5:56 PM

All replies

  • Hi,

    Thanks for your report.

    I will find a display card that has a multiple output ports to have a test. If get any light, I will post back.

    Juke Chou
    TechNet Subscriber Support
    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedbackhere.


    Juke Chou

    TechNet Community Support


    Thursday, February 16, 2012 5:56 PM
    Moderator
  • Hi,

    Have you tried to uncheck the checkbox "Use all my monitors for the remote session" and only use the polcy to limit the monitor number to 2? This would make the group policy take into effect only.

    Thanks,

    Spencer Shi


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, February 20, 2012 12:50 PM
  • Hi Spencer,

    Thanks for the reply. As I understand it the 'Limit maximum number of monitors' setting applies on the 'server-side' as it appears under the 'Remote Desktop Session Host' folder. However I did give it a go and I'm afraid it didn't work.

    Thank you for the suggestion though. I'm still scratching my head on this one!

    Phil

    Tuesday, February 21, 2012 10:47 AM
  • Hi Phil,

    I did not get a chance to test the issue with 3 monitors so far. After performing research, i find a blog talk about the feature in Windows 7. I am providing you for your reference.

    Using Multiple Monitors in Remote Desktop Session(http://blogs.msdn.com/b/rds/archive/2009/07/01/using-multiple-monitors-in-remote-desktop-session.aspx)

    I understand that you configured that via Group Policy now, for test purpose, could you please disable the policy but using the UI settings under TSconfig to control the number? Then check if the issue still persists.

    Thanks,

    Spencer


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, February 23, 2012 8:37 AM
  • Hi Paul,

    Have you got any update about the issue?

    Thanks,

    Spencer


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Saturday, February 25, 2012 8:42 AM
  • Hi Spencer,

    Yes and unfortunately I get the same result. So having removed the GP limitation and set the server-side to limit monitors to 2 via tsconfig.msc (I could only do this on a Server 2008R2 box as the tool wasn't available on the Windows 7 Enterprise boxes) :

    1) I logged in without the 'Use all my monitors' option selected -> appeared on one screen

    2) I logged in with the 'Use all my monitors' option selected -> appeared on one screen

    Thanks for following up on this.

    Phil

    Thursday, March 01, 2012 12:55 PM
  • I'll give this thread a bump because I'm seeing the same issue with Windows 7 to an 08 R2 server.  In my case I'm using 4 monitors and cannot get only 2 or 3 monitors to be part of the rdp session.  I'm not using a GPO, but just gpedit.msc on the machine itself.
    Wednesday, May 16, 2012 6:56 PM
  • Hello

    I also have problems with this. My system has 4 monitors and we have found no way of enabling a RDP session on 2 or 3 of the monitors.

    Please help!

    Wednesday, May 23, 2012 3:40 PM
  • Giving this thread a bump too as I am running into this wall right now and it is quite frustrating.
    Friday, May 25, 2012 1:57 PM
  • Still the same issue, what is the point to the limit monitors, if it gives you either one or all ???

    Can not limit a 3 monitor computer down to use only 2, it is either all 3 or just 1, no matter how you configure the server settings.

    So, again, I will ask. What is the point of having the option to limit monitors options of 1-4, if it does not work correctly?

    6 months and no one has an answer for this?

    Friday, August 31, 2012 3:38 AM
  • Bump.  I've been wrestling with the exact same issue for months, and it's driving me crazy.  The monitor limit is completely nonfunctional, and I've had to use a VM to limit it to 2 monitors.  This is not a great workaround as the VM is very resource-intensive and adds a layer of complexity that's totally unnecessary.

    Anyone have a solution?

    Wednesday, September 12, 2012 2:33 PM
  • Same here. Would love to get an answer to this. I fear the answer is 'all or one, take your pick'.

    GaryPharr

    Friday, September 14, 2012 8:37 PM
  • Bumping this again as I'm here trying to figure out the exact same thing. To say it is frustrating is an understatement.
    Friday, October 19, 2012 3:41 PM
  • Another bump is long overdue. Would have been really nice to have.
    Monday, January 21, 2013 1:53 PM
  • Bumping again.  I've been forced into the corner of 1 or all as well.
    Monday, February 04, 2013 9:43 PM
  • Bump. Same issue here on Windows 8. I want to use it on 2 of my 3 monitors.
    Thursday, February 07, 2013 1:00 PM
  • Bumping this again.  I am connecting from a Windows 2012 Hyper-V Host Workstation to VM's and it would be awesome to be able to have a Windows 8 VM on 2 monitors, windows 7 VM on 2 other monitors and then have a monitor for management tools.
    Monday, March 04, 2013 10:15 PM
  • Bumping this post. This feature would be extremely useful to a large number of users.
    Monday, March 18, 2013 12:53 PM
  • Same here... I have 4 monitors and I want to be able to use 2 or 3, but so far not luck.... and seems like I'm not the only one having a hard time with this situation...

    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    My guess is the Q&A/Testing department at Microsoft didn't test this feature properly, and they work in the assumption of one monitor and all monitors; never considering that the people eventually will use more than 2 monitors, and would like to use a subset of the total monitors when you have more than 2 monitors.... Why I say that? because, in order to enable such feature correctly it will be necessary to bring a window to select which monitors the user is want to activate for remote desktop. 

    I hope that somebody from Microsoft have the sincerity to come with an answer indicating that they are working to solve this situation, they don't have clue how to fix it, and/or with a simply statement... that feature is not supported and you have to live with that..... 

    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


    • Edited by moralesrd Wednesday, March 20, 2013 10:45 PM
    Tuesday, March 19, 2013 5:16 PM
  • Here is my work around for my 3x1 setup to use 2 monitors with a similar experience:

    edit the RDP file for the resolution I'm looking for.  Turn off multi monitor and turn off smart screen sizing (not really required)

    screen mode id:i:1
    use multimon:i:0
    desktopwidth:i:3840
    desktopheight:i:1080
    smart sizing:i:0

    Next I use auto hot key to make the app appear like a full screen, borderless app.  Windows+F11 resizes the window to desktop 2 and 3 and removes the border.  Win+f12 restores the border for easy move.

    Just FYI, the RDP client is odd in that it captures all key strokes so I had to use the class name of the window to target it.  You cannot have the app active.  Just select the desktop or another app and then hit win+F11 or win+F12.  Also, make sure the window is not maximized.

    Here is the ahk script:

    #f11::
    WinSet, Style, -0xCF0000, ahk_class TscShellContainerClass
    WinMove ahk_class TscShellContainerClass,, 0,0,3840,1080
    return
    #f12::
    WinSet, Style, +0xCF0000, ahk_class TscShellContainerClass
    return

    Link for autohotkey:

    http://www.autohotkey.com/

    • Edited by Agrrrrr Friday, April 26, 2013 8:33 PM
    Friday, April 26, 2013 8:30 PM
  • Bump from me as well - not being able to use 2 of my 3 monitors for RDP-sessions is a serious limitation for me. I am really limited by not being able to setup RDP this way. Please help by resolving this issue!

    /AZ

    Monday, April 29, 2013 6:01 AM
  • I wonder IF somebody from Microsoft is monitoring this Thread and be able to provide a real answer beyond of the copy/paste from the Microsoft blog from 2009????
    Tuesday, April 30, 2013 9:35 PM
  • I have the feeling that this thread has fallen on deaf ears :/
    Monday, May 20, 2013 3:52 PM
  • I hate to raise the dead, but necro post bump.

    Can anyone answer this question, Same issue on windows 8 to 2k3 Servers.


    Monday, August 26, 2013 2:06 PM
  • Everything that should work from multimon to changing max monitor in group policys to configuring RDP host server on client settings tab does not work at all. Clearly Microsoft won't fix this and it is very annoying indeed.

    There is a large group of people that really have a problem with this issue and now me including. So please Microsoft, what do you really have to say about this issue.

    I have three monitors and for my RDP session I want to use two of them and the third one local. We know all where we can makes changes in the configuration. But that advice won't work because the software does not work. But you might proof me wrong...

    So what's up!


    Wednesday, August 28, 2013 2:30 PM
  • Any update on this thread.  We are using 3 displays and would like to use 1 locally and the other 2 in an RDP session.  Hopefully a resolution is in the works.
    Wednesday, November 20, 2013 6:07 PM
  • Bumping this up.  Having the same issue here at a pretty large corporation that spends lots of money on MS products including Win 7 licenses.  This is a huge limitation.
    Wednesday, April 16, 2014 1:35 PM