none
ODBC drivers have 'disappeared' seemingly overnight - Windows 7 64

    Question

  • Our software creates and amends User DSN entries for reporting purposes as required (using VFP ODBC). I had some issues today, so tried removing the entries in case they were corrupt, and found that all of my user data sources display the message:

    ---------------------------
    Microsoft ODBC Administrator
    ---------------------------
    The setup routines for the Microsoft Visual FoxPro Driver ODBC driver could not be found.  Please reinstall the driver.
    ---------------------------
    OK   
    ---------------------------

    Clicking OK then raises the message:

    ---------------------------
    Driver's ConfigDSN, ConfigDriver, or ConfigTranslator failed
    ---------------------------
    Errors Found:



    The specified DSN contains an architecture mismatch between the Driver and Application
    ---------------------------
    OK   
    ---------------------------

    This happens with ANY of the user DSN entries I have (VFP, Dbase, Excel, Access).  

    Checking the drivers tab in the ODBC adminstrator console, for some reason I now only have SQL Native client and SQL Server listed.  

    I've tried uninstalling and reinstalling the driver to no avail, and also tried reinstalling MDAC and the standalone VFP ODBC drivers, but I've had no luck.  I'm aware that VFP ODBC is no longer supported, but it doesn't seem specific to this as it's occuring with all ODBC entries.  

    System was working fine last time I used it, and I can't see any evidence of new updates or anything that may have affected it, so I'm a little stuck now. does anybody have any ideas of what this might have been caused by, and how I can resolve it?

    Thanks.





    Monday, March 01, 2010 4:00 PM

Answers

  • Hi,

     

    Please try the latest version of Microsoft Visual FoxPro and see if it works:

     

    Microsoft Visual FoxPro 9.0 Service Pack 2.0

     

    If the issue persists, since this issue is related to Microsoft Visual FoxPro and we have specific forum for it, it is recommended that you go to Visual FoxPro Forum for help:

     

    Visual FoxPro Forum

     

    Thanks.


    Nicholas Li - MSFT
    • Marked as answer by dodgrile Wednesday, March 03, 2010 11:58 AM
    Wednesday, March 03, 2010 10:43 AM
    Moderator

All replies

  • I've since discovered that by going into the ODBC administration by running c:\windows\syswow64\odbcad32 I can see the drivers, but I'm still getting issues with Crystal reports being able to 'use' these connections.

    Tuesday, March 02, 2010 11:00 AM
  • Hi,

     

    Please try the latest version of Microsoft Visual FoxPro and see if it works:

     

    Microsoft Visual FoxPro 9.0 Service Pack 2.0

     

    If the issue persists, since this issue is related to Microsoft Visual FoxPro and we have specific forum for it, it is recommended that you go to Visual FoxPro Forum for help:

     

    Visual FoxPro Forum

     

    Thanks.


    Nicholas Li - MSFT
    • Marked as answer by dodgrile Wednesday, March 03, 2010 11:58 AM
    Wednesday, March 03, 2010 10:43 AM
    Moderator
  • Thanks, that seems to have solved it.  Still seems a little odd that this happened all of a sudden, well after installing VFP / Windows 7, but at least it appears to be resolved. 


    Wednesday, March 03, 2010 11:59 AM
  • Hi,

     

    Thank you for your update. I am glad to know the good news. Your efforts are highly appreciated.

     

    In the future, if you experience any issues regarding our products, you are also welcome to post a new thread in our forum. It is always our pleasure to be of assistance.

     

    Thanks again. Have a nice day!


    Nicholas Li - MSFT
    Thursday, March 04, 2010 4:22 AM
    Moderator
  • I had a problem using Crystal Reports. Windows 7 64 bit does not support the 32 Bit ODBC connector for visual foxpro 9.0 to run reports a workstation.

    The work around I employed was using Windows 7's XPMode. It works great. I installed CR and setup the ODBC driver on the Virual Machine. The Crystal Report Application is published automatically to Window 7's Menu. When you click on the Crystal Reports shortcut in Windows 7, the application starts immediately because the Virual Machine is usually in hibernation.  

    Bruce Greenstein, MCP

    Monday, April 05, 2010 4:37 PM
  • Hi

     

    They are all there but as default in a 64 bit OS it is the 64bit ODBC manager you see and it has only 64bit drivers.

     

    Run the C:\Windows\System32\odbcad32.exe

    and all the drivers are there.

    Thursday, May 20, 2010 2:16 PM
  • i try to install goldmine ver 9x today on new Win 7 Pro 32 bit PC and then when i created ODBC link i had a error

    "the setup routines for sql server odbc driver could not be accessed. Please reinstall the driver"

    Any idea?

    Friday, September 17, 2010 8:52 PM
  • I too am having problems with this. I am at VFP8.0 but have VFP9.0 available to install.  By running c:\windows\syswow64\odbcad32 and installing VFP9.0 rel2 will solve this issue?
    Wednesday, December 07, 2011 3:58 PM