none
USB Drive doesn't show up in My Computer

    Question

  • I have a 2.5" Seagate 500GB 7200RPM laptop drive mounted into a USB case.  I plug it into my USB port along with another one that goes from DC to a different USB port.  In Device Manager, it is shown as "ST950042 0AS USB Device," which tells me that it is being seen. However, when I open "My Computer," the drive does not show up. I have a failing drive that I keep all of my media files on and am trying to back that up to this drive, however, I cannot get a drive letter assigned to do open the drive and back up my files.
    Saturday, March 03, 2012 8:26 PM

Answers

  • Actually, I found my answer on another forum.  After reading several, involved answers that wanted me to disconnect all USB devices, and have Windows reload them, etc., the solution below worked perfectly:

    Go to Start > Run, type in DISKMGMT.MSC then select your drive in the bottom half of the window at the left, right-click on it, choose Initialize then right-click again and either partition and format it or format it.

    After I did the above, the disk asked me to assign a letter and when I did, I was able to open it and it is now copying everything to my backup disk. 

    Thank you for the prompt response.

    • Marked as answer by Slosh1014 Saturday, March 03, 2012 8:42 PM
    Saturday, March 03, 2012 8:41 PM

All replies

  • Did you check in Computer Management to see if the drive is displayed there and, if needed, assign a driver letter?

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    • Proposed as answer by MrTaiwan Sunday, December 16, 2012 4:05 PM
    Saturday, March 03, 2012 8:34 PM
  • Actually, I found my answer on another forum.  After reading several, involved answers that wanted me to disconnect all USB devices, and have Windows reload them, etc., the solution below worked perfectly:

    Go to Start > Run, type in DISKMGMT.MSC then select your drive in the bottom half of the window at the left, right-click on it, choose Initialize then right-click again and either partition and format it or format it.

    After I did the above, the disk asked me to assign a letter and when I did, I was able to open it and it is now copying everything to my backup disk. 

    Thank you for the prompt response.

    • Marked as answer by Slosh1014 Saturday, March 03, 2012 8:42 PM
    Saturday, March 03, 2012 8:41 PM
  • Actually, I found my answer on another forum.  After reading several, involved answers that wanted me to disconnect all USB devices, and have Windows reload them, etc., the solution below worked perfectly:

    Go to Start > Run, type in DISKMGMT.MSC then select your drive in the bottom half of the window at the left, right-click on it, choose Initialize then right-click again and either partition and format it or format it.

    After I did the above, the disk asked me to assign a letter and when I did, I was able to open it and it is now copying everything to my backup disk. 

    Thank you for the prompt response.

    This worked perfect for me. Thanks.
    Thursday, June 14, 2012 11:15 PM
  • this did not work for me it wont show up under add a device either

    Thursday, June 13, 2013 10:33 AM
  • Actually, I found my answer on another forum.  After reading several, involved answers that wanted me to disconnect all USB devices, and have Windows reload them, etc., the solution below worked perfectly:

    Go to Start > Run, type in DISKMGMT.MSC then select your drive in the bottom half of the window at the left, right-click on it, choose Initialize then right-click again and either partition and format it or format it.

    After I did the above, the disk asked me to assign a letter and when I did, I was able to open it and it is now copying everything to my backup disk. 

    Thank you for the prompt response.

    This worked perfect for me. Thanks.
    This work for me too. Thanks guys!
    Sunday, September 01, 2013 9:44 AM
  • Why doesn't my one still work?

    i got my important work there!

    Wednesday, November 06, 2013 5:57 PM
  • Why doesn't my one still work?

    i got my important work there!

    If you seriously want some assistance with your problem, then start your own post and provide lots of details about your system and your situation.  Absolutely no one can provide an answer to such an abstract question.  You mus provide details, lots of details.

    Read the Microsoft KB @ http://support.microsoft.com/kb/555375 on how to ask for help and then start your own thread.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Wednesday, November 06, 2013 7:39 PM
  • I tried Everything but none are working for me ,in diskmgmt.msc ,it shows REmovable Disk 1 "No Media" & it cant be formatted.Please HelP

    Sunday, December 22, 2013 5:41 AM