none
Windows 7 and "Folder In Use" error on network shares

    Question

  • When browsing a network share hosted by my Windows Home Server machine, Windows 7 generates thumbs.db files within each folder that has images or video.  If the files were local, it wouldn't be a problem because Windows 7 keeps a centralized store for thumbs.db files, but on a network share it's a huge annoyance because it keeps me from being able to move or rename the folder.  I get a "Folder In Use" error after trying to rename/move a network share that I've just viewed.  If I wait a minute or two and hit Try Again, all is well.  I also hate the simple fact that it's creating all these files, even though they're hidden by default, and it's dirtying up my very well groomed file structure.  Is there a way to disable the creation of thumbs.db files within the network share specifically?  Or at least is there a way to make it so they cache in a centralized store such as they do with local directories?  I'd rather not disable thumbnail caching altogether if possible.  I understand the performance implications from disabling thumbnail caching entirely, but I don't search network shares via thumbnails much anyway.  And the loss of productivity from having to wait to rename/move the folder far outweighs the lack of being able to see a thumbnail for me.
    Wednesday, July 22, 2009 2:56 PM

Answers

  • I believe I've found the fix.  Under gpedit, enable this setting and then reboot.

    User Configuration > Administrative Templates > Windows Components > Windows Explorer > Turn off the caching of thumbnails in hidden thumbs.db files

    So far, after deleting a few of the thumbs.db files and then viewing the directory again, they haven't been recreated.
    • Marked as answer by jahamala Monday, July 27, 2009 5:19 PM
    Monday, July 27, 2009 5:18 PM
  • im not sure but in GPO setting theres a way to prevent caching the choosen extension which i did in my settings,if my memory doesnt fail its in the User configuration tab,dont remember exactly where it was but i know i did here and set to prevent caching .db and others!!
    hope this helps..
    Best regards,
    RR
    • Marked as answer by jahamala Monday, July 27, 2009 5:18 PM
    Monday, July 27, 2009 2:58 PM

All replies

  • Anyone else experiencing the same issues?  I figured this to be a common annoyance.
    Monday, July 27, 2009 2:07 PM
  • im not sure but in GPO setting theres a way to prevent caching the choosen extension which i did in my settings,if my memory doesnt fail its in the User configuration tab,dont remember exactly where it was but i know i did here and set to prevent caching .db and others!!
    hope this helps..
    Best regards,
    RR
    • Marked as answer by jahamala Monday, July 27, 2009 5:18 PM
    Monday, July 27, 2009 2:58 PM
  • I believe I've found the fix.  Under gpedit, enable this setting and then reboot.

    User Configuration > Administrative Templates > Windows Components > Windows Explorer > Turn off the caching of thumbnails in hidden thumbs.db files

    So far, after deleting a few of the thumbs.db files and then viewing the directory again, they haven't been recreated.
    • Marked as answer by jahamala Monday, July 27, 2009 5:19 PM
    Monday, July 27, 2009 5:18 PM
  • This is an extremely annoying "feature" of windows 7. It is one of those bugs that microsoft will ignore because most people do not use the network enough to encounter it frequently. It is quite sad that they could not find this during testing. I was going crazy after ten minutes of installing windows 7. It happens on every computer with every version of 7.
    Tuesday, January 26, 2010 2:47 AM
  • Hi there,
    this very uncomfortable "feature" is driving me crazy. a "workaround" is to manage renaming etc. directly on whs via remotedesktop working with the shared folders on d: but as i think to remember, its not recommended.
    unfortunately i´m using a german version of win7 ultimate and didn´t find any item beeing comparable to your hint "...Turn off caching..." in gpedit under ...windows explorer.
    Some other ideas?
    TIA, Alex.
    Saturday, March 06, 2010 3:39 PM
  • I am having the same issue. I posted my frustration in here:

    http://social.technet.microsoft.com/Forums/en/w7itproui/thread/c0817162-3fcd-4823-bdf8-70b2936cd51b

    More or less the same issue.
    Sunday, March 07, 2010 2:58 PM
  • sorry,
    but the above stated workaround is working here actually, in german version it´s called: "Zwischenspeicherung von Miniaturansichten in versteckten "thumbs.db"-Dateien deaktivieren". One has to look under "Benutzerkonfiguration" - "Administrative Vorlagen" - "Windows-Komponenten" - "Windows Explorer" and set the value above to "Aktivieren".
    I experienced the problem of locked folders in stored music where the only graphic in a folder is the folder.jpg file which strangely lead win7 to generate thumbs.db on access (just marking a folder is enough!).
    The whole scenario - win7 ultimate client and a whs server - doesn´t seem to work well because i added the music folders to the music library and set the folder properties to optimize for MUSIC (!).
    So probably this is a point to start for the dev. teams, because i experience win7 to handle music as music not as graphics.
    For know i don´t know what problems i´ll experience with my pictures library with this workaround, probably slower thumbnail presentation in pictures folders?
    thanks to all, LX.


    Monday, March 08, 2010 7:28 AM
  • Thanks for the info jahamala, but as a "power" user of lots of videos and photos on a network share, I WANT to have my thumbnails cached, but I don't want that caching to interfere with my productivity. Those two needs should be provided by Microsoft's latest flagship OS (Windows 7), but as yet, I have not seen a solution. Great that you can turn off the "bug" - but we really need is for the bug to be fixed! Thanks.
    Friday, October 15, 2010 3:43 PM
  • This deserves a bump... it's a very reproducible problem, popping up every time I have a network folder with pics/videos in it. The workaround is to browse to another folder with images, then go back and delete/move the original target folder... but that's just a garbage solution. I don't (necessarily) want to disable all caching... I just want to be able to use my folders as intended.

    It's actually kinda mind-boggling how many bugs there are in MS software... and how little response each of them gets. With all the bugs that WERE fixed before it was released (and I'm sure there are tons, so thanks to the Windows team for fixing most of them!), it's actually kinda sad that the ones revealed in forums and websites are almost never fixed. Lots of bugs in MS Office regarding printing and file handling... plenty of bugs in Explorer regarding file and folder management. Why doesn't MS set up a task force to go through these bugs that people post online? Obviously a good number of people find them to be annoying enough to post about...

    Either way, +1 for this issue, and I can confirm this is a bug in the way Explorer releases file handles on thumbs.db on network shares. The problem does not occur on local drives. Haven't tested on a mapped drive.

    Friday, March 25, 2011 6:55 AM
  • I don't know if this is a related problem or not, but when I try to move folders between my laptop C: drive and and external drive, I also get *alot* of "File in use" messages - like every "fresh" move!  By "fresh" I mean the first time I try it.  If I go to a second folder and try to move it, I'll get the same error.  Then I go back to the original folder and move it and it goes fine.  So, then if I try the second folder again, same error.  So then I go to a third folder, try to move it, get the error.  Go back to the second folder and it moves fine!  See the pattern developing here?  It's a pain in the butt!

    I don't know if it's exclusively involving folders with thumbs.db but I do know some folders have those files.  These are folders with .MP3 files, so I suppose where there's cover art images, that's causing the problem.  I haven't tried turning off the thumbnail caching yet - this is a problem on personal laptop at home.


    Barry Hakala Senior Programmer Figi's Inc.
    Thursday, August 11, 2011 5:50 PM
  • Has anyone come up with an answer to this vexing issue? This is driving me nuts. this SHOULD be a simple matter, but clearly, it is not.  Please advise if there is a way to MOVE a file directory.  This *should* be simple.

     

    thanks

    Sunday, August 28, 2011 4:11 PM
  • I have been on Win7 Pro for quite some time and the local thumbs.db has only recently started showing up in the local folders.  I recall this was a problem when upgrading from Win XP but my laptop is a clean install from media.  I recently had to wipe and re-install Win7 Pro on my laptop and the problem began with after the SP1 install.

    We all want thumbnail caching - just not in the local folders.  The network share matter is a different animal.

    What is perplexing is that Win7 uses several central thumbs.db type cache files and doesn't need the local thumbs.db file, and yet I am getting the exact same behavior as the others in this post.  I've often wondered if the junctions are causing this, or perhaps if you sync to file shares for media like I do then once a thumbs.db is in a folder Win7 uses it - kind of a use local then central behavior.  Something for a deep gearhead to consider.

    My solution that so far seems to work is to do the following:
    - I always have "show all system and hidden files" on my computers... so set that first if not set
    - In Explorer go to Tools -> Folder Options -> View and check the box for "Always Show Icons, Never Thumbnails"
    - Next from c:\users\[name]\ search for all files named thumbs.db
    - Delete all of the thumbs.db files (you'll need admin privs)
    - Now return to the Tools -> Folder Options -> View and uncheck the box for "Always Show Icons, Never Thumbnails"

    This works for me, the local files no longer show up, and yet the performance is fine because Win7 is using the central db.

     

    Thursday, December 29, 2011 3:02 PM
  • Can't believe this is still happening. I just want to move a PDF from one folder to another. It's not open anywhere, and I even closed out the reader fully (since having Word open sometimes causes this error, even after the file has been closed). Still, after 10 minutes I can't move it. I finally just copied it, but it's bad form to have multiple copies of a file floating around the network drives. I can't delete the thumbs.db files, bc they're in use also.  ARGH.
    Friday, March 02, 2012 5:50 PM
  • Thanks Jahamala. It does it for me; after almost two months trying to find a solution and Microsoft engineers (technical support) insisting that the problem was on my files not on Windows 8... 

    Thanks a lot...

    Friday, January 31, 2014 11:55 PM