none
Required cd/dvd drive device driver is missing install on a new system

    Question

  • I am installing Windows 7, FROM SCRATCH, so I can not go to a folder or run regedit.
    This is a virtual machine, I will be running for work. I do not care if it is Parallels or VMware, I own both.
    I get the same error 'Required cd/dvd drive device driver is missing' no matter how i tried.
    I have tried from a DVD ISO and from a thumbdrive, it looks for CD/DVD drivers.
    I have even tried with NO CD/DVD and it still wants the drivers.I assume there are no CD/DVD drivers on the MS install dvd. 
    The system seems to be able to load the files from the dvd until the Win7 OS wants to load CD/DVD driver ' The OS can search the CD/DVD for these drivers (without these important drivers) it then fails and no install.
    End users should never see this on a final release.
    Sunday, September 06, 2009 3:34 PM

Answers

All replies

  • Hi

    Please see the following links for information about this known problem.

    CD/DVD DEVICE DRIVER IS MISSING - Microsoft TechNet Search

    Dreaded "A required CD/DVD Drive Device Driver is Missing" window on install

    Required CD/DVD device driver is missing problem

    The general consensus is that this problem is usually the result of a corrupt DVD or a bad download.

    Hope this helps.

    Thank You for testing Windows 7

    Ronnie Vernon MVP
    Monday, September 07, 2009 12:46 AM
    Moderator
  • Hi ma33709,

     

    In most cases, this issue can be caused due to the Win7 installation media is corrupted. You can try using another DVD or downloading the .ISO file again to check the results.

     

    If it does not help, you can copy the installation file to a USB device and boot from the USB device to install Win 7 again.

     

    For more information, you can refer to the following links:

     

    How to Install Windows 7 From USB Drive without Windows 7 ISO DVD

      

    WinToFlash Turns Your Windows Installation DVD into a USB-Based Installer

     

    Some of such issues are caused due to the hardware factor, we can also try upgrading DVD-ROM firmware to narrow down the issue.

     

    Good luck!

     

    Tuesday, September 08, 2009 8:42 AM
  • I had the same problem.
    I was also running the windows 7 beta.For the first disk (iso) I used power iso.
    the second one I remembered that windows 7 has an iso burner and used it for my second burn and it worked fine
    Tuesday, September 22, 2009 3:14 PM
  • We have had an instance with the same problem with one of our installs.

    what is the correct hash (md5 or sha1) for the action pack subscription downloads for the Windows 7 iso images?

    We are attempting to install the Win 7 pro x64 from the .ISO image from the MAPS site, and it is failing to install correctly.  Crawling the internet re veils that this is often due to a corrupt download. 

    I have not been able to find official md5/sha1 hash values for the ISO images, so we have no way to tell if the download was completely successful or not.

    It would be great if someone from Microsoft could post the correct hash values somewhere in technet, or better yet, on the actual download page.

    The value that I got from my image (SW_DVD5_Win_Pro_7_64BIT_English_X15-65805.iso) was sha1: f8e8a183021a6947c66074490ebad05e5549a84d, but I don't think I got a good download
    Tuesday, September 22, 2009 7:17 PM
  • update:

    We got another download, this time using the download manager, and this time we got a sha1 hash of

    50127304441a793ee51b3f501289f6599a559e9f

    This seems to match the hash values of other people who have downloaded and installed it successfully.

    It would be great if MS would put these on download page, so you would know if you got a good download or not.

    I would highly recommend that folks use the download manager, even though it is much slower if you have a good internet connection.

     


    Tuesday, September 22, 2009 7:25 PM
  • Yes- I recorded several faulty DVDs which gave various errors, including 'missing DVD driver'. Then used a USB external DVD drive, and produced a good DVD--  I plan to replace the faulty DVD burner, but need to make afew more shiny bird-scarers first!
    Wednesday, September 23, 2009 8:34 AM
  • Same thing happened to me on a IDE DVD drive....

    I downloaded ITE IT8211 ATA/ATAPI from here, extarcted to a usb drive and selected the one in the XP folder when the message poped up and it worked fine http://download.cnet.com/ITE-IT8211-ATA-ATAPI-Controller/3000-18492_4-209590.html

    Also when i tried a SATA DVD drive it worked fine too without the need of the ITE ATA/ATAPI driver
    Saturday, October 24, 2009 8:01 PM
  • I had this problem as well and it took me a while to figure it out in my case - Windows Vista, 7 and Server 2008 all had this problem - I couldn't get them to install.

    The dreaded "cd/dvd device driver missing" message came up.

    After I removed the UDF part of the installation DVD it just worked perfectly - it seems that for some reason and in some cases (in my case a USB DVD ROM) the UDF filesystem driver is not loaded/installed during setup and hence, Windows cannot see its own files - just the Readme.txt that there is no UDF filesystem driver installed.

     

    Anyway, I know that this may just help a few, but I hope it does as it took me days to figure it out.

     

    Monday, February 28, 2011 12:48 PM