none
Brightness control after resume sleep/hibernate broken

    Question

  • Many people having problems with the brightness control (doesnt work) when you resume your notebook from sleep/hibernate. I noticed that the problem only occurs if
    you set the action (sleep/hibernate) for when you closing the lid. But if you set the sleep/hibernate action for the powerbutton, the brightness works fine on resume.


    I have search many sites but no one has a fix yet. Does MS knows about this brightness problem for W7 ?

    Thursday, August 06, 2009 9:57 PM

All replies

  • This problem occurs also after manual set standby and power save dimming here, I have deactivated any actions on closing the lid. I have a Dell Inspiron 6400 with ATI mobility x1400...
    Monday, August 24, 2009 1:27 PM
  • I experienced similar problems when my screen would turn off and then go to sleep 10 minutes later on my thinkpad. Although the dimming feature is a great power saver, I turned it off to save myself from more headaches.

    Thursday, August 27, 2009 6:39 AM
  • I have the same problem with my Sony Vaio. All versions of going to sleep/hibernate work EXCEPT closing the lid option. It that is selected then my display won't dim/brighten on resume. It gets fixed with restart but starts again next time I close the lid.
    Have you found a solution?
    Thursday, October 29, 2009 9:01 AM
  • I've been having the same problem on my Sony Vaio VGN-FZ260e since upgrading to Win7.  My laptop uses the nVidia 8400m GT and I have the latest driver from Sony installed.  For some reason Sony says it is not going to support Win7 on this computer.  I find that unbelievable but there you have it!  So I assume asking Sony for a fix for this will fall on deaf ears.  Hopefully MS can fix it from their end.  nVidia has drivers available for the 8400m under Win7 but I don't know how they would interface with the Vaio's features.

    For now I'll disable the lid closing stuff but would sure like full functionality back someday.
    Tuesday, November 10, 2009 6:59 PM
  • I tried setting the lid closure action to "do nothing" for both plugged in and on battery.  Closing the lid still causes the problem with brightness control.
    Tuesday, November 10, 2009 7:23 PM
  • Just an update.  While doing a Windows Update I noticed a Sony Parser update under Optional Updates.  I hoped that this would solve the problem but it did not.  I have found that setting the Power option for the power button to sleep will allow the computer to go to sleep and wake up with the brightness controls working BUT you have to wait until the hard drive and power lights to go out before closing the lid.  If you just hit the power button and close the lid during the going to sleep process it will wake up with broken brightness controls.
    Tuesday, November 10, 2009 8:22 PM
  • I have the same computer and the same problem. Even more annoying is the fact that when I close the lid Windows will no longer turn off the display, even when on battery.
    I know the display switch still works because the display will turn off when closed when I'm in the BIOS setup. But I don't like my laptop to hibernate/standby when I simply close the lid, but I would like the display backlight to turn off to save power. This worked great in Windows Vista. In Windows 7, not so much.
    Monday, December 14, 2009 8:44 PM
  • Same Problem on a Lenovo X60s with Windows 7. Never was a problem on WindowsXP, Linux or FreeBSD.

    The bug is not reproducible consistently. It sometimes works fine. It seems that the ACPI driver support is totally unloaded afterward, because all the interface elements are missing in addition to the facts that the function buttons are not working anymore.

    Saturday, March 27, 2010 9:52 AM
  • I have exact same problem, I have the new Sony Vaio e-series...

    When I restart from Stand-by or Hibernate - the screen is full brightness and I can't turn it down....

    Any Fix out there?

    Saturday, April 03, 2010 11:46 AM
  • I'm also having the same issue with a Dell 6400 with an ATI x1400. The issue occurs for me when I have the lid setting to "Do Nothing" and close the lid. I find myself then unable to adjust screen brightness on the display (often left with a very dull display) until I restart the computer. Can Microsoft PLEASE fix this because it didn't happen in Vista.
    Monday, April 12, 2010 9:33 PM
  • I'm also having the same issue with a Dell 6400 with an ATI x1400. The issue occurs for me when I have the lid setting to "Do Nothing" and close the lid. I find myself then unable to adjust screen brightness on the display (often left with a very dull display) until I restart the computer. Can Microsoft PLEASE fix this because it didn't happen in Vista.

    I have the same configuration in my computer and I'm experiencing the same issue. A fix or workaround of any kind would be nice by now, it has been a year since I first had this issue with the RC and I can't believe this is still a problem.
    Tuesday, April 13, 2010 9:25 PM
  • I agree this problem has been present for a very long time!  This is not acceptable, I work for a University and our IT dept has had over 800 calls with regards to this problem alone since January!!  Come on please surely fixing this 'lid close' bug isn't rocket science.....
    Monday, May 03, 2010 1:33 AM
  • I have the exact same problem. My computer is a Asus N61Jq with Windows 7 Home Premium.
    Wednesday, May 05, 2010 9:16 PM
  • I have Sony Vaio VGN-FZ18L laptop and the same problem occurs! (Windows 7 Home Premium x86). Microsoft, pay attention to this issue!
    Thursday, May 06, 2010 11:10 AM
  • Hi Guys,

    I have this problem, I actually thought it was a hardware problem.

    I have my laptop lid to "do nothing" and on re-start from hibernate the screen is full brightness.

    The only fix I came accross was to close the lid and re-open. As I have it on "do nothing" the laptop remains on and brightness is restored.

    Thursday, May 06, 2010 11:30 AM
  • i see there is no real pattern to this..mine only does it when i close the lid for more than 5 or so minutes...i never put it in standby or hibernate...this seems to be a laptop problem and not just a thinkpad problem(i have the t60).
    Friday, May 07, 2010 1:02 AM
  • My Vaio EPCEB1Z0E  does the same thing.  As a work-around I find that pressing Fn+F7 (used to select internal/external display mode) then pressing enter to select the computer only display rectifies the issue without having to reboot.
    • Proposed as answer by Xenna Saturday, May 08, 2010 8:29 AM
    Saturday, May 08, 2010 8:24 AM
  • Xenna,

    That does not work on my new Sony Vaio with Windows 7

    Wednesday, May 26, 2010 3:08 PM
  • I've just bought Sony Vaio VGN-SR41M/W. Even though closing lid function is disabled i.e. do nothing, but it still gives me the same problem. Its related to system going to sleep even without closing lid. I'm not sure what to do as its a brand new laptop just 2 days old, shall I contact Sony through warranty or...???
    Friday, June 04, 2010 9:29 PM
  • My Vaio VGN-SZ4VWN/X  does the same thing.  The trick with Fn+F7 proposed by xenna doesn't work for me. I disabled the lid action for time being. I hope that someone is going to propose a fix for this annoying bug! I used to close the lid and put the laptop in the backpack and run (that worked in Vista)!

    Regards,

    Mike

    Tuesday, June 15, 2010 9:36 PM
  • This happens to me too, I have acer extensa 5630g and windows 7 32bit professional. Before it didn't happen all the time, just sometimes and usually on battery. Problem escalated few days ago when it started to happen every time whenever I put it into hibernation or sleep, whether it is on battery or not. Also the brightness slider disappears from power options. After restart everything works OK.

    But the interesting thing is that when this problem happens, I can still use the Acer ePower utility to control brightness.

    And I dont use the lid to go to sleep. Sleep button (Fn+F4) is used for sleep and power button for hibernation.

    It seems that this time installation of new catalyst 10.6 triggered the issue. After rolling back to older display driver it started to work again.

    Sunday, June 20, 2010 1:34 PM
  • I have a ThinkPad T500 (Windows 7 x86) which is set to do nothing when the lid closes. If I hit Function F4 to put it in sleep mode and close the lid before it finishes, the display brightness control is gone when I resume. But as suggested above, if I simply close the lid and open it again, it comes back, and since closing the lid doesn't do anything, it only takes 2 seconds to "fix" it, so to speak.

    If I let it finish going to sleep BEFORE closing the lid - the problem never occurs.

    And if the display brightness controls disappear, NOTHING changes it - you can apply any power scheme you want - no back door to changing it other than closing and re-opening the lid.

    Very odd...

    P.S.

    Thanks to cnagra for the suggestion - very valuable.

    Saturday, June 26, 2010 12:54 PM
  • I have a asus G73JH and it does the same thing. only fix is having the lid "do nothing" when closed. that fixes the brightness control back to normal. (I actually have to close the lid and reopen it everytime)
    Saturday, July 24, 2010 11:23 PM
  • This is happening here too on a ThinkPad Edge 13. After it decides to lock my brightness at 40%, nothing I can do will coax it back to giving me control--unless I restart. The brightness slider in the power options is gone too.

     

    Ugh...

     

    Edit. Sorry is this the right place to post? :/

    Sunday, October 24, 2010 7:50 AM
  • HP 6735b laptop windows 7 ultimate 64bit, not only have I been having teh brightness problems recently the brightness slider dissapeared from control panel power option but also from windows mobility centre.

    This does not return after a restart.

    The OP posted his questing in August 09 and its now November 2010?

    My organisation is considering a Windows 7 roll out soon but with all the problems still in teh OS at this stage we are probably better off sticking with XP, come on Microsoft what are you playing at?

    Does any one have any information about this?

    I have checked BIOS to see if there is anything about screen brightness there, the fn+f9 fn+f10 keys dont work either. the only thing I can think with teh slider is a recent win 7 update.

    Oh screen brightness works fine with fedora 13 live CD and the fn keys work no problem as well ....

     

    Edit : I just had a flash of brilliance, my account is not an administrator account when I logged in as administrator I had the screen brightness slider... seems silly not to allow that control with a user account! The fn keys however still do not work!

     

     

    Saturday, November 06, 2010 12:01 AM
  • Recently I have found that pressing FN+F7 as per my previous post has stopped working.  Maybe this stopped working the other day after my computer updated its display driver, but I cant be sure.  Even shutting the lid and opening it again did nothing.  The only cure was a shutdown and restart.

    This time when the screen got stuck on full brightness I went into the power settings and set the "choose what the lid does " setting to do nothing , clicked save changes , then shut the lid and when I opened it the brightness was fixed.

    Could this be an inverter problem rather than a windows problem?  Surely shutting and opening the lid with the setting do noting should just turn the backlight off/on?

    It would be interesting to know if the do nothing setting works on anyone elses computer.

     

    Edit: I also noticed that the Brightness slider is missing in the Windows Mobility Center when the brightness is broken and it re appeared once I had performed the above 'fix', which would suggest this is not likely a hardware problem.

    Friday, December 17, 2010 7:15 AM
  • Just happened to me for the first time since switching to 7 when it came out. A friend of mine experienced it very often, as far as I remember. A quick fix was uninstalling the monitor device (NOT display adapter) in Device Manager and then scanning for devices again.

    This temporarily fixes it. (EDIT: this is only a TEMPORARY fix and may not work)


    • Proposed as answer by Morderen Friday, February 11, 2011 8:32 PM
    • Edited by Edgars Batnya Monday, February 20, 2012 3:01 PM
    • Unproposed as answer by Morderen Friday, March 16, 2012 5:25 PM
    • Proposed as answer by ak11234 Sunday, April 29, 2012 11:30 PM
    Friday, December 24, 2010 6:27 AM
  • @Edgar B: u are real life saver. cant believe solution was this simple. Hats off to u. I had been wandering around over whole web from over a week and finally ended up with your suggestion that worked absolutely perfectly and fixed Fn keys as well as slider is back.

    Thanks a bundle times.

    Wednesday, February 02, 2011 9:59 PM
  • Thanks Xenna your solution worked for me! so this definitely is a software problem.

     

    Does anyone know how to make Microsoft aware of this bug?

    Tuesday, February 22, 2011 12:06 AM
  • Hi syscko, did Edgar's solution fix your problem completely or do you have to scan for changes everytime the brightness controls are broken?
    Tuesday, February 22, 2011 12:11 AM
  • SOLVED: Found the fix.

     

    Install/upate Thinkpad Hotkey drivers.

     

    Fixed mine

    • Proposed as answer by sammy t Tuesday, March 15, 2011 1:32 AM
    Tuesday, March 15, 2011 1:31 AM
  • Edgar's proposal is NOT a solution. You shouldn't have to reinstall something every time you use it. Surely someone has a real solution by now...
    Sunday, April 03, 2011 2:02 AM
  • It really occurs mainly when you close the lid after pressing the sleep/power button but it is solved by closing the lid for a couple seconds(once lid is set to do nothing). thanks
    Wednesday, April 06, 2011 1:16 PM
  • Many people having problems with the brightness control (doesnt work) when you resume your notebook from sleep/hibernate. I noticed that the problem only occurs if
    you set the action (sleep/hibernate) for when you closing the lid. But if you set the sleep/hibernate action for the powerbutton, the brightness works fine on resume.


    I have search many sites but no one has a fix yet. Does MS knows about this brightness problem for W7 ?


    Just close the lid for a couple seconds and it will redetect the controls. Of course this works for me when my lid is set to do nothing. cheers
    Wednesday, April 06, 2011 1:19 PM
  • Thanks Xenna.  Pressing Fn + F7, then selecting 'Computer Only', works well on my Sony Vaio with Win7.
    Saturday, May 07, 2011 9:16 AM
  • I have the same problem on my ASUS N61J.

    My observation is that the brightness adjustment disappears when I change power sources.

    For example, if I boot on AC power, I can sleep and hibernate the computer. I will still have brightness controls so long as the AC is plugged in when I wake the computer. However, if I wake the computer on battery, I lose brightness controls. Sleep, plug in, wake, and voila! brightness controls.

    Hope someone more tech savvy than me can find a permanent fix for this!

    Roy

    Sunday, May 29, 2011 2:43 PM
  • This problems still occurs I have my sony vaio for one and a half year now! Thank you for posting your solution. I have set the "choose what the lid does" setting to do nothing on power saving mode and also by full power and closed the lid and the brightness controller was available again. But I loved it to close the lid and send my notebook to sleep / hibernate. Now I can't use it anymore >_>. Why can't Sony or MS fix this problem?! I buy a mac next time!
    • Edited by Giwo01 Friday, January 13, 2012 11:23 AM
    Friday, January 13, 2012 11:22 AM
  • On the power settings at the bottom right of your screen (next to the cllock) you can choose between 2 power profiles.  Change one of these profiles to do nothing when you shut the lid, and leave the other to hibernate.  When the brightness fails click the "do nothing" profile, close the lid, open the lid, then change the profile back to the "hibernate profile". 

    • Edited by Xenna Thursday, January 26, 2012 9:19 PM
    Thursday, January 26, 2012 9:16 PM
  • I noticed that disabling and re-enabling my display adapter seems to fix the problem (NVIDIA Quadro FX880M on Win 7 Pro x64 SP1).
    Friday, February 03, 2012 9:13 AM
  • ******* GO ON THIS WEBSITE IT WILL SORT OUT YOUR PROBLEM IT WORKED FOR ME :D *******

    http://superuser.com/questions/308721/windows-7-brightness-slider-suddenly-gone

    Saturday, February 25, 2012 2:34 PM
  • So I've been experiancing similar issues with my HP dv7-6178us (screen stays DIM all the time) . It has a ATI Radeon HD 6490M video card.

    I tried everything on the HP site (reboot, hit the brightness buttons -- which weren't working, check mobility center -- which didn't have brightness controls, upgrade the BIOS, set the video settings to Manual in BIOS, boot with no battery installed) and I tried uninstalling and reinstalling the Radeon drivers (multiple versions). I also tried uninstalling the Monitor in Device Manager.

    I was very frusterated since the display brightness was normal in safe mode (forcing me to assume it was a software issue). Well, I got the problem fixed and this is how:

    When I opened Device Manager and checked the monitor driver (not display card) I noticed it was using a TeamViewer driver...I remember earlier this week I was remote controlling my laptop via Teamviewer and needed to blank the display. It forced me to install a Teamviewer monitor driver in order to blank the display. I uninstalled Teamviewer and the monitor immediately went to full brightness and my FN+F2/F# (brightness controls) worked again. The brightness slider also returned to windows mobility center.

    Who would have thought the teamviewer driver could mess all this up?

    Anyway, just thought I'd share. Hope it helps someone.

    -Ryan

    Thursday, March 08, 2012 8:46 PM
  • Wow, soon three years on and Sony has not fixed this issue. For me simply closing and opening the lid (with lid closing set to put the computer on stand-by in my case) restores brightness control after losing it in hibernation. Disabling and re-enabling the display adapter works but that would be an absolute pain every time you resume from hibernate. Suffice to say this was driving me mad, they could at least put some FAQ question out or something if they don't fix it. I never liked macs but now I do get the point after buying this Vaio...

    Tuesday, March 13, 2012 10:48 PM
  • Me too!!! Thanks so much!!! For months, I have strugled with this problem, spent hours looking online, hours with HP support, and this fixed It. By the way, I have a HP dv6t CTO Quad Edition Home Entertainment. Win7 x64 Home premium.

    Sunday, April 29, 2012 11:30 PM
  • Solved, and I quote as per the one I found in WEB, and it worked for me

    "For advanced users, I will simply say, Goto "devmgmt.msc", Install "Generic PnP Monitor" as your monitor driver.

    For those who don't know how to do that:

    1. Open "Device Manager"
    2. Under "Monitors" tree you will see installed monitor, PnP-Monitor (Standard) in my case
    3. Right click in it, and select update driver
    4. Select "Browse my computer for driver software"
    5. Select "Let me pick from a list of device drivers on my computer"
    6. Keep "Show compatible hardware" checkbox on
    7. Under driver list, you will see "Generic PnP Monitor"
    8. Select that option and Click "Next"

    Windows will install new monitor drivers and you display brightness will start working again."

    I have tried almost everything, but this worked for me... and it is not a workaround... once I did it.. it is always there and active...

    Regards.

    • Proposed as answer by J.Ding Tuesday, June 12, 2012 7:29 PM
    Tuesday, May 08, 2012 11:11 AM
  • Hmmm...  I have an HP Pavilion g4-1117dx with: AMD Vision 3300M, 320 GB HDD, AMD Radeon 6480G Discreet-Class GPU, 14" LED, Windows 7 and the latest GPU drivers (from HP). I experience the same issues mentioned above pertaining to the brightness controls locking up after closing the lid when it is set to "sleep" after closing the the lid.  Upon reopening the controls are of course, stuck and no brightness slider in power options. Only remedy I've found so far is to set the lid closure action to "Do Nothing" and shut and reopen to gain control again.  Or, of course reboot!

    I thought if I did what 'Eng M T' said above to reinstall the monitor driver as "Generic PnP Monitor" that it may take care of it.  Problem is, when I went to device manager to install the driver it was already installed.  So in this case the "Generic PnP Monitor" driver does not take care of the problem.

    It just seems, after reading about so many people experiencing the same issues with all different brands and hardware setups that its likely not the hardware, or the GPU drivers, that its likely a flaw in Windows 7.  I wish that someone at Microsoft would take the initiative to fix this area of their software.  Sounds like from above, that Vista didn't have those issues.  Perhaps recoding that area to work like Vista's, I dunno!

    Anyway, if anyone else has any tips or pointers they have found to remedy this issue please post!  I would greatly apreciate it.  Simply shutting the lid and taking off with it sleeping and returning later without finagling would be great!

    Tuesday, November 20, 2012 4:50 PM
  • It looks like there is a solution for this now. Please see http://support.microsoft.com/kb/2752407
    Wednesday, November 21, 2012 4:12 PM
  • Check this

    http://support.microsoft.com/kb/2752407

    Saturday, April 27, 2013 1:48 PM
  • I have the same issue. Sony Vaio vpceg, Win 7 Home preinstalled. It starts after some updates I think, may be few months ago. Before this about 1 year everything was fine.

    Restoring older system state helps for a while, but after some time problem reappeared. Windows updates are set to "auto".

    Nothing in this thread helps, kb2752407 also doesn't fix. Latest drivers for video (Intel) doesn't help.

    Sliders works, but really brightness doesn't change. After sleep with closing lid.

    Wednesday, May 15, 2013 7:10 AM
  • Hi all

    Not the first time I've experienced this issue. I found a fix for me so I hope this works for the rest of you too.

    I have my "closing the lid" set to do nothing, then with my laptop on and logged in I closed the lid, waiting a few seconds and opened it. My screen brightness controls were then restored.

    Hope this helps!

    Monday, February 03, 2014 11:29 AM
  • This usually works for me when the brightness setting gets stuck in the min/max settings:

    Hit Windows key and start typing Device Manager. Go to Device Manager -> expand display adapter -> right click on the child, click "Disable". Once the screen reloads, right click and click on "Enable".

    Monday, February 10, 2014 12:43 AM
  • This usually works for me when the brightness setting gets stuck in the min/max settings:

    Hit Windows key and start typing Device Manager. Go to Device Manager -> expand display adapters -> right click on the child, click "Disable". Once the screen reloads, right click and click on "Enable".
    Monday, February 10, 2014 12:51 AM
  • Thank u for giving this solution  
    Tuesday, February 25, 2014 6:48 PM
  • Thanks,

    That really worked !!!

    Sunday, March 23, 2014 3:06 PM