none
Windows 7 network Problem

    Question

  • I did a clean install of Windows 7 on a HP 5850 computer. It picked up my wired and wireless router, printer and all other workstations. My cable connection to the internet worked. Everything worked correctly. I removed the wireless router for another project.  Now Windows 7 will not connect to anything.  It stays in local mode and tells me I have an unidentified public network.  I have tried everything I can think of to fix the problem, no luck.  when I try to create a new connection to the internet the only options I receive are dial up or PPOE. No cable broadband connection available.  Help!!

    Monday, June 29, 2009 1:32 PM

Answers

  • From the IP configuration information, I found that the network does not have a valid IP address. The gateway it connects is 192.168.0.10. The DNS server is not the device that includes the gateway. However, in the route table, you have manually added a route that connects to 192.168.0.1.

    I suggest that you obtain the correct address of the router first. Then check the settings of the Local Area Network connection. Make sure that it obtains IP and Default Gateway address automatically, and click the Advanced button, delete all existed Default Gateway and DNS.

    If the issue persists, please let us know if the computer is in a domain or a workgroup. If it is in domain, if there is any other DHCP server that is hosted by Windows Server systems. 


    Arthur Xie - MSFT
    Tuesday, July 07, 2009 7:47 AM
    Moderator
  • Mr X,
     I think you have pointed out the problem.  I would do another "route print" to see where the box thinks it should go to get out to the world and any local nets.
     I think he has a bad route that was left over from when the wireless AP was in the mix, or the AP was in 'more than AP mode' before it was removed.  If the AP was handing out IP addresses rather than the wired router handling DHCP, when it was removed, the unexpired lease could leave the box in limbo.  It 'grew up' knowing itself to be on a specific network, and needs all those entries removed from the registry.  Good luck with that...

     To make things work, right now, without problems, set the IP manually for the NIC.
     The ipconfig output showed:
     NIC at: 169.254.106.210
     Gateway at :192.168.0.10
     DNS at : 192.168.0.75

     Your box (NIC) is not on the same net as everything else.  It is not seeing the router, and Autoconfig is sending it off to 169.254 land...
     If you manually set the IP to 192.168.0.xx, it should work.

     Please show all work when you turn in your assignment... i.e. do a 'route print' and an 'ipconfig' & cut'n'paste output ...

    If you look at the 2nd to the last para of <a href="http://technet.microsoft.com/en-us/library/cc779122.aspx">The IP routing table: TCP/IP </a> you will maybe understand why your computer sees bupkus.

     You can do a 'route delete' to get rid of any 169.254.x.x stuff.  And anything that is not on the same network as your NIC.    You can do the "route –p add 0.0.0.0 [IP address of the wired router]"
    as Mr X said, but put in the IP address you MANUALLY assign to the card.

     In short, clean up the route table, assign an IP manually, and add a manual route to the route table  to match the NIC IP.
    tom
    Wednesday, July 08, 2009 3:05 PM

All replies

  • Remove your adapter from device manager and allow it to be reinstalled. Any luck?
    Monday, June 29, 2009 1:34 PM
  • Tried that No luck. Network still came up as unidentified.

    Monday, June 29, 2009 2:13 PM
  • Go to start>run> type in secpol.msc. Click network list manager policies. You can change how Windows 7 identifies networks from here.
    Monday, June 29, 2009 4:16 PM
  • I suspect that the gateway it currently connects is incorrect. Please run the ipconfig /all and check if the Default Gateway is the router it connects right now.

    Also, please enter the following command in command prompt with administrator privilege.

    route print > %userprofile%\Desktop\routetable.txt.

    Then open the generated file routetable.txt on Desktop, and copy the contents into your post.


    Arthur Xie - MSFT
    Tuesday, June 30, 2009 10:26 AM
    Moderator
  • Could set up polices however did not change any thing still cannot connect
    Tuesday, June 30, 2009 9:53 PM
  • Routetable listing  Hope this helps
    ===========================================================================
    Interface List
     11...00 21 85 cd b3 6e ......Broadcom NetXtreme Gigabit Ethernet
      1...........................Software Loopback Interface 1
     12...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter
     13...00 00 00 00 00 00 00 e0 Teredo Tunneling Pseudo-Interface
    ===========================================================================

    IPv4 Route Table
    ===========================================================================
    Active Routes:
    Network Destination        Netmask          Gateway       Interface  Metric
            127.0.0.0        255.0.0.0         On-link         127.0.0.1    306
            127.0.0.1  255.255.255.255         On-link         127.0.0.1    306
      127.255.255.255  255.255.255.255         On-link         127.0.0.1    306
          169.254.0.0      255.255.0.0         On-link   169.254.190.220    276
      169.254.190.220  255.255.255.255         On-link   169.254.190.220    276
      169.254.255.255  255.255.255.255         On-link   169.254.190.220    276
            224.0.0.0        240.0.0.0         On-link         127.0.0.1    306
            224.0.0.0        240.0.0.0         On-link   169.254.190.220    276
      255.255.255.255  255.255.255.255         On-link         127.0.0.1    306
      255.255.255.255  255.255.255.255         On-link   169.254.190.220    276
    ===========================================================================
    Persistent Routes:
      None

    IPv6 Route Table
    ===========================================================================
    Active Routes:
     If Metric Network Destination      Gateway
      1    306 ::1/128                  On-link
     11    276 fe80::/64                On-link
     11    276 fe80::dcc9:f743:26d7:bedc/128
                                        On-link
      1    306 ff00::/8                 On-link
     11    276 ff00::/8                 On-link
    ===========================================================================
    Persistent Routes:
      None
    Tuesday, June 30, 2009 9:55 PM
  • hi
    i had similar problem
    this is what worked for me
    disable IPv6

    Open Network and Sharing center
    on left click "Change Adapter Setting"
    right click "Local Area Connection" and click "Properties"
    now
    uncheck these boxes
    Internet Protocol Version 6 (TCP/IPv6)
    Link-Layer Topology Discovery Mapper I/O Driver
    Link-Layer Topology Discovery Mapper Responder

    how that works for you
    and hope it keeps working for me
    Wednesday, July 01, 2009 7:46 AM
  • Tried that, no luck still the same.  Still shows as unidentified network with a red x between network and internet.  Will not connect to any devices on my home network.
    Wednesday, July 01, 2009 3:06 PM
  • well i'm not sure about wirelss
    i'm on broadband and i tried creating a new connection like you,
    but it didn't work
    so i deleted the connections then i disabled the ipv6

    but
    i don't have a "Home Network" setup
    I just have 2 computers that "aren't" networked together
    they just use the same modem/router

    can't help with networking mulitiple comps
    sorry


    Wednesday, July 01, 2009 7:35 PM
  • From the route table I can find that the default gateway route is missing. I suspect that the route for the wired router has been deleted because you need to set the wireless router to be the default gateway.

    Please follow the steps below to manually add routes for the wired router.

    route –p add 0.0.0.0 [IP address of the wired router]

    Next time, if you disconnect the wired router and connect to the wireless one, if the network does not work again, please use the following command to delete the route for the wired router.

    route –p delete 0.0.0.0 [IP address of the wired router]

    Please note that we need to run the above commands in Command Prompt with administrator privilege.

    The following articles may be helpful.

    Default Gateway Configuration for Multihomed Computers

    The IP routing table: TCP/IP


    Arthur Xie - MSFT
    Thursday, July 02, 2009 7:35 AM
    Moderator
  • New route table.  Posted the wrong one before.  Sorry.  Still no connection
    ===========================================================================
    Interface List
     11...00 21 85 cd b3 6e ......Broadcom NetXtreme Gigabit Ethernet
      1...........................Software Loopback Interface 1
     12...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter
     13...00 00 00 00 00 00 00 e0 Teredo Tunneling Pseudo-Interface
    ===========================================================================

    IPv4 Route Table
    ===========================================================================
    Active Routes:
    Network Destination        Netmask          Gateway       Interface  Metric
              0.0.0.0          0.0.0.0      192.168.0.1  169.254.190.220    276
            127.0.0.0        255.0.0.0         On-link         127.0.0.1    306
            127.0.0.1  255.255.255.255         On-link         127.0.0.1    306
      127.255.255.255  255.255.255.255         On-link         127.0.0.1    306
          169.254.0.0      255.255.0.0         On-link   169.254.190.220    276
      169.254.190.220  255.255.255.255         On-link   169.254.190.220    276
      169.254.255.255  255.255.255.255         On-link   169.254.190.220    276
            224.0.0.0        240.0.0.0         On-link         127.0.0.1    306
            224.0.0.0        240.0.0.0         On-link   169.254.190.220    276
      255.255.255.255  255.255.255.255         On-link         127.0.0.1    306
      255.255.255.255  255.255.255.255         On-link   169.254.190.220    276
    ===========================================================================
    Persistent Routes:
      Network Address          Netmask  Gateway Address  Metric
              0.0.0.0          0.0.0.0      192.168.0.1  Default
    ===========================================================================

    IPv6 Route Table
    ===========================================================================
    Active Routes:
     If Metric Network Destination      Gateway
      1    306 ::1/128                  On-link
     11    276 fe80::/64                On-link
     11    276 fe80::dcc9:f743:26d7:bedc/128
                                        On-link
      1    306 ff00::/8                 On-link
     11    276 ff00::/8                 On-link
    ===========================================================================
    Persistent Routes:
      None

    Thursday, July 02, 2009 4:07 PM
  • You are mixing or crossing networks.

    IPv4 Route Table
    ===========================================================================
    Active Routes:
    Network Destination        Netmask          Gateway       Interface  Metric
              0.0.0.0          0.0.0.0      192.168.0.1  169.254.190.220    276
            127.0.0.0        255.0.0.0         On-link         127.0.0.1    306
            127.0.0.1  255.255.255.255         On-link         127.0.0.1    306
      127.255.255.255  255.255.255.255         On-link         127.0.0.1    306
          169.254.0.0      255.255.0.0         On-link   169.254.190.220    276
      169.254.190.220  255.255.255.255         On-link   169.254.190.220    276
      169.254.255.255  255.255.255.255         On-link   169.254.190.220    276
    ..............................
     The gateway you use on the first line is on 192.168.x.x and the interface you use to get there is on 168.254.x.x  That will not work.
     The 169.254.x.x addresses are for 'local networks, and is an automatically assigned address.  You can use DHCP to get an address from your wireless, likely a 192.168.x.y address, if it is handing out IP addresses for your 'local' network that is invisible to the 'real net'.
      You could manually assign an address that would work with your wired interface, but normally you would use DHCP.
     If the machine cannot find a DHCP server, then it uses the 169.254.x.x series for 'casual' home networking.  That is causing a problem in my "7" box, as I have a weak wireless connection to an access point at the other end of the house.  "7" seems to drop and re-connect at its whim.  Using XP, I had a good solid connnection.
     Anyway, there is an Autoconfiguration setting you can disable that will let a "7" box be a little more patient with a DHCP server in getting an IP address.
     If you don't have a DHCP server, then the 169.254.x.x IP's should work to connect to the other boxes on the wired net.
     When "7" does finally work for me, it messes up the DSL modem, and disallows any other boxes from getting a DHCP assigned network address, with an "Error, access denied" message.  The only way to get an address on power-up is to reset the modem.
     I would suggest that the network team at M'soft take a look at what they changed from XP, default behavior and settings. and determine what changes they should make, if any, to allow continued network access without problems.  The current settings are causing difficulties...
    tom

    Added: go here and read about how you are being helped automatically:
    http://support.microsoft.com/kb/220874

    • Edited by tmwalsh0 Friday, July 03, 2009 12:41 AM add link to Autoconfiguration KB
    Friday, July 03, 2009 12:05 AM

  • 1.)

    Try turning off the firewall, specially if you have an antivirus like eset smart security, where it controls your subnet network.

    i suggest you turning disabling windows firewall and any other type of firewall application that you have, then do the following:

    widowns flag key + r  or start --> run --> cmd

    ipconfig /release

    ipconfig /renew

    ipconfig /flushdns

    and make sure that you are using obtain mode in you tcp/ip configuration on your network adapter.


    2.)

    try connecting any other computer or laptop and check if its going to work, you need to identify if this problem from your computer side only or from the router it self.

    good luck !
    Friday, July 03, 2009 12:53 AM
  • Thanks for Tom and Shady. Baywop, please try the suggestions above. I also suspect that you do not have an valid IP address. Please also upload the result after you run "ipconfig/all".

    Additionally, if we could determine that the network adapter does not obtain an IP address from the router, I suggest that you check related settings. On the computer, make sure that the Local Area Network is set to obtain IP address automatically, and on the router DHCP is enabled. If it does not work, manually assign a IP address and the Default Gateway on for the Local Area Connection on the computer.

    You may also try to upgrade the firmware of the wired router.


    Arthur Xie - MSFT
    Friday, July 03, 2009 6:27 AM
    Moderator
  • Will upload ipconfig/all tonight.  I do not have a valid IP address. I receive the 169 autoconfig address. I manually assigned an IP, mask, gateway and DNS.  System still shows unidentified network and refuses to connect to either the internal network or the internet. After assigning the IP manually when I ping other computers on the network I receive the message destination host unreachable. The manually assigned IP is 192.168.0.88, the computer being pinged is 192.168.0.75, Subnet mask gateway and DNS are the same on bith computers. The other two computers running XP have no problems receiving an IP from my router and connecting to the internet. They respond when pinging each other and the router. The Windows 7 machine is the only one with problems. It has disconnected itself from the network and refuses to connect.
    Friday, July 03, 2009 2:07 PM
  • How old is your wired router?
    If machines running XP connect but the Win7 machine doesn't, is it possible your wired router doesn't support autotuning - or needs an upgrade to tolerate Vista/7 networking behaviour?
    Friday, July 03, 2009 2:11 PM
  • The router is a Dlink DI-704UP.  When Windows 7 was first installed it worked without problems. A wireless router that was being used as a pass through device (DHCP disabled and hard wired to the Dlink) was removed from the network, that is when all the problems started.  The wireless device was reconnected but the problem still exists.
    Friday, July 03, 2009 8:33 PM
  • Does the HP have a wireless card in it, or is it to connect only via a wired interface?  If the HP had found the wireless AP before, it may still want to connect to it.
    You have turned off the firewall, or allowed pings to work in and outbound, right? 
     Do you have anything in system32\drivers\etc\hosts?  I keep seeing the words 'OnLink' in your ipconfig output.  Normally, if the hosts file is empty, or minimized, you would see the IP octets instead of words.

     Did you: Go to start>run> type in secpol.msc
     
    That dealy will let you set the 'action' to be taken when the computer finds a network... as in let the user name the network, so it is no longer 'unknown'.  One of the selections (middle one? or 2nd) has a list of 3 things to do.  I would let the user assign those three things, that way "7" would not reject them out of hand...?
    tom
    Friday, July 03, 2009 9:06 PM
  • Try uninstalling the driver completely then reboot and then reinstall it again, I will suggest you to try after that connecting your laptop to the any other router or wired network, and check if it’s going to work.

    Check the patch cord you using, try using another cable, and make sure the length of the cable do not exceed 70 meters maximum.

    Until this moment it’s not clear from us if your problem is existed on your network on your laptop itself.


    awaitting additional information.

    good luck.


    Microsoft Certified: MCP, MCSA, MCSA Security, MCSE, MCSE Security.
    Saturday, July 04, 2009 10:07 PM
  • yeah mines down again too
    i've only been able to connect a few times to the internet

    i have a modem/router
    2 comps
    one with xp is my main internet computer
    i just try pluging another cable into the modem/router to try to get windows 7 comp to look for updates etc.
    and most of the time it wont connect,
    probably only luck the few times it has
    the windows 7 comp had network card on motherboard a VIA card
    updated the drivers to the VIA drivers too

    thinking about getting a another network card to plug in, since they are so cheap
    and seeing how that goes
    Sunday, July 05, 2009 5:40 AM
  • HP computer does not have wireless. It is connected to the same AP as my two XP machines. XP machines talk to each other and to the internet. Nothing in etc \hosts, just the standard comments. Ran secpol as administrator, nothing changed cannot rename any network or change public/private profile.
    Sunday, July 05, 2009 3:08 PM
  • Tried all of that nothing worked. The problem is on the Windows 7 computer. All other machines talk to each other and to the internet. Windows 7 says it has an unidentified network and refuses to connect to anything.
    Sunday, July 05, 2009 3:11 PM
  • It'd be really nice if MS would find a solution to this MAJOR network connectivity problem. So far, not a peep. I lose internet connection every 30 minutes or so and have the troubleshooter restart my adapter. Its on their end ...not mine.
    Sunday, July 05, 2009 5:40 PM
  • Some things that I see in Baywop postings:

    TCP/IP may not be set for 'automatic' as needed for DHCP Server assinged TCP/IP information.
    169.254.xxx.xxx address in 'ipconfig /all' attached to ETH0 may be due to hardware fault
    Gateway does seem to be set to 192.168.0.1 as commonly used by most routers.

    I would advise to check your patch cords if hardwire connection to router is in use, if wireless - check hardware for loose connection or damage to antenna.

    Suggest looking at TCP/IP properties to make sure adapter is set for DHCP services rather than 'static' assignment.  Run IPCONFIG.EXE from command prompt window to check on existing TCP/IP assignments.  Use the  /release and /renew commands to test for DHCP Server connections.

    Copy output of ipconfig /all and past to reply as this example shows:

    Microsoft Windows [Version 6.1.7100]
    Copyright (c) 2009 Microsoft Corporation.  All rights re

    C:\Users\(Current User)>ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : IntelBox
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : myhome

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . : myhome
       Description . . . . . . . . . . . : VIA Rhine II Fast Ethernet
       Physical Address. . . . . . . . . : 00-04-61-A7-E8-C5
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::a8ee:972b:3774:fb83%13(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.1.5 (Prefered)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : Sunday, July 05, 2009 9:11:49 AM
       Lease Expires . . . . . . . . . . : Monday, July 06, 2009 9:11:48 AM
       Default Gateway . . . . . . . . . : 192.168.1.1
       DHCP Server . . . . . . . . . . . : 192.168.1.1

       DHCPv6 IAID . . . . . . . . . . . : 218104929
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-11-B2

       DNS Servers . . . . . . . . . . . : 192.168.1.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.myhome:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : myhome
       Description . . . . . . . . . . . : Microsoft ISATAP
       Physical Address. . . . . . . . . : 00-00-00-00-00-00
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 9:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling
       Physical Address. . . . . . . . . : 00-00-00-00-00-00
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e50:ed)
       Link-local IPv6 Address . . . . . : fe80::2044:588:b8
       Default Gateway . . . . . . . . . : ::
       NetBIOS over Tcpip. . . . . . . . : Disabled

    I have marked the important information in bold - use this to determine if your output looks good for your router as you should see similar information if it is set up correctly.

    Good luck.

    CB
    Sunday, July 05, 2009 6:42 PM
  • Those IP's would be correct if you're using a Linksys router. I am not. I know how to configure a router - that is not the issue, its a Win7 problem.
    Sunday, July 05, 2009 7:08 PM
  • I have a us robotics 8000a router that I have two win xp machines connected to both can surf the net and I can transfer files to and from. I connected a win 7 machine to the same network I can surf the net with the win 7 machine, but I can't see any of my winxp machines or transfer files. I looked in the nwtwroking area of win 7 and can't find the place to name a workgroup. The micrsift example looks differnt than what I see on my win 7 machine.
    Sunday, July 05, 2009 9:59 PM
  • Hi all,

    I'm not sure if my problems are the same being discussed here, but I know I'm having a problem.  :-(

    Win7 64-bit RC is installed on my home built desktop in my office (my attic, on the 3rd floor).  The configuration of the PC includes an Asus M3A78 mobo, AMD Phenom 9850 quad core, 4GB RAM, nVidia GeForce 9600 GTS, and a Netgear RangeMax NEXT WN311B adapter.  There doesn't seem to be any rhyme or reason to the drops, but I lose connectivity a lot more than I should (if at all).  My netowrk indicator will all of a sudden show a /!\ on it, and when I hover the mouse over it, the error displays 'No Internet access'.  When I try to browse to my router (Verizon-badged Actiontec MI424WR) at 192.168.1.1, I can't even connect to it.  A reboot is the only option I have...and sometimes, the PC hangs on the reboot.  Tonight when I did the reboot, I was able to restart normally.

    Since the router is G spec, I'm thinking the first thing I should try is remove my N spec adapter and see what happens.  Any ideas what else I should be looking at?

    Many thanks,
    -Ed S

    Monday, July 06, 2009 1:12 AM
  • Hi Ed,

    If seems a DHCP client issue. I suggest you upgrade the network adapter driver. Most of such issues are caused by incompatible driver. Also, please try to upgrade the firmware of the router.

    This issue is a quite different issue than the original one we discuss in this thread. If we need further discussion, please create a new thread in this forum. Thanks.


    Arthur Xie - MSFT
    Monday, July 06, 2009 7:50 AM
    Moderator
  • Ipconfig on my win 7 machine.

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : My-PC
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
       Physical Address. . . . . . . . . : 00-21-85-CD-B3-6E
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2002:43c1:e237:1234:8cd9:61e2:8866:6ad2(Preferred)
       Temporary IPv6 Address. . . . . . : 2002:43c1:e237:1234:2c5c:4aa6:cfb:cf8d(Preferred)
       Link-local IPv6 Address . . . . . : fe80::8cd9:61e2:8866:6ad2%17(Preferred)
       Autoconfiguration IPv4 Address. . : 169.254.106.210(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.0.0
       Default Gateway . . . . . . . . . : fe80::21e:e5ff:fea6:bcf3%17
                                           192.168.0.10
       DHCPv6 IAID . . . . . . . . . . . : 285221253
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-11-9E-3E-99-00-21-85-CD-96-6D
       DNS Servers . . . . . . . . . . . : 192.168.0.75
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.{4A89CC7C-6376-461A-B2EE-AA561F827766}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tuesday, July 07, 2009 12:05 AM
  • From the IP configuration information, I found that the network does not have a valid IP address. The gateway it connects is 192.168.0.10. The DNS server is not the device that includes the gateway. However, in the route table, you have manually added a route that connects to 192.168.0.1.

    I suggest that you obtain the correct address of the router first. Then check the settings of the Local Area Network connection. Make sure that it obtains IP and Default Gateway address automatically, and click the Advanced button, delete all existed Default Gateway and DNS.

    If the issue persists, please let us know if the computer is in a domain or a workgroup. If it is in domain, if there is any other DHCP server that is hosted by Windows Server systems. 


    Arthur Xie - MSFT
    Tuesday, July 07, 2009 7:47 AM
    Moderator
  • Mr X,
     I think you have pointed out the problem.  I would do another "route print" to see where the box thinks it should go to get out to the world and any local nets.
     I think he has a bad route that was left over from when the wireless AP was in the mix, or the AP was in 'more than AP mode' before it was removed.  If the AP was handing out IP addresses rather than the wired router handling DHCP, when it was removed, the unexpired lease could leave the box in limbo.  It 'grew up' knowing itself to be on a specific network, and needs all those entries removed from the registry.  Good luck with that...

     To make things work, right now, without problems, set the IP manually for the NIC.
     The ipconfig output showed:
     NIC at: 169.254.106.210
     Gateway at :192.168.0.10
     DNS at : 192.168.0.75

     Your box (NIC) is not on the same net as everything else.  It is not seeing the router, and Autoconfig is sending it off to 169.254 land...
     If you manually set the IP to 192.168.0.xx, it should work.

     Please show all work when you turn in your assignment... i.e. do a 'route print' and an 'ipconfig' & cut'n'paste output ...

    If you look at the 2nd to the last para of <a href="http://technet.microsoft.com/en-us/library/cc779122.aspx">The IP routing table: TCP/IP </a> you will maybe understand why your computer sees bupkus.

     You can do a 'route delete' to get rid of any 169.254.x.x stuff.  And anything that is not on the same network as your NIC.    You can do the "route –p add 0.0.0.0 [IP address of the wired router]"
    as Mr X said, but put in the IP address you MANUALLY assign to the card.

     In short, clean up the route table, assign an IP manually, and add a manual route to the route table  to match the NIC IP.
    tom
    Wednesday, July 08, 2009 3:05 PM
  • The very first thing I would try is to assign a static IP to the ethernet adapter.  In this case looking at your output of:

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
       Physical Address. . . . . . . . . : 00-21-85-CD-B3-6E
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

       IPv6 Address. . . . . . . . . . . : 2002:43c1:e237:1234:8cd9:61e2:8866:6ad2(Preferred)
       Temporary IPv6 Address. . . . . . : 2002:43c1:e237:1234:2c5c:4aa6:cfb:cf8d(Preferred)
       Link-local IPv6 Address . . . . . : fe80::8cd9:61e2:8866:6ad2%17(Preferred)
       Autoconfiguration IPv4 Address. . : 169.254.106.210(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.0.0
       Default Gateway . . . . . . . . . : fe80::21e:e5ff:fea6:bcf3%17
                                           192.168.0.10
      
    DHCPv6 IAID . . . . . . . . . . . : 285221253
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-11-9E-3E-99-00-21-85-CD-96-6D
       DNS Servers . . . . . . . . . . . : 192.168.0.75
       NetBIOS over Tcpip. . . . . . . . : Enabled


    I see that the autoconfig address is one that is usually can be associated with hardware fault or misconfigured DHCP settings on the server appliance.  Also - as others have pointed out your Gateway IP should match your Router's IP address, and the DNS server should point to the router or be "autoconfig" to pick it up from the DHCP server of the router as well.

    Do you have any servers running on your network?  Any Linux machines or print servers?  If they have DNS or DHCP server packages installed it may be causing some confusion as well.

    Some thing you may need to check on:
    1.  Router settings for DHCP Server
    2.  Router settings for DNS pass thru
    3.  If you are using a NIC, try a known good one and see if problems still exist

    Additionally follow suggestions by others to change the Gateway, Router and DNS to point at the proper IP.

    Lastly  - test any changes before moving to the next to see at what point the problem is resolved.

    Good luck.
    Monday, July 27, 2009 10:21 PM
  • The network connectiontroubleshooting  in window 7 is still frustrating and not easy for normal and average users moreover the self diagnostic tools are not helpful.
    Tuesday, September 15, 2009 5:52 PM
  • Is secpol.msc avalable in Win7 Home Premium?  It won't run from "run" in start menu.  I found two files with that name.  They both get snap-in errors when the MMC comes up, even if I run them as an administrator.  Searched for help in KB, forums, technet, etc.

    I'm working on a problem like this and would like to try the secpol tool as mentioned above.

    thanks,

    Jeff
    Thursday, October 29, 2009 10:15 PM
  • Jeff,
     The secpol.msc script is used to adjust the 'security' stuff on networks, such as what to do when you find a network, assigning a specific network a specific level of security, etc.  If you have a working 'home' network, and check its status, you will see a little house between your computer and the outside world network when you check status.  If security is set to treat a home network that way.
     I quit using "7" after getting all the disconnects.  I have a HP with Media Center, and "7" didn't offer a tuner card driver, so my memory of this is back in July.
     As delivered, I think the security setting is to not use 'unknown' networks.  They are untrusted.  I think you have to make a conscious decision to connect to them.  The security policy allows you to set, IIRC, the default action when 3 different kinds of networks 'appear' or are discovered.  There are multiple options and I don't remember them.  They did not fix my problem from way back, as I was disconnected with serious irregularity.  It would work, then stop, then work, though I think rebooting did make it come back, too.
     Check on the KB for secpol.msi ???

    tom

    . ... sorry, I didn't see you'd searched KB.  I still think it is there, somewhere...
    tom
    Monday, November 02, 2009 11:15 AM
  •      I´m with the same problem here too.  I´m using a D-link router 2640 and two network cards:  Realtek RTL8139 and on-board ASUS Atheros.
    I solved the problem putting the speed at 10 mbs full duplex. 
         I´m waiting for a driver update from Microsoft for Windows 7.
    Saturday, December 05, 2009 9:54 AM
  • Hi guys - been looking for a secure way to let you know how I fixed the issue yesterday on my machine.

    I could see that DHCP is sending offers but Win 7 is not picking it up so I enabled  dhcp andthen  teredo on the inbound side of core networking and VOILA not a problem since :D

    I've since gone back and noted that DCHP-in seems to be all we need :)

    Could you guys at Technet just check that my approach didn't leave any gaping security holes before flagging as answer.

    Sorry if garbled but I woke up and thought that I haven't posted my cure for the win7 shakes.

    Everyone else

    Wait for some confirmation before applying this fix as I'm not 100% on the security implications of the proposed fix and I haven't spelled it out clearly so that any non-techies can wait for the official step by step from Microsoft.
    • Proposed as answer by antointhe Tuesday, December 22, 2009 7:50 AM
    Tuesday, December 22, 2009 7:49 AM
  • I am having the same problem. I put windows 7 on one of my pc's a few weeks ago. For a few days it seemed to work fine. But now for some reason only one of the network cables seem to actually get the internet. Windows 7 pc will work, but my xp machine won't. Swap over the cables in the back of the router and the windows 7 machine won't work but xp does. And win 7 pc comes up as unidentified network. It's like only that one port works. But when the win 7 pc is working, xbox live won't work properly. So for live I have to have xp plugged in. It's really weird and I have looked through tons of forums, people have made suggestions of which I have tried them all but nothing seems to work.

    Not sure what to do any more, just waiting for a fix :-)


     Edit/Delete Message Reply With Quote Multi-Quote This Message Quick reply to this message
    Reply
    Monday, January 04, 2010 6:58 PM
  • This seems to be a common problem, I might be able to add a little more  info into this as I've been battling with a similar problem for a while.
    Background - Win7 64bit, worked fine then suddenly networking stops working. Try different network cable, router, and 3 different broadcom drivers (inc the built in Microsoft one)
    Windows is refusing to pick up a dhcp address. Other machines on the same cable can pick an address fine.
    Setting the IP manually partially works to some extent, but some websites are inaccessable - for example www.bbc.co.uk times out but other sites are unaffected.
    DNS appears to be functioning correctly and a tracert will complete on inaccessable websites.

    Things I have tried -
    Firewall & Security changes
    Network driver changes
    Host file changes
    DNS changes
    Router & Physical cable change

    In Virtualised XP mode you can directly access the network card rather than using NAT. In NAT mode the XP image has the same problem, but changing to directly accessing the adapter and the XP system picks up a DHCP address fine and can access the inaccesable websites.
    So I have two IE windows open, both on the same machine running on the same hardware, through the same infrastructure and one works fine and the other is buggered.

    This appears to be a problem related to some component of win7 networking services, brought on by a recent update.
    Tuesday, January 26, 2010 12:39 PM

  • I had networking problems as well. 3 computers running Windows 7. 2 had Adobe CS3 installed which brings with is a piece of software called Bonjour. These two computers had no end of networking problems. 1 was a desktop connected to the router and the other was a laptop connecting via WiFi. Third computer didn't have CS3 and didn't have any trouble at all.

    In trying to find a solution (nothing seemed to work), I came across the solution shown below in a different thread and thought I would share it. I installed the upgrade for Bonjour (it's listed as Windows Vista 64 software) and all of my network problems cleared up. My thanks to "PDX Prod Mgr". Brilliant!


    "
    PDX Prod Mgr Users Medals Users Medals Users Medals Users Medals Users Medals
     Proposed Answer
    I had the same problem when I rebuilt my Windows 7 system.  I had CS3 installed on my system, it installs an old version of bonjour.  If you inspect your program files\bonjour directory, see if you have an EXE and DLL file dated 2006.   Jump over to apple's website and search for windows bonjour.   I found the newer download here:  http://support.apple.com/downloads/Bonjour_for_Windows    

    Download and install this (you don't have to uninstall the old Bonjour)  and reboot.  This fixed my install and I no longer have the network error you describe.  If you look at that folder now,  you will have the newer DLLs (and some other gunk.)   
    "
    Sunday, February 14, 2010 5:55 PM
  • I recently installed windows 7 on one of my XP pcs, now I have the infamous networking issue.
     At home I have a relatively large network with about 10 devices networked, this all works flawlessly. However Windows 7 does not.
     
     Approx 90% of the time when Win7 Pc is booted, network will come up as unidentified. To solve this I have been waiting several minutes, then unplugging network cable, re-plug cable. For me, once the network is active, it stays active until reboot.

    No Bonjour installed here, just dodgy win7 network protocol.

    Its bad form for MS to ignore these bugs from BETA.
    Wednesday, February 24, 2010 1:51 PM
  • I am encountering a similar issue with the office network I am managing.

    Small office with 3 XP desktop clients, 1 Win2000 desktop, 1 Win7 HP desktop, and 1 Win7 Ultimate laptop. All network connections to the router were wired until 1 1/2 weeks ago when I brought in a Linksys WRT120 to piggyback to the router to provide wireless fuctionality as an WAP.

    Plugged it in and configured it using the Win7 laptop. Worked like a breeze and did not interfere with network connectivity or discovery.

    Users decided to ditch the wireless because it did not provide a substantial increase in service. So I removed it from the main router. All the desktop machines can see each other on the network and connect to the internet, however the laptop can only connect to the internet and cannot be seen on the local network by any other computer.

    Are these symptoms of the same issue as described by Baywop and could implement the same suggestions for his/her problem?
    • Proposed as answer by ChinoTico80 Thursday, March 11, 2010 1:41 PM
    Thursday, March 04, 2010 3:18 AM
  • So I read all of the replies and tried all of them and NUFFIN worked. But I did try a combination of things and FINALLY IT worked. I Found the solution for this Infamous problem for me.

    1) Updated Firmware on Router.
    2) Made sure Network Adapter Driver was Updated.
    3)ipconfig /release
       ipconfig /renew
       ipconfig /flushdns
    4)Reset/uplug Router
       a) Reconfig the security on the SSID,Password,Admin etc.......
       b) Made sure router firewall is on.
    5) Turned off Windows 7 firewall
    6) Restarted computer.

    7)Then yelled Woooot!And enjoyed 1 week straight of FREEDOM of network problems and then posted this after that one week of testing.

    Hope this helps anyone and everyone from this problem. I don't know for anyone else but it worked for me. This after talking to Manufacturer, reformatting, using useless win7 troubleshooter and reading online posts. Knowledge is power and thank you all for sharing it with me. God Bless.

    Thursday, March 11, 2010 1:55 PM
  • Microsoft should be punished for its poor implementation of UPNP...

    The problem with network access has NOOTHING to do with:

    a) Power settings

    b) Driver updates

    c) Bonjour services

    d) anything else

     

    If somebody solves the problem by disabling firewalls and antivirus, they must be ____ nuts

    The real problem is that Mister Softee has no idea how to implement UPNP.... and we are the Beta-Testers... once again... it messes up with conflicting IP adresses and lost Internet connections, although router connection still works, which can drive you silly in solving the problem..

    The one solution that helps is to:

    a) Shut down upnp services on Windows7

    b) Much better: Shut down upnp on your router, because it is  a security risk (http://www.us-cert.gov/current/archive/2008/01/15/archive.html)

    and you will see: IT WORKS

     

    • Proposed as answer by JLBenc Tuesday, June 08, 2010 10:48 PM
    Wednesday, May 12, 2010 5:02 PM
  • THANKS FOR YOUR POST!!

     

    I had been smashing my head on the desk since lunchtime, and (six hours later) found your recommendation and worked like a charm...

    (However, a colleage of mine tried it and still has no connectivity.. weird..)

    Tuesday, June 08, 2010 10:47 PM
  • It only kinda worked for me.  Now I can see the drives(YEA!!)  I stopped UPNP on my router(Wipipe, MBR900).  There still seems to be a permission issue even though I have the drives shared.
    Wednesday, July 14, 2010 11:19 PM
  • New finding now my email is down.....and the windows7 machine has lost the wipipe preventing reconfig.  I rebooted the machines when I brought it back up this morning.

     

    We need Window8 with networking that actually works. (or go back to xp)

    Thursday, July 15, 2010 1:26 PM
  • Microsoft should be punished for its poor implementation of UPNP...

    The problem with network access has NOOTHING to do with:

    a) Power settings

    b) Driver updates

    c) Bonjour services

    d) anything else

     

    If somebody solves the problem by disabling firewalls and antivirus, they must be ____ nuts

    The real problem is that Mister Softee has no idea how to implement UPNP.... and we are the Beta-Testers... once again... it messes up with conflicting IP adresses and lost Internet connections, although router connection still works, which can drive you silly in solving the problem..

    The one solution that helps is to:

    a) Shut down upnp services on Windows7

    b) Much better: Shut down upnp on your router, because it is  a security risk (http://www.us-cert.gov/current/archive/2008/01/15/archive.html)

    and you will see: IT WORKS

     

    it might not be a one size fits all


    That seems really interesting but my fresh installs seem to work fine.

    Once I found the virus on my system (I assume it was 'channelling' my ip traffic) I got great connectivity.

    Friday, July 16, 2010 11:52 AM
  • I tried most of the solutions on this page to link 2 windows 7 desktop & laptop to no avail. Got a bizhub pro c5501 on my network and wasted 2 days trying to find it then I realised 'oh ok it worked on XP but not on 7?'. Put XP disc in while 7 was running, wouldnt let me install XP but let me install drivers. 1 min later all the network was working again. Give it a go....this is the first time i've written i a forum but I had to pass this info on. hope it helps someone.
    Friday, February 18, 2011 11:01 AM
  • I am having the same issues with Windows 7 and networks.  I have a router that is networking 3 hardwired desktops and one wireless laptop.  I can ping each computer, but all networked computers do not show up under the network, but the do show up on the network map.  They also lose connections they redisover them.  I have been at this for days.  They are all brand new HP desktops running windows 7 as is laptop.

    This is making my life miserable since it is a small business and connections keep getting lost.

    Saturday, February 26, 2011 2:34 PM
  • 169.254.xxx.xxx is the default address assigned by microsoft when your computer is set to dhcp, and fails to get a dhcp assignment from your router

    this address will not connect to anything. Its only an emergency ip assigned when you have nothing else to work with.

    your having a problem with your nic or your router.

    if you are willing to use a static ip address, you can make it work by setting a static ip, this would typically be something like 192.168.1.2 with a gateway

    of 192.168.1.1

    this depends on your router, in my case this would work fine on an actiontec router, it would probably work on many others

    you can check by starting your web browser and trying to connect first to http://192.168.0.1/ if that works, if not try http://192.168.1.1/ if that works

    else borrow another connection and type in the brand name and model of your router and download its user manual. What you need is to find out its default

    network address, the one you type for the web interface to your router, (this will be your real gateway address) once you have the gateway, you know what to assign as the network ip

    grep

     

    Saturday, May 14, 2011 9:31 PM
  • I have the very same problem.   Based on the other replies, how do I locate the IP and Gateway address in Windows 7 to set them manually?  Also, do I need to download any support ware?
    Monday, April 09, 2012 1:59 PM
  • update the network driver for intel ....from the intel website..

    if unable to find then here is the alternate link for win 7 32 bits

    http://www.sendspace.com/file/uli73h

    Sunday, August 19, 2012 8:17 AM
  • update the network driver for intel ....from the intel website..

    if unable to find then here is the alternate link for win 7 32 bits

    http://www.sendspace.com/file/uli73h

    Sunday, August 19, 2012 8:21 AM
  • update the network driver for intel ....from the intel website..

    if unable to find then here is the alternate link for win 7 32 bits

    http://www.sendspace.com/file/uli73h

    Sunday, August 19, 2012 8:22 AM
  • update the network driver for intel ....from the intel website..

    if unable to find then here is the alternate link for win 7 32 bits

    http://www.sendspace.com/file/uli73h

    Sunday, August 19, 2012 8:22 AM
  • update the network driver for intel ....from the intel website..

    if unable to find then here is the alternate link for win 7 32 bits

    http://www.sendspace.com/file/uli73h

    Sunday, August 19, 2012 8:22 AM
  • update the network driver for intel ....from the intel website..

    if unable to find then here is the alternate link for win 7 32 bits

    http://www.sendspace.com/file/uli73h

    Sunday, August 19, 2012 8:23 AM
  • update the network driver for intel ....from the intel website..

    if unable to find then here is the alternate link for win 7 32 bits

    http://www.sendspace.com/file/uli73h

    Sunday, August 19, 2012 8:23 AM
  • update the network driver for intel ....from the intel website..

    if unable to find then here is the alternate link for win 7 32 bits

    http://www.sendspace.com/file/uli73h

    Sunday, August 19, 2012 8:23 AM
  • update the network driver for intel ....from the intel website..

    if unable to find then here is the alternate link for win 7 32 bits

    http://www.sendspace.com/file/uli73h

    Sunday, August 19, 2012 8:23 AM