"You don't have permission to save in this location"


  • I believe I have set myself as administrator.  Administrator appears beneath my name at sign on.  I skipped creating a password as I am the only user. When downloading a file for my canon scaner I got the message "C:\Program Files (x86)\Canon\Cannon Download\tb4135_en.exe.  You don't have permission to save in this location.  Contact the administrator to obtain permission.  Would you like to save in the ..........folder instead? "  I have tried selecting other directories but get the same result.  I successfully downloaded Another program from Canon only minutes before.  How can I instal this file/programe?  Without it my scanner is useless.
    I realise that it is not good sense to run permanently as administrator.  Can I set up a separate administrator sign in once I have set up all the programs I lost when installing Win7
    Saturday, October 31, 2009 3:23 PM


  • Hi,


    You may try the following suggestions one by one to check the issue.


    Suggestion 1: Temporarily disable antivirus program.


    Suggestion 2: Click Start, All Programs, right click Internet Explorer and click Run as administrator.


    Suggestion 3: Click Start, type inetcpl.cpl into Search box and press Enter. Switch to Security tab, uncheck “Enable Protected Mode (requires restarting Internet Explorer)” and click OK.


    Suggestion 4: Click the Start Button, type "User account control" and press Enter. When the User account control settings box appears, move the slider to Never notify and click OK.


    What’s the result?



    Arthur Li - MSFT
    Monday, November 02, 2009 5:28 AM

All replies

  • Hi

    If this is simply an update for the Canon driver/software, the easiest solution is to download the file to the Desktop. Right click the file and select the Run As Administrator option to install.

    Some tips.

    You should always assign a password to all Administrator accounts, even though you are the only user. This helps when a malicious file tries to gain access to the system and is also necessary for all of the built-in security components to work properly.

    Remember, in Windows 7, all Administrator accounts operate as normal user accounts unless you explicitly 'elevate' a function by using the run as administrator option or approve the UAC prompt when it pops up.  

    Hope this helps.

    Thank You for using Windows 7

    Ronnie Vernon MVP

    Saturday, October 31, 2009 6:45 PM
  • ...the easiest solution is to download the file to the Desktop....

    Although correct, I do not believe this i the best advice or practice.  Downloaded files saved to 'Desktop' are messy/unsightly/cumbersome.  It is best practice to use the 'Downloads' folder which is located within the user account folder, and for which an entry is present on the Start Menu.  this is the system 'default' save location for downloads.

    All downloaded files can be safely and conveniently stored there.  Sub-folders can be created and used for help with organising and retrieving.  If downloaded files are program patches or updates they can be launched from there, and will find the program install folder to patch successfully.

    If downloads have been stored elsewhere on the system already the user may not be currently getting prompted to store files in the default 'Downloads' folder.  This is easy to correct.  When the next download is conducted, when prompted for a save location browse to:

    System drive -> Users folder -> User account folder -> Downloads.

    Afterwards, the system will prompt with the correct download folder, for subsequent downloads.

    • Proposed as answer by Techwrighter Saturday, October 31, 2009 10:07 PM
    Saturday, October 31, 2009 10:06 PM
  • Hi,


    You may try the following suggestions one by one to check the issue.


    Suggestion 1: Temporarily disable antivirus program.


    Suggestion 2: Click Start, All Programs, right click Internet Explorer and click Run as administrator.


    Suggestion 3: Click Start, type inetcpl.cpl into Search box and press Enter. Switch to Security tab, uncheck “Enable Protected Mode (requires restarting Internet Explorer)” and click OK.


    Suggestion 4: Click the Start Button, type "User account control" and press Enter. When the User account control settings box appears, move the slider to Never notify and click OK.


    What’s the result?



    Arthur Li - MSFT
    Monday, November 02, 2009 5:28 AM
  • I figured out the solution to this problem in Windows 7. I assume this will work with other OS too.
    1.  Right-click on the drive that is causing the problem.
    2.  Left-click on Properties.
    3.  Click on the Security tab.
    4.  In the first window click on Administrators (your computer name-PC Administrators).
    5.  Just below the window click on Edit.
    6.  Click on Administrators (your computer name-PC Administrators) again.
    7.  Here's the key to making it work. If Apply is grayed-out, check a box in the Deny column. It will then bring up Apply.
    8.  Check a box in the Allow column. It should check all of the boxes except the last one and uncheck all of the boxes in the Deny column.
    9.  Click Apply. It should run a scan of the files in the drive. When the scan is finished, click Ok. The first box should still be open.
    10. In the first window, click on Users (your computer name-PC\Users) and repeat steps 5-9, of course clicking on Users (your computer name-PC\Users)
    instead of Administrators (your computer name-PC Administrators).
    NOTE:  You may not have to click in the Deny column after the first scan is completed for step 10 as indicated in step 7.

    • Proposed as answer by DotCav Tuesday, May 31, 2011 8:27 AM
    Tuesday, May 31, 2011 8:22 AM
  • Thanks DotCav, worked for me saving PDF995 files on my new Win 7 box (previously got "You don't have permission to save in this location" etc errors at the File Save As dialog box).


    Wednesday, June 01, 2011 2:45 AM
  • Thanks DotCav, worked for me. I was having problems printing/saving .xps files from Internet Explorer. I could print/save .xps files from other applications, but not ie. This fixed it.
    Saturday, July 23, 2011 3:28 PM
  • Hey DotCav

    I've done exactly what you said and I get an error shortly after the scan begins that says


    An Error occured while applying security information to:

    D:\System Volume Information

    Access is denied.


    D:\ is a partition on my hard drive I made to store all my documents, etc.  It worked fine for awhile but has recently denied me access.  I think it might have something to do with sharing D:\ in my homegroup.  I shared it a few days before I found this problem.  I've stopped sharing the drive to try an fix the issue but I keep getting this error.


    Any ideas?

    Wednesday, August 03, 2011 11:22 PM
  • Sorry I took so long to reply. I didn't get a notification stating someone replied to this thread. I just happened to come back to check and see if anyone replied to this thread. 

    I'm kind of stumped on that one for the moment. If I think on it for a while I might be able to figure it out. For now, the only thing I can suggest is to do a System Restore to a point before you started the sharing. 

    Friday, August 26, 2011 7:51 PM
  • I can't change my host file either. I did all the changes listed above, as described, but when it was running the scan there are several that came up, including C:\Windows, that it says is denied!!!

    What is going on with this WIN 7....I need to change the host file and can' matter what I do it seems access is denied.


    What esle could it be ??

    Wednesday, August 31, 2011 8:59 PM
  • If I'm not mistaken, a host file has to do with the OS and IP address names. The method I posted is a solution I figured out for an issue I had where my external hard drive was being denied access when I first plugged it into my new Windows 7 computer that had no problems when plugged into my XP one.
    So, I'm not sure that this method can work for an issue with a host file as I haven't come across that.

    • Edited by DotCav Monday, September 12, 2011 10:24 PM
    Monday, September 12, 2011 10:24 PM
  • Hi!

    I just created a profile here just so that I could respond to this and hopefully provide the solution you are looking for.

    I've come across this lil hiccup a couple of times out of the blue, and it always takes me a minute to remember the solution.  Each time, I forget it's for the exact same simple rediculous technical reason. 

    What happens is I'll be trying to upload a photo or attach one to an email.  As I'm viewing the preview thumbnails to select for attachment, I'll think to myself "hmm its a lil too large, let me resize it first".  And since I can already see the thumbnail image in the attachment windows, I just went ahead and right clicked "open with" my image editor,  rather than closing that whole attachment/upload process, and accessing the image via libraries>pictures (Win 7) BEFORE clicking the item/photo in the image viewer to view the photo in full view right clicking "open with". 

     It's a really rediculous technical glitch, but thats where the issue lies. 

    So next time, try "open with" on the full view of the actual item or image you are working with instead "open with" on the thumbnail, and see if that resolves your issue with being able to save your work after.

    I hope this helps :)

    Sunday, December 04, 2011 8:14 AM
  • I figured out the solution to this problem in Windows 7. I assume this will work with other OS too.
    .... ....
    7.  Here's the key to making it work. If Apply is grayed-out, check a box in the Deny column. It will then bring up Apply.
    ... ...

    No, sorry, no "Apply" button at all, not grey, not black, not there. Any other ideas???? Oh, wait... You mean in the second window (My god, MS is mad about window over window over window). OK, added a check, removed it, clicked Apply, got "Access is denied". That seems to say You can't change your administrator permissions because you are not alllowed to change your permissions. Reminds me of my parents: "Why? Because I said so!"
    • Edited by Lance666 Monday, January 23, 2012 10:18 AM
    Monday, January 23, 2012 10:13 AM
  • Here's how I edit the C:\Windows\System32\drivers\etc\hosts file.

    It gave "You don't have permission to save in this location.." but I solved it in this way:

    1. Right click on the file. In my case, "hosts"

    2. Select Properties -> Security.

    3. Click "Edit" to change permissions. If you only find: 

    • System
    • Administrators (yourComputerName\Administrators)
    • Users(yourComputerName\Users)

    You need to click "Add..", where you "Enter the object names to select": 

    • userName (Simply the name you see when you login to Win7)

    Click OK.

    4. Return back to the list. Now you will see:

    • System
    • userName(yourComputerName\userName)
    • Administrators (yourComputerName\Administrators)
    • Users(yourComputerName\Users)

    Select userName(yourCompusterName\userName from the above list, and then

    Change the "Permissions for userName": 

    • Read & Execute (Allow)
    • Read (Allow)
    • Write (Allow)

    Make sure you have the above allowed. Click OK.

    5. Click OK and close the properties for the file.

    Now you can edit the file!

    • Edited by raejean99 Thursday, February 09, 2012 9:39 AM
    Thursday, February 09, 2012 9:34 AM
  • Didn't you know? In order to create a market Windows is available to any dummy who can muster up the cash to buy it.


    "MODERN PROGRAMMING is deficient in elementary ways BECAUSE of problems INTRODUCED by MODERN PROGRAMMING." Me

    Friday, February 10, 2012 7:11 AM
  • If you are logged in to administrator account, you can try disabling the UAC in the computer to resolve the issue. This one worked for me. No need to disable antivirus application and windows firewall.

    • Edited by Jibendu Saturday, March 24, 2012 9:54 PM
    Saturday, March 24, 2012 9:51 PM
  • This is an annoying problem that seems to come from a change in the windows 7 OS settings. On a PC I bought last year, I had no problem, but on a new one I cannot save where I want with the message "you dont have pemission to save to this folder" etc. Its a real simple solution. You think you have administrator rights but you  dont, even if it says administraor on your user account. Run whichever programme you are using as an administrator by right clicking and choosing "run as administrator". So if you are downloading to a folder where you cannot save to then right click Internet explorer, or whatever browser you use, and run as admin then save etc.
    Saturday, April 21, 2012 4:55 PM
  • DotCav's solution is right on the money. The writer obviously understands the problem behind the error message and therefore offers a real solution. If I had spent another couple of hours (or days) reading Windows 7 Inside Out, I might have arrived at the solution for myself, but I certainly prefer to act on someone else's having got there (in effect) first. Taking the long way--reading the book--is enlightening in general, but it also supplies a lot of information for which one will never have any use and wastes finite space in the head that is needed for other uses.
    • Edited by kinderwe Monday, July 09, 2012 3:13 PM
    Monday, July 09, 2012 3:11 PM
  • Had the same issue on Win 8 RC 9200. Trying to edit the hosts file - even though I am in the Administrators group which has full access to the file, I was denied on the save write operation. I edited the permission and explicitly set my user account to full read and write and I was able to save. Looks like a possible bug?
    Thursday, September 13, 2012 12:00 AM
  • Thanks Arthur_Li

    I tryed two and four and it worked you are very gook I didt have to reinvernt the wheel. I am just getting started with Windows 7 Home and IE9 and the learning ccurve is a lot harder than others I used

    Thanks rod 

    Saturday, September 29, 2012 6:18 PM
  • Hi: Athur_Li

    I tryed your fixx for permission  two and four and it worked great. I am useing a peogram called doPDF 7. Iused it in Win XP and IE8. I changed over to windows 7 and IE9 whitch I am sorry I did. I waited this long to make the switch. The problem I am having noe is the file wont save to the folder? 

    Thanks for your help rod 

    • Proposed as answer by rodlll Sunday, September 30, 2012 2:31 PM
    Sunday, September 30, 2012 2:30 PM
  • Greetings.  I have been having this same problem on an ASUS ee121 Tablet since I bought it.  It is the one computer I have that has almost no hard drive space left and I am desperate to be able to save files on my server computer.  Thanks to this thread, I discovered that I am set up as administrator OK, but still have very limited rights and am unable to change the settings.  When I get into Permissions for explorer and click on Administrator, I only have "Read % execute" and "Read"  and can't check any other boxes--grayed out...  This may not be my proeblem, but all my other computers give me all kinds of control like some of the folks have talked about on this forum....and the other wierd thing is that I can save files from the tablet to any other shared drive in my system except for the Server.  I recently upgraded (?) to Win8 and nothing changed.  Any hel would be appreciated!!
    Tuesday, November 13, 2012 12:33 AM
  • Dotcav, i tried your solution and it didn't work, I then tried raejean99's and thankyou muchly it worked! my issue was that I couldnt save changed file settings in CFF Explorer, and now i can :) thankyou everyone who posted for trying to help, much appreciated!
    Tuesday, November 27, 2012 12:56 AM
  • Man you are awsemone..thanks!!!
    Sunday, December 16, 2012 11:51 PM
  • This solution worked out for me.

    Thank You

    Thursday, November 28, 2013 2:07 PM
  • None of the solutions on this page worked for my issue but I did come up with a solution. 

    My problem began after installing Windows on a new hard drive. I keep most of my files on a second hard drive for ease of use when the OS goes goofy or hard disk fails. I could save to most folders on this preexisting hard drive I call E:/, but one if particular would not allow me to do so even after the suggestions in this thread.

    I was able to save the files I needed to where I desired without issue when and if I ran the program to begin with selecting it directly from the Start Menu and choosing Run as Administrator. While that works, it's frustrating. It slows down computing. I tried all the permissions suggestions as well as adding a fresh username and allowing all permissions afterward.

    My solution, we'll call the problem folder E:/DOCUMENTS-1 for ease.

    Go to E:/

    Create a new folder called DOCUMENTS-2

    Go into folder DOCUMENTS-1, press ctrl+a to select all, press ctrl+c to copy all files

    Go back to E:/

    Go into newly created folder, DOCUMENTS-2

    Press ctrl+v to paste all the files over. Should be very quick if they're on the same drive.

    Attempt creating a new file with Word or Paint, etc and saving into DOCUMENTS-2, if it works you're golden.

    Delete previous problem folder DOCUMENTS-1 and then proceed to rename the new folder whatever it is you actually wanted to it be called. 

    Seems asinine for the system to not allow you to save a file to a folder but then ALLOW you to copy everything and the delete everything. Goofy to have to do this but I can save, read, write etc within all my folders.

    Hope this helps somebody


    • Proposed as answer by Alan Hope Wednesday, September 14, 2016 8:38 AM
    Sunday, March 02, 2014 8:37 PM
  • Thank you Datcav.  The solution provided worked for me in Win8 also.  Thank you very very much.

    Monday, May 05, 2014 4:26 AM
  • Hi,


    You may try the following suggestions one by one to check the issue.


    Suggestion 1: Temporarily disable antivirus program.


    Suggestion 2: Click Start, All Programs, right click Internet Explorer and click Run as administrator.


    Suggestion 3: Click Start, type inetcpl.cpl into Search box and press Enter. Switch to Security tab, uncheck “Enable Protected Mode (requires restarting Internet Explorer)” and click OK.


    Suggestion 4: Click the Start Button, type "User account control" and press Enter. When the User account control settings box appears, move the slider to Never notify and click OK.


    What’s the result?



    Arthur Li - MSFT

    • Edited by uRLffvvxguh Sunday, November 02, 2014 4:13 PM MsFTon
    • Proposed as answer by uRLffvvxguh Sunday, November 02, 2014 4:14 PM
    Sunday, November 02, 2014 4:12 PM
  • Thank you this worked for me I am using Windows 8. 
    Saturday, January 17, 2015 4:42 PM
  • Hi, I seem to be having this problem on windows 7. I get it when saving anywhere other than my documents, even in folders I have created (eg C:/editing files) I have tried the recommendations to set the security permissions but I just get access is denied. I am using the only account on my computer as admin.
    Tuesday, April 07, 2015 10:57 PM
  • Windows has a little vulnerability that you can use to successfully put a file in the C: drive. First, save it to the documents folder, then once it has downloaded, drag and drop the application/folder/file into the C: drive in file explorer. I do realize this answer is a bit late, but I post it anyway for users who come here to day with the same problem I just had.
    Sunday, May 24, 2015 11:22 PM
  • I had this problem and tried everything and finally fixed it after my Surface pro 3 started having the same issue and I remembered just prior to the problem starting on my SP3, a home group app appeared on my desktop and I never put it there. it removed itself from desktop shortly after so I searched for the message (you need administrative permission to save in this location) and included the words 'home group'.

    Long story short, I stopped home group file sharing and in the property tab, I returned file locations to default. It worked. After months of searching, I am finally able to save in any location I choose. The fix was instant and didn't even require a reboot.

    The reason it asks for administrative permission to save in any location even though you are on the administrative account is because even though you are logged in as administrator, the user file is actually just a standard account with an administrative title which is why the computer identifies you as a standard user account. It sounds crazy but it isn't good to open the true administrator user file. It is for your own protection that it is done this way.

     I am so glad to finally have a fix that doesn't involve lowering security or messing up user and registry files.

    Good Luck and please post if you have success.

    • Edited by camatz Sunday, May 31, 2015 1:42 AM
    Sunday, May 31, 2015 1:36 AM
  • Sure. All files should be saved on the desktop. No wonder Windows is on the way out.
    Wednesday, July 08, 2015 9:02 AM
  • Didn't work for me.
    Wednesday, July 08, 2015 9:09 AM
  • my OK vote is wrong.

    i expected something to deceide between OK <--> Not working

    It does not work on my PCs!

    Monday, July 27, 2015 3:11 PM
  • Hey justinwacker

    Thank you. I have been struggling with this and reading up on forums all day. I've just installed Windows X and everything went nuts and I couldn't save anywhere. This has just sorted it out.

    Friday, July 31, 2015 2:32 PM
  • You're the man (woman) raejean99! Your solution worked just beautiful for me. Cheers!
    Thursday, August 06, 2015 8:21 PM
  • Thanks for this suggestion.  Sounds reasonable.  Unfortunately, in newly downloaded Windows 10, it didn't work.  I got to step 8 and could not check any box in "Allow" column.  When trying to proceed by clicking Apply (it did come up when I checked a box in Deny column), I got the same aggravating "donk" sound and something about permissions.  So, I quit.

    Curiously, all of these "permission" or "no access" problems are on "My XXXX" folders.  My Documents, My Pictures, etc.  In the Windows Explorer tree, I also see "Documents" and "Pictures" folders.  Fortunately, both of these open, and I can access all of my files.  Its just the "My XXX" folders that have that disgusting sound and security notice.

    In further reading, I keep running into something about a .dll file being corrupted.  Then, I get messages about fixing it in the registry, which I really an not qualified to do.  I also get solicitations from strange sources to "use this program to fix it rather than spend hours trying to fix it yourself".  I stay away from these solicitations, as I suspect they are malicious and only want to put something evil in my registry.

    But, I digress.  Any further suggestions to fix this security problem would be much appreciated.

    Saturday, August 15, 2015 12:50 PM
  • One other thought.  This is why many people migrate to Mac.  Since I have iPhone and iPad, I am also considering this, although I've been a faithful and mostly happy user of PC for decades.

    Too bad Microsoft can't seem to get this right.

    Working between PC and my iPhone/iPad for storage, etc., is not always a successful experience.  For whatever reason, they DO NOT play well together ...... guess its because they are competitors.  Sadly, its just the user community that suffers from this sour relationship (PC v. Mac).

    Saturday, August 15, 2015 1:10 PM
  • I apologize if I repeat instructions already posted but I had this problem for months and tried everything, some of which was scary because I am no genius with computers.  I finally went on a limb with my own instincts thinking it was related to home group settings and indeed in my case it was. All I had to do was stop sharing files. Problem solved. I still can't believe it went on as long as it did and was something as simple as home group share settings but I do hope this post spares others of the months of headache I went through trying to figure it out.
    Saturday, September 05, 2015 3:03 AM
  • Does this procedure work with Google Chrome?    I am going nuts over this problem of not being able to print PDF files after they are scanned.  Access Denied...Same story I am adminstrator,, etc.  Can I run through these procedures with Chrome since I don't use Internet Explorer?

    Thanks for any help you can throw my way.  I am going nuts fighting this...Windows 10 Chrome

    Thursday, January 14, 2016 1:27 AM
  • Thanks Arthur Li your suggestion 1 put me on the right track. 

    My screenshot program (Greenshot) was prevented from saving to Dropbox with the "You don't have permission to save in this location" message.

    Fix: In my AV program (BitDefender) I added Greenshot to the trusted programs list in the "Ransomware Protection" module. 

    • Edited by tartist Saturday, February 13, 2016 10:51 AM
    Saturday, February 13, 2016 10:33 AM
  • worked !!! but i had to reboot first
    Monday, February 22, 2016 6:02 PM
  • Thank you DotCav! I was having a similar issue in Windows 10. Your solution fixed the problem straight away!
    • Edited by stbelgiq Friday, July 01, 2016 12:29 AM
    Friday, July 01, 2016 12:28 AM
  • Well go to start go to all apps and right click it and then press more then set as administer and click yes when a alert comes up (It worked for me!!)
    • Proposed as answer by Gamer124 Tuesday, August 09, 2016 5:57 AM
    Tuesday, August 09, 2016 5:56 AM
  • Oh My Goodness....... 

    Jut installed Windows 10 and have the same setup as someone above - Data on a second Hard Drive - OS and Programs on SSD and since install of 10, i keep getting the error above.

    Tried taking ownership, I was already administrator.... very frustrating!!

    Completed your suggested method and Bingo.... Problem Solved!

    Many Thanks!!

    Saturday, November 12, 2016 10:13 PM
  • Does not work
    Wednesday, December 14, 2016 1:59 AM
  • Spot on Arthur! You ROCK dude. Concise answers, solved this fuss no muss!
    Friday, December 30, 2016 5:22 PM
  • Worked like a charm on Windows 7 for a QB file I we needed to back up to restore on a different computer.
    Monday, February 13, 2017 7:44 PM
  • THANK YOU! This saved me.
    Thursday, April 27, 2017 3:21 PM
  • OMG!! UAC was the reason!! thanks for the solution.

    Thursday, June 22, 2017 11:28 PM