none
Can't see network drives in the Open dialog box RRS feed

  • Question

  • Just reimaged to Windows 8.1 the other day and now I can't see any of my mapped network drives when I go to File/Open from some programs.

    When I go to Open I only see my local drives but no network drives.  This is not happening in all programs but is happening in some.  Most recently I'm trying to use the Windows 7 USB creation tool thing and can only see my local drive but it's happened in a few other programs as well.

    Anyone know what might cause this?  I can browse to the drives just fine and some programs can list them normally.  Very strange.

    Thursday, September 25, 2014 8:27 PM

All replies

  • Hi,

    Is there any error message when you try to map network Drive manually? It would be better to provide more details about error message.

    Generally speaking, this problem can be caused by Network Connection problem, please make sure your Client PC could access to Network Drive PC.

    In addition, please check Network Drive PC security setting, if there is any firewall policy prevent this operation.

    If still no use, please check Event Viewer if it identify this problem.


    Roger Lu
    TechNet Community Support

    Friday, September 26, 2014 3:10 AM
    Moderator
  • Hi,

    Is there any error message when you try to map network Drive manually? It would be better to provide more details about error message.

    Generally speaking, this problem can be caused by Network Connection problem, please make sure your Client PC could access to Network Drive PC.

    In addition, please check Network Drive PC security setting, if there is any firewall policy prevent this operation.

    If still no use, please check Event Viewer if it identify this problem.


    Roger Lu
    TechNet Community Support

    There is no error.  There is no connectivity problem.  THe drives map automatically and always have.  I can open up File Explorer and browse these drives all I want.  I can open up Word and browse to these drives just fine.

    However, when I open certain programs, and click File | Open, the mapped network drives just simply aren't there.  I only see C and D and that's it.

    Friday, September 26, 2014 3:19 AM
  • Hi,

    What does your meaning by "when I open certain programs, and click File | Open"? Is the program locate at Network Drive? When this problem occures, it seems like these Drive was unmapped. Could you map it again manually? Besides this, it would be better to use Process Monitor to capture the activity of openning program, it maybe helpful to find the reason of this problem.

    Please click the link below to download Process Monitor:

    http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx

    Note: When using Process Monitor to captuer trace, please set Filter as the program you tried to open, also contains File Explorer process.


    Roger Lu
    TechNet Community Support

    Sunday, September 28, 2014 6:09 AM
    Moderator
  • So here's a screenshot.  I was going through Bitlocker Encryption today and when I clicked the option to Save the recovery file I was given the box on the right.  Notice it only shows me my local drives.  The box on the left is a standard File Explorer window showing my various mapped drives that all function just fine.

    I had to save the file to my flash drive and then copy it form there out to the network drive I needed it to go to.  This has come up at various times in various programs when doing an Open or Save or something that involves viewing the file/folder list from within the specific program.

    Wednesday, October 15, 2014 4:30 PM
  • Hi,

    I made a test in our testing enviroment, same phenonmena with yours. In my opinion, this should be design by default. Actually, you can choose the Mapped drive throuhg Network at the end of left panel in your save recoveroy password dialog.


    Roger Lu
    TechNet Community Support

    Tuesday, October 21, 2014 6:24 AM
    Moderator
  • Hi,

    I made a test in our testing enviroment, same phenonmena with yours. In my opinion, this should be design by default. Actually, you can choose the Mapped drive throuhg Network at the end of left panel in your save recoveroy password dialog.


    Roger Lu
    TechNet Community Support

    This doesn't happen only on this one program.  I have encountered this on multiple programs and it's frustrating that I can't open up files I need because the mapped drivers just aren't there.

    If this is by design, someone should be fired.

    Tuesday, October 21, 2014 1:39 PM
  • I saw this happening on Win10 with a few programs.  For each program I unchecked Properties->Compatibility->Run this program as an administrator, after that the File Open dialogs in each program showed the mapped network drives.  I guess the mapping is per user and they weren't mapped as administrator.
    Wednesday, July 12, 2017 8:09 PM
  • There's a fix.

    1 - run regedit
    2. - locate HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/CurrentVersion/Policies/System
    3 - create a new DWORD entry with the name EnableLinkedConnections and value 1.
    4 - restart your computer
    5 - now you can see and use network drives with these installers or applications.

    I found the solution here:

    https://social.msdn.microsoft.com/Forums/windows/en-US/f0073f80-cedb-4b7a-96b9-20e4b22c2424/folderbrowserdialog-does-not-show-network-drives-on-windows-8?forum=windowscompatibility

    Posted by: Jobab A

    Tuesday, August 22, 2017 12:04 PM
  • I saw this happening on Win10 with a few programs.  For each program I unchecked Properties->Compatibility->Run this program as an administrator, after that the File Open dialogs in each program showed the mapped network drives.  I guess the mapping is per user and they weren't mapped as administrator.

    RIGHT HERE IN BOLD ^^^                      

    It's taken a while to reach this conclusion, but I've found that the mapped drives' visibility in the shell depends on what credentials were used to map the drive, and what account you're currently logged in with, as well as (apparently, i'm discovering) the userspace the app that's invoking file explorer operates in - and by userspace, i mean is it running as system (NT Authority\SYSTEM), user, admin user, impersonation of any other account, etc.

    Try this to test it out - run CMD.exe as an administrator (using context menu --> "Run as Administrator") and enter

           "net use K: \\networkedserver\sharename /Persistent:NO" 

    it should complete successfully, but if you open file Explorer, and look for the mapped K drive, it will not be there (unless you're logged in as Administrator).  you can remove the "invisible" mapped drive by entering 

           "net use K: /delete"

    in a CMD.exe window, again, run as administrator, or it won't be able to remove the K: drive created in the previous step.

    Interesting, right?

    And, Mr. Wu, I can't believe you had to clarify with the OP several times to understand the nature of the issue..

    Tuesday, July 3, 2018 6:52 PM
  • You can use this to access the command prompt "impersonating" the NT Authority/System account and therefore you can run netuse etc.. to map shares directly under that account. 

    This of course is only if using CIFS. If you use NFS to map shares and create a loop back policy then it will no longer be "user config" and instead "computer config" that will allow all user accounts/applications to see the same drive letter mapped share.

    https://stackoverflow.com/questions/77528/how-do-you-run-cmd-exe-under-the-local-system-account

    Wednesday, September 5, 2018 3:14 PM
  • This resolved my issue.  Thank you Jobab A!
    Thursday, December 27, 2018 10:38 PM
  • Doesn't work on Win10 using a 32 or 64-bit DWORD running regedit as the program that has no access to mapped drives.
    • Edited by CityguyUSA Thursday, November 28, 2019 4:49 AM
    Thursday, November 28, 2019 4:46 AM