none
Windows 7 won't let me edit information... I.E. mp3 file information like artist,

    Question

  • I am trying to edit information for my mp3's so they are all organized in iTunes, it will not let me do it.  iTunes doesn't let me edit the information either! Help!?
    Monday, October 26, 2009 8:01 AM

Answers

  • Hi,

    You can right click the MP3 file and click Properties. Switch to "Detail" tab and then you can eidt the MP3 information, such as Title, Artists and Composers. Can you modify the information successfully?

    If the information cannot be modified by iTunes, you may need contact Apple support for further assistance.

    Thanks,
    Novak
    • Marked as answer by Novak Wu Friday, October 30, 2009 3:06 AM
    Tuesday, October 27, 2009 2:04 AM

All replies

  • Hi,

    You can right click the MP3 file and click Properties. Switch to "Detail" tab and then you can eidt the MP3 information, such as Title, Artists and Composers. Can you modify the information successfully?

    If the information cannot be modified by iTunes, you may need contact Apple support for further assistance.

    Thanks,
    Novak
    • Marked as answer by Novak Wu Friday, October 30, 2009 3:06 AM
    Tuesday, October 27, 2009 2:04 AM
  • Papa Smurf didn't reply as to whether your solution helped. It didn't for me. I can get to the details tab but am not allowed to edit. Checked to see if files/folders were read only, and they weren't. I tried using ID3 Tagit and it can't change the properties either.
    Monday, November 09, 2009 6:37 PM
  • I'm having the same problem.  I try to open up the details tab, and all the fields are blank, and I cannot enter any data.  My media library is a completely unusable mess as a result.  I don't use iTunes, only WMP.

    Background info:

    I upgraded from Windows Vista Business x64 to Windows 7 Pro x64.  I have a separate drive for my OS and my multimedia, so I thought it may have been an issue with drive permissions and such.  But after taking ownership of the entire drive and sub folders and checking my permissions, I still can't edit meta data on MP3's.  I'm the admin and only user on this machine.

    This is really quite irritating.

    Oddly enough, all of the music which is currently dis-organized was completely fine when I had Vista installed.  I only discovered this inability to edit meta data when I discovered that I was "missing" a huge percentage of my music due to missing meta data.  (they were all filed under "unknown artist."  Again, this didn't happen w/ Vista.)

    I can get over having to re-enter meta data.  But being locked out of organizing my own music is pretty lame.
    Tuesday, November 10, 2009 2:23 PM
  • Amusing update to this situation:

    It isn't only that I can't edit the details of music files, Windows 7 doesn't see the details for music that I know has details entered.  When I was using vista, all my artists had properly entered details for artist, album, track, and so on.  Everything was peachy.

    Then I upgraded to Windows 7.  50% of my music files show blank details now.  This causes them all to be filed under "unknown artist" in Windows Media Player.  What the?!!!  It used to work!!! 

    After trying every permissions and ownership fix I could think of, I started to wonder.... what if the information isn't missing after all?  What if Windows 7 is just not seeing the data there?  So, just for the sake of comedy, I fired up the old XP virtual PC which I have installed with my Windows 7 Pro.  In XP's Windows Explorer, I browsed over to one of the "missing" folders.  Everything was there.  XP saw all the meta data... artist, album, song, EVERYTHING.  On the same drive.  Same machine. Everything the same, except the OS.

    Now that's interesting.... in a totally maddening, tear your hair out while cursing at Microsoft kind of way.

    Thursday, November 12, 2009 5:14 PM
  • To illustrate what's going on, here's a quick screen cast:

    http://www.youtube.com/watch?v=9DNolh8AQdg

    Audio is a bit quiet for some reason, but should get the point across.
    Friday, November 13, 2009 4:12 AM
  • I too am having the same problem. I have a new PC (Oct. 28, 2009) with Windows 7 installed. I had added numerous CDs to my iTunes and was able to edit individual track information without any problem. On 11/10/09 there were several windows updates that were forced on me when I shut down my PC. The next day when I went to iTunes several of the most recent CDs that I had just entered were GONE. No big problem.....I simply added the folders again and the music was back in my library. HOWEVER, if I then select an individual track/song and click on INFO, all of the information is grayed out and it cannot be edited. I was able to do this earlier in the week. I have not changed any of the setting in my PC.  THIS IS EXTREMELY FRUSTRATING. There was not a recent update to iTunes so I doubt the problem lies in the iTunes software. Since then I have searched forum after forum. The most obvious suggestion is that I have to change my folder/file properties so that they are not Read Only. When I go into folders properties for ANY of my folders, Windows 7 had a GREEN BLOCK highlighted next to Read Only. I simply uncheck this so it isn't green and in the top of the box it states "unset read only'. Then I click apply. Then I get a message that states "do you want to apply these setting to all subfolders and files....and I click Yes/OK. Then I see a quick scroll of all of my music titles quickly appears across the center of the box seemingly indicating that it is applying the changes. BUT....the read only green highlighting comes right back as soon as I enter the folder properties again. I also have tried numerous ownerships, permissions, etc. trying to gain access TO MY OWN FILES. It simply won't work. I don't know if this is a problem with WINDOWS 7, but like the other member above I copies my library into another PC running Windows XP and suddenly I can edit all of my music tracks again.

    I HOPE SOMEONE FINDS A SOLUTION TO THIS SOON or I may abandon using my Windows 7 PC for my Ipod use. Such a shame to buy a new PC and have these frustrating problems.
    Monday, November 16, 2009 1:38 AM
  • If anyone from Microsoft would ever get back to us, I'd be happy to send them a folder of music which is suffering from this problem. 
    • Proposed as answer by Mark.A. _ Tuesday, November 17, 2009 10:06 PM
    Monday, November 16, 2009 3:12 PM
  • Just thought I would add my 2 cents to this topic. I also have the same problem. Just got this puter 4 days ago.  I have a copy of Vista still in the box we use as a door stop. So far 7 seems very friendly. I am sure there will be a fix.
    Monday, November 16, 2009 5:05 PM
  • Novak-  Any help would be appreciated... please see new posts, or video here:
    http://www.youtube.com/watch?v=9DNolh8AQdg
    Wednesday, November 18, 2009 5:18 AM
  • It appears to be an issue with ID3v2.

    I used Winamp to remove the ID3v2 tag so that only the ID3v1 tag was used.  Suddenly both Windows 7 and Windows Media Player 12 were able to see the files.

    But it takes too long to change this on a file by file basis, so i'm going to look into batch ID3 tag editors.
    • Proposed as answer by Mark.A. _ Wednesday, November 18, 2009 8:17 PM
    Wednesday, November 18, 2009 8:17 PM
  • did the solution provided by Mark.A solve most of the issue here?
    Thursday, December 10, 2009 6:21 AM
  • did the solution provided by Mark.A solve most of the issue here?
    I don't know but the way i solve the problem is first I convert all of my musics to WMA and the with 3rd party software (TagScanner ) and edit the tags of the songs !! so in the WMP 12 all the Albums , Artist and etc categorized like the past in WMP 11

    by the way i think this is something that push Windows users to use WMA instead of MP3 but clearly it is not MONOPOLY policy because WMP is feature which is not available by default and need to download from Microsoft web site

    Microsoft Certified System Engineer 2003
    Thursday, December 10, 2009 4:12 PM
  • Nah, if you like MP3 you like MP3.  FHG (people behind large chunks of MP3) and MS are on fine terms, and I've got various holiday cards from their dev team around my office.  There's no anti-MP3 bias.  ID3 is a lightly messy standard, but that's neither here nor there, really. If you *really* know the history of MP3, you'll recall that

    Probably your clip either has permission problems (as would be verifiable through attempting to edit that MP3 (ID3) in a secondary editor such as WinAMP) or the ID3 tags are written in a way that the player doesn't understand.  That kind of special failure would be interesting to understand.  And there is an excellent case to be made that the player's error should be *way* clearer about *why* it's failing to edit the ID3 tags.
    Thursday, December 10, 2009 6:37 PM
  • Ok i just figured out how to do it

    Steps:

    1. Right click on the folder where ALL your music is kept (e.g. mine is kept in D:\Music)
    2. Click properties
    3. Click the security tab
    4. Under the group everyone click full control
    5. Click apply

    This should work as it worked for me
    • Proposed as answer by Animal72 Thursday, January 07, 2010 3:55 AM
    Friday, December 18, 2009 12:52 PM
  • ok so I'm almost positive that I found the solution to this problem. Basically Windows Media Player sucks large amounts of rhino balls. Every time you open up an audio file with windows media player that file is still registered as running, and therefor you cannot edit that file.
    Press Ctrl+Alt+del and run the task manager. Now click on the "Processes" tab and scroll all the way down to the bottom of the list and look for a file named "wmplayer.exe *32" and end the process. Problem Solved :)! Also I would recommend using a different media player such as VLC otherwise your gonna run into the same problem everytime you open a media file with windows media player. Hoped this helped peace :)!
    Saturday, December 26, 2009 9:18 AM
  • It appears to be an issue with ID3v2.

    I used Winamp to remove the ID3v2 tag so that only the ID3v1 tag was used.  Suddenly both Windows 7 and Windows Media Player 12 were able to see the files.

    But it takes too long to change this on a file by file basis, so i'm going to look into batch ID3 tag editors.

    I agree with Mark.A. I use mp3Tag Pro . This program let me edit and manipulate different information easy, quickly and with a minimum effort. But if you don't want to pay for a program so you can download mp3tag.
    Wednesday, December 30, 2009 10:40 AM
  • This worked for me.  Thank you Wolf_Dogg.
    • Proposed as answer by Animal72 Thursday, January 07, 2010 3:55 AM
    Thursday, January 07, 2010 3:53 AM
  • I think it is the ID3v2 as well. I am using MusicBrainz Picard to do batch tag editing and lookup. Most of the files worked just fine but on some MusicBrainz could edit and view the tags but Windows 7 couldn't. I then went and changed the taging options in MusicBrainz to include ID2v1 tags, remove APEv2 tags, and used ID3v2 version 2.3 rather than 2.4, and I switched from UTF-16 text encoding to ISO-8859-1. One of those things worked because after doing that, all of the tags showed up in windows 7 like normal.
    Tuesday, January 12, 2010 6:00 AM
  • Ok i just figured out how to do it

    Steps:

    1. Right click on the folder where ALL  your music is kept (e.g. mine is kept in D:\Music)
    2. Click properties
    3. Click the security tab
    4. Under the group everyone click full control
    5. Click apply

    This should work as it worked for me

    by far the best answer.....works great, thanks very much for the tip !
    Tuesday, January 12, 2010 9:48 PM
  • I too am having this problem in Win7 env, and I can definately say that WinXP also had it's issues with music-file metadata; however, the problem in WinXP was not the ability to edit, but rather the stickiness of the edits in WMP11.... Unless you changed a file to read only, the WinXP/WMP11 would spontaneaously revert your edits a small percentage of the time.

    The issue with Win7 is a bit different, and for 99% of cases it is a permissions issue. I would NOT set 'Everyone' to full control. As an Admin, I simply set Administrators to full control and I found that I also had to set HomeUsers to full control (I assume because I have a Homegroup, and as the creator, I am a part of it... this is also a problem though, since I should inherit Admin privies explicitly from Admin group, should NOT need to also have HomeUsers set as Admin privies).

    Backj to the point: Mark.A. may be right (file-format issue), since there are 38 mp3 files I have (out of 25,000) that simply will NOT let me edit metadata, regardless of ANY permissions settings.

    I will attempt to convert these 38 files, and I am very certain that this will fix the problem.
    _________________________________________________________________________________
    _________________________________________________________________________________

    OK, I just converted several of those 38 mp3 that were giving me problems.

    MORE BACKGROUND
    I prefer to edit metadata directly in the file intself via properties. One can also edit certain metadata using Win7 WMP (I have verified that the metadata gets written to the file properties if not RO). the 38 misbehaving files could not be edited directly, regardless of RO/permissions (that is why I think Mark.A. is on the right track); however, I was able to use WMP to download metadata, and this seemed to do the trick as far as seeing correct info in WMP, BUT the metadata was still not written directly to the files.

    FIX
    After converting to .wma format (batch processing using Goldwave: http://www.goldwave.com/release.php; File > Batch Processing), the metadata suddenly appears in Win Explorer, and I can edit.

    I also verified that permissions for me REQUIRED that I set HomeUsers (or Users or Everyone) to 'full control' or 'edit/change metadata'. I used HomeUsers, since this is more restrictive. I also set SYSTEM to 'full control' so that any updates that I want to apply via the automated internet updater would stick. I plan on removing all edit permissions from EVERY user type once I get the info correct (ANDI will set to RO!)

    I really hope that that Microsoft will help with the 'Effective Permissions' issue regarding the need to set HomeUsers or other general users rather than simply Administrators...

    Good luck.
    • Proposed as answer by _DHV_ Sunday, January 24, 2010 7:29 PM
    Sunday, January 24, 2010 7:19 PM
  • Same problem (unable to change mp3 file details in WMP or explorer) but just fixed it.

    A relatively easy way of changing ID3 tags is in the itunes library- right click in the selected file(s) and 'convert ID3 tags... ' then as ID3 tag version, v2.2 seems to work ok.

    Problem solved
    jm

    ps- I cant take credit for this fix, found it here http://social.technet.microsoft.com/Forums/en/w7itpromedia/thread/d226a3ba-6f4a-43b9-ae2a-7910bb77d498
    • Proposed as answer by jmmaddox Tuesday, February 02, 2010 12:46 AM
    Tuesday, February 02, 2010 12:46 AM
  • To stay universally compatible, you must use ID3v2.3 tagging for MP3 content.... it's the de facto standard.  Don't use ID3v2.4, a somewhat still-born specification that didn't get well accepted.  See http://www.id3.org  Windows Media Player, Zune, Windows Explorer, etc. does not support ID3v2.4.

    For the folks that see truncated or corrupted tags... This is likely because the files you have include ID3v2.4 tags along with backwards compatible ID3v1.1 tags.   So, WMP ends up reading the ID3v1 tag since it can't see the ID3v2.4 tag at all.

    An easy way to "fix" or manipulate tags is to use Mp3tag.  See http://www.mp3tag.de/en/  It defaults to ID3v2.3 out of the box.  You can easily and in bulk update all your metadata to ID3v2.3.

    So, make sure the applications you use are set to ID3v2.3 for MP3... and you will not experience corruption and incompatibility issues.
    • Proposed as answer by nbeam85 Tuesday, December 14, 2010 2:19 PM
    Tuesday, February 02, 2010 10:00 PM
  • I'm glad some people have found solutions, but I thus far have not.  I've tried Wolf_Dogg's good tip, but it didn't do anything for me unfortunately.  Also, gr0mmet had an interesting idea, but can't be the cause in my case since quite a few of the affected file are at least 5 years old, so it couldn't be an issue with them using the latest "greatest" unstable ID3 standard.

    Also, just to complicate matters, I can see and edit all tag information when I use the Windows XP virtual machine which is built into Windows 7 Pro.  Which is weird.  Same machine, same files, but using XP and WMP 11 instead of Windows 7+WMP 12.

    Judging from the number of people who are having this issue in both iTunes and WMP, as well as the tag editor in Explorer, I think it's safe to say that it is not a WMP or iTunes issue... It's something about Windows 7 itself.
    Friday, February 12, 2010 4:08 AM
  • Here's the error I get if I try to use the tag editing fields that Windows Explorer displays when you have a MP3 file highlighted:
    Photobucket

    Friday, February 12, 2010 4:17 AM
  • Ok i just figured out how to do it

    Steps:

    1. Right click on the folder where ALL  your music is kept (e.g. mine is kept in D:\Music)
    2. Click properties
    3. Click the security tab
    4. Under the group everyone click full control
    5. Click apply

    This should work as it worked for me
    Forget the rest of the answers given - this one is absolutely spot on. Excellent work there Wolf_Dogg
    • Proposed as answer by tsunami_637 Tuesday, March 23, 2010 8:22 PM
    Monday, February 15, 2010 12:05 PM
  • You have to change the user account control (UAC) settings. Go to the start menu, control panel, user accounts and family safety, user accounts, change user account control settings, and make it so you are never notified. Restart and it will work.
    • Proposed as answer by tsunami_637 Tuesday, March 23, 2010 8:17 PM
    Friday, March 19, 2010 1:14 AM
  • I had this problem and thought it might be because I keep all music on an external hard drive, but the answer proposed my Wolf_Dogg worked great for me.. all sorted now without having to redo all my library thankfully!!
    Tuesday, March 23, 2010 8:22 PM
  • easy fix took no longer that 3 minutes to fix over 10,000 files

     i used mp3Tag basic (free) selected the folder with my files in then edit select all then hit save, all tags show the correct info again.

    Sunday, April 04, 2010 9:31 AM
  • Mark.A.

    I am experiencing exactly that problem.

    Any Solutions yet?

    Thursday, April 08, 2010 9:48 AM
  • None of the other fixes worked for me but catepelose's advice to change UAC settings did the trick. Also I found this change was necessary to get another program to work as well. Thanks very much.
    Sunday, April 11, 2010 7:22 PM
  • Make sure to right click on the folder the file is in and not the file itself. Go to properties. Click on the security tab. Look at "Group or user names". Highlight the ones you want to change (the account you are using for example or multiple ones). Below it, it says "To change permissions, click Edit. Click edit, and check Allow beside Full control, apply, ok. That shoud be it. Thank you very much Wolf_Dogg. Thought I might try to get a little bit more specific for some people.
    Tuesday, April 13, 2010 2:49 AM
  • budde377-

    I tried all the solutions here, with no luck.  Permissions and ownership sounded like a good solution, but unfortunately did not work.  The only thing that I have found thus far is batch editing your files via ID3TagIt.

    Basically, strip all of the ID3v2 information, save, then copy all data from ID3v1 back into ID3v2.3.  This seems to fix it. 

    These problem files did not have ID3v2.4, ownership and permissions were all correct... so i have no idea what the problem was.  But, things are more or less working well now.  My only remaining issue is that WMP is constantly losing/forgetting album art.  I've had better luck getting the album art to stick if I just pull a JPG off the internet and apply that... the find album info option in WMP seems pretty finicky.

    Here's a video with more detailed instructions:

    http://www.youtube.com/watch?v=CNqXZRfZEhc

     

     

    Tuesday, April 13, 2010 6:31 AM
  • Mark.A.

    Thank you very much for your reply.

    But it doesn't seems to work for me!

    I'm really going crazy here...

    Friday, April 16, 2010 3:54 PM
  • Mark.A.

    Thank you very much for your reply.

    But it doesn't seems to work for me!

    I'm really going crazy here...


    It was driving me nuts for ages aswell. Nothing on the web either. Well lots of stuff that doesn't work. Then I did this...

    Ripped a CD on Windows 7 Then checked all its security/ownership/inheritance/Users properties of these. Then applied the same exact settings to the folder I had music in on the external drive. This only worked for some albums so I realised some folders were inheriting properties from parent folders and some weren't. So I had to do this to the whole drive by doing the same for the drive itself. Also make sure that all subfolders will inherit these properties.

    When you are doing it make sure you go through all the setting and it matches exactly. For some reason Windows 7 is seeing unknown users, and users on my external  that are different from the files created by Windows 7 ripping a CD. I'm guessing, if I log on as a different user, or use a different PC with the drive I'll have the same problems again, and will have to set all theses properties again.

    This is not progress, and I'm sure most non techie users will be complete stumped by this. I wonder is it related to folder types that Windows 7 assigns to folders. Another feature thats not needed.

    • Edited by MustangM Sunday, April 18, 2010 10:57 AM Reworded.
    • Proposed as answer by kghp04 Tuesday, April 27, 2010 6:15 AM
    Sunday, April 18, 2010 10:55 AM
  • To: Everyone

    I didn't use any 3rd party program to get ID3 Tags of every song that i have... I am using Windows 7 and im just started to use this OS yesterday and i had a the same problem like everybody....

    I just log in as administrator to my computer and went to my external hard drive where all my music kept (F:Drive)

    Make it sure you have to right click on the folder not on the driver....

    then click "properties"

    Click on "Security"

    Click " EDIT" then there is a small window will pop up.... on the Group or User Names:

    Click "CREATOR OWNER" and choose "Allow" and then

    Click "Full Control".... it will takes a while if you have more than 100 albums....

    ....After this method.... you can add per album in iTunes (V.9) then you can edit the way you want it.....

     

    I hope i can help to everyone..... if you have more question just ask me and i will happy to help everyone.... if i can....

     

    DJ @ Melbourne, Australia

    Tuesday, April 27, 2010 6:44 AM
  • Hi,

    You can right click the MP3 file and click Properties. Switch to "Detail" tab and then you can eidt the MP3 information, such as Title, Artists and Composers. Can you modify the information successfully?

    If the information cannot be modified by iTunes, you may need contact Apple support for further assistance.

    Thanks,
    Novak

    Well, that's how it's supposed to work but it doesn't in my Win7 Home installation. My music player, Songbird displays my archived mp3, ogg, wma files tags correctly, plays songs correctly, but Windows Explorer messes things up.

    1. When I rip a CD it puts files in My Music as loose files, not in their album or artist folder.
    2. In reorganizing some files I am unable to edit files via right click on Properties, and editing or adding information. It is as though the items are "grayed out."
    3. I tried the change permissions suggestion found later in this thread and things got worse. Now I am not granted access to My Music, although all the check boxes for full access are marked with a check.
    4. I saw a download that seemed to deal with this issue but based on the file name I assumed it was for Win7 64bit, and mine is 32 bit.
    I am now going to reboot and see if the administrator (me) is still denied access to My Music even though all permissions are checked off as granted.
    1.   

    Sunday, May 02, 2010 10:52 PM
  • I'm having this problem too. I can't see the details on certain music files. But when I first had Windows 7 and downloaded some music into it, I dont have any problems editing it until now. I can edit those music files now but I cant edit the recent music I downloaded. I dont understand. I'm using iTunes to edit my music. I hope someone have a solution to this! Its driving me crazy!
    Wednesday, May 12, 2010 11:58 PM
  • Try using this: http://www.mp3tag.de/en/download.html Worked for me. If it still doesn't work, try copying and pasting it and dropping the new files into Mp3tag
    Friday, May 14, 2010 9:22 PM
  • Wolf_Dogg, you're a hero!
    Friday, May 28, 2010 2:45 AM
  • I had this issue as well....Here is the fix I found myself...No 3rd party software needed....

    The issue I had was that I found I could edit some mp3's but not all.  I too have been through several upgrades from XP to vista, to Windows 7 x64 bit.

    What I did was I went to the My Music Folder, right click , go to properties.

    Go to the security tab, then click on the advanced button.

    Under the Permissions Tab click on Change Permissioins.

    All you want to change is put a check in the box "Replace all child object permissions with inhertitable permissions from this object"

    Hit Apply.  This will reset all the permissions for every file in your my music folder according to your current security setup.

    Voila - Now this worked for me and I was having some files editable, some not.  I find I have to do this sometimes to my files when migrating operating systems to regain access and full control to my files.  I can get into major detail, but you get the idea.

    If this doesn't work for you, you might need to dig further and retake ownership of your files and check the security again.  Then start over with my instructions again.

    I'm using Windows 7 64bit with primarily windows media player and MP3's.  Hope this helps you guys.

    Friday, November 05, 2010 2:55 AM
  • well basically what a few of you have been saying is right, but there is a laughably easy way to do it, i have tested it on a few comps so it should work for everyone.

    Firslty: go to your music, create a new folder and put all your music in there, if you have any folders there already, just move them in too.

    Next, go to the folder and right click then click properties, go to security.

    Now go to the edit button, just below the list of people or groups with permission.

    Then scroll down and there should be a "person" marked WMPNetworkSvc, and change the permissions to full control.

     

    This should give you full control over changing the details of windows media player files, as i said i tested it and it works for every file, also takes less than a minute to do all your music this way. So yeah enjoy ;D

    Saturday, November 06, 2010 10:10 PM
  • Ok i just figured out how to do it

    Steps:

    1. Right click on the folder where ALL  your music is kept (e.g. mine is kept in D:\Music)
    2. Click properties
    3. Click the security tab
    4. Under the group everyone click full control
    5. Click apply

    This should work as it worked for me

    This worked for me.  I had tried something similar several times.  I tried adding the permission for a subfolder and it didn't work.  It only worked when I followed Wolf_Dogg's process to the letter and applied the change to the root folder where ALL the music was stored.

     

    Kudos Wolf_Dogg, this was driving me crazy(I've moved my music across several different PCs and multiple different OSs.   I didn't want to reorg my music again and I was able to keep all my playlists in tact.

    • Proposed as answer by nbeam85 Monday, December 13, 2010 4:33 PM
    Friday, November 12, 2010 11:12 PM
  • OK,

    I have scanned up and down this forum several times and you are all dealing with different problems. One group of you, a majority, is dealing with permission and ownership problems. The other group of you are dealing with iD3 tag version issues... like me... which are infuriating...

     

    A. You need to have ownership of your files in windows... Look here: http://www.howtogeek.com/howto/windows-vista/add-take-ownership-to-explorer-right-click-menu-in-vista/    This article and the nice accompanying download are fantastic. There is a .reg file you can download which adds a "take ownership" option to the windows shell right click menu. You can right click on the root folder that holds all of your music and select "take ownership"... I am pretty sure that it is inherited by all child files and folders. If you are the "owner" of a file you should have "full control" by default. 

     

    B. You are dealing with the id3 tags issue, like me, and are really really annoyed because all of the permissions and ownership in the world won't fix it. gr0mmet nailed this one on the head. Go to http://www.mp3tag.de/en/download.html and get the program, it is a very small and completely FREE program which works beautifully. Here is what I did which has completely restored my entire library is Windows Media Player:

    1. Install the program

    edit - After you are done installing make sure that WMP is completely closed down, not just minimized. You need all of your files to be available for editing

    2. In the program go to the "File" Menu and choose "Add Directory" - Select the root directory that contains all of your music and WAIT....

    3. One it is done scanning you will see ALL of your music and the type of tag it has. In my case I had several bad tags and a lot of id3v2.4... which as pointed out by gr0mmet, windows media player 11/12 freaks out about and doesn't read properly...

    4. Here is how to fix the problem very easily.... Go to the "edit" menu and click "select all"

    5. Now, pay attention, with everything selected, in the left pane of the program you will see all of the different tag fields (artist, composer, year, etc.), go to the "comments" tag block and just fill in some garbage... "abcdefg"... (I don't really care a whole lot about comments so I selected this block because if I screwed it up it wouldn't matter.) now, highlight the garbage you just typed (abcdefg) and replace it with this < keep >... Some of you at this point are thinking, we just put back into the block what was already there to begin with... Yes... we did, but the reason we just went through that rigamarole is because the program now thinks that we have changed something on all of the files and will give us the option to "save" the files.

    edit - make sure your put < keep > EXACTLY as you see it here, otherwise you might lose all of your comments on your files (if you care about them). I actually just copied and pasted "< keep >" from one of the other fields.

    6. With all of your songs still highlighted go up to the upper left hand corner underneath the file menu and click the little blue 3.5" diskette (why do we still use this for an icon???) to "save" all of your files.

    7. Wait... it took mine several minutes to re-save the information on all of my files...

    8. Go into Windows Media Player and click your library button... or something... The idea is that you should get WMP to update your library again. You should get a notification of it doing as much in the lower right hand corner. Once again... WAIT... in my case I got back like HALF of my media library which was not there before... This took about 10 minutes or so.

     

    -Total time to fix your entire library ... I would say not more than 30 minutes....

    This wonderful little program uses id3v2.3 tags by default, and when it re-saves your information it changes the tag version to this default... that is what we are doing and that is why it works. Way less headache than doing one file or even 1 album at a time... In my case, from what I can tell I didn't lose any information and now all of my tags are consistent for the first time since I started organizing my music a decade and a half ago. If you are ____ retentive like me about keeping files on your computer organized, getting this straightened out is awesome :).

     

     

    NOW - If someone could tell me how to force WMP to use id3v2.3 tags instead of id3v2.4 for all future tagging, that would be nice. I can't find the option to change what tag format it uses anywhere. I would prefer it not screw up new music and rips coming in...

    • Edited by nbeam85 Monday, December 13, 2010 4:58 PM updated wording
    • Proposed as answer by nbeam85 Tuesday, December 14, 2010 2:18 PM
    Monday, December 13, 2010 4:33 PM
  • NOW - If someone could tell me how to force WMP to use id3v2.3 tags instead of id3v2.4 for all future tagging, that would be nice. I can't find the option to change what tag format it uses anywhere. I would prefer it not screw up new music and rips coming in...

    As far as I know, WMP always uses ID3v2.3 for tagging MP3s, and never v2.4.

    Tim De Baets
    http://www.bm-productions.tk
    Tuesday, December 14, 2010 8:57 PM
  • Good job figuring that one out Wolf Dogg....  Thank you
    Sunday, December 19, 2010 3:56 AM
  • nbeam85s solution worked for me on my Win 7 64 bit machine. It wasnt a permissions problem just the id3v2.4 issue. I took a shortcut in his instructions though that saved a little time.

    After you add your directories and you can see all of your songs click the column labeled "tag" to sort your files by the type of tag they have.

    Scroll down to the id3v2.4 tagged files and only select those to edit. (Shift click or ctrl click for multiple files.) For me, these were the files that were giving me grief.

    Make the small change to the comments field and click the save button.

    This saved a bunch of time for me since it only had to alter the few problematic songs instead of my entire (large) library

    I also had to do this for mp3s that had no tag at all but after the changes were made all files were editable in windows explorer and read properly WM12

    Thursday, January 20, 2011 11:07 AM
  • This is THE answer. For some reason there must be a specific account that is used to set those properties and if it doesn't have the appropriate permissions it wont let you.

    A little bit odd considering my personal account already had full control over the file.

    Cheers Wolf

    Friday, February 18, 2011 6:31 AM
  • You are brilliant - worked a treat.  Thank you the problem was driving me crazy

     

    Saturday, March 26, 2011 11:36 PM
  • SPOT ON, FIXED MY ISSUES, CAN NOW ALTER THE INFO OF SONGS ETC IN ITUNES!!!!!!!!

     

    THANKS BUD

    Thursday, March 31, 2011 12:03 PM
  • does this also work for videos? Because I can't edit information from my videos either... and the ownership solution didn't work for me >_<
    Monday, May 23, 2011 5:55 PM
  • calflo: what's the file type of your videos (AVI, WMV, MPG...)?
    Tim De Baets
    http://www.bm-productions.tk
    Monday, May 23, 2011 7:29 PM
  • well basically what a few of you have been saying is right, but there is a laughably easy way to do it, i have tested it on a few comps so it should work for everyone.

    Firslty: go to your music, create a new folder and put all your music in there, if you have any folders there already, just move them in too.

    Next, go to the folder and right click then click properties, go to security.

    Now go to the edit button, just below the list of people or groups with permission.

    Then scroll down and there should be a "person" marked WMPNetworkSvc, and change the permissions to full control.

     

    This should give you full control over changing the details of windows media player files, as i said i tested it and it works for every file, also takes less than a minute to do all your music this way. So yeah enjoy ;D



     

    THIS IS IT!!  I tried all the other solutions with no luck. Was able to get iTunes to change tags but not Foobar, did this and all is well. THANK YOU BRANACANE.
    Friday, May 27, 2011 5:07 PM
  • Hi, thank you very much, this works.Just one thing I'd like to add is that the Output Folder has to be a different one from the Source Folder, because initially I tried to save the formatted file into the same folder, and the details still could not be edited (even though the formatted file is auto saved under a different file name). Then I tried just saving the file onto desktop instead of the Source Folder, and it worked.

    Thanks again for sharing (:

     

    Monday, May 30, 2011 9:39 AM
  • NOTE: You cannot edit the information if Windows Media Player is open. Close Windows Media Player, and then follow Mr. Wu's instructions.
    • Proposed as answer by roro44 Wednesday, June 08, 2011 3:02 PM
    Wednesday, June 08, 2011 3:02 PM
  • I have been having the same issue.... but for video files. I can edit my music files all day long. Im having issues with video. However i have noticed that i can edit mp4 file type without an issue

     

    Saturday, June 18, 2011 8:35 AM
  • digiforce: what's the file type of the videos you're having issues with (AVI, WMV, MPG...)? What are the exact issues?

    Tim De Baets
    http://www.bm-productions.tk
    Saturday, June 18, 2011 9:40 AM
    • Proposed as answer by ASperson Monday, August 08, 2011 12:44 AM
    • Unproposed as answer by ASperson Monday, August 08, 2011 12:44 AM
    Wednesday, July 13, 2011 10:59 AM
  • So I found a way that works for me. I use Itunes and WMP, but notice some of my mp3s are id3v2.4 and id3v2.3 and the ones that cannot edit are 2.4 so I assume 2.4 is the culprit. So I just go into Itunes select the ones that are id2.4 or just everything and just converted them all to v2.3. I just converted everything to 2.3 and It worked for me but I have about 23k songs so it took a little while....^^
    Monday, August 08, 2011 12:49 AM
  • Stumbled across this forum while having similar issues with id3 tags displaying in explorer/wmp. I finally found a solution over at hydrogenaudio's forum where someone suggested that it was possible the mp3's had "chained id3 tags." That is an id3v2 tag followed by an id3v2.4 tag. It's my understanding that windows 7 (and obviously wmp) do not support the id3v2.4 and opted for the legacy id3v2.

    The solution suggested (which worked for me) was to use foobar2000. Load your music library (or afflicted mp3's) and select all. Then right-click and select: Tagging>MP3 Tag Types> Select the "Override ID3v2 Revision" and select ID3v2 as your format. Finally select the 'Update Files' button and let it process.

    After doing this I had no more issues with explorer/wmp reading and displaying the tag information. Hope this helps somebody! 

    Sunday, August 28, 2011 3:23 AM
  • okay, i know its 2 years later, but..

    i had the same issue and have it fixed by selecting the songs (in iTunes) that you are having the issue with, and right-click and Convert IDTAG-3. and check id3, and drop-down box set to "none"

    hope that helps.

     

    • Proposed as answer by xorcst Tuesday, August 30, 2011 5:04 PM
    Tuesday, August 30, 2011 5:04 PM
  • haha, i had a similar suggestion, i just convereted the tags to ID3, and that fixed the issue.

    i was just click EVERYTHING, and found that, i was like COOL!!!

     

    • Proposed as answer by xorcst Tuesday, August 30, 2011 5:06 PM
    Tuesday, August 30, 2011 5:06 PM
  • I'm using Window 7  64bit

    I try the Wolf_Dogg cure but..

    When i get into properties there's no security tab... ?

    Any ideas ?

    Monday, September 05, 2011 11:03 PM
  • Onibaba: you need to right-click your actual music folder, outside of the Music library (in your case, C:\Users\Nigel\My Music)
    Tim De Baets
    http://www.bm-productions.tk
    Friday, September 09, 2011 8:15 PM
  • Thankyou tim.

    I have now done all the below..

    1. Right click on the folder where ALL your music is kept (e.g. mine is kept in D:\Music)
    2. Click properties
    3. Click the security tab
    4. Under the group everyone click full control
    5. Click apply

    But when i right click a music song file & click properties then details i still cant edit any details on the same music files i had probs with before..

    All of this is just to try and get media player 12 to recognise the 13 albums in my collection that it so far refuses to..

    I've now replaced the original settings on the everyone tab..

    I'll try a couple more things then give up..

    Tis a pity as i really liked media player otherwise. :-(

     

    Friday, September 16, 2011 10:00 AM
  • What's the file type of the affected music files (MP3, WMA, WAV...)? If it's MP3, then I suggest that you scan the files with MP3 Validator and let it repair any problems it found.

    Tim De Baets
    http://www.bm-productions.tk
    • Proposed as answer by albedo Friday, September 23, 2011 8:32 PM
    • Unproposed as answer by albedo Friday, September 23, 2011 8:32 PM
    Sunday, September 18, 2011 6:39 PM
  • I had the same symptoms on 2 different Win7 64-bit machines - unable to edit mp3 details, neither in the bottom bar of Explorer, nor in WMP.

    In both cases, this simple change fixed the problem:

    Right click on your Music folder, then select "properties".  If you see the Read-only option box is darkened, like such:

    then click the Read-only box one time so that it is not darkened, like such:

    Then click okay, and confirm.  This will change all files and folders within from Read-only to Read/Write, and will allow you to edit the details/meta-data.

    Worked for me.

    • Proposed as answer by ShakeIt Thursday, December 29, 2011 3:18 AM
    Thursday, September 29, 2011 2:57 PM
  • All, if you are still having this problem and you have dBpoweramp installed, make sure you have the latest version (14.2) There has been this recent bug fix: "Bug Fix: Uninstall could leave the Windows Property details page for previously registered formats (such as mp3) inoperable" Once I upgraded to the latest version, all my tags reappeared in Windows Explorer and I was able to edit my tags, yay
    • Proposed as answer by DirtyPaws11 Monday, October 31, 2011 5:12 AM
    Monday, October 31, 2011 5:12 AM
  • I did what you said, but when I went back to edit the music information, it wouldn't work. I went back, and it re-checked the read only box. It does this everytime. It's very annoying and Windows has never done this to me until recently.
    Sunday, December 04, 2011 1:12 AM
  • ALL OF YOU STOP! You're making this much harder than it is. I had the same problem and thought it must be the "Read Me" box or that I didn't have the security set right to change the file details. Your problem is in the "Comments" section of the file. Some DORKS out there like to put weird crap in the comment section of the file. Some audio converters will put garbage in them as well. Right click the file and go to "Properties" then "Details". Go down to "Comments" and get rid of EVERYTHING in the comment section. You can bulk delete comments as long as the comments are the same. Otherwise you have to do them individually. I know how frusterated you are and I'm confident this will cure your problem of the "Read Me" box always reappearing checked and file details changing back everytime you exit.
    • Edited by Will9441 Sunday, December 18, 2011 9:04 PM misspelling
    Sunday, December 18, 2011 8:54 PM
  • BINGO! Simplest and easiest solution. Just do this on one or all folders where you have music.
    Thursday, December 29, 2011 3:19 AM
  • OK. For those of you who are still having this problem, I highly recommend this video. http://www.youtube.com/watch?v=CNqXZRfZEhc&feature=related

     

    Just follow the steps correctly and it should work. Also after your done you should close and re-open the explorer window. Happy music library organizing!

    Monday, January 02, 2012 12:35 AM
  • make a copy and then edit it
    • Proposed as answer by d richardson Thursday, October 18, 2012 10:29 PM
    Tuesday, January 17, 2012 11:44 PM
  • dunno if you guys solved it..its easy..

    1.) right click on the mp3 "Properties".

    2.) go to "Security"

    3.) click on "Edit" at "To change permissions, click Edit."

    4.) highlight "Users (xxxx-PC\Users)"

    5.) allow all permissions by ticking all the box below.

    6.) apply

    now you can edit all the details.

    Tuesday, February 07, 2012 2:02 PM
  • Okay...STOP!  If you're in Windows Explorer, click on a song and look at the bottom of the screen.  THAT is where you edit all the info for a particular song. You don't need to convert it to anything else, you don't have to mess with permissions. Just LOOK DOWN.
    Sunday, March 11, 2012 1:24 PM
  • Ok i just figured out how to do it

    Steps:

    1. Right click on the folder where ALL your music is kept (e.g. mine is kept in D:\Music)
    2. Click properties
    3. Click the security tab
    4. Under the group everyone click full control
    5. Click apply

    This should work as it worked for me
    Alright I was having the exact same problem. I had a bunch of unnamed, unartisted, etc. music files and I couldn't change anything but the name. Doing the above completely fixed my problem. I am running Windows 7 64bit and have been dealing with this problem for who knows how long. Anyway, very helpful and thanks!
    Sunday, June 03, 2012 8:10 PM
  • Big thanks Mark. This was exactly what was causing my issue. Removed the ID3v2 tag and immediately was able to edit the file.
    Monday, June 04, 2012 9:30 PM
  • You nailed it for me, Mark!  Thank you very much!!
    Wednesday, July 25, 2012 10:36 PM
  • Unfortunately, when I do that, it keeps changing back even after I hit "APPLY"

    Saturday, July 28, 2012 5:02 AM
  • xXm0nk3y6uttXx: do what? Please create a new question in this forum and provide a description of your issue, including any relevant details.

    Tim De Baets
    http://www.bm-productions.tk

    Tuesday, July 31, 2012 6:52 PM
  • Ok i just figured out how to do it 

    Steps:

    1. Right click on the folder where ALL  your music is kept (e.g. mine is kept in D:\Music)
    2. Click properties
    3. Click the security tab
    4. Under the group everyone click full control
    5. Click apply

    This should work as it worked for me

    Didn't work for me. I suspect my issue is with ID Tags which I shall try next

    • Edited by pobox90210 Monday, August 20, 2012 11:52 PM
    Monday, August 20, 2012 11:51 PM
  • Ok i just figured out how to do it 

    Steps:

    1. Right click on the folder where ALL  your music is kept (e.g. mine is kept in D:\Music)
    2. Click properties
    3. Click the security tab
    4. Under the group everyone click full control
    5. Click apply

    This should work as it worked for me

    Didn't work for me. I suspect my issue is with ID Tags which I shall try next

    • Edited by pobox90210 Monday, August 20, 2012 11:52 PM
    Monday, August 20, 2012 11:51 PM
  • Ok i just figured out how to do it 

    Steps:

    1. Right click on the folder where ALL  your music is kept (e.g. mine is kept in D:\Music)
    2. Click properties
    3. Click the security tab
    4. Under the group everyone click full control
    5. Click apply

    This should work as it worked for me

    Didn't work for me. I suspect my issue is with ID Tags which I shall try next

    • Edited by pobox90210 Monday, August 20, 2012 11:52 PM
    Monday, August 20, 2012 11:51 PM
  • solution:

    go to the root folder -> RC properties -> sharing tab -> share.

    this problem stems from ownersship handling in windows (post xp). you can verify that by going to:

    root folder -> RC properties -> security tab -> advanced -> owner tab

    you will see something other than your windows account user name (usually a bunch of numbers) under the Current Owner bar. well, this is the problem. this should read something you recognize, like your user name...

    • Proposed as answer by Slick_Puller Monday, September 17, 2012 7:38 AM
    Monday, September 17, 2012 7:38 AM
  • I have made an account just to say thank you and I love you lol
    Sunday, September 30, 2012 8:33 PM
  • This has all been worthless.  I've tried everything and still have files that I can not edit tags. I've tried everything and still no success. Has anyone really fixed this problem and if so how did you do it?

    I even set up an old XP system to try some things.  Strangely enough I can edit tags on it after taking ownership but the tags still won't show up on the Windows 7 system.

    Friday, October 12, 2012 3:55 AM
  • To be more specific, make a copy of the file. I was able to alter the metadata of the copied file. Then I deleted the original, and renamed the copy back to the original.
    Thursday, October 18, 2012 10:30 PM
  • That was exactly my problem!!  As soon as I booted the song from the WMP list, I could edit it on iTunes or Windows or where ever.  Blah to WMP!....
    Friday, October 19, 2012 5:28 PM
  • Did same as "d richardson" says and worked for me too.


    • Edited by jimmybeaner Saturday, November 03, 2012 1:44 AM
    Saturday, November 03, 2012 1:42 AM
  • I love how the mod marked their own reply as THE answer - nice job Mr. Obvious! Thanks for the detailed description of what we are having problems doing.

    Anyway... using the tag editor worked for me, and without the long instructions. Just add the folder containing the problem files, select the files, click save (with no extra steps), tags converted - done. None of the other solutions worked for me - I suspect because they were different problems. Additional info: the ID3v2.4 tag issues are probably caused by ripping audio from a video source file - hence the converter used in that step is causing most of the problems to begin with.

    • Proposed as answer by tahwos Wednesday, December 19, 2012 9:35 PM
    Wednesday, December 19, 2012 9:34 PM
  • Hey people,

    I don't know what sort of details you are willing to edit, but here's my story...

    In my case I had a few songs which had incorrect titles, so what I did was: 

    1) Find them in your Windows Media Player

    2) Choose "Find album info" 

    3) In a pop-up window on the right there will be search results, which you might want to apply to your album. The song titles were changed to correct ones in my case

    4) On the left there is an option to edit album information, here you can edit song numbers, titles, contributing artists, composers.

    Options presented are quite limited as you can see, but that was the fastest way for me to solve my problem (incorrect titles). 

    Monday, December 24, 2012 1:58 AM
  • I had same/similar problem and fixed it. Problem: Not able to edit details for music files.

    The causes and solutions in my case were:

    1. Music files were in use by a program. In my case the program was Windows Media Player. Solution - close all music player programs for now, at least until you have isolated the problem.
    2. I was not viewing the file in its original location. If you are viewing the file via your Windows 7 "music library", you cannot edit from that view. The same is probably true for most other views, such as short cuts, search result panes, and even music players. It seems that some players only edit music when it is in use by that particular player. Solution: Make sure you are viewing you music file directly from its location, eg. C:\Users\MyName\Music\MusicWeLove.... Once you have the original file location, then you can right click on the file name, go to Properties, then go to Details, and now one last thing....
    3. The details pane has 2 columns. When a row is highlighted, both columns in that row are highlighted, so that the 2 columns look like one field. This can mislead you. If you point and click on the left half of the highlighted area, you are in the wrong column and you can't edit anything. Solution: Point and click over to the right side of the highlighted area for each row. The editing field will then open and you can enter in the values/names that you want.

    Wednesday, December 26, 2012 1:04 AM
  • Thanks Mate. After struggling with permissions for three days, your solution (Tag Editor) worked for me. (I had downloaded varios iTunes, Winamp, Media Monkey) - nothing could edit the tags.   mp3tag tag editor showed the v2.4 and !Bad id3.2 files (which were the ones that could not be edited). An interesting problem and simple solution. Interestingly some files could only be edited on the second or third attempt. cheers

    Wednesday, December 26, 2012 2:42 AM
  • And I am sticking with WMP as the rest do not stream to my new Sony HiFi
    Wednesday, December 26, 2012 2:44 AM
  • This Forum seems to have the largest thread on this issue that I've seen and I've seen lots.

    I have tried everything on here:

    1) I am running WIndows 7 Ultimate 64bit on my PC.
    2) I was able to view all mp3 tag information a couple of weeks ago in explorer and WMP. 
    3) Now no tag information is displayed in either one now (Explorer or WMP).
    4) I have never had iTunes on my PC and most of my mp3's have come from converting .flac files.
    5) There is no ID3v2.4 tag information in the files.
    6) I have set everyone full control for Music folder.
    7) I am unable to edit files in explorer.
    8) If I edit files from a Tag editor the info does not display in explorer.
    9) I can see tag info for .flac and .wma files.
    10) I have uninstalled and reinstalled WMP 3 times.
    11) I have run a program form Microsoft forum to re register all WMP dlls.

    Other info:

    1) I have 3 computers and a NAS on my network.
    2) 2 PCs (1 is my PC) have Windows 7 Ultimate 64bit 1 has Windows 7 Home 64bit.
    3) From my PC I can't see any Tag info on the other network drives mp3 files.
    4) The other 2 PC's can view all Tag info on NAS and all computers.
    5) If I install dBpoweramp I am able to view all Tag info on all computers.
    6) I believe dBpoweramp has a dll (mp3.dll) that gets registered on the insall that allows this.
    7) If I uninstall dBpoweramp I can nolonger view any Tag info on any computers again.
    8) I have done a new install of Windows 7 on a different drive on same PC and explorer displays all mp3 Tag info.

    I believe that it is a dll problem in Windows 7 that looks after displaying this info that is either missing, corrupt or has become unregistered. Windows XP has a dll (shmedia.dll) that looks after displying this info. I am unable to find one that does this for Windows 7 64bit.

    Yes I can leave dBpoweramp installed but I'd rather find the reason why it has happen and do a proper fix.

    If anyone knows the Windows 7 64bit dlls required to display mp3 tag info I would much appreciate it.

    Thanks in advance.

    EDIT:  I have also ran sfc /scannow with no errors.



    • Edited by D00ger Friday, January 04, 2013 6:43 PM
    Thursday, January 03, 2013 6:43 PM
  • I tried all of the above solutions and none of them were successful, but this worked fine. Thank you!
    Monday, May 06, 2013 2:44 PM
  • I will give a solution that worked for what I was experiencing.  I will give a background explanation of what I was doing and what happened. 

    I was cleaning up the ID3 tag info on a lot of my files so that they would show correctly when loaded on my ipod and also in my MixMiester DJ Software.

    To do this I personally (though their are probably lots of programs to do this) am using Roxio's RecordNow Premier. This allows me to Batch Identify using Gracenote the ID3 info.  It also allows me to convert audio files as needed.  So I ran across a folder of roughly 1000 or so 80's songs with only the file info, no contributing artist, no genre, no title ect.  No problem I always batch ID my files anyway so I have the correct (or as correct as Gracenote is) file info. 

    For the life of me I couldn't find out why I was unable to change the tags.  I too found that WinAmp would do it but not in a way I was used to.  I knew it was NOT a folder permissions problem because all the other songs let me do what I needed.  So through sheer dumb luck, trial and error I came up with this process which then enabled me to change the tags. 

    Note at first I was like many of you who though to CONVERT my songs...which does work, but at what loss to quality.  I mean converting to begin with unless its a WAV file is compressing the file, which means loss of quality.  So the original mp3 you had was ALREADY at a loss in quality, so converting Again means even further loss to quality...this was unacceptable to me.

    Try this and lemmie know if it helps you as well.

    1.  Go to folder with questionable songs in it and open it. 

    2.  Highlight all the songs in question

    3.  Right Click the songs with them highlighted and choose properties.

    4.  Click the Details Tab

    5.  Click the Blue Link which says Remove Properties and Personal Information

    6.  Then in the box it opens choose the bubble with the Remove the Follow Properties from this file

    7.  Click any one of the ones in the list (I chose title)

    8.  Hit okay

    Now the computer will remove those properties from every file you had highlighted.  After it does this process you can then load the songs into your own batch software program (again I use Roxio RecordNow Premier.)  and hopefully as it did with my songs let you look up and change the ID3 tags in your music in a more efficient way. 

    again hope this helps

    Saturday, June 08, 2013 8:50 PM
  • This worked for me - combining some steps from other posts:

    1. Convert mp3 file(s) into wma file(s). I use Switch Sound File Converter.

    2. Right click the file > Properties > Details. Edit tags (alpha-numeric only) > Apply > OK.

    3. Make a copy of the file and paste it into the same folder.

    4. Play a bit of the copy file.

    5. Delete the original file.

    6. Right click in the folder > Properties. Turn off Read-only > Apply > OK > OK - this has to be done for each file as it does not stick - bug?

    7. Edit copy file name back to the original by deleting '- Copy.'

    8. Convert file(s) back to mp3.

    That's it!

    Sunday, June 23, 2013 9:04 PM
  • When you right click on the file you wish to edit go to the properties option. Down the bottom it says read-only and by default it will selected. Unselect it and you can edit away!
    Friday, July 26, 2013 9:38 AM
  • I just spent HOURS looking through this post. I tried everything humanly possible without wanting to download any 3rd party programs. I watched videos and did countless searches and after reviewing everything in this page i found two posts that solved EVERYTHING. Alright I will quote a post that was WAY towards the bottom of the page. This should solve the editing mp3 information problem for literally everyone. 

    "Okay...STOP!  If you're in Windows Explorer, click on a song and look at the bottom of the screen.  THAT is where you edit all the info for a particular song. You don't need to convert it to anything else, you don't have to mess with permissions. Just LOOK DOWN."

    Basically at the bottom of the page in windows explorer is where you can EDIT all the information you want on an mp3 file (i.e. artist, title, album,genre etc). Simply click at the bottom after highlighting an mp3 and BAM you can type and change.  

    SECONDLY the other solution that will help everyone is.

    "
    Steps:

    1. Right click on the folder where ALL  your music is kept (e.g. mine is kept in D:\Music)
    2. Click properties
    3. Click the security tab
    4. Under the group everyone click full control
    5. Click apply

    This should work as it worked for me"

    This will allow you guys to change the properties of any song that you may be having issues changing the properties for. NOTE that it is not the "Music" folder persay. Rather its the Folder within that folder that has all your music. So if there is a "my music" folder thats the one you want to adjust.

    ALSO make sure there are no "READ ONLY" files. this will stop you from editing your music as well. This solution is the solution for those who dont want to download any programs, adjust any file types, or do any type of converting. its simple and to the point. Windows has not failed us... they just decided to move the place in which item information can be edited. Hope this helps everyone quickly! 

    ~FleshyPudge~

    P.s. My first post ever... I hope you guys find it useful. 

    • Proposed as answer by Fleshypudge Tuesday, August 13, 2013 2:10 AM
    Tuesday, August 13, 2013 2:10 AM
  • Hi, i'm having the same problem but these 'solutions' aren't helping. it's only 2 albums that are 'unknown' because of the information that isn't there.

    "Steps:

    1. Right click on the folder where ALL  your music is kept (e.g. mine is kept in D:\Music)
    2. Click properties
    3. Click the security tab
    4. Under the group everyone click full control
    5. Click apply

    This should work as it worked for me"

    where it says "under the group everyone click full control", i don't have the group as a choice and I am getting nowhere with this  - any help with why I havent got this choice to help?

    • Proposed as answer by G00seEggs Saturday, April 12, 2014 10:19 PM
    Wednesday, August 14, 2013 2:46 PM

  • Fleshy Pudge's solution did not work as I can edit everything BUT the title, and that is what I need to edit. The Read-only box in the folder properties will not stay unselected.
    Saturday, October 05, 2013 7:47 PM
  • I am having a similar problem. The Properties - Details for ALL MP3 files are locked. I have tried all of the solutions on this thread and nothing has worked. I'm not sure what it is, but I know what it is not.

    1) It is not a permissions issue. I have ownership of all MP3 files. I even re-took ownership of an MP3 to test and nothing changed. I have tried setting permissions on separate files and on all files in the My Music folder -- nope. I use Minilyrics to synchronize lyric files with my songs. The lyric files reside in the same folders as the MP3 files and I can edit the lyric files in Notepad. So it can't be Minilyrics or any type of permissions issue otherwise the lyric files would be locked too. I use Winamp for playback and the Winamp playlist files are also stored under the My Music folder and they are editable in Notepad.

    2) It is not an issue with ID3v2.4.  I use MP3Tag to edit the properties. It's easier for editing multiple files and yes, I can edit the properties via MP3Tag. Every single one of my MP3s is ID3v2.3. I sorted the Tag column ascending then descending then ascending again, just to make sure it was truly sorted. On each sort, the top file showed ID3v2.3 -- ID3v2.4 never showed. I embed the artwork from the original album in each MP3 file. Once again, MP3Tag makes short work of this for an entire album. However, each MP3 file no longer shows the album artwork when viewed as a large icon in Explorer. This is what got me to investigate in the first place.

    3) It is not ALL music files. I have one music file that is an M4A type. I can edit those properties with no issue. I also downloaded a new MP3 (can't edit it), converted it to M4A and it became editable. I did this with my account and with a different account as well. Same results. And the M4As also show the album artwork in Explorer when viewed as large icons. However, when I used an online converter to convert an MP3 to WMA, the WMA file was not editable in Explorer.

    4) It is not Windows Media Player. I stopped using WMP because of the damage it did to my FOLDER.JPG files. I've actually had to write some batch files that go out and kill the little 200x200 and 75x75 size icons that WMP creates. I store my album artwork under a completely different folder so I can fix what WMP destroys. WMP is NEVER open. However, there is a WMPNETWK.EXE process running as a service. I stopped and disabled the service, rebooted, and got the same results.

    5) It is not malware or a virus. I use Microsoft Security Essentials and I don't quarantine any files -- I have them set for removal when any malware is found. Active scanning has found questionable websites occasionally, but it cleans any files. I scan once a week and while items have been detected, they are removed. The system is clean.

    It SOUNDS like a problem in Windows Explorer dealing with MP3 files. Possibly an update from Microsoft. And it wouldn't be the first time that Microsoft has altered files, such as DLLs, to make someone else's stuff not work. It could be by accident but that would be the WILDEST stroke of bad luck in the history of computers. Microsoft is BIG on Digital Rights Management and MP3s don't fit into that. WMAs do, and my experience above could be a fluke. M4A files are working fine and they can be protected for DRM.

    I'll keep looking for an answer and post it here if I do. I just think this is going to take longer than expected.

    Monday, February 03, 2014 1:01 AM
  • Yes! Yes! Yes! Finally something that worked. Thank you. I'm not completely bald now. Read this whole thread and this is the one that worked...
    Wednesday, March 12, 2014 6:43 AM
  • Here is what I did. Copy and Paste the .mp3 file. Now you can edit the copied file. simple as that.
    Wednesday, March 19, 2014 4:19 AM