none
Windows 7 RC 32-bit fails to renew DHCP lease and resorts to 169.254.x.x ip address

    Question

  • I cannot find any entries in Windows 7 system logs to indicate a problem with the DHCP client.  The OS seems to be quite happy giving itself a 169.254.x.x ip address after the lease expires.  I cannot predict when the problem will occur.  Windows 7 is running on a desktop with the power profile set to High Performance.

    This behavior does not occur with Windows XP, Vista, Fedora or Ubuntu.

    The lease period is 4 hours.

    UPDATE:  I obtained the lease on Wednesday, April 23, 1873 !!!!! and the renewal failed.

    Screenshot of ipconfig /all - http://www.flickr.com/photos/16845090@N05/3578812525/

    UPDATE 2:  Windows 7 is capable of correctly knowing when it obtained the DHCP lease.  I would assume the renewal process is successful under these circumstances.
    Saturday, May 30, 2009 7:27 PM

Answers

  • OK.  To demonstrate how to re-produce this bug, I did the following:

    1.  Set the BIOS time to 5 hours ahead of actual time.
    2.  Booted Windows 7 RC build 7100
    3.  Windows 7 RC obtained a new DHCP lease.  I noted the lease obtained time stamp.
    4.  Using the Windows Internet Time Settings dialog box, I told Windows to synchronize with time.windows.com causing the computer time go back 5 hours.
    5.  The DHCP lease obtained time stamp is now back in 1873.

    Here is a link to a screen shot showing three command windows - http://www.flickr.com/photos/16845090@N05/3637235021/sizes/l/

    Left command window is just after bootup at 5:46:33AM on June 18, 2009 which is 5 hours ahead of actual time.  The lease obtained time stamp is for 5:45:32AM on June 18, 2009.

    Right command window is the result after I synchronized the PC time with time.windows.com.  The time changed to 0:47:28AM on June 18, 2009.  The lease obtained time stamp is for May 11, 1873 at 11:17:16PM .  Note the lease expires time stamp has changed from 9:45:31AM to 4:45:20AM.

    The center command window is the result after ipconfig /release and ipconfig /renew.  All is back to normal.
    Thursday, June 18, 2009 6:09 AM

All replies

  • I can understand other users of Windows 7 not responding to my post since this issue is most definitely a bug, but no reply from a Microsoft representative?  Even if the reply was just "Thanks for your feedback." or "Please give us the following information:...."
    Thursday, June 04, 2009 2:49 PM
  • hi,

    check your date and time settings on DHCP server in 1st place. Also check DHCP config. 4 hour lease time is littlebit srange. Post your findings, and we will see what to do nest.

    druid

    Sunday, June 07, 2009 7:45 AM
  • When using mobile Windows XP clients, long DHCP leases would cause the client to retain the lease when traveling between networks.  I don't mind running cmd.exe and executing "ipconfig /release" followed by "ipconfig /renew".  However, not everyone is me.

    I can now re-produce the problem at will.  If I move the OS time back after the DHCP lease has been obtained, the lease obtained date/time stamp will be WAY off.  This occurs because my Windows 7 box is also used for Ubuntu/Fedora which change the system time to be 5 hours ahead.  I end up changing the Windows 7 time after the DHCP lease has been obtained.  Makes me want to experiment on my Vista box and see if it happens there also.

    OK.  Just switched over to Vista and tried to duplicate the problem.  Vista changes the lease expires date/time when I change the system time.  Windows 7 changes the lease obtained time.  Opposite behavior between DHCP clients on Vista and Windows 7.  Vista does not break by changing the system time after the DHCP lease has been obtained.
    Sunday, June 07, 2009 8:18 AM
  • Doesn't a quick release renew change the timestamp at least?
    Wednesday, June 17, 2009 5:08 PM
  • I think that the problem is on DHCP server with time settings. how otherwise can be leased ipconfig with date Wednesday, April 23, 1873?! fix time and date on DHCP server, check the DHCP pool and try it again.

    druid
    Wednesday, June 17, 2009 5:33 PM
  • Yes, Adam.  A quick release/renew does fix the time stamp problem.  I just found the situation rather amusing with the date being 1873.  With a little bit of thinking, I fixed the problem caused by dual-booting into Fedora on the same PC.  Fedora was setting the system time to GMT which made the time 5 hours off for Windows 7.

    The question still is - why does Windows 7 not try to obtain a new DHCP lease when the current lease expires?  The DHCP server is available and ready to issue a new lease.  When Windows "creates" a 169.254.x.x ip address, that is a valid IP address so Windows will never try to get a new DHCP lease until I do a release/renew.
    Wednesday, June 17, 2009 9:27 PM
  • Um, when a DHCP client gets a DHCP lease, it notes the date and time of when it gets the lease.  That has nothing to do with the DHCP server.  The timestamp on the lease is correct until I set the clock back 5 hours.

    FYI - I am running an open-source Linux firewall.

    "For Linux and Unix, the universe began at midnight UTC (a.k.a. Coordinated Universal Time , formerly Greenwich Meridian Time), or 12:00 a.m. on Jan. 1, 1970. The system clock tells time by counting the number of seconds since the Linux "universe" began. This method of telling time is referred to as the Unix Epoch . "
    Wednesday, June 17, 2009 9:39 PM
  • OK.  To demonstrate how to re-produce this bug, I did the following:

    1.  Set the BIOS time to 5 hours ahead of actual time.
    2.  Booted Windows 7 RC build 7100
    3.  Windows 7 RC obtained a new DHCP lease.  I noted the lease obtained time stamp.
    4.  Using the Windows Internet Time Settings dialog box, I told Windows to synchronize with time.windows.com causing the computer time go back 5 hours.
    5.  The DHCP lease obtained time stamp is now back in 1873.

    Here is a link to a screen shot showing three command windows - http://www.flickr.com/photos/16845090@N05/3637235021/sizes/l/

    Left command window is just after bootup at 5:46:33AM on June 18, 2009 which is 5 hours ahead of actual time.  The lease obtained time stamp is for 5:45:32AM on June 18, 2009.

    Right command window is the result after I synchronized the PC time with time.windows.com.  The time changed to 0:47:28AM on June 18, 2009.  The lease obtained time stamp is for May 11, 1873 at 11:17:16PM .  Note the lease expires time stamp has changed from 9:45:31AM to 4:45:20AM.

    The center command window is the result after ipconfig /release and ipconfig /renew.  All is back to normal.
    Thursday, June 18, 2009 6:09 AM
  • That is an odd one sir. I want to see if it does it to mine too.
    Thursday, June 18, 2009 2:05 PM
  • I wonder if this could be the problem?

    http://support.microsoft.com/kb/928233

    Kerry Brown MS-MVP - Windows Desktop Experience
    Thursday, June 18, 2009 2:13 PM
  • Kerry - The instance in which Windows 7 RC does not request a new DHCP lease is when the lease obtained time stamp is from so long ago.  It seems that Windows 7 thinks the DHCP server it obtained the lease from is no longer available when the lease is 99.x% expired.  Hence, the auto-generated 169.254.x.x ip address.

    Upon bootup, DHCP works fine.  When lease obtained time stamp is in this century, DHCP lease renewal works just fine.

    I have not seen any case when Windows 7 fails to obtain an IP address with my DHCP server.
    • Edited by SwampKracker Friday, June 19, 2009 7:19 PM spelling
    Friday, June 19, 2009 6:42 PM
  • We just had the sam problem orig winXP and new Win7 pc's connected to network and domain DHCP scope registered both types of computer but only winXP pc's applied the IP adresses, after alot of testing we found that if we deleted the DCHP scope and recreated it, both types of operating systems can now retrieve their IP configurations
    Wednesday, August 28, 2013 12:19 AM