none
USB devices not seen by XP Mode

    Question

  • I have recently upgraded to Windows 7.

    Some of my work uses VS6 so I have generated an XP Mode vm.

    When I go into XP Mode, 3 USB ports (on my laptop) are not been "seen" by XP Mode. These 3 USB devices are:

    A Receipt Printer.

    A Symbol bar code scanner.

    A Scanner/Scale.

    None of these USB are seen in XP Mode's "USB" drop down box on its toolbar.

    How can I get XP Mode to see these 3 USB devices?

    TIA!!!

    Thursday, May 12, 2011 2:16 PM

Answers

  • Hi,

     

    To attach the USB device, make sure the Integration Feature is enabled. After that, when connecting the USB device, click USB button on the toolbar and select your product.

     

    After that, click My Computer in XP mode and it will show under Device with Removable Storage.

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, May 16, 2011 9:39 AM
    Moderator

All replies

  • You need to attach the USB device to the VM. This will detach it from the host OS. Look at the USB menu on the VM when its running.

     


    My MVP is for the Windows Desktop Experience, i.e. Windows XP, Vista and Windows 7 IT

    Remote Assistance is available for a fee.

    I am best with C++ and I am learning C# using Visual Studio 2010

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    Thursday, May 12, 2011 4:25 PM
  • Vegan, Thanks for the response...

    But how do I attach a USB device to the XP Mode vm when the USB devices are not listed in the Tools drop-down menu (in the XP Mode vm)?

     

     

    Thursday, May 12, 2011 5:28 PM
  • You need to see if vpc is recognizing your devices.

    Shut down virtual machine, ( not hibernate), open VPC, right click XP mode, click settings, click intergration and see what it is showing and what is checked. Make sure "enable at startup" is checked, and all your devices you want to start are checked.

     

    Thursday, May 12, 2011 10:51 PM
  • Hi,

     

    To attach the USB device, make sure the Integration Feature is enabled. After that, when connecting the USB device, click USB button on the toolbar and select your product.

     

    After that, click My Computer in XP mode and it will show under Device with Removable Storage.

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, May 16, 2011 9:39 AM
    Moderator