none
Windows 7: How to Disable Automatic Activation

    Question

  • I'm setting up a couple of Windows 7 virtual machines for testing purposes. Unfortunately VMware workstation enables automatic activation during Windows installation without giving me the option to disable it.

    I guess this might bring me into trouble when a couple of Windows 7 clients will try to activate themselves providing the same configuration IDs.

    How can I disable automatic activation after setup has taken place?

    TIA
    Saturday, September 19, 2009 11:20 PM

Answers

  • The only node I've found containing resembling entries is HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SoftwareProtectionPlatform , but it doesn't contain the key Manual . And it's doubtable that creating that key would work given this new structure.
    Hi, if you expand even further to:

    HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SoftwareProtectionPlatform\Activation

    you will find a key named Manual, its type is REG_DWORD and probably have the value of 0x00000000 (0)

    I had the same problem as you and gambled by changeing the value to 0x00000001 (1) then rebooted Windows 7 while connected to internet. It seems to work, no automatic activation and I'm surfing the net.

    Maybe someone can verify my gamble as the correct solution to this problem?
    • Marked as answer by BetterToday Thursday, October 01, 2009 7:33 PM
    Thursday, October 01, 2009 4:22 PM

All replies

  • Hi, Just for others who read this, when you are installing from W7 disc watch out for the tick in Automatic Activation box untick it. Only thing you can do is to not allow connection to the internet in Vmware. Slan go foill, Paul  
    Sunday, September 20, 2009 12:14 PM
  • Hi, have a look at the link below:

     

    Enable and disable Auto-activation feature

    You can refer to the steps in the article to disable the Auto-activation feature. Although the steps are for Windows Vista, they are also fit for Windows 7.

     


    Cecilia Zhou
    Tuesday, September 22, 2009 7:32 AM
  • Hi Cecilia,

    thanks for your reply.

    I've found this link by goggling myself, but unfortunately the method described therein doesn't apply to Windows 7: There is no HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SL node present in Windows 7.

    The only node I've found containing resembling entries is HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SoftwareProtectionPlatform , but it doesn't contain the key Manual . And it's doubtable that creating that key would work given this new structure.
    Tuesday, September 22, 2009 11:13 AM
  • Actually, you can try to create a DWORD value under the key HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SoftwareProtectionPlatform.  Set the value name as Manual and the value data as 1.

     

    Regards.


    Cecilia Zhou
    Thursday, September 24, 2009 2:34 AM
  • Unfortunately I can't confirm. I've got another Windows 7 installation having manual activation running. That registry branch is the same on this VM as on the automatically activating Windows 7 VM, I'm afraid. So that doesn't seem to do the trick :(
    Thursday, September 24, 2009 8:42 AM
  • Hi, you can try the application described in the following link:

     

    Windows 7 : Disable Activation of Windows 7 and Server 2008


    Regards.


    Cecilia Zhou
    Friday, September 25, 2009 2:08 AM
  • Thanks Cecilia for pointing me there!

    ...but isn't this solution ...er ...illegal?
    Friday, September 25, 2009 9:56 AM
  • The only node I've found containing resembling entries is HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SoftwareProtectionPlatform , but it doesn't contain the key Manual . And it's doubtable that creating that key would work given this new structure.
    Hi, if you expand even further to:

    HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SoftwareProtectionPlatform\Activation

    you will find a key named Manual, its type is REG_DWORD and probably have the value of 0x00000000 (0)

    I had the same problem as you and gambled by changeing the value to 0x00000001 (1) then rebooted Windows 7 while connected to internet. It seems to work, no automatic activation and I'm surfing the net.

    Maybe someone can verify my gamble as the correct solution to this problem?
    • Marked as answer by BetterToday Thursday, October 01, 2009 7:33 PM
    Thursday, October 01, 2009 4:22 PM
  • Splendid! This is the node! On my Windows 7 installation with a 30 day trial period the value is "1" whereas on my Windows 7 installation with automatic activation it's "0".

    That's it.
    Thursday, October 01, 2009 7:41 PM
  • How to use Windows 7 for 360 days without activation:

    http://www.askvg.com/how-to-use-windows-vista-for-approx-one-year-without-activation/

    You're welcome!

    Thursday, January 28, 2010 10:34 PM
  • Coool!

    I wonder how long this tweak will work in Windows 7... AFAIK, Microsoft has disabled it in Vista after while.
    Friday, January 29, 2010 11:27 AM
  • How to use Windows 7 for 360 days without activation:

    http://www.askvg.com/how-to-use-windows-vista-for-approx-one-year-without-activation/

    You're welcome!

    I've tried this fix and it did take me from 1 day to automatic activation to 30 but that's as far as I get. I've rebooted several times and went back into DOS as admin using the
    slmgr -rearm command but it doesn't increase the number of days. Either MS has figured it out fairly quickly or I'm not doing something right but the instructions are pretty straight forward. Any suggestions? 
    Monday, February 01, 2010 6:57 PM
  • Yep, same with me. I have Windows 7 Ultimate downloaded from the MSDN website. Probably that version is different from retail ones..?

    But for me, I'm satisfied with 30 days... Enough time to install a virtual machine and use it for a while.
    Monday, February 01, 2010 7:03 PM
  • The only node I've found containing resembling entries is HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SoftwareProtectionPlatform , but it doesn't contain the key Manual . And it's doubtable that creating that key would work given this new structure.
    Hi, if you expand even further to:

    HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SoftwareProtectionPlatform\Activation

    you will find a key named Manual, its type is REG_DWORD and probably have the value of 0x00000000 (0)

    I had the same problem as you and gambled by changeing the value to 0x00000001 (1) then rebooted Windows 7 while connected to internet. It seems to work, no automatic activation and I'm surfing the net.

    Maybe someone can verify my gamble as the correct solution to this problem?
    Well I have went through the exact path (note I have windows 7 ultimate 32 bit) except the Key "manual" already had the value of 1, while I still get the notification. Instead, a Key named "notification disabled" had the value of 0, So I changed that to 1 instead. And I will try to come back here to comment on how well that works. But you guys can try that if you want, so far so good for me. And you type "regedit" for those who dont know, in either "run" or like my OS type it into "search programs and files" to get into the system to start the path listed in my quote. Although this does not directly relate to "automatic" activation, I am attempting to keep the OS from shutting down after the activation time limit is over, which I think is relavent enough to be interesting in this forum.



    Saturday, May 21, 2011 11:27 PM