none
Not able to start VMWare Workstation even after removing Hyper-V RRS feed

  • Question

  • I've got a Windows 10 Enterprise system that had Hyper-V installed but I instead needed to use VMWare Workstation because Hyper-V lacks smartcard support. I've removed the Hyper-V role but still get a message that Workstation and Hyper-V are not compatible and to remove the Hyper-V role. I've tried to remove the role using PowerShell, BCEDIT and from Add/remove windows features with no luck. I even uninstalled VMWare, reinstalled Hyper-V and then uninstalled it and then installed VMWare again to see if that would fix it but same result.  The only service I can find running is HV Host Service and stopping it makes no difference.  I there anything else I can try?
    Monday, March 20, 2017 3:15 PM

All replies

  • Hello

    When Hyper-V is installed, it sets hypervisorlaunchtype=Auto, which starts the hypervisor at boot time.

    To run another hypervisor on the same system you will need two versions of the loader, one with hypervisorlaunchtype=Auto for the Hyper-V instance and the other with launchtype=Off for the other, and multiboot between them. 


    Regards, Regin Ravi

    Monday, March 20, 2017 3:36 PM
  • Actually I've already tried that command - bcdedit /set hypervisorlaunchtype off.  It reports that it ran successfully but makes no difference. 
    Monday, March 20, 2017 10:29 PM
  •  Enterprise is the vital clue. This has come up in the VirtualBox forums.

     You can't access hardware virtualization if you are using device guard. That could well be your problem.


    Bill

    Monday, March 20, 2017 11:09 PM
  • Hi greatestcommonfactor,

    Please open an administrator command line and run "dism /online /get-features" to ensure all the hyper-v components have been disabled.

    "bcdedit /set hypervisorlaunchtype off"
    Have you restarted the machine to make it take effect? 
    Please run "bcdedit /enum all" to ensure it has been configured successfully.

    Best regards

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, March 21, 2017 3:08 AM
    Moderator
  • So I ran "dism /online /get-features" and found that the following were disabled:

    Microsoft-Hyper-V-All
    Microsoft-Hyper-V-Tools-All
    Microsoft-Hyper-V-Management-Clients
    Microsoft-Hyper-V-Management-PowerShell
    Microsoft-Hyper-V
    Microsoft-Hyper-V-Hypervisor
    Microsoft-Hyper-V-Services

    And the following were enabled:

    Microsoft-Hyper-V-Common-Drivers-Package
    Microsoft-Hyper-V-Guest-Integration-Drivers-Package

    I disabled the two above using "Dism /online /Disable-Feature /FeatureName:".

    Running "bcdedit /set hypervisorlaunchtype off" shows the operation completed successfully but after the restart I still can't get VMWare Workstation to start.

    I'm not really certain what I should be looking for after running "bcdedit /enum all" but there was a section on Hypervisor that showed:

    identifier              {hypervisorsettings}
    badmemoryaccess         Yes
    hypervisordebugtype     Serial
    hypervisordebugport     1
    hypervisorbaudrate      115200

    Tuesday, March 21, 2017 3:15 PM
  • Are you running this in a VM?  I don't think the Hyper-V common drivers package and guest integration can be installed on a physical OS installation.

    I checked a couple of my Win10 installs, with and without Hyper-V none have either of those 2 packages installed.

    Tuesday, March 21, 2017 4:49 PM
  •   And have you checked whether the Enterprise host OS is running Microsoft Device Guard? 

      Device guard uses hardware virtualization and will block VMWare even if the hypervisor is not running.

    https://technet.microsoft.com/en-us/itpro/windows/keep-secure/requirements-and-deployment-planning-guidelines-for-device-guard#hardware-firmware-and-software-requirements-for-device-guard

      Note the warning in red.

     

    Bill

    Tuesday, March 21, 2017 10:19 PM
  • Thursday, March 23, 2017 10:12 PM
  • After trying the above fixed the computer went into some type of bitlocker loop where bitlocker would go into recovery mode and ask for the bitlocker key and after it was entered the system would go to the repair window and then go immediately back to the bitlocker key menu.  I finally decided to just re-image the machine. If it happens again I will try the steps above.
    Friday, March 24, 2017 8:29 PM
  • I have a Azure VM (Size D8s_v3) and having trouble getting VMware workstation to run.

    I have disabled Device Guard via Group Policy as shown below. 

    I have also made sure that the Hyper-V feature is not installed.

    Lastly in PowerShell I ran the following to make sure that the feature was disabled.

    Disable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V-Hypervisor

    I am still having the issue of not being able to start a VM using VMware. Any suggestions?

    Sunday, November 17, 2019 7:47 AM
  • There is no simple "silver bullet" solution. You just have to find what, in your system, is using hardware virtualization and preventing VMWare from using it. The list of these is growing longer every day. Within Windows there are plenty - Credential Guard, Device Guard, Sandbox etc.  There is also an increasing list of non-Microsoft apps which do the same thing, including some anti-virus scanners.


    Bill

    Sunday, November 17, 2019 10:11 PM
  • Well I went in and disabled the following Services. Still having a issue though. Can you provide any specific things to check? This is a "out-of-the-box" Azure VM (Version 1809) that hasn't had anything installed on it yet, besides VMware Workstation. 

    Monday, November 18, 2019 1:25 AM