Intermittent Mouse Failure with Windows 7


  • I have been observing intermittent mouse failure under Windows 7 since RC2. I initially thought this was my own system/mouse causing the issue (Logitech G5 Laser Mouse) where the mouse would randomly fail and completely lose all power(20 mins to 2 hour intervals roughly), with the only possible fix is to physically remove the device from the USB port and reconnect it. This was observered on both RC2 and Final, did not happen under Vista.

    However, now in work we have upgraded most of out computer from Windows XP to Win 7 (clean installation) we are experiencing the same issues on most of the machines. In each case there is no common hardware (ranges from old intel socket 478 machines to modern quad cores) and no common type of mouse (variety of MS Optical Wheel Mouse, Logitech G5 Laser, Logitech MX518 and random others). Failures are not happening on all the systems but on the ones that do have the issue its every 2-4 hours. These systems were previously running Windows 7 where there was no such issue.
    Thursday, October 29, 2009 12:38 PM

All replies

  • Hi,


    Since the computer model and mouse model are different, it is hard to determine the root cause. According to my test, this issue does not occur on my computer.


    Before going any further, I would like to know if the computers are in the domain or if any same device is used by these computers.


    To troubleshoot this issue, please may update BIOS and Motherboard driver first.


    If the issue persists, try running in Clean Boot mode.


    You can also try the following steps:


    Modify the Registry


    1. Click the Start Button, type "regedit" (without quotation marks) in the Start Search box and then press ENTER.

    2. Navigate to the following key:




    3. Right click the {36FC9E60-C465-11CF-8056-444553540000} entry, choose "Export", select Desktop in the Save in box and type backup in File Name. Click Save.


    Please Note: The backup file is on the Desktop and named backup.reg. We can simply restore the registry by double-clicking the backup.reg file.


    4. Highlight this key ({36FC9E60-C465-11CF-8056-444553540000}), on the right pane, and then check if Upperfilters and Lowerfilters value are present. If so, please right click on the values and select "Delete" to remove them.

    5. Restart the computer.


    Hope it helps.

    Vivian Xing - MSFT
    • Marked as answer by Vivian Xing Tuesday, November 03, 2009 9:59 AM
    • Unmarked as answer by Hitsuji Monday, December 07, 2009 2:39 AM
    Friday, October 30, 2009 8:59 AM
  • I've got the same problem, no problems on vista, but on windows 7 my g5 mouse gets random "blackouts" varying from 2 sec to infinity, where it reconnects and sensitivity is reset to "middle setting". Ive tried updating chipset drivers, tried with and without logitech setpoint which supports windows 7.

    Motherboard is a gigabyte ga-p35-s3g. Running windows 7 64bit. Was gonna try the regedit modification, only to notice i did not have any upperfilter or lowerfilter listed at all on that key ({36FC9E60-C465-11CF-8056-444553540000}).

    Considering buying a new mouse but reading how that didnt help, i dont think i will.

    Thursday, November 05, 2009 4:20 PM
  • I found this suggestion, tried it, and so far ive had no problems. Its still a bit early, but thought i might  as well suggest it while i remember it;

    I tried method 1, so far with luck;

    Method 1

    *For Microsoft Windows Vista (and windows 7)
    Click Start, and type device manager in the Start Search box.
    Click Device Manager in the Programs list.
    If you are prompted for an administrator password or confirmation, type your password or click Continue.
    In the Device Manager dialog box, expand Universal Serial Bus controllers.
    Right-click USB Root Hub and then click Properties.
    In the USB Root Hub Properties dialog box, click the Power Management tab.
    Remove the check from the Allow the computer to turn off this device to save power check box. Repeat steps 1 through 4 for each USB Root Hub listed in the Device Manager.

    If u do it manually, it turns itself back on after reboot. To do it permanently do as shown on
    • Proposed as answer by ReVeiLeR Thursday, November 05, 2009 5:04 PM
    Thursday, November 05, 2009 5:04 PM

    If the issue persists, try running in Clean Boot mode.


    You can also try the following steps:

    This did not fix the issue. Did a clean installation with Win 7 Ultimate 64 bit without installing anything (no drivers no updates). After a few days of testing (mainly booting the computer loging into main account and leaving the machine alone for several hours at a time) there were no problems. Installed VC 2005 redist and MS Security Essentials. Then promptly ran Windows Update to install correct drivers and update windows (excluded optional language installs). After the next reboot the problem returned. So it would appear to be either driver related or related to an MS product.
    Monday, December 07, 2009 2:57 AM
  • Hi,

    How about performing a system restore first:

    System Restore
    1. Click the Start Button, type "system restore" (without quotations) in the start search box and press enter.
    2. Click "Choose a different point" and click next.
    3. Check Show more restore points box.
    4. Choose a date before this issue happening, and click Next.
    5. Click Finish.

    After that, you can install the driver updates one by one to narrow down the root cause.
    Vivian Xing - MSFT
    Monday, December 07, 2009 6:10 AM
  • Is there any update?
    Vivian Xing - MSFT
    Friday, December 11, 2009 8:08 AM
  • Not to be offensive or anything, but his last post was that he tried with a clean install of windows 7, which means a system restore would be rather pointless.

    After realizing the answer i proposed earlier actually only worked halfway sorta, i decided to go get a new mouse. Bought the microsoft intellipoint 3, and installed the intellipoint drivers. When i then connected my old g5 laser mouse i at first had no problems. But after a while the mouse started dieing completely, so my guess is that my mouse was just too old. I would suggest you tried installing the intellipoint tho, see if that helps. It might as i experienced a performance improvement on my g5 logitech before it got nuts.
    Friday, December 11, 2009 9:32 PM
  • I am having the same issues with the mouse but also the keyboard on a docked Dell Latitude.  The USB ports seem to randomly lose power.  Keyboard lights go out and mouse laser goes out for a few seconds and then it all comes back on.  All USB root hubs were verified to NOT allow the "let computer turn off" under power management.  BIOS has been updated, registry does not include the Upperfilters and Lowerfilters values.  The fact that it is both USB devices tells me that this is NOT a problem with the mouse or keyboard in particular but something with usb in general.  FYI, it happened 4 times as I wrote this post...  VERY annoying.
    Wednesday, March 03, 2010 4:10 PM
  • I have also noted this. Windows 7, latest updates (no updates outstanding as of 3/16/10). Microsoft wired optical mouse on USB port. This is a new (within one week) installation of Win 7. Approximately 2 days ago I began to experience total mouse failures with no apparent cause. On disconnect/reconnect of mouse the USB device is not recognized. On restart the mouse is not recognized. On safe mode restart the mouse is not recognized. On hardware shutdown and start, the mouse resumes function. This would seem to indicate a driver + software issue. I'd say it's pretty serious and quite real given the number of people responding here.
    Wednesday, March 17, 2010 1:00 AM
  • Same sort of thing, Windows 7 Pro.  Worked fine for months, then the 2-5 second delays began.  Those continued, and the disconnect/reconnect tones sound, then the mouse is fine for a variable amount of time.  I've removed and let Windows reinstall the drivers, tried different mice (all detected as HID mice at 100mA) from MS and HP, different USB ports on different motherboard hubs, changing power settings for the USB ports and the computer to S3 only, uninstalled most utilities that were installed when it was working normally, and created a new windows profile which resulted in the same behavior with nothing else loading.  I found different video drivers from the ones MS was sending with Windows Updates to install and replaced most drivers whether there were updates or not.

    None of that worked.  It seems to have progressively gotten worse, now after booting, with only Explorer, MS Defender, and ATI Catalyst Control Center running, just moving the cursor around the screen will cause the mouse resets. 

    Windows Security Essentials, Avast, Malwarebytes, and a couple of online scanners find nothing unusual.  Scandisk is good.

    I'm going to install Ubuntu or some distro to verify that it's not hardware, it seems to be software, and worse with flash apps running, but it has deteriorated to the point now that the port will reset with the computer sitting idle.  Since I see these reports going back to beta and into 64-bit Vista, I'm not hopeful of an answer, just chiming in with my experiences.

    Maybe I'll try 32-bit Vista, I think my academic list includes it.

    Wednesday, April 21, 2010 11:58 AM
  • Hi Jalek,

    Running multiple anti-virus programs simultaneously can cause problems. Use Avast or Windows Security Essentials only with Windows firewall and uninstall the others. Disabling does not remove the confilcting components.

    Disable MS Defender.

    Still have the mouse problem?

    If yes, try right clicking the usb controller in device manager, and updating the driver for it.  


    • Edited by Nano Warp Wednesday, April 21, 2010 12:09 PM added info
    Wednesday, April 21, 2010 12:06 PM
  • Hi Algae,

    Have you installed the Windows 7 driver for your mouse. Check here and apply if it is available:

    Wednesday, April 21, 2010 12:11 PM
  • Hi ReVeiLer,

    The G5 is supported by Logitech for Windows 7.

    Drivers here:

    Have you discovered this by now as your post is old?

    Wednesday, April 21, 2010 12:18 PM
  • If yes, try right clicking the usb controller in device manager, and updating the driver for it.  

    The drivers had been uninstalled and updated both from ASUS's website and through Windows Update at different times.

    Running under Linux seemed to work... then after some time, the mouse light goes out just as with windows.  I guess the ICH9 chipset must be failing, trying different USB channels doesn't help for long.  Both Logitech and Microsoft mice behave similarly.

    Both odd and annoying.  I guess it's time to upgrade.

    Thursday, April 22, 2010 11:54 PM
  • Jalek,

    I am curious now, which motherboard are you using?  Intel .inf updates will not help usb issues. Intel notes for usb problems to look where you already have, at the manufacturer's support. But, what if it is a BIOS setting, that needs to be changed?

    Friday, April 23, 2010 2:11 AM
  • Thanks, i'll give it a shot. Dont have access to my homecomputer untill next week but ill give it a try.

    My motherrboard is a gigabyte p35 s3g, just pouring out info incase it doesnt work.
    Friday, April 23, 2010 7:57 AM
  • ReVeiLer,

    On your motherboard,(P35-S3G) I would check that the five usb settings are set to enabled.

    1. Usb Controller 2. Usb 2.0  3.Usb keyboard support 4. usb mouse support 5. Legacy usb storage detect

    F10- Save and Exit

    Check the Gigabyte site to determine if they have provided a new driver(s) for Win 7 or BIOS update. 

    Friday, April 23, 2010 11:45 AM
  • Yeah ive tried it now, still no success, the mouse still goes on\off once in a while and resets its dpi settings. I got all the usb options i can on, cant have legacy usb storage on, for some reason when i do, the cpu overclocking ive done wont stick.

    Guess ill just stick to my intellimouse 3 untill i either get a new motherboard or a new computer. My friend which got the same mouse does not have these problems, but then again, he doesnt have the same computer either.
    Saturday, April 24, 2010 7:43 AM
  • Jalek,

    I am curious now, which motherboard are you using?  Intel .inf updates will not help usb issues. Intel notes for usb problems to look where you already have, at the manufacturer's support. But, what if it is a BIOS setting, that needs to be changed?

    Nevermind all that.. I connected an old Microsoft trackball and the problems have been gone since.  Apparently the different mice I had tried were all HID-compatible as far as drivers went.  This is using an Intellipoint driver instead.  It was a 2006 version, so driver corruption could still have been the problem, since uninstalling hardware doesn't always mean what it says.

    I don't know why the Linux install had an issue, it probably hadn't been configured properly and I didn't check into it enough.


    Sunday, April 25, 2010 2:15 AM
  • I am suffering from this issue as well:

    I have a MICROSOFT Habu mouse that uses HID-Mouse drivers provided by Windows 7

    I have tried the following things:

    (1) Checking Each USB root hub to ensure power savings is not set

    (2) Checking the mouse under device manager to ensure the device will not sleep

    (3) Downloading the USB bandwidth/latency meter to confirm I have enough computing power

    (4) Downloading and installing the latest Habu Drivers (v2.21)

    When my Microsoft mouse fails to work with a Microsoft Operating system, and the only answer provided is do a system restore and patch individually to determine the root cause of the problem I raise concerns.  I did not pay $150 to have to trouble shoot patches that are developed by the vendor.

    Additional testing should be done by the software engineers and technicians to debunk this issue in lieu of leaving the issue to the community to theory craft a solution.

    If the solution is to replace my $60 mouse with a $20 low end optical mouse, I'm formatting to linux.

    Sunday, April 25, 2010 11:07 PM
  • Id say its operative system\windows in this case's fault, not the mice vendors or the producers of it. And as it doesnt happen everywhere, its most likely the computer hardware setup that goes wrong somewhere. To me it feels like a "what are the odds?!" problem.

    OstridgeBot: another option could be that you got a faulty mouse. Tried it on other computers? over time? Probably have but cant be too sure. And if its faulty you can just get a new one from the vendor.
    Monday, April 26, 2010 1:18 PM
  • ReVeileR: Generally I would agree, except.  I've been running Windows 7 successfully since December 2009.  My hardware and software configurations stay relatively steady state.   The failure just started occurring in early April.  Something changed and I'm fairly confident it was not operator induced.
    Tuesday, April 27, 2010 12:52 AM
  • I seem to be having the same problems. I went on vacation and came home to find that my G5 mouse is no longer working and I get random blue screens in Windows 7. I plug in my usb wireless logitech mouse and have no problems at all. On bootup my G5 is recognized and lights up, but once windows 7 starts, it stops. Will not work after I unplug and then plug back in. I also have a logitech G15 gaming keyboard, and it works fine, not sure if there is some conflicting issue between the two devices(never had one before). I've tried swapped ports to see if this will clear the issue, along with the updates in this post but nothing is working:(

    Tuesday, May 04, 2010 2:14 AM
  • All-

    I have your solution.  Take your current malfunctioning mouse and throw it in the waste bin or give it to a friend.  Go to Walmart, but an $11 Logitech optical mouse and be happy.

    From additional research I did on the forums and Google, this problem has existed for select folks since Vista SP2.  Microsoft has not addressed it and more than likely won't.  Once it starts there is no way to stop it (Save loading XP or Linux)

    Addressing the comments above, my $11 mouse works just fine on my Windows 7 machine.  My Microsoft Habu mouse works fine on my XP machine.  Issue resides at the Windows 7 driver / interface level.

    I suppose I could continue to trouble shoot, but I'm not on the payroll at Microsoft so I won't be doing them any favors.  In the mean while, I highly discourage buying Microsoft hardware in light of what has occurred.

    Saturday, May 08, 2010 4:47 PM
  • It's so irritating, you spend a ton of money on a mouse that allows you to play games, and for hobby, work in CS4 Photoshop. That mouse gave me so many options. I hate MS :( I have two optical mouses, but their small size(they must make them for small children)  does not fit well in my hands and causes severe cramping if used for CS4. I will call and yell at some Indians, that will make my day. 
    Saturday, May 08, 2010 5:52 PM
  • Has this issue been resolved as the last post seems to be way back in May, and its August now.
    Saturday, August 07, 2010 6:06 AM
  • Well here it is March 28th 2011, it began as sporatic audio alerts of USB ports being egaged by a PDA plugged into a USB port going on and off at will. Next it progressed to sporatic USB mouse failure.  Microsoft Optical Mouse Blue, thought the cable was bad as it seem to fail at certain spots of motion. Switch mice to a Dynex optical USB and within a day had the same failures return. Changed the mouse pad thinking the silver surface may be causing wierd feedback, no luck. Switch Ports on rear of HP Media Center Phenom Quad 9600 with 4 Gigs.  Even tried the front ports and problem always returns.  Tried taking the USB mouse and plugging into a USB to PS2 adapater plugging into the PS2 port. Problem returned. Switched to a total of 5 different mice with PS2 and USB interfaces and all fail after short period of mouse activitity. Front USB ports, no luck. Switch power saver on USB HUBs off, no luck. This has all happened in the last few weeks, is this a BUG in Service Pack? Or something else passed down in the numerous automatic updates?

    I want stability back and tired of waiting for the PC to unlock.  Also for a note the Mouse functions when on a screen like right mouse copy command or similar functions seem to be missing now from many applications.  I see the frustration driving a person to switch to ubuntu or linux but NO Windows 7 is good lets find out what you guys screwed up this time.


    • Proposed as answer by woosnamc Wednesday, March 30, 2011 5:20 PM
    Tuesday, March 29, 2011 6:29 AM
  • Well you have read my frustration with above, so I may have a solution.  I got so frustrated I de-installed all USB mice drivers. Rebooted, but this time with an old Ball type PS2 Mouse.  The System came up clean. 48 hours of operation and even though reduced mouse functionality (extra buttons, and scan wheel, and laser) the Mouse has not acted up even once. No System delays like before.  I then Unplugged the PS2 mechanical mouse, and Plugged a Dynex Laser USB mouse into the front USB port. I have been using now for almost 24 hours and NO return of the the Lockups or delays as before.

    I think removing the old USB mouse completely.  Using a temporary Mechanical mouse and ReBooting Clean removed all of the offending USB drivers and then Rebooting again gave me a Clean Registry and that has eliminated the problem.

    Keeping my fingers crossed.

    Wednesday, March 30, 2011 5:28 PM