none
Unable to install RDS roles - Windows Server 2016STD RRS feed

  • Question

  • I am currently having an issue installing RDS on a Windows Server 2016STD. This server IS currently a domain controller. I know it's not recommended to run a terminal server on a DC but it is what is required for the situation. 
    From what I understand Microsoft temporarily disabled the ability to install both RDS and ADDS on a single server, but from the info I can find on Server 2016 this has since been re-allowed. 

    I am attempting to do a session-based deployment.

    When trying to go through the standard deployment method, the installation fails on the RD Connection Broker role service with: "Failed: Unable to install RD Connection Broker role server on server 'Server'".

    If trying to install with the Quick Start deployment method, the deployment fails at Remote Desktop Services role services with the error: "Failed: Unable to install the role services. Exception calling "Translate" with "1" argument(s): "Some or all identity references could not be translated."

    There don't appear to be any errors or relevant events in the Event Viewer.  

    Any help will be greatly appreciated!


    Monday, December 11, 2017 4:51 AM

All replies

  • Hi,

    What's the build version of the DC?

    I just installed RDS services (Quick Start) successfully on a DC, Windows Server 2016 Datacenter with OS build 14393.1884.

    I suggest you enable RDMSDeploymentUI and RDMSUI-trace logs to find out why the installation fails.

    To enable logs, follow these steps:

    1. On the Remote Desktop (RD) Connection Broker server, create the following registry key: HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\RDMS
    2. Create the following two registry entries under the registry key: 
    • Entry: EnableDeploymentUILog
      Data type: REG_DWORD
      Value: 1
    • Entry: EnableUILog
      Data type: REG_DWORD
      Value: 1

    After that, restart Server Manager and re-produce the issue.

    Introduction to log files that are useful for troubleshooting RDS issues in Windows Server 2012

    https://support.microsoft.com/en-sg/help/2747656/introduction-to-log-files-that-are-useful-for-troubleshooting-rds-issu

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, December 12, 2017 10:50 AM
    Moderator
  • Hi,

    Are there any updates at the moment?

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, December 14, 2017 9:32 AM
    Moderator
  • Hi,

    Is the issue resolved?

    If yes, please mark useful reply as answer, which would be much more efficient for forum community members to find helpful information.

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, December 18, 2017 5:09 AM
    Moderator
  • Hi Sorry for the late reply, 

    I enabled the logging as per your advice, but it just gives me the same info as provided by the GUI when installing. 
    Further I tried installing the RDS roles one by one through powershell and noticed that it only fails when trying to install connection broker. All other roles install successfully. When trying to install the connection broker I am given an error saying "Role can't be installed due to a pending reboot onthe specified server". I have triple checked to make sure there are no pending reboots, and the registry is not flagged for a reboot. Updates are all the latest, and there are no pending updates. 
    Any more advice would be greatly appreciated!

    • Edited by JBADD23 Tuesday, December 19, 2017 2:50 AM
    Monday, December 18, 2017 6:49 AM
  • Hi,

    I assume that you have tried reboot, what's the exact build version on the server? You may run Winver.exe to confirm.

    Is there any third party software installed? If yes, please disable/uninstall and try again.

    Is Windows Internal Database service running? What the account that it's running under?

    You may use Process Monitor to capture real time thread activities to further debug the issue.

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, December 19, 2017 6:33 AM
    Moderator
  • Thanks for getting back to me again. 
    Yes I have tried multiple reboots, and no third party software as of yet. 
    The internal database is running and it's running under the Network Service account. 

    I tried demoting the DC back to just a member server, I was able to install all RDS roles including server manager via the quick deployment. Everything was working fine until the server got promoted back to a DC. Once promoted, the connection broker service would fail when starting with an error "The service started and then stopped again" with nothing further indicated in any logs. 

    Tuesday, December 19, 2017 9:00 AM
  • Hi,

    Remote Desktop Connection Broker and AD DS coexistence was not supported in Windows Server 2012, but it was supported later with Servicing Stack Update of September 2013 2871777:

    Remote Desktop Services role cannot co-exist with AD DS role on Windows Server 2012

    https://support.microsoft.com/en-us/help/2799605/remote-desktop-services-role-cannot-co-exist-with-ad-ds-role-on-window

    It should work to install AD DS and RD CB on Windows Server 2016, though it's not recommended.

    You may try to run Process Monitor to further debug the issue, or open a case with Microsoft to find out the cause of the issue.

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, December 20, 2017 8:40 AM
    Moderator
  • Hi,

    FYI, I have a very similar set of symptoms in an environment I'm building for a customer, including also trying the trick of demoting my DC to member server status, installing RDS, promoting back into DC status and ending up with RD CB service starting and immediately stopping with little in the way of helpful explanation.  I've opened a premier support case and am waiting for a support engineer in the RDS team to review some logs I've supplied. 

    I'll post back once I have anything more useful, but would be interested to hear if the original poster has made any further progress in the meantime.

    One interesting thing to note - an engineer from the ADDS team has already a) confirmed "it should work" and b) run up a simple one-server lab environment where it does in fact allow installation of RDS roles (including CB) on top of a fresh WS2016 server with ADDS installed.   Of course... the real world is never quite that clean and tidy, and we have other DCs at other OS releases, a different domain functional level, etc, etc. 

    Monday, January 22, 2018 11:48 AM
  • Hi Nathan,

    I face the exact same issue, did you got some solution?7

    Many thanks in advance.

    Júlio

    Friday, February 9, 2018 6:47 PM
  • Hi Júlio....

    Sort of.

    We ended up deciding to adjust our architecture to fit into a scenario that we have seen working - the one with the "clean" WS2016 server running AD DS role + RDS role.  For us, we could easily see spending a lot of time troubleshooting this without a strong probability of success.... or we could spend a relatively short amount of time just creating a new domain and migrating across less than a dozen users + workstations. 

    Good luck with your scenario - I hope that this workaround will be viable for you too, or that you have budget to add another instance of Windows Server to your solution, so you can split the AD & RDS roles out on to separate servers. 

    Regards,

    N

    Saturday, February 10, 2018 11:39 AM
  • I had the same issue. Joined server to existing domain and dcpormoed it. Can not install Session broker on it. dcpromo the server out, session broker installs without issue but as soon as you dcpromo it, Session Broker breaks.

    What worked for me was:

    1.  You must change the Windows Internal Database service to run as a domain account before reinstalling RDS (I suggest creating a new account)
    2. You must move the FSMO roles to the Domain controller before installing RDS
    3. You must log into the server with an account that does not have mydoc redirection enabled (I know it is weird) when installing RDS
    4. You must add the server to "Terminal Server Computers", "RDS Management Server", "RDS Remote Access Servers", & "RDS Endpoint Servers" in ADUC before installing


    Thursday, September 5, 2019 1:59 AM
  • This is fix for below error

    Error: Unable to install RD Connection Broker role service on server

    Please take a full backup of registry and perform below steps

    1. Deleted registry key 'Enabled' in key path 'HKLM:\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\SSL 2.0\Client'
    2. Updated The registry value "Enabled" to "fffffff" in key path 'HKLM:\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Client\Enabled'
    3. Updated The registry value "Enabled" to "fffffff" in key path 'HKLM:\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Client\Enabled'
    4. Deleted registry key 'Functions' in key path 'HKLM:\SOFTWARE\Policies\Microsoft\Cryptography\Configuration\SSL\00010002\Functions'

    Reboot the server and try to install the RDS


    • Edited by Suriii Monday, September 16, 2019 7:02 PM
    Monday, September 16, 2019 7:02 PM