Wireless lag spikes every 60 or so seconds while gaming


  • I have googled this many many times, and tried a variety of different fixes, to no avail.

    Basically after installing W7, i've been getting this lag spike which reaches up to 3000ms, which occurs every 60 seconds.

    I've been told that this is because windows looks for other "better" networks to connect to.

    I have tried the following:

    WLAN Optimizer
    Vista AntiLag
    Resetting the wireless drivers to XP drivers
    Manually disabling the auto-config through cmd.exe
    Disabling WLAN AutoConfig in services (this makes wireless not work altogheter)

    Here is my driver info:

    Interface name: Wireless Network Connection

        Driver                    : D-Link Wireless G DWA-510 Desktop Adapter
        Vendor                    : D-Link
        Provider                  : D-Link
        Date                      : 10/03/2008
        Version                   :
        INF file                  : C:\Windows\INF\oem18.inf
        Files                     : 1 total
        Type                      : Native Wi-Fi Driver
        Radio types supported     : 802.11b 802.11g
        FIPS 140-2 mode supported : Yes
        Hosted network supported  : No
        Authentication and cipher supported in infrastructure mode:
                                    Open            None
                                    Open            WEP-40bit
                                    Open            WEP-104bit
                                    Open            WEP
                                    Shared          WEP-40bit
                                    Shared          WEP-104bit
                                    Shared          WEP
                                    WPA-Enterprise  TKIP
                                    WPA-Enterprise  CCMP
                                    WPA-Personal    TKIP
                                    WPA-Personal    CCMP
                                    WPA2-Enterprise TKIP
                                    WPA2-Enterprise CCMP
                                    WPA2-Personal   TKIP
                                    WPA2-Personal   CCMP
        Authentication and cipher supported in ad-hoc mode:
                                    Open            None
                                    Open            WEP-40bit
                                    Open            WEP-104bit
                                    Open            WEP
                                    WPA2-Personal   CCMP
    Sunday, February 26, 2012 2:31 AM


  • This issue may be caused by your network devices that are not compatible with auto-tuning feature. Refer to the following article to disable auto-tuning.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Monday, March 05, 2012 6:20 AM

All replies