none
DVD Movie: Windows cannot access the specified device, path, or file. etc. RRS feed

  • Question

  • I recently upgraded from Vista Home Premium to Windows 7 Home Premium. Before the upgrade, playing DVD movies were fine. I have two DVD drives that are working the same. When I put a Movie in the drive, the drive will recoginze the disk and give the name of the movie like it should. It will not auto start the movie even though the autoplay is turned on for Windows Media Player. If I double click on the drive with the movie in it, I get the response "Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item." I have tried several different apps as the default, but all do the same thing. I can open any of them such as WMP and start the movie from with in and it will play fine. Music CD's and apps will start fine. It is only DVD Movies that will give me the error. I have removed WMP and Media Center and reinstalled them to no avail. One other thing that I have noticed, in the Media Center, I don't have a choice to play DVD's there under movies. I have upgraded two other computers and they all play fine. I have downloaded the Take Possesion.reg, but it won't give me any options for the dvd drives, only files that may be within. Help? Thanx in advance for any help.
    Thursday, November 5, 2009 4:55 AM

Answers

  • Warren333-

    1. Run Regedit
    2. Navigate the tree to HKEY_CLASSES_ROOT\DVD\shell\play\command
    3. Double click the (Default) value on the right side of the split dialog (Edit String dialog should appear)
    4. Copy the contents of the Value data field
    5. Click cancel on the Edit String dialog
    6. Right click on the right side of the split dialog
    7. Choose New->Expandable String Value
    8. Just hit enter if the cursor is allowing you to change the name of the new value
    9. Doublie click the New Value you just created (Edit String dialog should appear)
    10. Paste the string you previously copied into the Value Data field
    11. Click OK on the Edit String Dialog
    12. Now on the left hand side of the split dialog, highlight the folder  HKEY_CLASSES_ROOT\DVD\shell\play\command
    13. Right click it, and choose Export
    14. Save this file to some location of your choosing, and some name of your choosing.
    15. Close regedit
    16. Go to the location you saved the file
    17. Right click the file, and choose the Edit option (should launch the file open in notepad (or some other text editor)
    18. You should see something similar to (Don't just copy and paste what I have below, because this PC has WinDVD installed):

    [HKEY_CLASSES_ROOT\DVD\shell\play\command]
    @="\"C:\\Program Files (x86)\\InterVideo\\WinDVD\\WinDVD.exe\" %1"
    "New Value #1"=hex(2):22,00,43,00,3a,00,5c,00,50,00,72,00,6f,00,67,00,72,00,61,\
      00,6d,00,20,00,46,00,69,00,6c,00,65,00,73,00,20,00,28,00,78,00,38,00,36,00,\
      29,00,5c,00,49,00,6e,00,74,00,65,00,72,00,56,00,69,00,64,00,65,00,6f,00,5c,\
      00,57,00,69,00,6e,00,44,00,56,00,44,00,5c,00,57,00,69,00,6e,00,44,00,56,00,\
      44,00,2e,00,65,00,78,00,65,00,22,00,20,00,25,00,31,00,00,00

    19. Now delete the first line:
    @="\"C:\\Program Files (x86)\\InterVideo\\WinDVD\\WinDVD.exe\" %1"

    20. Now replace everything in front of the = of the remaining line with just the @ character, final results should look similar to:
    [HKEY_CLASSES_ROOT\DVD\shell\play\command]
    @=hex(2):22,00,43,00,3a,00,5c,00,50,00,72,00,6f,00,67,00,72,00,61,\
      00,6d,00,20,00,46,00,69,00,6c,00,65,00,73,00,20,00,28,00,78,00,38,00,36,00,\
      29,00,5c,00,49,00,6e,00,74,00,65,00,72,00,56,00,69,00,64,00,65,00,6f,00,5c,\
      00,57,00,69,00,6e,00,44,00,56,00,44,00,5c,00,57,00,69,00,6e,00,44,00,56,00,\
      44,00,2e,00,65,00,78,00,65,00,22,00,20,00,25,00,31,00,00,00

    21. Save the notepad file and close Notepad
    22. Now double click the file you just saved, a warning should appear saying you're going add stuff to the registry.
    23. Click Yes to Continue
    24. A Dialog should appear stating the values were added to the registry
    25. Re-open regedit
    26. Traverse back to HKEY_CLASSES_ROOT\DVD\shell\play\command (you should already be there)
    27. Now the value on the right hand side labeled (Default) should have the same Data as before, but the Type should indicate it is REG_EXPAND_SZ

    Good luck, hope it works for you too. 
    Tuesday, January 12, 2010 7:01 PM
  • Warren333-

    1. Run Regedit
    2. Navigate the tree to HKEY_CLASSES_ROOT\DVD\shell\play\command
    3. Double click the (Default) value on the right side of the split dialog (Edit String dialog should appear)
    4. Copy the contents of the Value data field
    5. Click cancel on the Edit String dialog
    6. Right click on the right side of the split dialog
    7. Choose New->Expandable String Value
    8. Just hit enter if the cursor is allowing you to change the name of the new value
    9. Doublie click the New Value you just created (Edit String dialog should appear)
    10. Paste the string you previously copied into the Value Data field
    11. Click OK on the Edit String Dialog
    12. Now on the left hand side of the split dialog, highlight the folder  HKEY_CLASSES_ROOT\DVD\shell\play\command
    13. Right click it, and choose Export
    14. Save this file to some location of your choosing, and some name of your choosing.
    15. Close regedit
    16. Go to the location you saved the file
    17. Right click the file, and choose the Edit option (should launch the file open in notepad (or some other text editor)
    18. You should see something similar to (Don't just copy and paste what I have below, because this PC has WinDVD installed):

    [HKEY_CLASSES_ROOT\DVD\shell\play\command]
    @="\"C:\\Program Files (x86)\\InterVideo\\WinDVD\\WinDVD.exe\" %1"
    "New Value #1"=hex(2):22,00,43,00,3a,00,5c,00,50,00,72,00,6f,00,67,00,72,00,61,\
      00,6d,00,20,00,46,00,69,00,6c,00,65,00,73,00,20,00,28,00,78,00,38,00,36,00,\
      29,00,5c,00,49,00,6e,00,74,00,65,00,72,00,56,00,69,00,64,00,65,00,6f,00,5c,\
      00,57,00,69,00,6e,00,44,00,56,00,44,00,5c,00,57,00,69,00,6e,00,44,00,56,00,\
      44,00,2e,00,65,00,78,00,65,00,22,00,20,00,25,00,31,00,00,00

    19. Now delete the first line:
    @="\"C:\\Program Files (x86)\\InterVideo\\WinDVD\\WinDVD.exe\" %1"

    20. Now replace everything in front of the = of the remaining line with just the @ character, final results should look similar to:
    [HKEY_CLASSES_ROOT\DVD\shell\play\command]
    @=hex(2):22,00,43,00,3a,00,5c,00,50,00,72,00,6f,00,67,00,72,00,61,\
      00,6d,00,20,00,46,00,69,00,6c,00,65,00,73,00,20,00,28,00,78,00,38,00,36,00,\
      29,00,5c,00,49,00,6e,00,74,00,65,00,72,00,56,00,69,00,64,00,65,00,6f,00,5c,\
      00,57,00,69,00,6e,00,44,00,56,00,44,00,5c,00,57,00,69,00,6e,00,44,00,56,00,\
      44,00,2e,00,65,00,78,00,65,00,22,00,20,00,25,00,31,00,00,00

    21. Save the notepad file and close Notepad
    22. Now double click the file you just saved, a warning should appear saying you're going add stuff to the registry.
    23. Click Yes to Continue
    24. A Dialog should appear stating the values were added to the registry
    25. Re-open regedit
    26. Traverse back to HKEY_CLASSES_ROOT\DVD\shell\play\command (you should already be there)
    27. Now the value on the right hand side labeled (Default) should have the same Data as before, but the Type should indicate it is REG_EXPAND_SZ

    Good luck, hope it works for you too. 

    !!!!Thanks Much!!!!  Work perfectly
    Tuesday, June 1, 2010 1:41 AM

All replies

  • Hi Denpag,

    Hope the following Microsoft KB can help you:

    Windows Media Player Does Not Play Audio CD-ROMs Automatically

    Thanks.
    Friday, November 6, 2009 3:35 AM
  • Thanks for the response. No good. All of the assciations and defaults are there. Also, the KB was for WMP 7. I am using WMP12. Thanx again, Denver
    Friday, November 6, 2009 2:59 PM
  • Hi Denver,
    I suggest you run a tool named
    Process Monitor to monitor system behavior.


    To do it, start Process Monitor. Then repro the issue, and stop Process Monitor. 
     

    If possible, please save the log and upload to Windows Live SkyDrive (http://www.skydrive.live.com/) and share the URL with us.

     

    Thank you for your cooperation. I am looking forward to your reply.

     

    Thanks.

     

    Wednesday, November 11, 2009 9:32 AM
  • I have the same issue.  Running Win 7 Ultimate x64, upgrade from vista ultimate x64.  I have multiple dvd programs installed, and I'm not sure if one of them screwed up the Play context menu entry.  I've tried changing the autoplay of a dvd to any of several programs, all to no avail.  I've uploaded a process monitor log captured with a right-click, Play selection.  This results in the error message Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item.  I also get this same error message by double clicking the dvd drive in explorer w/ a dvd loaded.

    I also exported my HKCR\DVD reg key.

    http://cid-ff63cd1dec2e152c.skydrive.live.com/browse.aspx/DVD-Play%20issue

    Looking forward to some resolution to this very annoying problem. 

    Thanks,
    Grant
    Sunday, December 6, 2009 8:48 PM
  • I had the same problem with the process monitor. What I find curious though, if I have Windows Media Player open, and insert a DVD into the drive, Media Player will auto play the DVD as if I inserted the disk with nothing open. Close media player and the disk will not play. Windows Media Center won't do anything with DVD's.
    Denver
    Monday, December 7, 2009 3:44 AM
  • I figured out a solution for the problem with double clicking, or choosing the Play context menu option from the explorer window of a dvd drive and getting the access denied error.  I typically don't use AutoPlay, so I haven't really dug into that -- even though Autoplay still doesn't work at all for me when I insert a dvd.

    It appears the registry value type was wrong for the Play option.  When you look in the registry editor at HKEY_CLASSES_ROOT\DVD\shell\play\command
    the (Default) value type said REG_SZ for me, and the Data was "%ProgramFiles(x86)%\Windows Media Player\wmplayer.exe" /prefetch:4 /device:DVD "%L"

    (This would be different if your windows version is not 64bit, i.e. "%ProgramFiles%\Windows Media Player\wmplayer.exe" /prefetch:4 /device:DVD "%L"  )

    The issue is that this should be a REG_EXPAND_SZ type value instead.  To fix is somewhat of a pain, as you can't just edit the type of a value or create a (Default) key of type REG_EXPAND_SZ from the regedit GUI (afaik at least).

    What I did was to create a new value, called whatever, of type "Expandable String Value" and copy and paste the data from the Default to the new key.  Then export the entire command key to .reg file.  Edit the .reg file in a text editor to swap the entire value after the = of your new key, with the @ key (which is the default).  Then merge the .reg file back to the registry. It's easiest to do this way, since expandable stores the string as hex ascii values, while string type is just a quoted string.

    Right clicking a dvd drive and choosing Play, or double clicking the drive successfully launched Media Player for me now. shazam!

    Thursday, December 10, 2009 2:00 AM
  • Thanx Grant, that did fix the double click problem. I can live with the autoplay not working. I also got the Play DVD to work in the Media Center.
    I found the following fix:
    try regedit
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Media Center\Start Menu\Applications]

    "HideDVD"=dword:00000000 set to 0

    It was on an Australian web site: http://www.xpmediacentre.com.au/community/windows-vista-media-center-os/34294-play-dvd-missing.html

    Thanx again, Denver
    Thursday, December 10, 2009 6:17 AM
  • Grant, like the solution you posted and I'm with you until you get to the fix part. I'm not as computer literate as you are and creating expandable string values means absolutely nothing to me, but I can follow instructions. If you have the time please can you write me a quick idot guide to inputting the fix into the regedit.

    Warren333
    Monday, January 11, 2010 4:40 AM
  • Warren333-

    1. Run Regedit
    2. Navigate the tree to HKEY_CLASSES_ROOT\DVD\shell\play\command
    3. Double click the (Default) value on the right side of the split dialog (Edit String dialog should appear)
    4. Copy the contents of the Value data field
    5. Click cancel on the Edit String dialog
    6. Right click on the right side of the split dialog
    7. Choose New->Expandable String Value
    8. Just hit enter if the cursor is allowing you to change the name of the new value
    9. Doublie click the New Value you just created (Edit String dialog should appear)
    10. Paste the string you previously copied into the Value Data field
    11. Click OK on the Edit String Dialog
    12. Now on the left hand side of the split dialog, highlight the folder  HKEY_CLASSES_ROOT\DVD\shell\play\command
    13. Right click it, and choose Export
    14. Save this file to some location of your choosing, and some name of your choosing.
    15. Close regedit
    16. Go to the location you saved the file
    17. Right click the file, and choose the Edit option (should launch the file open in notepad (or some other text editor)
    18. You should see something similar to (Don't just copy and paste what I have below, because this PC has WinDVD installed):

    [HKEY_CLASSES_ROOT\DVD\shell\play\command]
    @="\"C:\\Program Files (x86)\\InterVideo\\WinDVD\\WinDVD.exe\" %1"
    "New Value #1"=hex(2):22,00,43,00,3a,00,5c,00,50,00,72,00,6f,00,67,00,72,00,61,\
      00,6d,00,20,00,46,00,69,00,6c,00,65,00,73,00,20,00,28,00,78,00,38,00,36,00,\
      29,00,5c,00,49,00,6e,00,74,00,65,00,72,00,56,00,69,00,64,00,65,00,6f,00,5c,\
      00,57,00,69,00,6e,00,44,00,56,00,44,00,5c,00,57,00,69,00,6e,00,44,00,56,00,\
      44,00,2e,00,65,00,78,00,65,00,22,00,20,00,25,00,31,00,00,00

    19. Now delete the first line:
    @="\"C:\\Program Files (x86)\\InterVideo\\WinDVD\\WinDVD.exe\" %1"

    20. Now replace everything in front of the = of the remaining line with just the @ character, final results should look similar to:
    [HKEY_CLASSES_ROOT\DVD\shell\play\command]
    @=hex(2):22,00,43,00,3a,00,5c,00,50,00,72,00,6f,00,67,00,72,00,61,\
      00,6d,00,20,00,46,00,69,00,6c,00,65,00,73,00,20,00,28,00,78,00,38,00,36,00,\
      29,00,5c,00,49,00,6e,00,74,00,65,00,72,00,56,00,69,00,64,00,65,00,6f,00,5c,\
      00,57,00,69,00,6e,00,44,00,56,00,44,00,5c,00,57,00,69,00,6e,00,44,00,56,00,\
      44,00,2e,00,65,00,78,00,65,00,22,00,20,00,25,00,31,00,00,00

    21. Save the notepad file and close Notepad
    22. Now double click the file you just saved, a warning should appear saying you're going add stuff to the registry.
    23. Click Yes to Continue
    24. A Dialog should appear stating the values were added to the registry
    25. Re-open regedit
    26. Traverse back to HKEY_CLASSES_ROOT\DVD\shell\play\command (you should already be there)
    27. Now the value on the right hand side labeled (Default) should have the same Data as before, but the Type should indicate it is REG_EXPAND_SZ

    Good luck, hope it works for you too. 
    Tuesday, January 12, 2010 7:01 PM
  • Thanks a lot - that worked for me too. I still have one problem with DVD's - can you help? When I put in a blank DVD, I have Autoplay set to open Windows DVD Maker. But all I get is an error stating that "This file has no program associated with it for performing this action. Please install a program, or if one is installed, create an association for it in Default Programs." I don't see a way to do anything in Default Programs though.

    DVD Maker works fine if I open it by itself. Could this be a registry problem too?
    Monday, March 8, 2010 10:34 PM
  • Warren333-

    1. Run Regedit
    2. Navigate the tree to HKEY_CLASSES_ROOT\DVD\shell\play\command
    3. Double click the (Default) value on the right side of the split dialog (Edit String dialog should appear)
    4. Copy the contents of the Value data field
    5. Click cancel on the Edit String dialog
    6. Right click on the right side of the split dialog
    7. Choose New->Expandable String Value
    8. Just hit enter if the cursor is allowing you to change the name of the new value
    9. Doublie click the New Value you just created (Edit String dialog should appear)
    10. Paste the string you previously copied into the Value Data field
    11. Click OK on the Edit String Dialog
    12. Now on the left hand side of the split dialog, highlight the folder  HKEY_CLASSES_ROOT\DVD\shell\play\command
    13. Right click it, and choose Export
    14. Save this file to some location of your choosing, and some name of your choosing.
    15. Close regedit
    16. Go to the location you saved the file
    17. Right click the file, and choose the Edit option (should launch the file open in notepad (or some other text editor)
    18. You should see something similar to (Don't just copy and paste what I have below, because this PC has WinDVD installed):

    [HKEY_CLASSES_ROOT\DVD\shell\play\command]
    @="\"C:\\Program Files (x86)\\InterVideo\\WinDVD\\WinDVD.exe\" %1"
    "New Value #1"=hex(2):22,00,43,00,3a,00,5c,00,50,00,72,00,6f,00,67,00,72,00,61,\
      00,6d,00,20,00,46,00,69,00,6c,00,65,00,73,00,20,00,28,00,78,00,38,00,36,00,\
      29,00,5c,00,49,00,6e,00,74,00,65,00,72,00,56,00,69,00,64,00,65,00,6f,00,5c,\
      00,57,00,69,00,6e,00,44,00,56,00,44,00,5c,00,57,00,69,00,6e,00,44,00,56,00,\
      44,00,2e,00,65,00,78,00,65,00,22,00,20,00,25,00,31,00,00,00

    19. Now delete the first line:
    @="\"C:\\Program Files (x86)\\InterVideo\\WinDVD\\WinDVD.exe\" %1"

    20. Now replace everything in front of the = of the remaining line with just the @ character, final results should look similar to:
    [HKEY_CLASSES_ROOT\DVD\shell\play\command]
    @=hex(2):22,00,43,00,3a,00,5c,00,50,00,72,00,6f,00,67,00,72,00,61,\
      00,6d,00,20,00,46,00,69,00,6c,00,65,00,73,00,20,00,28,00,78,00,38,00,36,00,\
      29,00,5c,00,49,00,6e,00,74,00,65,00,72,00,56,00,69,00,64,00,65,00,6f,00,5c,\
      00,57,00,69,00,6e,00,44,00,56,00,44,00,5c,00,57,00,69,00,6e,00,44,00,56,00,\
      44,00,2e,00,65,00,78,00,65,00,22,00,20,00,25,00,31,00,00,00

    21. Save the notepad file and close Notepad
    22. Now double click the file you just saved, a warning should appear saying you're going add stuff to the registry.
    23. Click Yes to Continue
    24. A Dialog should appear stating the values were added to the registry
    25. Re-open regedit
    26. Traverse back to HKEY_CLASSES_ROOT\DVD\shell\play\command (you should already be there)
    27. Now the value on the right hand side labeled (Default) should have the same Data as before, but the Type should indicate it is REG_EXPAND_SZ

    Good luck, hope it works for you too. 

    !!!!Thanks Much!!!!  Work perfectly
    Tuesday, June 1, 2010 1:41 AM
  • Pretty smart. Thanks, it worked for me as well.

    Now the questions is what caused this to happen in the first place?

    Friday, June 25, 2010 10:51 AM
  • I found removing the command folder then uninstalling and reinstalling Windows Media Player works.

    -skuno23

    Wednesday, August 18, 2010 4:21 PM
  • I tried all methods and none work except skuno23's one.

    That worked like a charm.

    Thanks skuno23

    Monday, August 30, 2010 2:33 AM
  • GrantDavis, thank you for your input.

    Just for any of you looking for help here... what GrantDavis has said ALSO works for Audio CDs having this problem.

    For me, everytime I double clicked my audio-cd it would give that error, I followed everything GrantDavis said BUT instead of going to the DVD folder in the registry I just went to the AudioCD folder (HKEY_CLASSES_ROOT\AudioCD) and did what he said exactly.

     

    it fixed it for me :)

     

    Thanks a lot man!! :D


    Molten Ice http://www.netsafehouse.com/
    Thursday, October 14, 2010 3:21 PM
  • Reg files for fixing this (tested/worked!)

    http://www.winhelponline.com/blog/fix-dvd-play-error-windows-cannot-access-the-specified-device-windows-7/

    Sunday, November 28, 2010 10:58 PM
  • Just a short note to say thanks for your detailed explanation and assistance. This problem was driving me crazy but your instructions were 100% and have solved it for me. Cheers!
    Tuesday, September 6, 2011 8:57 PM
  • Thanks for the fix. I tried doing it but when I go to the Edit String Dialog, it is empty so I have nothing to copy. Any ideas what I can do?

     

    Thursday, September 8, 2011 2:00 AM
  • Try the link R. Berman provided.  Just download the zip at the bottom of the page and import the appropriate reg file (32 or 64bit).  That file should set the default player to windows mediaplayer.
    Thursday, September 8, 2011 2:25 PM
  • Thanks God!   Working perfectly!  :)
    Thursday, September 15, 2011 12:30 PM
  • Aye skuno23. Thanks. This worked for me too. This is clearly a problem with the registry, but GrantDavis' method did not work for me either. HKEY_CLASSES_ROOT\DVD\shell\play\command - (Default) was empty (null?), nothing to copy. This problem developed for me after installing Virtualbox and trying to use a multi-session cdrw. not sure if that caused it, but I don't know what else could have. At the same time that this happened the command entry for BlazeDVD also got screwed up (it pointed to a .dll file) which cause me to get "D:\ is not a valid win32 application". I manually changed it from "xxx.dll" to "blazedvd.exe" and fixed that too. VLC media player menu option worked fine all along, BTW. Dose anyone know how this problem arises?
    Thursday, September 22, 2011 8:15 AM
  • WOW!!!!!

     

    JUSt wanted to say THANK YOU!!! THANK YOU!!!!

     

    I was SOO frustrated with my DVD player not working, I was about to take it to a repair shop.

     

    I went step by step with your explination and it works just fine now.

     

    Very much appreciated!!!!!!

    Wednesday, November 2, 2011 12:37 AM
  • Thank you, Molten Ice.

    My default didn't have value so I couldn't fix the DVD problem with GrantDavis advice. Then I found the easier fix for DVD in http://www.winhelponline.com/blog/fix-dvd-play-error-windows-cannot-access-the-specified-device-windows-7/

    but I still have problem with Audio CD. Your post shows me the light!

    Thursday, November 10, 2011 3:36 AM
  • Reg files for fixing this (tested/worked!)

    http://www.winhelponline.com/blog/fix-dvd-play-error-windows-cannot-access-the-specified-device-windows-7/

     easy and working solution - fixed my problem in few seconds, thanks so much!

    • Proposed as answer by Paurav Gandhi Saturday, July 28, 2012 5:07 PM
    Sunday, February 19, 2012 6:48 PM
  • Thank you soo much! I've been trying to find a fix for a while. thanks!
    Friday, July 6, 2012 2:53 PM
  • Thank you very much. I've been trying to solve this for a long time. Funny enough I've already looked at this thread before but I missed your post.
    Friday, July 13, 2012 12:38 AM
  • Celia, Thank you. This helped me to fix my issue. This link lets to download a .zip file which has a .reg file inside. When I tried to open this .reg file in notepad I found same codes as answered by "GrantDavis". Your mentioned link has exported .reg file by some one which works perfectly. Many thanks again for simple short cut.

    Saturday, July 28, 2012 5:05 PM
  • Worked great on first click, Thanks a bunch
    Thursday, August 9, 2012 2:37 AM
  • Thank you a million!!! It does fix the problem instantly! 

    My problem was caused by downloading Realplayer and I had found other people had same problem after installed Realplayer last year. I am surprised that Realplayer still not fixing it.

    Sunday, August 4, 2013 4:52 AM
  • Thanks so much for the clear, detailed explanation. Must have taken some time to write, and it helped many people, including me! Worked like a charm!
    Friday, August 16, 2013 11:29 PM
  • I have just discovered this problem on my PC, and have found by way of successfully playing the DVD by way of another program that it is something to do with Windows Media Player. 

    Actually upon further investigation, I have found that it is only when attempting to have WMP play a DVD from the Computer window that this error occurs.

    • Edited by Tsadi9 Saturday, January 25, 2014 6:15 AM
    Saturday, January 25, 2014 5:54 AM
  • hi grant davis, im having the same dvd issue, i started proceeding with the fix you posted, but when i got to the value data field there was nothint there to copy, what exactly should i do from here? please keep in mind im like the other guy on the thread, not very computer literate but i can follow directions. thank you for your time and hope to here from you soon

    sincerely timothy raymond

    Monday, February 3, 2014 9:57 PM
  • Timothy: as already suggested here, please try the registry fix at http://www.winhelponline.com/blog/fix-dvd-play-error-windows-cannot-access-the-specified-device-windows-7. It boils down to the same as the manual fix.


    Tim De Baets
    http://www.bm-productions.tk

    Tuesday, February 4, 2014 7:41 PM
  • YES!!!!!!!!!!!!!!!!!!!!!!!!!! I'm a genius--I mean YOUR  a genius. Many thanks!!!!!!!!!
    Tuesday, February 11, 2014 12:09 AM
  • For those still having the same issue after the changes above, you might also need to change HKEY_CLASSES_ROOT\AudioCD\shell\play\command. After I made those changes it worked like a charm!

    Thanks Warren3333

    Sunday, March 9, 2014 8:40 PM
  • Many thanks
    Saturday, April 5, 2014 6:11 PM
  • 3. Double click the (Default) value on the right side of the split dialog (Edit String dialog should appear)
    4. Copy the contents of the Value data field

    At step 4, there is nothing in the value data field for me to copy... 

    Friday, July 4, 2014 10:14 PM
  • AudreyTam: please create a new question in this forum that describes the problem that you're experiencing. Thanks!

    Tim De Baets
    http://www.bm-productions.tk

    Sunday, July 6, 2014 2:44 PM
  • Thank you so much!!!

    Great help!!!!!!!!!!

    Saturday, January 17, 2015 4:09 AM
  • thanx guys for reply. it was not association problem,it has command problem i have fix it by copying playwith command value data and paste it in play command value data. Here is the steps which i had follow :-

    1. Run Regedit
    2.  Navigate the tree to HKEYCLASSESROOT\DVD\shell\play\command
    3. Double click the (Default) value on the right side of the split dialog (Edit String dialog should appear)
    4.  You will see value data has empty.
    5.  then goto HKEYCLASSESROOT\DVD\shell\playwith\command
    6. Double click the (Default) value on the right side of the split dialog (Edit String dialog should appear)
    7. Copy the contents of the Value data field
    8.  Click cancel on the Edit String dialog
    9.  again come to play/command and paste the value data .
    10.  problem will be fixed. :)
    Thursday, April 9, 2015 3:11 PM
  • Worked perfectly - thanks!
    Wednesday, June 17, 2015 3:48 PM
  • Hi,

    I have the same problem as others except I'm running on Windows 8 and the value data field is empty. Do you have any suggestions? 

    Much appreciated, 

    Quynh

    Saturday, July 25, 2015 3:46 AM
  • I did exactly this and I got a pop up that said.

    D:/

    Application not found.

    Could you have an idea what I did wrong?

    Thursday, July 30, 2015 6:22 AM
  • Thank you! It worked perfect for Assassin's Creed II(Game Software) DVD...
    Wednesday, May 10, 2017 6:03 AM