none
Need more than 16bit color depth on Windows XP Mode

    Question

  • Hi there,

    i´m testing windows xp mode with some applications, which are not compatible with Windows 7. I want to roll out some clients with Windows 7 and catch all compatibility problems with WindowsXP-Mode. But i´ve got a problem. We need a software called "Siemens Sinutrain Student Version" and this Software runs only with Windows XP 32bit and 32bit color depth.

    any hints / suggestions?

    thx ´n greetz

    marc
    Tuesday, October 06, 2009 11:04 AM

Answers

  • Using a desktop link requires XP Mode. You can choose either XP Mode or 32-bit color. If you want XP Mode and 32-bit color, you'll have to make more extensive changes to RDP.

    You can try putting this in the registry of the XP Mode vm and see if 24-bit color in XP Mode is sufficient:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services]
    "fDenyTSConnections"=dword:00000000
    "UserAuthentication"=dword:00000000
    "ColorDepth"=dword:00000004
    • Marked as answer by Marc Weimann Wednesday, October 07, 2009 1:44 PM
    Wednesday, October 07, 2009 11:58 AM

All replies

  • XP mode uses terminal services to connect you to the vm. That's why you are limited to 16-bit color. If you turn off Integration Features, you can get 32-bit color. It's also possible to fiddle with various Remote Desktop settings and enable 32-bit color.
    • Marked as answer by Linda Yan Wednesday, October 07, 2009 1:00 AM
    • Unmarked as answer by Marc Weimann Wednesday, October 07, 2009 9:54 AM
    Tuesday, October 06, 2009 12:09 PM
  • Hi John,

    i turned the integration features off and my application works! this is very nice, but i want to start my app via the startmenu or a desktop symbol on the host machine.

    If i start an application with a desktop link on my host system, i´ll get an error from my application. XP Mode starts my app in 16bit color depth.

    Is there such a thing ?
    Wednesday, October 07, 2009 7:04 AM
  • Using a desktop link requires XP Mode. You can choose either XP Mode or 32-bit color. If you want XP Mode and 32-bit color, you'll have to make more extensive changes to RDP.

    You can try putting this in the registry of the XP Mode vm and see if 24-bit color in XP Mode is sufficient:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services]
    "fDenyTSConnections"=dword:00000000
    "UserAuthentication"=dword:00000000
    "ColorDepth"=dword:00000004
    • Marked as answer by Marc Weimann Wednesday, October 07, 2009 1:44 PM
    Wednesday, October 07, 2009 11:58 AM
  • Great John! Awesome!!!!

    it works!

    i added

    "ColorDepth"=dword:00000004

    now, i can change the color depth in my win xp mode machine to 24bit. thats not 32bit, but my app works!

    very, very nice.

    thank you !

    • Marked as answer by Marc Weimann Wednesday, October 07, 2009 1:44 PM
    • Unmarked as answer by Marc Weimann Wednesday, October 07, 2009 1:44 PM
    Wednesday, October 07, 2009 1:04 PM
  • John, i'm a novice.  how do I do this?

    Thanks
    Thursday, December 03, 2009 5:33 AM
  • Where di I turn off the integration features?  I'm a novice.

    Thank you
    Thursday, December 03, 2009 8:36 PM
  • c:\users\%username%\virtual machines
    select Windows XP Mode
    click Settings from the menu bar
    Uncheck enable at start-up for Integration Features
    Thursday, December 03, 2009 10:51 PM
  • Or use %USERPROFILE%\Virtual Machines
    Thursday, December 03, 2009 11:26 PM
  • how can i make my xp faster after i turned off the integration service? it became slow again after i turned of integration service and turn to high 32bit color...
    Wednesday, January 27, 2010 4:45 AM
  • The only way to get 32bit color with WVPC and XPMode is to disable the Integration Components.  The highest color depth with the IC enabled is 24bit.
    Tuesday, December 13, 2011 7:24 PM
  • The IC are key to performance.  You are facing contradictory choices here.
    Colin Barnhorst Windows 7 Ultimate x64 on DIY with 6GB ram.
    Tuesday, December 13, 2011 7:39 PM
  • John,

    I tuned off the Integration and I got 32bit color. THe only problem is all my partitioned drive went away and I can't access it anymore. I have to turn on the Integration again to access those drives. I also have the problem that my partitioned drives are being seen as a network drive. Please help. Thanks

    Friday, January 20, 2012 5:50 AM
  • You have 2 choices with VPC:

    32 bit color without integration components

    24 bit color with integration components

     

    Otherwise you'll need to look for a non-MS solution.

    Friday, January 20, 2012 9:18 AM
  • I saw this post on how to change it to 24 bit.

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services]
    "fDenyTSConnections"=dword:00000000
    "UserAuthentication"=dword:00000000
    "ColorDepth"=dword:00000004

    But I dont nkow how to get there. Can you guide me how to do it.

    Friday, January 20, 2012 11:01 PM
  • You need to edit the Registry.  Incorrectly editing the Registry can make your OS unusable if errors are made.  If your XP Mode has important data make sure you back it up before you edit the Registry.  You do so at your own risk.

    To edit:

    1. In XP Mode (not Windows 7) click Start-->Run

    2. type "regedit" and press enter

    3. Go to HKEY_Local_Machine and click the + to expand.  Continue to expand the tree and scroll until you reach: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services

    -You can see your location in the status bar on the bottom of the Registry Editor window

    4. Right click in the white space on the right-hand window, and select New-->DWORD Value

    5. Enter "ColorDepth" for the name and press enter

    6. Double-click ColorDepth to open it and enter "4" in the Value data box.  click OK.

    7. Reboot, once you reboot, right-click the desktop, click Properties and change your color depth under settings.

     

     

    • Proposed as answer by flybefree Saturday, January 21, 2012 3:44 AM
    Friday, January 20, 2012 11:43 PM
  • Smjain,

     

    Thanks, It worked. I really do appreciate it.

    Saturday, January 21, 2012 3:03 PM
  • I have tried this procedure and it does work as advertized here, but I still cannot activate the advanced display settings tab that allows setting the eyesight-saving 120 DPI font mode.  This is a major limitation of the XP mode operation.

    Also, if I disable integration, my XP Mode seems to go away until it is re-enabled.

    MLB

    Thursday, May 09, 2013 5:01 AM
  • How do you turn off the integration features?
    Saturday, March 07, 2015 5:41 PM