WIndows 7: No Administrator Rights and C:\ is not accessible


  • help... I cannot access my local hard drive after the system has booted and I have logged in. I get the following error: "C:\ is not accessible Access is denied." I then navigated to the Control Panel, Administratives Tools, Computer management and got the following network error: "Windows cannot access C:\Windows\system32\compmgmt.msc" Detail error code: 0x800704b3 I clicked the Diagnose tab and got the following error: "An error occurred while troubleshooting. A problem is preventing the troubleshooter from starting." I clicked "View error details" and got the following response: Package ID: Unknown Path: C:\Windows\diagnostics\system\networking Error code: 0x80070005 Source: Engine User: Context: Restricted It appears that I have lost all administratives rights for my login. Can you help me regain access to my local hard drive and administrative rights. thanks, Ruben
    Friday, July 24, 2009 2:15 PM

All replies

  • If your account is not an ‘administrators’ account, this should work:

    Go to Control Panel > All Control Panel Items > User Accounts > Change your account type.

    However, I have a feeling it’s not as simple as that.


    Friday, July 24, 2009 2:26 PM
  • I wish it was that simple... I think this problem is a result of creating a homegroup with the wrong password. It's time for some registry hacking to reset Administrator rights. 

    Friday, July 24, 2009 3:39 PM
  • I read another thread several days ago describing this exact same problem (deleting a Homegroup removed all rights). I think that user ultimately had to reinstall. (Sorry.)
    Friday, July 24, 2009 6:39 PM
  • Please try the following steps.

    1. Please download the subinacl.msi file from the following link and save the installation patch on the Desktop:

    Download details SubInACL (SubInACL.exe)

    2. Please go to the Desktop and double click the downloaded file.

    3. Please select the C:\Windows\System32 folder as the Destination Folder during the installation. Later we will use this tool to reset the permission settings on the current machine.

    Note: If UAC (User Account Control) window is prompted for permission to continue, please click "Continue"

    4. Click "Start". In the Start Search bar, type: "notepad" (without quotes) and press Enter.

    5. Copy the following commands and then paste them into the opened Notepad window:

    @echo off
    subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f
    subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f
    subinacl /subdirectories %SystemDrive% /grant=administrators=f
    subinacl /subdirectories %windir%\*.* /grant=administrators=f
    subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=system=f
    subinacl /subkeyreg HKEY_CURRENT_USER /grant=system=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=system=f
    subinacl /subdirectories %SystemDrive% /grant=system=f
    subinacl /subdirectories %windir%\*.* /grant=system=f
    @Echo =========================
    @Echo Finished.
    @Echo =========================

    6. After the above commands are finished, please close the Notepad window. Choose Save when you are prompted to save the file. Type "reset.bat" as the file name and choose Desktop from the left panel as the save location.

    7. Refer to the Desktop and right click the reset.bat file, then choose "Run as administrator."

    8. You will see a DOS-like window processing.

    NOTE: It may take several minutes. When it is finished, you will be prompted with the message: "Finished, press any key to continue".


    Arthur Xie - MSFT
    Monday, July 27, 2009 7:27 AM
  • Hi there,

    I am trying things as i post this, so sorry if it seems a little bit wierd to read.

    Same thing just happened to me. Got the message, "C:\ is not accessible" Was messing around with homegroups, restarted and bam. No c:\ access.

    Arthur, can't do a whole lot of the things in that list. 

    First off, can't download the file. Anywhere you try and save it, it says "C:\ is unaccessible" even on other drives. 

    Secondly, install shield can't be accessed as well as everything else in control panel. Surprised control panel even worked. Can't even browse C:\. The only things i can browse on C:\ are My Documents. Nothing can be run.

    Can't make a notepad file. Can't run it.

    Just booted into safe mode. C:\ has no permissions set of course, so i added "Everyone" back into it. A few things worked, but most were still blocked (anything relating to My Documents (things associated with Homegroups)), but i was able to access C:\ again after this. 

    I will try what you have said now that i have a small amount of permissions again.

    Am back in Windows now. Everything seems as normal. Have not been blocked by any permissions. Things seem fixed, but i doubt it because i saw how many things were blocked when i readded permissions...

    • Edited by M00_cow Friday, July 31, 2009 11:18 AM
    Friday, July 31, 2009 11:13 AM
  • Hi,

    There should be several system components that are protected. We could not get the ownership of these components in any conditions.

    Another method could help us to take ownership. You may try it to take ownership of other components. Please boot with the Windows 7 DVD, select to repair the system. Then use the takeown command in Command Prompt.

    The following website can be referred.

    Windows Server TechCenter - takeown 

    The above method still could not help us to take the ownerships of protected system components.

    Otherwise, I just would like to know how it would happen. Is the system upgraded or clean-installed? Is the current system drive has been mounted in other systems?

    Arthur Xie - MSFT
    Friday, August 07, 2009 6:56 AM
  • Quick way to fix.

    restart in safe mode

    open file explorer
    right click on C:\
    select Properties option
    choose security tab
    click advanced button
    select owner tab
    click Edit button
    click on the name you want ownership rights changed to ie: your administrator user
    tick the box "replace owner on subcontainers and objects"
    hit apply

    this should restore your ownership of C:\

    hope this helps

    Monday, August 10, 2009 2:29 PM
  • Just as a follow up.

    This error is caused by removing your computer from a homegroup that you created when you are the only member of teh group. I'm not sure if the error is replicated after another user joins.

    Monday, August 10, 2009 2:34 PM
  • Hi Ignatiousdragon

    Since your problem description was substantially different from the problems described in this thread, I split your post to a new thread. Here is a link to your new thread.

    Windows cannot access the specified device, path or file

    Thanks for understanding.

    Ronnie Vernon MVP
    Forum Moderator
    Tuesday, August 11, 2009 9:20 AM
  • Arthur,

    I couldn't install the SubInACL routine, because the system couldn't access the disk to run the installer.  If I reboot in 'Safe' Mode, I still have NO direct access to the disk, and can't change the security settings.  However, I can run Regedit, so some hope that I can hack the registry enough to be able to save some files before I have to reinstall Widows 7. 
    Is there some registry settings I can edit to at least access my files long enough to save them offline??

    This is a MAJOR Problem - completely corrupting the disk access to the point that you have to reformat and start from scratch, losing EVERYTHING!!  It appears that this problem has been Known for at least a Month, yet No Warning from MICROSOFT, or 'patch' to keep Homegroups from botching the disk.  I know this is 'beta', but you guys have gone into production, and No Warning, Fix or something to keep this from happening AGAIN?!?!  Come On, Redmond, you could have at least Warned us - you have our emails when we signed up!!

    I completely loved 7, even though I hated Vista - until now.  Since I have been badly burned, I'm much more reluctant to trust 7 again!
    Monday, August 24, 2009 11:08 PM
  • i have the same problem with my C: drive and i try that with no luck.
    Monday, June 28, 2010 11:00 PM
  • Hi You could try one of the following

     another way is to enable a right click nenue item to manage any folder. This is

    or the trird way is


     Regards Tad

    Friday, November 05, 2010 6:49 AM
  • I found this thread because I was having the same problem.


    this is how i fixed it.


    Right Click C:\

    Select Properties

    Select the Security Tab

    Click the Advanced Button

    Click the Change Permissions

    Click add

    Click Advanced

    Click find now

    Scroll thu the list and find Authenticated Users (it may only say Authenticated)

    Press OK

    Press OK

    Press OK

    Press OK

    Press OK

    Now it should be working

    Thats what worked for me

    • Proposed as answer by Bryan Lange Tuesday, March 15, 2011 10:19 PM
    Monday, March 14, 2011 6:15 AM
  • Thank you! I've been trying to fix this problem for a few days now, and this seemed to work. After clicking OK to Authenticated Users, dont forget to check the box that allows Full Control. I also added our user name/Administrator to that permission list, and the hard drive unlocked. Thanks again!
    Tuesday, August 02, 2011 3:08 AM
  • Hi Arthur

    I am having the same issues as everyone else as far as being an Administrator being denied access to my own files.

    I was running XP-Pro 2002 and upgraded to Windows 7-Premium.  I thought I read everything on the subject before downloading and installing.  I used the Windows BackUp Software, did the compatibility check and so on and so forth. 

    I followed your instructions and it took forever to configure whatever it was doing.  To make a long story short I am still denied access to my Documents and Settings and also to my Downloads...H E L L O Microsoft - what the hell are you thinking. 

    Then I came back and followed the instructions from Captain Awesome and again whiz-burp-bubble and so on.  It accepted all the authorization checks and when I reloaded and tried out my Documents and Settings, again I was denied access although every check mark is in place.

    Next stop is Microsoft for a refund...duped again by Microsoft.


    Wednesday, July 18, 2012 4:41 AM
  • After doing Arthur's well written steps, unfortunately both the downloaded file and the notepad script files on my desktop were "locked" somehow (they became "C;\ is not accessible") and I was unable to delete them or drag them to the Recycle Bin.

    If anyone has that same problem, remember to reboot your computer and go into Safemode and there you can easily delete those 2 files.

    Harry Brooks

    Sunday, October 13, 2013 7:02 PM
  • Ouch: when I followed Geof's steps, I encountered this error "Error Applying Security" An error occurred whilte applying security information to C:\hiberfil.sys  The process cannot access the file because it is being used by another process.  Continue or Cancel 

    I tried Continue... but Windows Security popped up and started listing files then stopped with the same error at C:\pagefile.sys

    and many repeated similar errors with the screen showing "Changing ownership of..."

    Sunday, October 13, 2013 8:05 PM
  • i have the same problem with my C: drive and i try that with no luck.

    Sunday, February 09, 2014 11:59 AM