Can't print. Error message: Active Directory Domain Service is currently unavailable


  • Suddently I can't print. When I select "find printer" I receive error message "Active Directory Domain Service is currently unavailable" I have Windows 7 and am trying to print to Canon MX870. Printed fine when I left for work this morning. I have no idea what happened. Any suggestions? I've tried a variety of things over the past 3 hours with no luck. Can't print from word, outlook notepad.

    Thursday, December 01, 2011 5:10 AM


All replies

  • Hi,


    Method 1:


    Troubleshoot printer problems


    Fix printing problems by resetting the print spooler


    Check if the issue is resolved.


    Method 2:


    Let us try updating the printer driver which might help you in resolving the issue.


    Click on the link below for more information on updating the printer drivers.


    Find and install printer drivers


    Check if the issue is resolved.


    Method 3:


    Remove the printer and add it again:


    ·         Go to Control Panel

    ·         Select Printers

    ·         Right-click on Add Printer

    ·         Select Run as Administrator


    Now try to add your network printer




    Leo   Huang



    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, December 02, 2011 3:06 AM
  • Hello, none of those options listed above worked for me. I get the "Active Directory..." message when trying to add printer on Word, the "cant open find printer" message when trying to print from web, and the print management or services options do not appear in my Windows 7 control panel, even after search.

    I think I might've made an adjustment to my user security, or access settings, device settings, or may have deleted something? My network printer does show in the Devices section, and is installed correctly. It's just that programs such as Word just cannot access and print.

    Any advice please?

    Saturday, September 01, 2012 7:43 AM