Extremely Slow Network Transfer under 550kbps Windows 7


  • I have a small home network with a total of 5 Windows 7 Professional PCs on them. One is being used as a storage server.

    All 4 connected machines get beyond pathetic transfer speeds ranging from 900bps (yes bytes) to a max of 513kbps. So far I have done EVERYTHING I have found online to solve this issue which includes the following

    Turning off autotuning and rss, turning off RDC, turning off IPv6, and QoS

    I have swapped out the cables, upgraded cables from Cat5e to cat 6, switched out the router. All routers and switches are gigabit, all computers connected have gigabit ports. I've tried setting 1Gbps full duplex on all the machines.

    I have even tried wireless which still maxes out at 1mbps for about 3 seconds before dropping to 200kbps or slower.

    I've tried disabling the antivirus with no change.

    I have changed out drivers updated rolled back you name it I've done it. Updated firmware on the new router still the same issue.  

    Disabled Jumbo Frame, enabled flow control

    I've even tried Total Commander for transferring files and still same issue.

    What else can I possibly do to make my network functional for sharing files?

    To make sure all settings are clear my router has 4 Gigabit ports its Wireless N and Windows 7 Compatible

    All machines have gigabit LAN ports All are realtek.

    All systems are running Windows 7 Professional SP1

    All have current up to date LAN drivers

    All are perfectly able to download from the internet well beyond the limitations of file transfers on my network (getting 500kbps-2mbps download speeds from the internet)

    All drives transfering from and to a 7200rpm and 10krpm hard drives. 

    • Moved by Ken Warren Tuesday, April 10, 2012 11:20 PM off topic for Windows Home Server forums (From:Windows Home Server Software)
    Tuesday, April 10, 2012 11:13 PM

All replies

  • You have done really a lot to increase your network speed to reasonable levels (In my understanding, all computers are affected). What I do not see in your list is:

    1. Have you tried to use another switch?

    2. Have you tried to fix transfer rate on one side and automation on second?

    3. Have you tried analyze network traffic and latencies with network monitor (either from Microsoft or free Wireshark)?

    4. Are there any traces in Event logs?

    5. Is there any software, that may influence the network capability (either indirectly by taking resources or directly)

    6. Have you tested by Performance Monitor if there are any queues longer than ONE?



    Wednesday, April 11, 2012 6:34 AM
  • Under device manager - Network adapters

    NIC properties - Advanced

    "Link Speed & Duplex" see if you are using "Auto Negotiation".

    Try using 10 mbps Full Duplex, then reboot and test the speed.

    Try using 10 mbps Half Duplex, then reboot and test the speed.

    Then you can try the same with 100 mbs, see which one will give you the best performance.

    I am thinking that your NIC might be switching down the speed due to some problem in your network.

    Wednesday, April 11, 2012 1:47 PM
    1. The computers are through three different switches. All gigabit and two different brands. So technically yes since they are running through different switches.
    2. Yes I have tried to set the rate on one side and the leave it unchanged on the other and still the same issues.
    3. I have looked at network traffic and its minimal well under 200kbps as an average (only changed when my fiance was watching netflix)
    4. No trace event logs to be seen on any of the machines.
    5. None of the computers are running any software that could effect speeds, no sharing software of any kind. The Internet security (GFI) I even disabled with no change.
    6. Not sure what you mean by Performance Monitor queue longer than 1. Can you explain that one?
    Wednesday, April 11, 2012 3:33 PM
  • Tried every combination of that and no real changes. The 10mbps full duplex got me up to 612k for about 5 seconds then dropped to even slower at 260kbps. The rest it was a steady 512kbps from start to finish.

    What kind of network problems could effect all computers that are mostly through different switches and effect wireless computers in the same way?

    Wednesday, April 11, 2012 4:21 PM
  • Connect two computers with ethernet cross cable and see what the speed is. If the speed is high, then the problem is either in communication between computer and switches. Double check the configuration settings of switches.

    What have you seen in network traffic.



    Wednesday, April 11, 2012 5:14 PM

  • Getting 6-9mbps directly through. Even hooked up a NAS directly to the router and tested a transfer from the storage server to the NAS and got between 1.5-3mbps which is still pretty sad being so close to a direct connect.

    Network traffic has been extremely minimal. Average traffic on the network is in kbps theres so little. Once again hooked the data server up directly to yet another router basic 10/100 belkin router and have the desktop try and copy data from it and a laptop try and wirelessly copy data and this 10/100 150 wireless router is only doing 256k half of what the gigabit 300N router was.

    Oh and for the switches they are basic unmanaged netgear GS108 gigabit switches. So no interface and no settings that can be altered.
    Thursday, April 12, 2012 3:37 AM
  • I may have found my culprit but it doesn't make sense that it would cause it. I have multiple Netgear powerline adapters for the bedroom office TV and media room TVs (we live in a high rise with a single coax connection in the front room in a weird corner) So we use netflix and hulu plus for all our TV viewing. All TVs have been able to stream through them no problem. When I disconnected the powerline cable and restarted the computers I'm getting 21mbps transfer rates hard wired and 4.3-5mbps download speeds from the router.

    I don't understand how that could so horribly degrade transfer rates of everything on the network. Thing thats odd is that when I plug back in one powerline box to the router and hook up the powerlines again for the bedroom and media room the signal has not degraded again. I haven't hooked back up the 3rd because it was plugged in behind a shelf and I don't feel like moving it again tonight. Am I missing something? How would it even effect a wireless devices transfer speeds?

    I'm going to keep an eye on transfer speeds to see if they plummet again or not.

    Thursday, April 12, 2012 4:19 AM
  • Spoke too soon I guess. Started transferring 16GB worth of files to the server and it went from 21mbps then after a min down to 7mbps 3 min later 3.94mbps 15 min later 2.48mbps 5min later 2.15mbps keeps getting slower and slower...what could be causing this?
    Thursday, April 12, 2012 5:08 AM
  • Hi,

    Please kindly understand in 512k bps max network, max download bandwidth should be about 128kbps. Since there are more than one computers, 900bps is not a unexpected speed.

    You'd better double check the configuration settings of switches.  There are too many switchers on your network, five computers on three different brands switcher network.

    You may connect two computers via one switcher without connecting any other device for a test.  I suggest you build network with the same brand switcher.

    Friday, April 13, 2012 1:37 AM
  • But its not a 512kbps max network. Thats the issue. The speed I've been getting has been maxing out at 512kbps when it should be in the double digits mbps range. All switches are unmanaged switches and all switches are netgear gigabit switches. There are a total of 6 systems and two switches I've just tested out other switches to rule out a bad switch. One switch has 3 printers and an iMac, and the other switch has two desktop workstations then there are two wireless laptops.

    There should be no 512kbps max anywhere in that equation.

    Friday, April 13, 2012 2:51 AM
  • Hi,

    You may connect one switcher and one Windows 7 client for testing one by one, and then replace another switcher.

    Have you done these and the issue persists?  I think you may find the problematic client or device, some details are important to resolve this issue.

    Since you have two switchers, please pay attention to your connection, be sure the connection between swithers and router is correct.


    TechNet Community Support

    • Edited by Ivan-Liu Friday, April 13, 2012 5:18 AM
    Friday, April 13, 2012 5:17 AM
  • I've been doing that between a windows 7 desktop and the data server thats hooked directly to the router. I've tried hooking to the NAS as well and its the same issue no matter the computer, no matter the switch they are all getting quickly degrading transfer rates.
    Friday, April 13, 2012 4:48 PM
  • To reset the router by default or hook your computer directly to the Internet via dialing-up networking. (You may contact ISP.)  Maybe your router is suspect.


    TechNet Community Support

    Monday, April 16, 2012 7:18 AM
  • I've used 3 different routers and 4 different modems now...the router is not the issue, the modem is not the issue. And I can't do dialup. Uverse does not support dialup.
    Tuesday, April 17, 2012 10:17 PM
  • Hi,

    "All are perfectly able to download from the internet well beyond the limitations of file transfers on my network (getting 500kbps-2mbps download speeds from the internet)"  "...the router is not the issue, the modem is not the issue"   " no matter the computer, no matter the switch they are all getting quickly degrading transfer rates." you mentioned. 

    There must be some device working abnormally, router, switcher, client or NAS.  Although they work well alone, it does not mean that they work well together.

    Why you cannot dialup or connect Internet directly?  You should be able to connect Internet without router or switcher.(contact ISP)


    TechNet Community Support

    Wednesday, April 18, 2012 7:48 AM
  • Uverse does not support dialup. Its not a standard DSL service. Our building has no landline phone service. The phone jacks do not support voice service only uverse which is not compatible for dialing out when no voice service is supported by the line. Uverse only supports VOIP phone service.
    Wednesday, April 18, 2012 6:33 PM