Windows 8 Pro cannot connect to WPA2-Enterprise?


  • I just did a fresh install of Windows 8 Pro, the final, RTM Build, that i got from Dreamspark Premium. Up to this point, everything on my laptop had been working fine with Windows 7, including WPA2-Enterprise. But after i did the fresh install the university network no longer works.

    I click the network name, enter credintals, then it hangs, saying its "connecting" for about 3 minutes until it finally fails to work.

    Friday, August 31, 2012 3:17 PM

All replies

  • Are you using a Certificate on the radius server? Is the Certificate signed or self signed? and what radius server are you using?

    Friday, August 31, 2012 9:25 PM
  • I am also having this exact same issue. I also got windows 8 Pro from Dreamspark and upgraded from Win 7 and am  having the same issue at my university. When I put in credentials it asks if I'm sure I want to connect because of the certificate I click connect and after a few seconds or minutes depending on the day it says cannot connect. troubleshooting hasn't helped at all either.



    Friday, September 21, 2012 6:34 PM
  • I am having same problem

    I tried third party software and windows too

    all of them they don't work

    WPA2 Enterprise EAP-TTLS PAP

    certificateyou have to install it


    Tuesday, October 30, 2012 3:09 AM
  • Hi,

    I had similar problems after installing Windows 8 even thought it seemed to install the correct drivers for my WiFi card.

    My resolution was to download the latest Windows 7 Drivers from the manufacturers homepage and then install them under compatibility mode.

    Everything worked perfectly after this.

    Tuesday, October 30, 2012 7:07 PM