none
keyboard layout in DOS box

    Question

  • How do I get Danish (I am danish) keyboard layout in DOS box?

    If I run a command prompt window everything seems to work, but if I start a DOS application, the keyboard layout is english.


    OS version: Windows 7 Professional Danish 32 bit
    Sunday, October 11, 2009 2:45 PM

Answers

  • Hi,

    Based on my research and test on our test machine, after Windows NT, the DOS application reads the NLS settings from the DOS environment of the NTVDM instead of Win32 settings. The command prompt uses the Win32 NLS setting you configure in Control Panel, Regional Settings. In Windows 7 the DOS KEYB command is replaced by KB16.COM which is located in the %SystemRoot%\System32 directory. You can enable the danish keyboard by running the following command in elevated privileges.

    C:\Windows\System32\KB16 DK,850,C:\Windows\System32\KEYBOARD.SYS

    To more information, please refer to the following website:

    Keyboard Layout under Command Prompt

    Note: we provide this link for reference, there may be some changes without notice. Microsoft doesn't guarantee any change.

    Best Regards
    Dale

    Thursday, October 15, 2009 8:30 AM
    Moderator

All replies

  • Hi,

    Do you set Danish keyboard as the default keyboard layout for your system? Can you type danish in a command prompt? Please make sure that you set both keyboard layout and language locale to Danish in Region and Language panel. BTW, to configure the keyboard layout for a specific language, please refer to MS-DOS Goto Keyb Syntax

    Best Regards
    Dale
    Tuesday, October 13, 2009 5:09 AM
    Moderator
  • Hi Dale..
    Danish keyboard is set as default. The installation has been run choosing danish at all the prompts, just like in the installation of XP.
    If I launch a command prompt window (start - run - cmd) I have danish keyboard layout - if I then do it again from inside the command box I have US keyboard layout - same if I launch a program requiring the command box - US keyboard layout.
    Then I close the boxes typing exit - launch cmd again - danish keyboard... seems that settings are not inherited to next level.

    Strange

    I have none of that in Win XP Pro SP3 - launch all the cmd's you want - danish keyboard all the way with no options or config's set.

    - regards

    Thyge
    Wednesday, October 14, 2009 9:58 AM
  • Hi,

    Based on my research and test on our test machine, after Windows NT, the DOS application reads the NLS settings from the DOS environment of the NTVDM instead of Win32 settings. The command prompt uses the Win32 NLS setting you configure in Control Panel, Regional Settings. In Windows 7 the DOS KEYB command is replaced by KB16.COM which is located in the %SystemRoot%\System32 directory. You can enable the danish keyboard by running the following command in elevated privileges.

    C:\Windows\System32\KB16 DK,850,C:\Windows\System32\KEYBOARD.SYS

    To more information, please refer to the following website:

    Keyboard Layout under Command Prompt

    Note: we provide this link for reference, there may be some changes without notice. Microsoft doesn't guarantee any change.

    Best Regards
    Dale

    Thursday, October 15, 2009 8:30 AM
    Moderator